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Welcome to Mubasher Pro 
 

 

Thank you for subscribing to Mubasher Pro. 

Mubasher Pro is a client-server based real-time market information dissemination and trade 

solution, targeted at active traders and sophisticated investors and connects to Regional and 

International stock exchanges.  

Mubasher Pro is packed with features to guide you in making sound investment decisions. 

Some highlights of Mubasher Pro include advanced charting tools for Technical Analysis, up-

to-date News and Announcements from world renowned sources, Portfolio Simulator, 

comprehensive tools and options to track your trading account and much more! 

Enjoy the benefits of trading with Mubasher and let your profits soar!  

 

 

Getting Started with 

Mubasher Pro 
 

 

Customize Mubasher Pro 

 

Shortcuts  

 

Help Desk 

 

Help Version 9.0.01 
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Getting Started with Mubasher Pro 
 

INTRODUCTION   

When using Mubasher Pro for the first time, you will need to specify 

connection details, configurations, password details and also know how to 

export or import data from your previous installations, if any. 

 

TOPICS IN THIS SECTION  

Default and non Default Markets 

Connecting to Mubasher Pro 

Connecting to Mubasher Pro using SSO 

Connecting to Broker 

Changing Passwords 

Configure Mubasher Pro 

Configure Screen Settings 

Export User Data 

Import User Data 

Exit from Mubasher Pro 

Uninstall Mubasher Pro 

View Entitlements 
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Default and non Default Markets 
 

INTRODUCTION 

The markets that are available to you under your subscription can be 

categorized as Default Markets and non Default Markets.  

Full Markets (Defaults Markets) 

For Exchanges with full market subscription, price update information is 

disseminated to the client application for all the listed 

instruments/symbols of that exchange. This feature allows you to have full 

market view for the subscribed exchange. Note that when the number of 

instruments/symbols increases the data that is transmitted to the client 

application will be at higher level, requiring a greater bandwidth 

requirement. The full markets you are subscribed to, are listed under the 

Market Watch option in the Watch List menu.  

Symbol Driven Markets (Non Default Markets)  

Exchanges that have a greater number of symbols traded are given to 

users as symbol driven or non default market subscriptions. Users have to 

subscribe for the symbols for which they require market information. 

Therefore to view details about these symbols a request has to be sent by 

adding the required symbols to a Watch List. Data transmission to the 

client application will only take place for the subscribed 

instruments/symbols of those exchanges. All major international market 

subscriptions are provided as symbol driven markets.  

 

The following features are not available for Symbol Driven 

Markets: 

 

 Time & Sales 

Summary 

 Snap Quote 

 Announcements 

 Bandwidth Optimizer 

 Charts in MetaStock format, MetaStock 

related Options  

 Tabular Indicator Properties 

 Export History 

 Volume Watcher 
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 Ticker  

 Market Time & Sales 

 What if Calculator 

 Download Manager 

 Custom Index 

 Cash Flow Analyzer 

 History Analyzer 

 Scanner 

 Strategy Monitor 
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Connect to Mubasher Pro 
 

INTRODUCTION  

Most users can connect to the application using the following method. 

Single Sign On users, refer Connecting to Mubasher Pro via SSO section 

for details. 

  

PROCEDURE  

To connect to Mubasher Pro: 

1. Load Mubasher Pro by double clicking on the Mubasher Pro icon 

from the desktop. The User Login window opens. 

2. Enter Username and Password in the relevant fields.  

3. Click on OK button. 

When you connect for the first time, backlog trades (Trades which were 

executed from the time of market open) will be downloaded in the 

background and it takes a few minutes (depending on your internet 

connection speed) to view the live market information. 

 

Notes: 

  Tick and enable the Save Username and Password option, to save your 

Username and Password in the workspace. This allows you to login 

automatically to Application Servers and you will not be prompted for your 

pricing credentials again. 

  Always check the connection bulb indicators to make sure you are connected 

to the Application Price Server. When Mubasher Pro disconnects from server, 

you are notified via a disconnection popup message. 

  Users with Single Sign On (SSO) option, will not be able to connect to the 

application using this method. For details refer to Connecting to Mubasher Pro 

via Single Sign On in this guide. 
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RELATED INFORMATION  

Getting Started with Mubasher Pro 

Connecting to Mubasher Pro using SSO 

 
 
Connect to Mubasher Pro using SSO 
 

INTRODUCTION  

Users with Single Sign On (SSO) option are provided with a single 

Username and Password to login and trade in the application. This 

facility is enabled depending on your subscription, please contact the Help 

Desk for further details.  

 

The following pages provide information as to how to connect to 

Mubasher Pro using SSO for different types of users: 

Trade Web Users 

Other Users 

 

TRADE WEB USERS  

To connect to Mubasher Pro with a single Username and Password:  

1. Connect to the portal provided by your broker using the given 

Username and Password.  

2. Go to Services > Select Launch Mubasher Pro option. A popup 

window opens.  

3. In the popup window, select the option Click here to launch Mubasher 

Pro. This launches the application from the installed location. 

Once the application started, you will not be prompted for your login 

credentials until you log out from the application. 
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OTHER USERS  

When Connecting to Mubasher Pro, you will be shown the Trade Login 

Window. 

1. In the Trade Login window, Enter the Login and Password.  

2. Select the Broker from the drop down Menu. 

 

  Tip:  

  Use the Virtual Keyboard to enter the Password.  

 

Once the application started, you will not be prompted for your login 

credentials until you log out from the application. 

 

RELATED INFORMATION  

Getting Started with Mubasher Pro 
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Connect to Broker 
 

INTRODUCTION  

To start trading via Mubasher Pro, you need to connect to the trading 

server.  

 

PROCEDURE  

To login to the Trade Server: 

Method 1 

 Click on the Connect to Broker    icon in the icon panel. The Trade 

Login window opens. 

Method 2 

 Go to File menu > Select the Connect option. The Trade Login window 

opens. 

 

Figure 1 - Trade Login window 

 

 

1. Enter your Username and Password (Use the Virtual Keyboard to 

enter your password for maximum security). 

2. Select Broker from the Broker drop down. 

3. Click on the OK button.  
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  Tip:  

  If you wish to save the username you can select the Remember the 

Username option, and if you wish to login more securely, select the Virtual 

Keyboard option. 

 

 

VIRTUAL KEYBOARD  

The Virtual Keyboard enhances your security by preventing unauthorized 

users from tracking your key strokes, which is also known as keystroke 

logging.  

 

To enable the Virtual Keyboard option: 

1. Open the Trade Login window. (Click on the Connect icon in the icon 

panel to do this.) 

2. Tick and enable the Virtual Keyboard option. The Virtual Keyboard 

pops up on the screen (See Figure 1). 

 

Figure 1 - Virtual Keyboard 
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3. Press the relevant keys on the Virtual Keyboard and click on the 

Close button. Your Password appears in the Password field. 

4. Click on OK button. 

Notes: 

  Users with Single Sign On (SSO) option, will not be able to connect to the 

application using this method. For details refer to Connecting to Mubasher 

Pro via Single Sign On in this guide. 

  Single Sign On (SSO) is the process where you will receive a single 

Username and Password for both price information and trading. This facility is 

available depending on your subscription; contact the Help Desk for further 

details. 

 

RELATED INFORMATION  

Getting Started with Mubasher Pro 

Connecting to Broker for the first time 
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Connect to Broker for the first time 
 

INTRODUCTION  

When you are connecting to Trade for the first time you will be prompted 

to validate your account. You will be prompted to enter Passport 

Number, NIC or Company Registration. This is the same information 

that you provided during registration process. 

 

Figure 1 - User Validation when connecting to Trade for the First time 

 

Once you validate your account you will be prompted to change your credentials 

for security purposes.  Hence, you will be required to change your Trading 

Password and Trade Authentication Password, both at the same time. 

 

Note: 

  This is a mandatory task for all types of users including Single Sign On users. 

 

 

RELATED INFORMATION   

Connecting to Broker 

Getting Started with Mubasher Pro 
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Change Passwords 
 

INTRODUCTION  

Mubasher Pro gives you different Passwords for price and trade servers 

(or both) in order to enhance your security. You can change these 

Passwords at any given time. 

 

The following sections will guide you on how to do the same: 

Change Price Login Password 

Change Trade Login Password  

Change Single Sign On (SSO) Password 

 

RELATED INFORMATION  

Getting Started with Mubasher Pro 
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Change Price Login Password 
 

INTRODUCTION  

The Price Login Password is used to login to Mubasher Pro and to get 

price information from the exchanges you are subscribed to.  

 

PROCEDURE  

To change your Price Login Password: 

1. Go to File menu. 

2. Select Change Password option. The Change Password window 

opens. 

3. Enter the Old Password. 

4. Enter your New Password. 

5. Re-enter the new Password in the Confirm Password text box. 

6. Click on the OK button to proceed. 

 

RELATED INFORMATION   

Changing Passwords 

Password Strength Meter 
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Change Trading Passwords 
 

INTRODUCTION  

Mubasher Pro provides you with the following Trade Passwords: 

 Trade Login Password – Used to login to the Trade server to carry out 

trading functions. 

 Trading Authentication Password – Used to execute any trading 

activities and transactions such as Buy, Sell, Amend, Cancel Order, 

Withdraw funds from security account etc. 

You can change any one or both of these passwords at any given time. 

 

PROCEDURE  

To change your Trading Password: 

1. Go to Trade menu. 

2. Select the Change Password option. The Change Passwords 

window opens. 

In the Change Passwords window: 

To change the Login Password: 

1. Type your Old Password. 

2. Type your New Password and re-enter your new password in the 

Confirm Password field. 

3. Click on the OK button or proceed to fill the Trade Password section 

if you want to change the Trade Password.  

 

To change the Trade Password (Trade Authentication Password) 

1. Type your Old Password. 

2. Type your New Password and re-enter your new password in the 

Confirm Password field. 

3. Click on the OK button to apply the Password change.  
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Tip: 

  You can either change both the Trade Login and Trading Passwords or 

one of it. Enter the relevant information and click on the OK button. 

 

RELATED INFORMATION   

Changing Passwords 

Password Strength Meter 

 

 
 
Change SSO Password 
 

INTRODUCTION  

SSO Users can change their passwords at any given time. The following 

pages show how to change passwords for the different types of users: 

 

Trade Web Users 

Other Users 

 

RELATED INFORMATION  

Getting Started with Mubasher Pro 
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Trade Web Users 
 

INTRODUCTION  

Trade Web users are provided a single username and password to login to 

price as well as trade servers. You can change the password at any given 

time. 

 

PROCEDURE  

To change your Trade Web SSO Password:  

1. Connect to the portal provided by your broker using the given 

Username and Password.  

2. Go to Services > Select Change Password option. The Change 

Password page opens.  

3. In the Change Password page, Enter the requested information in the 

correct places.  

4. Click on Submit button. 

 

RELATED INFORMATION   

Changing SSO Password 

Password Strength Meter 
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Other Users 
 

INTRODUCTION  

Depending on your subscription, certain Single Sign On (SSO) users 

maybe provided with the following Passwords: 

 Login Password - Used to login to both trade and price servers. Hence, 

you will login to both servers at the same time. 

 Trading Authentication Password - Used to execute any trading 

activities and transactions such as Buy, Sell, Amend, Cancel Order, 

Withdraw funds from security account etc. 

You can choose to change any one or both of these passwords at any 

given time. 

 

PROCEDURE  

To change your passwords: 

1. Go to Trade menu. 

2. Select the Change Password option. The Change Passwords 

window opens.  

3. Type your Old Password. 

4. Type your New Password and Re-enter your new password in the 

Confirm Password field. 

5. Click on the OK button to apply the Password Change.  

 

Tip: 

  You can either change both the Trade Login and Trading Passwords or 

one of it. Enter the relevant information and click on the OK button.  

 

RELATED INFORMATION   

Changing SSO Password 

Password Strength Meter 
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Password Strength Meter 
 

INTRODUCTION  

The Password Strength Meter available in the Password text field can 

help you to gauge the strength of your password as your login credentials 

and personal information are more secure with a Strong Password. The 

colour changes of the bar, allows you to easily identify the strength of 

your Password. 

 

The strength of your password along with its characteristics can be 

categorised as follows: 

Strength of 

your password 

Password features 

Short This password constitutes of only one or few 

characters which is of only one type, such as letters 

or numbers or symbols. 

Weak This password constitutes of a few characters which is 

of  only one type such as letters or numbers or 

symbols. 

Good This password constitutes of characters which is a 

combination of letters, numbers, and symbols. 

Strong This password has characters which are a 

combination of uppercase and lowercase letters, 

numbers, and symbols. 

 

RELATED INFORMATION  

Getting Started with Mubasher Pro 
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Connection Settings 
 

INTRODUCTION  

The Connection Settings window enables you to view the current 

Mubasher Pro connectivity settings and also  the ability to edit the 

connectivity details without logging out of Mubasher Pro. Dialup Users 

please dialup your ISP or to the number provided by broker and then 

connect. 

 

PROCEDURE  

To setup Mubasher Pro connectivity: 

Method 1 

1. Go to File menu > Select Connection Settings option. The 

Connection Settings window opens. 

 

Method 2 

 Press CTRL + F keys. The Connection Settings window opens. 

 

In the Connection Settings window:  

2. Enter the URL or the IP of the market data server in the Market Data 

text field.(Application Server IPs are pre- saved, please do not change 

this information unless advised by the help desk / broker) 

3. Enter the URL or the IP of the Broker (Trade Server) in the Broker text 

field.(Application Server IPs are pre- saved, please do not change this 

information unless advised by the help desk / broker). 

4. Enter the Default User Name* and the Password*. 

5. Enter SOCKS proxy and Web proxy settings if required (IP and Port 

number of Proxy) (Please set your Proxy only if you are trying to 

connect through a firewall. Dialup users need not set this). Make sure 

the relevant flag is selected for each proxy. 

7. Click on OK button. 
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Note: 

  * The fields Default User and Password will not be available for users with 

Single Sign On (SSO) option. 

 

 
RELATED INFORMATION  

Getting Started with Mubasher Pro 

Configure Screen Settings 
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Configure Screen Settings 
 

INTRODUCTION  

Use this option to configure the screen settings of the application to view 

the application in dual screen mode. The dual screen mode enables you 

to plug in an additional monitor to your PC / notebook and enables you to 

view Mubasher Pro on both screens. Before you start using this option, 

you need to enable the second monitor. 

 

PROCEDURE 

To view Mubasher Pro in dual screen: 

1. Plug in the second monitor to your PC / Laptop VGA port. 

2. From the Start menu, go to Control Panel > Select Display option. 

The Display Properties window opens. 

 

Figure 1 - Enable second monitor using the Display Settings window 
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3. In the Displays Properties window, go to Settings tab, click on the 

Display drop down to enable the second monitor (see Figure 1). 

4. Now open Mubasher Pro, go to Customize menu > Preferences sub 

menu > Select Options. The Options window opens. 

 

Figure 2 - Options window 

 

 

5. In the Options window, Enable Dual Screen Mode. 

6. Select the required setting, i.e.: Open Popup in left screen / Open 

Popup in right screen. 

7. Click on OK button. 

 

Note: 

  When enabling the second monitor in the Display Properties window, you 

are required to enable the option, extend my windows desktop to this 

Monitor (see Figure 1). 

RELATED INFORMATION  

Getting Started with Mubasher Pro 
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Export User Data 
 

INTRODUCTION  

You can export your Watch Lists, Workspaces, Custom Columns, Custom 

Indexes and Others (Symbol Alias) by using this option. 

 

PROCEDURE  

To export data: 

1. Go to File menu. 

2. Select the Export User Data option. The Export User Data window 

opens (See Figure 1). 

 

Figure 1 - Select data to be Exported 

 

 

3. In the Export User Data window, select the Items you wish to Export. 

4. Click on the Export button.  

5. Specify a location for the data to be exported to and click on Save in 

the Export to Folder window (See Figure 2).  
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Figure 2 - Export User Data 

 

 

RELATED INFORMATION  

Getting Started with Mubasher Pro 
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Import User Data 
 

INTRODUCTION  

You can import your exported data using this option. 

 

PROCEDURE  

To import data: 

1. Go to File menu. 

2. Select the Import User Data option. The Import User Data window 

opens (See Figure 1). 

3. Select the file you wish to import and click on the Open button.  

4. Next, select the required data and click on Import button to import 

your data (See Figure 2). 

 

Figure 1 - Import User Data 
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Figure 2 - Select data to be imported 

 

 

 

RELATED INFORMATION  

Getting Started with Mubasher Pro 
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Exit from Mubasher Pro 
 

INTRODUCTION  

You can log out of Mubasher Pro at any time by auto-saving the current 

settings or without saving the current workspace settings.  

 

PROCEDURE  

To log out of Mubasher Pro: 

Method 1 

 Go to File menu > Select Exit option. 

 

Method 2 

 Click on    icon to exit from the icon panel. 

 

Method 3 

 Press CTRL + T from the keyboard. 

 

 

RELATED INFORMATION  

Getting Started with Mubasher Pro 
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Uninstall Mubasher Pro 
 

INTRODUCTION  

You can uninstall Mubasher Pro using one of the following methods at any 

given time.  

Prior to uninstalling the software, please note the following: 

Windows Vista users / Windows XP / 2000 users 

Before you attempt to follow the step stated below, make sure that you 

login to Windows as the Administrator or have Administrative 

Privileges to successfully uninstall Mubasher Pro from your machine.  

 

PROCEDURE  

To Uninstall Mubasher Pro from your PC: 

Method 1 

 Go to Start menu > Programs > Mubasher Pro > Select Uninstall 

Mubasher Pro option. This displays the Installation Wizard. Follow 

the instructions on screen to proceed**. 

 

Method 2 

Windows Vista users: 

1. Go to Start menu > Control Panel> This displays the Control Panel 

window. 

2. In the Control Panel window, select Programs & Features > Select 

Mubasher Pro and click on Uninstall. Follow the instructions on 

screen to proceed**. 

 

Windows XP / 2000 Users: 

1. Go to Start menu > Settings > Select Control Panel option. 

2. In the Control Panel window, Select Add or Remove Programs 

option. This displays the Add or Remove Programs window. 
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3. Select Mubasher Pro  and click on the Change / Remove button. 

This displays the Installation Wizard. Follow the instructions on 

screen to proceed**. 

 

Note: 

  Trade Web users will not be able to use Method 2 and perform the 

uninstallation of the application. 

 

 

 

SAVING USER PROFILE DETAILS  

**To keep your existing user profile details when uninstalling: 

Note: 

  Applicable if the version you are uninstalling is of series 9. 

 

When uninstalling is in progress a message is displayed giving you the 

option to keep or delete your existing user profile details (See Figure 3). 

When this message is displayed you can do one of the following; 

 Select Yes - If you select Yes, your user profile data* will not be 

deleted when the application is uninstalled. If you install a new version 

the new user data will be added to the existing profile data. This way 

you do not have to download history again or re-enter login details when 

new versions are installed. 

 Select No - Your user profile data* will be deleted when uninstalling 

and a new user profile created if a new version is installed. 

*User profile data includes chart data, time and sales data, meta stock 

data, cash flow information and saved workspaces. 

Note: 

  If Yes is selected when uninstalling and the user profile is not deleted, when 
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you install a new version you will be given the option of either keeping the 

saved user profile data or deleting it (See Figure 4). 

- Select Use Existing Profile, to keep the user profile data and use it 

when the new version is installed. 

- Select Replace Existing Profile, to delete the profile data and create a 

new one for the new version. 

 

Figure 3 - Message to keep or delete user profile data when uninstalling 
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Figure 4 - Message to keep or delete user profile data when installing 

 

RELATED INFORMATION  

Getting Started with Mubasher Pro 
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Exploring the Workspace 
 

INTRODUCTION  

This section of the help guide has information about the workspace of the 

application. 

 

TOPICS IN THIS SECTION  

Depending on your subscription, the options and the default workspace 

available for you with Mubasher Pro is as follows: 

 

View the Regional Interface 

Shortcuts to Functions 

Customizing the Application 

Managing Workspaces 

View Entitlements 
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View Regional Interface 
 

INTRODUCTION  

The diagram below shows the Interface (Work Area) of the Regional 

version of Mubasher Pro. The numbered sections in this diagram are 

explained below: 

 

INTERFACE 

 

 

Work Area as it appears in Mubasher Pro: 

A: Show/Hide Panel B: Panel Area C: Status Bulbs D: Select Panels icon E: 

Your Workspace F: Account Expiry Date  G: Connection Status Bar  H: 

Ticker Area I: Icon Panel J: Menu bar 
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 Show / Hide Panel - This button lets you display or hide the Panel 

displaying market summary information of selected Symbols / 

Exchanges.  

 Panel - This area displays market summary information of selected 

Symbols / Indices / Exchanges. The information  displayed can be 

selected as required using the Select Panels icon.  

 Status Bulbs - These indicates your Log in status to Price and Trade.   

 Panel Options through Select Panels icon - Lets you customize the 

information displayed in the Panel as you require.  

 Workspace - Workspace area.  

 Account Expiry Date - This indicates your account expiry date. This 

message will be displayed in red 7 days before your account expires and 

you will have to renew your subscription to continue using Mubasher Pro 

after the indicated date.  

 Connection Status Bar - Appearing at the bottom left hand corner the 

connection status bar displays your connection status.  

 Tickers - Appearing below the panel area the Tickers display 

information of trades in the Watch Lists as and when it takes place. The 

Advanced Ticker displays Announcements and News releases in addition 

to the Market / Symbol information.  

 Icon Panel - Equipped with icons to gain easy access to some of the 

available functions. This lets you access the functions with a click of 

button rather than going through the menu to access them.   

 Menu Bar - The main menu 

Note: 

  * Please note that the availability of the options may defer depending on 

your subscription. 

 

RELATED INFORMATION:  

Exploring the Workspace 

Icon Panel 
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Panel 

Panel Options 

Workspace 

Viewing Entitlements 

 

 
Shortcuts to Functions  
 

INTRODUCTION  

Mubasher Pro is designed to be user friendly and gives you quick access to 

functions through the following; 

 

AVAILABLE SHORTCUTS  

Icon Panel 

Index Panel 

Hotkey Guide 

Navigator 

Right Click menus 

Mouse Gestures 

Mini-Toolbar 

 

RELATED INFORMATION:  

Exploring the Workspace 
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Icon Panel 
 

INTRODUCTION  

The list of icons in the icon panel are listed in the below table with a 

description of their functions. 

 

Table 1: Icon panel  

Icon Description 

 

Allows to exit after saving or without saving the current workspace 

settings. 

 

Connects to the Broker. Once connected if you want to disconnect 

from broker, click the disconnect  icon.  

 
Opens the Announcements window. 

 
Opens the Market Time and Sales window. 

 

Show or Hide a moving Ticker for symbols currently being Traded, 

when the Market is Open. 

 
Opens ProChart window. 

 

Enables you to change the language allowing you to view the 

application in the language of your choice (The available languages 

depend on the Mubasher Pro version). 

 

RELATED INFORMATION:  

Shortcuts to Functions 
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Index Panel 
 

INTRODUCTION  

The Index Panel displays market summary information from a single 

exchange or from multiple exchanges. Mubasher Pro provides you the 

flexibility to customize the Index Panel as required. 

 

The options available will differ depending on your subscription. 

Regional Users 

 

Show / Hide Index Panel: 

You can show/hide the Index panel any time using the icons given next to 

the icon panel as shown below: 

 
Show Index Panel Icon 

 
Hide Index Panel Icon 

 

 

RELATED INFORMATION:  

Shortcuts to Functions 
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Regional 
 

INTRODUCTION  

Users with one or more Regional Markets (E.g.: Dubai Financial Market) in 

their subscription will be able to view the Index Menu Panel.  

 

PROCEDURE  

To view the Index Menu Panel simply click on the  icon from the Index 

Panel. Listed below are the options available in the Index Menu Panel. 

 

Show Main Index Panel 

Show Stretched Index Panel  

Show Symbol Panel  

Index Graph Panel  

 

 

 

RELATED INFORMATION:  

Shortcuts to Functions 
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Show Main Index Panel 
 

INTRODUCTION  

The Show Main Panel option can be used to view a market summary of a 

selected Exchange.  

  

PROCEDURE  

To view the Main Panel: 

 From the Select Panel menu (Click the Select Panels icon to open) > 

Select Show Main Panel. The Main Panel is displayed (See Figure 1). 

 

Figure 1 - Main Panel 

 

 

To Change the Exchange: 

 Right Click on the Exchange Name > Select required Exchange. 

The date, time and market status is displayed for the selected 

exchange. 

 

Note: 

  The Exchange list includes non default markets, giving you the ability to view 

details as required. 

 

To select the Index: 

 Right Click on the Index name > Select required Index (The index list 

includes all indices of the selected Exchange.) 

The Value, Change and % Change is displayed for the selected Index. 
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View Commodity prices from the Panel 

You can view the global prices of leading commodities such as Oil, Gold, 

Silver and Forex Rates etc. through the main panel.  

 Click on the area as indicated in figure 2 below. The list displayed 

includes the list of available commodities in addition to Net Cash % and 

% Cash Map. Select one of the commodities to display the commodity 

and its price in the Main Panel. 

 

Figure 2 - Main Panel with commodity list open 

 

 

To view % Cash Map: 

 Click on the area as indicated in figure 2 given above > Tick the % 

Cash Map option. This displays the % Cash Map for the selected 

Exchange.  

Note: 

  % Cash Map represents the Cash In percentage from the total turnover 

([Cash In/(Cash In + Cash Out)]*100). The cash in and cash out percentages 

are represented graphically, where the green area represents the Cash In 

percentage and the red area represents the Cash Out percentage. 

 

Figure 3 - Main Panel with % Cash Map 
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Index Forecast: 

Note: 

  This feature is available only for Indices of the Saudi Stock Market. 

 

A forecast is provided during market Pre-Open time to help investors of 

the Saudi Market to grab the opportunity to be a market gainer and to 

avoid any losses. It predicts what the change for the selected index will be 

at market open based on the opening price of all the symbols in the index. 

Predicted figures are displayed for Value, Change and % Change. The 

word forecast is given in front of the index name to indicate that the 

displayed figures are forecasted values (See Figure 4). Note that this 

forecasted values are available only at market pre-open time and is 

displayed only till market opens. 

 

Figure 4 - Main Panel with forecast values during market pre-open time 

 

 

This forecast is also displayed in the Index Graph Panel at market pre-

open time. 

 

RELATED INFORMATION:  

Shortcuts to Functions 

Panels 
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Show Stretched Index Panel 
 

INTRODUCTION  

The Show Stretched Index Panel option can be used to view a 

maximized version of the index Panel. The Intraday graph for selected 

index is displayed when the market is open as shown in the diagram 

below.   

 

PROCEDURE  

To view Stretched Index Panel: 

 From the Index Menu Panel menu > Select Show Stretched Index 

Panel. This displays the Stretched Index Panel (See Figure 1) 

Figure 1 - Maximized Index Panel 

 

 

To revert back to the default view (minimized view) (See Figure 

1): 

 From the Index Menu Panel menu > Select Show Main Index Panel 

 
 
 

Figure 1 - Default View – Minimized view (Main Index Panel) 

 

 

RELATED INFORMATION:  

Shortcuts to Functions 

Index Panel 
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Show Symbol Panel 
 

INTRODUCTION  

Using the Show Symbol Panel feature, you can add up to five 

Symbols/Indices from the same exchange or multiple exchanges 

(depending on your subscription) and monitor the market at ease. 

 

PROCEDURE  

To view Index Panel in Show Symbol Panel mode (See Figure 1): 

 From the Index Menu Panel menu > Select Show Symbol Panel 

 

Figure 1 - Show Symbol Panel mode 

 

 

To revert to the default view (minimized view): 

 From the Index Menu Panel menu > Select Show Main Index Panel 

 

To Add a Symbol / Index to a Panel: 

1. Click on the Click here to add a Symbol area (See Figure 1). The 

Symbol Search window opens. 

2. In the Symbol Search window, you may search for the required 

Symbol / Index. 

3. Click on OK button to add the symbol to the panel. 

RIGHT CLICK OPTIONS   

Show Symbol Panel – Right Click options 
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The following Right Click Menu options are available within the Show 

Symbol Panel Mode: 

 Detail Quote 

This displays the Detail Quote window for the relevant Symbol / Index. 

  Tip:  

  You may also view the Detail Quote for the symbol /index in the panel by 

clicking on the required symbol/index. 

 

 Open Chart 

This option displays the graph for the selected symbol / Index (Intraday 

and Historical data of the selected Symbol / Index in a Graphical 

Presentation). 

 

 Change Symbol 

This option allows you to replace the existing Symbol / Index with a 

different Symbol / Index. 

 

RELATED INFORMATION:  

Shortcuts to Functions 

Index Panel 
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Index Graph Panel 
 

INTRODUCTION  

Use the Index Graph option to view the Intraday Graph of a selected 

Index in any subscribed Exchange. 

 

PROCEDURE  

To view a graph in the Index Graph Panel: 

1. From the Index Panel options menu > Select Index Graph menu. 

The Index Graph Panel is displayed (See Figure 1). 

2. In the Index Graph Panel, select the required Index and the 

Intraday graph is displayed accordingly. 

 

Note: 

  The Intraday graph is plotted using the value of each trade for the day. The 

highest and lowest values for the day are indicated as shown in figure 1 

below. 

 

Figure 1 - Index Graph Panel 

 

To Change the Exchange: 

 Click on the Exchange Name > Select required Exchange. 

The date, time and market status is displayed for the selected 

Exchange. 
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Note: 

  The exchange list includes non default markets, giving you the ability to 

view details as required. 

 

To select the Index: 

 Right Click on the Index name > Select required Index (The index list 

includes all indices of the selected Exchange.) 

The Value, Change and % Change is displayed for the selected index. 

 

To revert to the default view (minimized view): 

 From the Index Panel options menu > Select Show Main Index Panel. 

 

Index Forecast: 

Note: 

  This feature is available only for Indices of the Saudi Stock Market. 

 

A forecast is provided during market Pre-Open time to help investors of 

the Saudi Market to grab the opportunity to be a market gainer and to 

avoid any losses. It predicts what the change for the selected index will be 

at market open based on the opening price of all the symbols in the index. 

Predicted figures are displayed for Value, Change and % Change. The 

word forecast is given in front of the index name to indicate that the 

displayed figures are forecasted values (See Figure 3). Note that this 

forecasted values are available only at market pre-open time and is 

displayed only till market opens. 
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Figure 3 - Main Index Panel with forecast values during market pre-open time 

 

 

This forecast is also displayed in the Main Index Panel at market pre open 

time. 

 

RELATED INFORMATION:  

Shortcuts to Functions 

Index Panel 

 
 
Hotkey Guide  
 

INTRODUCTION  

Mubasher Pro has a wide range of pre-defined Hotkeys to give you quick 

access to important functions. Listed here, is the list of Hotkeys, with a 

description of its function. 

 

HOTKEYS  

Table 1: Hotkeys and the functions 

Hotkey Functions 

F1 Help 

Mubasher Pro Online Help Guide. 

F2 Market Time & Sales 

Displays a pop up to select the Exchange to view Time and Sales 

details. 

F3 Graph Presentation  
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Displays Chart for the selected Symbol. 

F4 Snap Quote 

Displays Snap Quote for the selected Symbol. 

F5 Market Depth By Price (Best 5) 

Displays the market Depth by Price window for the selected 

symbol.  

F6 Market Depth By Order (Best 10) 

Order Book Details By Order for the selected Symbol. 

F7 Market Indices  

Displays Market Indices. 

F8 Full Quote 

Displays Full Quote for a selected symbol. 

F9 Buy Order 

Displays Buy Order window. 

F10 Sell Order 

Displays Sell Order window. 

F11 Account Summary 

Displays Account Summary. 

F12 Order List 

Displays Current Order List.  

CTRL + N Connects to the Price Server (if not connected already). 

CTRL + F Configure  

Opens the Configure window.  

CTRL + O Open  

Opens a Workspace. 
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CTRL + E Save Workspace As 

Allows you to save a Workspace with a different file name. 

CTRL + P Page Setup 

Opens the Page Setup window. 

CTRL + B Trade Login 

Opens the trade login window to login to the trade server. 

CTRL + T Exit 

Exits Mubasher Pro. 

  

 

Note: 

  Hotkeys F9, F10, F11, F12 and CTRL + B work only if you have a Trading 

Enabled Account. 

 

RELATED INFORMATION:  

Shortcuts to Functions 
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Navigator  
 

INTRODUCTION  

Mubasher Pro gives you a Navigator with some frequently used Hotkeys 

neatly arranged on it. This gives you quick access to important functions 

without opening them from Full Market / Watch List windows.  

The Navigator can be invoked by simply pressing any key on the 

keyboard.   

 

PROCEDURE  

In the Navigator panel, you can simply type the Symbol and then click on 

the relevant function on the Hotkey panel, or press the relevant hotkey 

from the keyboard to invoke the selected feature for the symbol entered.  

 

Figure 1 - Navigator 

 

 

Symbol Entry Syntax  

The syntax of typing your symbol in the Navigator varies depending on the 

exchanges you have subscribed to and the markets in the exchanges. 

 Symbol Entry Syntax (General)  

 

Simply type in the Symbol Code. 

E.g.: GOOG 

 

 Symbol Entry Syntax for Markets with sub markets 

 

Certain markets have sub markets. In such cases the syntax is different; 

please enter the details in the following manner. Symbol`Market Code. 

 

E.g.: Listed below are few examples from the Kuwait Stock Exchange 

(KSE): 



© 2002-2010 DirectFN Ltd Page 62 

 
 

 ABK`R (for KSE exchange with Symbol ABK, Regular Market) 

 ABK`O (for KSE exchange with Symbol ABK, Odd Lot Market) 

 ABK`F (for KSE exchange with Symbol ABK, Forward Market) 

 

Once you have entered the symbol and exchange details, click on the 

relevant function on the Hotkey panel, or press the relevant Hotkey from 

the keyboard. 

Note: 

   Hotkeys F9, F10, F11 and F12 work only if you have a Trading Enabled 

Account. 

 

RELATED INFORMATION:  

Shortcuts to Functions 

 



© 2002-2010 DirectFN Ltd Page 63 

 
 

Right Click menu 
 

INTRODUCTION  

Mubasher Pro gives you quick access to a vast range of functionality via 

Right Popup menus. The Right Popup menu is the popup which appears 

when you  Right Click on a specific window Area, while selecting a Symbol 

or an Index. 

 

 

Mubasher Pro provides you with the following Right Click menu 

options: 

Right Click menu - Functions 

Right Click menu - Watch List options 

Right Click menu – General options 

Right Click menu – Heading options 

Right Click menu – Value Added Services 

 

RELATED INFORMATION:  

Shortcuts to Functions 
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Mouse Gestures 
 

INTRODUCTION  

Use Mouse Gestures to get quick access to certain vital functions in the 

application. 

Mouse Gestures are simple movements made using the mouse or other 

pointing device (E.g.:Touch Pad, Track Ball). When applied, a line is drawn 

in the workspace area (known as a gesture line - as shown below) and the 

relevant window / function is displayed on the screen. 

 

PROCEDURE  

To access a function / window using Mouse Gestures: 

1. Select the required symbol from the relevant market data window 

E.g.:Watch List 01. 

2. Press and hold the right mouse button and drag the pointer as 

required to draw the required gesture. The available gestures are given 

in the table below. The relevant function window is displayed. 

 

Listed in the table below are the Mouse Gestures that are available 

in the application: 

Table 1: Mouse Gestures 

Mouse 

Gesture 

Function / 

Window 

activated 

Gesture Line 

(the direction 

is as shown 

by the arrow) 

Drag the 

pointer from 

left to right  

Displays the 

Intraday Graph 

for the selected 

symbol 

 

Drag the 

pointer from 

right to left 

Displays the 

History Graph for 

the selected 

symbol 
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Drag the 

pointer from 

top to 

bottom  

Displays the Cash 

Flow Detail 

Quote for the 

selected symbol 

 

Drag the 

pointer from 

bottom to 

top  

Displays the Time 

& Sales window 

for the selected 

symbol 

 

Drag the 

pointer from 

bottom to 

top and then 

left  

Displays the 

Special Order 

Book window for 

the selected 

symbol 

 

Drag the 

pointer from 

bottom to 

top and then 

right  

Displays the 

Order Book 

Calculator 

window for the 

selected symbol 

 

 

RELATED INFORMATION:  

Shortcuts to Functions 
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Mini-Toolbar 
 

INTRODUCTION  

Mubasher Pro provides you some important functions via the Mini-

Toolbar. This toolbar is available in most windows with  tabular data.  The 

table below lists the icon and the respective functions. For details refer to 

General Options in this help.  

 

Table 1: Mini Toolbar 

Mini-Toolbar 

icon 

Functions 

 
You can customize the Font Type of the data 

displayed in the  selected window.  

 
You can customize the Font Size of the data 

displayed in the  selected window.  

 Increase the Font Size. 

 Decrease the Font Size. 

 Bold the text in the displayed window. 

 Italicize the text in the displayed window. 

 
Once you customize the font settings, use the 

Default icon to reset it to the default font setting. 

 Copy data. 

 Link to Excel. 

 Customize displayed currency. 

 Customize displayed decimal places. 

 Filter data in the displayed window. 

 
Customize the selected window. E.g.: Font size, 

Colour, Grid lines etc. 
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Column Settings. Here you can add and remove 

the required column from windows such as Full 

Market / Watch List. 

 Customize Cell selection. 

 Hides/Shows the title of the selected window. 

 Re-size Columns to Fit. 

 

RELATED INFORMATION  

Shortcuts to Functions 

Right Click menus > General Options  

 
 

Customizing the Application 
 

INTRODUCTION  

Mubasher Pro lets you customize all major areas of Mubasher Pro such as 

colours & font of any window to give your own look and feel, as well as 

work with a workspace of your choice, or choose your window layout style.  

 
 

TOPICS IN THIS SECTION  

To learn more about customizing Mubasher Pro: 

Customizing Themes 

Customizing Workspaces 

Customizing Windows 

Changing Windows Settings 

Customizing Columns 

 

RELATED INFORMATION:  

Exploring the Workspace 
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Customize Themes 
 

INTRODUCTION  

Mubasher Pro gives you a variety of themes to suit your taste and mood. 

Using the Themes option you can change the theme colour of the 

windows, workspaces and pop-ups in Mubasher Pro.  

 

PROCEDURE  

To apply a different theme:  

1. Go to Customize menu > Select Themes option. 

2. Select the theme of your choice from the themes list. 

 

RELATED INFORMATION:  

Customizing the Application 
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Customize Workspaces 
 

INTRODUCTION  

Using Mubasher Pro you can save as many workspaces as you wish and 

display any one of them on the screen according to your requirement 

(See: Save your Workspace). 

 

PROCEDURE  

To select a workspace of your choice: 

 Go to Customize menu > Workspaces > Select the required 

workspace. 

 

  Tip:  

  You can set any workspace as default by selecting the Make Default 

Workspace option from the File menu. 

 

RELATED INFORMATION:  

Customizing the Application 

Managing Workspaces 
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Preferences 
 

INTRODUCTION 

The options available under the Preferences menu lets you customize the 

application as required. 

 

TOPICS IN THIS SECTION  

Performance Optimizing - Bandwidth Optimizer 

Change Language 

Change Mubasher Pro Options 

Change Chart Options 

 

RELATED INFORMATION:  

Customizing the Application 
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Optimizing Performance 
 

INTRODUCTION  

There are several ways to optimize the performance of Mubasher Pro to 

reduce the time delays between the client and the Mubasher server.  

 

TOPICS IN THIS SECTION  

Bandwidth Optimizer - Use this when whole sectors/Exchanges have to be 

disabled.  

Selecting Disable from Right Click Menu - Use this if you require only a few 

symbols disabled.  

Data Delay - Use this to rectify data delays that occur due to network 

connectivity problems or high network traffic. 

 

RELATED INFORMATION:  

Preferences 
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Bandwidth Optimizer 
 

INTRODUCTION  

Use the Bandwidth Optimizer option to optimize the performance of 

Mubasher Pro. You can disable an exchange, a sector and/or its symbols 

as preferred. Once disabled, data feeds will not flow through for the 

disabled Exchanges/Sectors/Symbols thereby saving the bandwidth and 

increasing the performance of the application. This in turn reduces 

unnecessary time delays.  

 

PROCEDURE  

To use the Bandwidth Optimizer: 

Method 1 - From the Tools menu 

1. Go to Customize menu > Preferences > Select Bandwidth 

Optimizer option. The Bandwidth Optimizer window opens (See 

Figure 1). 

 

Figure 1 - Bandwidth Optimizer window 
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2. In the Bandwidth Optimizer window, Select the Exchange / Sector 

you want to disable. This would disable all symbols in the selected 

Exchange/Sector.  

3. If only selected symbols in the sector is to be disabled, click the + sign 

next to the relevant sector and tick the required symbols from the list.  

4. Click the OK button. 

 

Method 2 - Automatic Pop-Up 

When the time delay between the Mubasher server and the client exceeds 

one minute due to high traffic or connectivity problems an error message 

will appear asking if you want to Optimize the Bandwidth. When this 

appears click the OK button. This will take you to the Bandwidth Optimizer 

window. In the Bandwidth Optimizer window follow steps 2, 3 & 4 as given 

above.  

 

  Notes:  

  You can select the Show All, Show Enable and Show Disable options as 

you wish to filter the data displayed in the Bandwidth optimizer window 

(See Figure 1). 

 Show All - Will display both enabled and disabled symbols 

 Show Enable - Will display all enabled symbols 

 Show Disable - Will display all disabled symbols, if any. 

  Disabled symbols are highlighted in grey in the Watch Lists. 

 

RELATED INFORMATION  

Optimizing Performance 

Preferences 

Mubasher Pro Tools 

 



© 2002-2010 DirectFN Ltd Page 74 

 
 

Disable option 
 

INTRODUCTION  

You can disable preferred symbols directly from the Watch List Right-Click 

menu using the method below; this method is best suited if you want to 

disable only one or two symbols of the Watch List. For whole 

Sectors/Exchanges to be disabled the Bandwidth Optimizer option should 

be used.  

 

PROCEDURE  

To disable a symbol: 

1. Open the required Watch List / Market Watch window. 

2. Right Click on required symbol. 

3. Go to the Right Click menu > Select Disable option. 

 

To reactivate a disabled symbol: 

 To reactivate the disabled symbol, Go to the Right Click menu > Select 

Enable option. 

Notes: 

  Disabled symbols are highlighted in grey colour in the Watch List.  

  The Disable option is available only for symbols of default markets. 

 

RELATED INFORMATION  

Optimizing Performance 

Bandwidth Optimizer 

Preferences 

Mubasher Pro Tools 
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Data Delay 
 

INTRODUCTION  

There can be instances when there is a delay in receiving data from the 

Mubasher server due to network connectivity problems or high network 

traffic. An automatic pop-up window is displayed as a result (See Figure 

1). Click the OK button when this pop-up is displayed and Contact 

Customer Support through any of the following methods; 

Via Live Chat 

Contact the Help desk 

 

Figure 1 - Automatic data delay pop-up message 

 

 

RELATED INFORMATION  

Optimizing Performance 

Bandwidth Optimizer 

Preferences 

Mubasher Pro Tools 
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Change Language 
 

INTRODUCTION  

Mubasher Pro supports many languages, allowing you to view the 

information in the language of your choice. Once you change the language 

you must close and re-open the application for the language change to be 

effective. 

When the application is installed and loads for the very first time, you are 

prompted to select the default language. However, if you wish to change 

the default language again, you may use the Change Language option. 

  

PROCEDURE  

To switch between languages: 

Method 1 

 Go to Customize menu > Preferences > Change Language > Select 

the Language of your choice. 

 

Method 2 

 Select the Switch Language icon   in the Icon Panel.  

Note: 

  The languages supported depend on your Mubasher Pro version. 

 

RELATED INFORMATION  

Preferences 

Mubasher Pro Tools 
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Change Mubasher Pro Options 
 

INTRODUCTION  

Using the Options window, you will be able to toggle several important 

options in Mubasher Pro. 

 

PROCEDURE  

To open the Options window: 

 Go to the Customize menu > Preferences sub-menu > Select 

Options. This will open the Options window as in Figure 1. 

 

Figure 1 - The Options window 

 

 

The following options are available in the Options window: 

Time Zones 

Select Language 

Auto Scroll Interval 
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Hide News Indicator 

Auto Scrolling 

Arabic Numbers 

Show Tab Panel 

Show Alias 

Show Min & Max 

Show 52Wk High & Low 

Combined Order Book 

Popup New Announcements 

Save Time and Sales on Exit 

Put to Same Layer 

Dual Screen Mode 

 

TIME ZONES 

Using Time Zones option you can set a different time zone for the 

subscribed exchanges. By default the system sets each exchange with the 

respective time zone. If you are in a different time zone and wish to set 

the time accordingly, you can do so using this feature. 

 

SELECT LANGUAGE 

Mubasher Pro supports many languages, allowing you to view the 

information in the language of your choice. Once you change the language 

you must close and re-open the application for the language change to be 

effective. 

When the application is installed and loads for the very first time, you are 

prompted to select the default language. However, if you wish to change 

the default language again, you may choose from the Select Language 

drop-down. 
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AUTO SCROLL INTERVAL 

You can select the Auto Scroll Interval using this option. The values 

range from one (1) to fifteen (15) seconds. This should be selected only of 

the Auto Scrolling option is turned on. 

 

HIDE NEWS INDICATOR 

You can select to hide the News Indicator appearing in Watch lists using 

this option. The values available range from 10 minutes to 4 hours. Select 

'never' if you do not want to hide the indicator. This is selected by default. 

 

AUTO SCROLLING 

The Auto Scrolling option automatically plays a highlighted bar on all 

open Full Market / Watch List windows. This feature is recommended for a 

non-interactive mode usage where the terminal is typically used by several 

people. 

 

ARABIC NUMBERS 

Mubasher Pro gives you the flexibility to display Arabic numbers in both 

English and Arabic modes. 

 

SHOW TAB PANEL 

The Tab Panel is located at the bottom of the application (above the 

Bottom Panel). When enabled, it can be used to identify the minimized 

windows within the Application workspace. Hence, using the Show Tab 

Panel option, you can show / hide the tab panel.  

 

SHOW ALIAS 

When you have created Aliases for securities listed in Watch Lists or 

Market View Windows using the Edit Alias option, you  have the option of 

displaying the Alias created by you instead of the description provided by 

the Server using the Show Alias option.  
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SHOW MIN & MAX 

Use the Show Min & Max feature to highlight the symbols in Watch Lists 

to indicate if they have reached the minimum /  maximum price for the 

day. The symbols are highlighted in Red / Green as given below; 

 Minimum Price (If the last trade price of the symbol has reached the 

minimum price) - The row is highlighted in Red and font colour is 

Black. 

 Maximum Price (If the last trade price of the symbol has reached the 

maximum price) - The row is highlighted in Green and font colour is 

Black. 

 

SHOW 52 WK HIGH & LOW 

Use the Show 52Wk High & Low feature to highlight the symbols in 

Watch Lists to indicate if they have reached the highest / lowest price in 

52 weeks. The symbols are highlighted in Red / Green as given below; 

 

 52 Week Low (The stock has reached the lowest price in 52 weeks) - 

The row is highlighted in Red and font colour is White. 

 52 Week High (The stock has reached the highest price in 52 weeks) - 

The row is highlighted in Green and font colour is White. 

 

COMBINED ORDER BOOK 

The Combined Order book feature gives you the Bid orders, Offer orders 

and Price for the best 5 levels and is available when the market is open. 

Thereafter the Market Depth by Price is displayed in the Combined 

Order Book mode (See Figure 2). (To open Market Depth By Price, Go to 

Right click menu of selected symbol > Select Market Depth by Price).  
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Figure 2 - Market Depth By Price in Combined Order Book mode 

 

 

The following details are available in Market Depth by Price when 

Combined Order book option is enabled (See Figure 2): 

Bid Splits - Number of orders at each bid price level. 

Bid Qty - This is the cumulative quantity offered under each of the bid 

price. 

Price - This is the bid price level. 

Offer Qty - This is the cumulative quantity offered under each of the offer 

price. 

Offer Splits - Number of orders at each offer price level. 

 

For easy reference of information all bid information is highlighted in 

Green and the offer information is highlighted in Pink. 

 

POPUP NEW ANNOUNCEMENTS 

If you wish have the Announcement window to pop up with the latest 

announcements, you can enable this option. 

 



© 2002-2010 DirectFN Ltd Page 82 

 
 

SAVE TIME AND SALES ON EXIT 

Depending on how you wish to view the Time and Sales information, you 

have the following options to choose from: 

 

 When the Save Time & Sales on Exit option is enabled: 

The Time and Sales information available for the day is loaded every 

time the application is re-opened. 

 When the Save Time & Sales on Exit option is disabled: 

The Time and Sales information is available only from the moment the 

application was opened.  

 

E.g.: If the application was closed and re-opened during the market 

open / pre-open times, you will notice that Time and Sales information 

would be missing from the time the data initially was downloaded. 

 

PUT TO SAME LAYER 

You can select to open all windows in the same layer. When many 

windows are open at one time clicking on any window brings it to the front 

when this option is selected.  

 

DUAL SCREEN MODE 

You can enable Dual Screen Mode in Mubasher Pro using this options. For 

information on how to configure your display settings and a description of 

Dual Screen Mode, see Configure Screen Settings. 

 

RELATED INFORMATION  

Preferences 
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Change Chart Options 
 

INTRODUCTION  

You can Change the options related to ProChart from within Mubasher Pro 

using the Chart Options window. 

 

PROCEDURE 

To go to the Chart Options window: 

 Go to the Customize menu > Preferences sub-menu > Select Chart 

Options. This will open the Chart Options window as in Figure 1. 

Figure 1 - Chart Options window 

 

 

For more information on changing chart options, see the Setting Chart 

Preferences section in the ProChart Help. 

 

RELATED INFORMATION  

Preferences 
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Customize Windows 
 

INTRODUCTION  

Mubasher Pro‟s Customize option allows you to customize the colours, 

sizes, fonts, grids, highlighter, text and headings for all types of windows 

and the main board. 

 

PROCEDURE  

To view Customizer window (See Figure 1):  

Method 1 

 Right Click anywhere on the window. Go to Right Click menu > Watch 

List Options > Select Customize option. The Customizer window 

opens. 

Method 2 

 Right Click on the column header of the window > Go to Right Click 

menu > Select Customize option. The Customizer window opens. 

Method 3 

 Right Click on a selected window > Click the Customize icon  on the 

mini toolbar. The Customizer window opens. 
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Figure 1 - The following Customize options are available in most windows: 

 

 

Note: 

  The above screenshot applies for the Customizer window when it is opened 

through the Watch List and Market Watch windows. The layout of the screen 

is different when opened through other windows. 

 

TOPICS IN THIS SECTION  

Customize Main Board Font 

Customize Table Headers 

Customize Line Spacing 

Apply Grid & Customize Columns 

Apply Customizations 
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Customize Main Board Font 
 
INTRODUCTION  

You can customize the Main Board Font of a window. 

 

PROCEDURE  

To customize the main board: 

Method 1 

1. Right Click anywhere on the window. Go to Right Click menu > Watch 

List Options > Select Customize option. The Customizer window 

opens. 

Method 2 

1. Right Click on the column header of the window > Go to Right Click 

menu > Select Customize option. The Customizer window opens. 

Method 3 

1. Right Click on a selected window > Click the Customize icon  on 

the mini toolbar. The Customizer window opens. 

 

In the Customizer window: 

2. Click on the Main Board Font option. The Select a Font window 

opens.  

3. In the Select a Font window, specify the Font Type, Size, and Style. 

4. Click on the OK button to apply your customization to the selected 

window (See: Apply Customizations). 

 

RESET TO ORIGINAL SETTINGS 

Use this option to revert the font settings of the window to the default 

setting.  
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PROCEDURE  

If you change the Main Board font setting of any window using the 

Customizer window, you have the option of setting it back to the default 

setting. 

To restore windows settings to default: 

1. Go to Right Click menu > Select the Default icon  from the mini 

toolbar. 

Note: 

  Only the Main Board Font will be restored to the default setting. The header 

font cannot be set back to the default setting. 

 

RELATED INFORMATION:  

Customizing Windows 

Customizing the Application 
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Customize Table Headers 
 
INTRODUCTION  

You can customize the Table Header Font of a window. 

 

PROCEDURE  

To customize the table header font of a window:  

Method 1 

1. Right Click anywhere on the window. Go to Right Click menu > Watch 

List Options > Select Customize option. This displays the 

Customizer window. 

Method 2 

1. Right Click on the column header of the window > Go to Right Click 

menu > Select Customize option. This displays the Customizer 

window. 

Method 3 

1. Right Click on a selected window > Click the Customize icon  on 

the mini-toolbar. This displays the Customizer window. 

 

In the Customizer window: 

2. Click on the Table Header Font option. This displays the Select a 

Font window.  

3. In the Select a Font window, specify the Font type, Size and Style. 

4. Click on the OK button to apply your customization to the selected 

window (See: Apply Customizations). 

 

RELATED INFORMATION:  

Customizing Windows 

Customizing the Application 
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Customize Line Spacing 
 
INTRODUCTION  

You can customize the Row Height of a window. 

 

PROCEDURE   

To customize the row-height of a window:  

Method 1 

1. Right Click anywhere on the window. Go to Right Click menu > Watch 

List Options > Select Customize option. This displays the 

Customizer window. 

Method 2 

1. Right Click on the column header of the window > Go to Right Click 

menu > Select Customize option. This displays the Customizer 

window. 

Method 3 

1. Right Click on a selected window > Click the Customize icon  on 

the mini toolbar. This displays the Customizer window. 

 

In the Customizer window: 

2. Click on the Line Spacing drop down and select the required line 

height (0 to 10).  

3. Click on the OK button to apply your customization to the selected window 

(See: Apply Customizations). 

 

RELATED INFORMATION:  

Customizing Windows 

Customizing the Application 
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Apply Grid & Customize colours 
 
INTRODUCTION  

You can customize the Grid of a window. 

 

PROCEDURE   

To customize a window’s Grid:  

Method 1 

1. Right Click anywhere on the window. Go to Right Click menu > Watch 

List Options > Select Customize option. This displays the 

Customizer window. 

Method 2 

1. Right Click on the column header of the window > Go to Right Click 

menu > Select Customize option. This displays the Customizer 

window. 

Method 3 

1. Right Click on a selected window > Click the Customize icon  on 

the mini toolbar. This displays the Customizer window. 

 

In the Customizer window: 

1. Click on the Enable Custom Settings option. This applies grid lines to the 

selected window. 

 

In the Basic tab: 

2. You can customize the grid lines by selecting an option from the drop down 

list.  

 Both - Apply vertical and horizontal grid lines.  

 Vertical - Apply only vertical grid lines. 

 Horizontal - Apply only horizontal grid lines. 
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 None - Disable grid lines. 

4. Click on the Colour Palette option corresponding to the required feature, to 

get the Colour Palette window.  

5. In the Colour Palette window, you can navigate between Pre-defined, HSB 

and RGB colours. Select the desired colour from the relevant tab. 

6. Click on the OK button to apply your customization to the selected window 

(See: Apply Customizations). 

Use the Table Settings section to customize the row colours as required.  

 

In the Advanced tab of the Custom Settings: 

Using the advance tab you can customize the cell colours and the font 

colours of selected values in the selected Watch List / Market Watch 

window. 

To change the font and cell colours of min, max, 52 Wk Low and 52 Wk 

High prices, select the required option by ticking the corresponding box 

and change the colours using the respective colour palette windows.  

1. Click on the Colour Palette option corresponding to the required feature, to 

open the Colour Palette window.  

2. In the Colour Palette window, you can navigate between Pre-defined, HSB 

and RGB colours. Select the required colour from the relevant tab. 

3. Click on the OK button to apply your customization to the selected window 

(See: Apply Customizations). 

Note: 

  To set it back to the default state after you apply custom settings to your 

windows, Open the Customizer window > Disable the Enable Custom 

Settings option. 

 

RELATED INFORMATION:  

Customizing Windows 

Customizing the Application 
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Apply Customizations 
 

INTRODUCTION  

You can choose which windows to apply the customizations to, upon 

changing the settings. 

 

PROCEDURE  

To Apply Customizations: 

1. Do the required changes in the Customizer window. 

2. In the Apply To section of the Customizer window, there are three 

options to choose from, which decide which windows the customizations 

will apply to; 

 This Window Only - Selecting this option would change the settings 

for the window that was chosen to be customized.  

E.g. : If you selected to customize WatchList 01, the customizations 

will apply only to WatchList 01 

 All Opened Windows - Changes will be applied to all windows of 

this type (All Watch list windows and Volume Watcher window) that 

are open at the time, but not windows that are opened subsequently. 

E.g. : If WatchList 01, WatchList 02 and two Conditional WatchList 

windows are open, changes are applied to all four windows. 

 All Windows - Changes will be applied to all windows of this type 

(All Watch list windows and Volume Watcher window) that are 

currently open and when opened subsequently.  

E.g. : If only WatchList 01 was open at the time the customization 

was done, and WatchList 02 is opened afterwards, WatchList 02 will 

have the same custom settings specified in the Customizer window. 

3. Click the OK button to apply the changes. 

RELATED INFORMATION:  

Customizing Windows 

Customizing the Application 
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Changing Windows Settings 
 

INTRODUCTION  

Mubasher Pro gives you the facility to determine the layout of the windows 

in your workspace, depending on your requirement.  The following are 

options available within Mubasher Pro. 

 

Change Windows Layout Style  

Detach a Window 

 

CHANGE LAYOUT  

You can set the Window Layout Style depending on your requirement. The 

available layouts include Cascade, Tile, Tile Horizontally and Tile Vertically. 

To change the layout of the displayed windows: 

1. From Windows menu > Select Cascade/Tile/Tile Vertically/Tile 

Horizontally. 

2. The windows are arranged on the workspace accordingly. 

Note: 

  The default window layout is Cascade. 

 

 
DETACH A WINDOW  

Most windows within the application are detachable. 

To detach a window from the application: 

 Click on the Detach  icon located on the top of the window. Once 

detached it is displayed as a separate window on the taskbar.  

Note: 

   A Detached window, when minimized remains as a separate window on the 

taskbar. 
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Restoring a window back to its normal state after detaching: 

For options and features available through the main menu:  

To restore a detached window all you have to do is close the window. Once 

closed, the window will be in attached mode in the application. (For E.g.: 

Market Summary window, Market Indices window etc.)  

 

Note: 

  When these windows are in detached mode and if the application is closed 

with the workspace saved and the same workspace is reopened the detached 

window will be closed.  

 

Right Click menu options: 

To restore the detached window you have to close it and open the window 

again through the application. (For E.g.: Detail Quote, Snap Quote, Market 

Depth By Price etc) 

 Click  to Close the detached window > re-open it through application. 

 

Note: 

  When one of these windows are in detached mode and you save your 

workspace and close the application, when re-opened with the same 

workspace the detached window will be displayed in attached mode. 

 

 

RELATED INFORMATION:  

Customizing the Application 

Customizing Windows 
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Watch List Customization 
 

INTRODUCTION  

You can customize your custom Watch Lists as well as the Market Watch 

and Market sector Watch Lists as per your requirement. The options 

available to you are as follows; 

 

MOVE SYMBOLS IN A WATCH LIST  

To move symbols within a Watch List: 

You have the option of moving the symbol position of selected symbols in 

a Watch List. 

1. Select the symbol. Click on the selected symbol and while having the 

mouse button pressed down press CTRL key on your keyboard. 

2. Drag and drop the symbol to the position required. 

 

ADJUST WATCH LIST COLUMNS  

To Drag and Adjust Watch List Columns: 

You can move the position of columns in Watch Lists by clicking on the 

required column header and dragging it to the required position. 

 

RELATED INFORMATION:  

Customizing the Application 
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Managing Workspaces 
 

INTRODUCTION  

Using Mubasher Pro, you can have more than one workspace and you can 

load the workspace of your choice, whenever you wish. When you load 

Mubasher Pro for the first time, the default workspace is loaded. 

Thereafter, you can create new workspaces and load them at any given 

time.  Furthermore, you can set the frequently used workspace as default. 

 

TOPICS IN THIS SECTION  

Open your Workspace 

Save Workspace 

Make your workspace default 

 

RELATED INFORMATION:  

Exploring the Workspace 
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Open Your Workspace 
 

INTRODUCTION  

You can open a previously created workspace at any given time. 

 

PROCEDURE  

To open a saved Workspace: 

Method 1 - using File menu 

1. Do one of the following and the Open Workspace dialog box is 

displayed: 

 Go to File menu > Select Open option. OR 

 Press Ctrl + O. 

 

In the Open Workspace dialog box: 

2. Select the required workspace.  

3. Click on the Open button. 

 

Method 2 - using Customize menu 

1. Go to Customize menu > Select Workspaces option. 

2. This displays the list of workspaces you have created before. 

3. Select the required workspace you wish to load. 

 

  Tip:  

  If you wish to revert to the default Workspace, go to Customize menu > 

Workspaces > Select Default option. 

 

RELATED INFORMATION  

Managing Workspaces 
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Save Your Workspace 
 

INTRODUCTION  

Once you have made the required changes to the workspace, you need to 

save it if you wish to use it later. 

 

PROCEDURE  

To save all changes to your current workspace: 

 Go to File menu > Select Save option. OR 

 Press Ctrl + S keys. 

  

To save your workspace with a new name / different location: 

1. Do one of the following and the Save Workspace As dialog box is 

displayed: 

 Go to File menu > Select Save As option. OR 

 Press Ctrl + E keys. 

2. In the Save Workspace As dialog box, give any File Name / 

Location you need and click on Save button. 

 

  Tip:  

  Your saved workspace will appear with the extension .wspx 

 

RELATED INFORMATION  

Managing Workspaces 
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Make Your Workspace Default  
 

INTRODUCTION  

Using this option, you can make a required workspace load when you 

connect to the application. 

 

PROCEDURE  

To specify a default workspace to load every time you connect to 

the system: 

1. Go to Customize menu > Select Workspaces > Select the required 

workspace from the list. This loads the required workspace. 

2. Next, go to File menu > Select Make Default Workspace option. 

Note: 

  You can manually set a default workspace only if you have one or more saved 

workspaces. However, if only one workspace is present, the Make Default 

Workspace option is disabled and system loads the default workspace. 

 

 

RELATED INFORMATION  

Managing Workspaces 
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View Entitlements 
 

INTRODUCTION  

Using the Entitlements option, you can view details of the features and 

exchanges that are available along with your current subscription. You 

may change these entitlements anytime by upgrading your subscription. 

(For further information regarding this contact the Help Desk). 

 

PROCEDURE  

To view Entitlements: 

Method 1 

 Go to Help menu> Select Entitlements option.  

 

Method 2 

 Click on the Account Expiry Date message* displayed on the Bottom 

Panel of the application to view the Entitlements window (See Figure 

1). 
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Figure 1 - Workspace with the Entitlements window opened by clicking the Account Expiry details 

 

 Notes: 

  

*The Account Expiry Date message will be displayed in red 7 days 

before your account expires and you have to renew your subscription to 

continue using Mubasher Pro after the indicated date. 

  
Entitlements that you have will be grouped under several types. Click on 

the  icon to expand the entitlements that are grouped into a type. 

  
The Common Features group contains features common to all 

exchanges subscribed via Mubasher Pro. 

  
The Groups named after Exchanges, when expanded, show type of data 

available for the selected exchange (e.g.: Market Depth, Time and 
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Sales). 

  
Your Entitlements, (depending on your subscription) are indicated by 

ticks. 

 

RELATED INFORMATION  

Exploring the Workspace 

 

 
 
Accessing Real Time Market Data 
 

INTRODUCTION  

Mubasher Pro provides you with the most interactive tools to monitor 

Market movements via customizable Watch Lists, and real-time 

performance information of markets. 

Using Mubasher Pro‟s Watch Lists and Market Watch options, you can 

track performances of multiple symbols from multiple markets, or an 

entire Market, from a single interface. 

 
 
TOPICS IN THIS SECTION  

Watch Lists 

Watch List - Right Click Menus 

Mubasher Pro Options 

Value Added Services 
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Watch Lists 
 

INTRODUCTION  

This section covers the types of Watch Lists available through Mubasher 

Pro. 

 

TOPICS IN THIS SECTION  

Create Watch Lists - Create your own Watch Lists to keep track of symbols 

as required.  

Market Watch - Allows you to watch the market movements of all 

subscribed exchanges in one screen. Market movements can be viewed in 

two modes.  

Market Sectors - Gives you the facility to monitor Stock Market Sectors 

and allows you to see the movements of different sectors of selected 

exchanges. 

Custom Watch Lists 

Watch List and Market Watch Indicators 

Column Definition Guide 

 

RIGHT CLICK MENUS  

Mubasher Pro gives you quick access to a vast range of functionality via 

Right Click menus. The Right Click menu is the popup which appears when 

you Right Click the mouse on a specific window area. The functions 

available differ according to the type of Watch List.  

 

Mubasher Pro provides you with the following Right Click menu 

options: 

Right Click menu - Functions - Common to Watch Lists and Market Watch 

windows.  
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Right Click menu - Watch List options - Unique to your personalized Watch 

Lists.  

Right Click menu – General options - Common to both Watch Lists and 

Market Watch windows 

Right Click menu – Heading options - Common to both Watch Lists and 

Market Watch windows 

Right Click menu – Value Added Services - Common to both Watch Lists 

and Market Watch windows 

 

 

QUICK ACCESS TO FUNCTIONS   

You have quick access to certain functions through the Watch List Columns 

as given below. When you double click on each Column a function window 

will be displayed.  

 

 To open New Order window 

If you have trading enabled when you double click on the columns Bid, 

Bid Qty, Offer and Offer Qty for the selected symbol the Place Order 

window will be displayed.  

If trading is not enabled the Market Depth By Price window is displayed 

when you double click on these columns. 

 

 To open the Cash Flow Detail Quote window 

Select symbol > Double click on  % Cash Map, Net Money Flow, Bid 

Trades Turnover, Offer Trades Turnover, Bid Trades Volume, Offer 

Trades Volume, Bid Trades and Offer Trades columns.  
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 To open the Market Depth by Price window 

When trading is not enabled when you click on certain columns the Market 

Depth By Price window is displayed. If trading is enabled the New Order 

window is displayed when you double click on these columns. 

Select symbol > Double click on Bid, Bid Qty, Offer and Offer Qty 

columns.  

 

 To open Detail Quote window 

Double clicking on any column other than the ones given above will open 

the Detail Quote window.  

 

 To open the Graph window 

Select symbol > Double click on OHLC column. 

 

Tip: 

  To move symbols up and down within a watch List, simply select the symbol 

> Press the CTRL key > drag and drop the selected symbol to the position 

required while keeping the CTRL key pressed.  

  To Drag and Adjust Watch List Columns: 

You can move the position of columns in Watch Lists by clicking on the 

required column header and dragging it to the required position. 

 

RELATED INFORMATION:  

Accessing Real Time Market Data 

Watch List Customization 
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Market Watch 
 

INTRODUCTION  

Market Watch allows you to watch the market movements of all subscribed 

exchanges in one screen. Market movements can be viewed in Full 

Market and Today Traded mode.  

 

Full Market mode displays trade information for all the symbols of a 

selected Stock Exchange.  

Today Traded mode displays all symbols that have traded on the current 

day for a selected Stock Exchange. 

You can access these modes from the Watch List menu where all the 

subscribed exchanges are displayed.  

 

PROCEDURE 

To view an Exchange in the required mode: 

 Go to Watch List menu > Select Market Watch option> Select an 

Exchange > Select Full Market / Today Traded as required.  

Figure 1- Full Market 
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Figure 2 - Today Traded 

 

 

Tips: 

  You can easily identify which mode was loaded by looking at the title bar of 

the respective window. 

  When you double click on certain Columns of Watch Lists a function window 

will be displayed. Please refer to the section given under Watch List topic for 

more information.  

  To move symbols up and down within a watch List, simply select the symbol 

> Press the CTRL key > drag and drop the selected symbol to the position 

required while keeping the CTRL key pressed.  

 

 

RELATED INFORMATION  

Watch Lists 

Market Sectors 

Accessing Real-Time Market Data 
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Market Sectors 
 

INTRODUCTION  

Mubasher Pro gives you the facility to monitor Stock Market Sectors and 

allows you to see the movements of different sectors of selected 

exchanges. You can view movements of multiple sectors of multiple 

exchanges at any given time. 

View Market Sectors 

View Sector Overview 

 

PROCEDURE  

VIEW MARKET SECTORS 

 Go to Watch List menu > Select Market Sectors option > Select 

required Exchange > Select the required Sector (E.g.: Agricultural) 

(See Figure 1). 

 

Tip: 

  To move symbols up and down within a watch List, simply select the symbol 

> Press the CTRL key > drag and drop the selected symbol to the position 

required while keeping the CTRL key pressed.  

  When you double click on certain Columns of Watch Lists a function window 

will be displayed. Please refer to the section given under Watch List topic for 

more information.  
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Figure 1 - Market Sector window 

 

 

 

VIEW SECTOR OVERVIEW 

 Go to Watch List menu > Select Market Sectors > Select required 

Exchange > Select Sector Overview option. This displays the Sector 

Overview window for the selected Exchange (See Figure 2).  

 

Figure 2 - The Sector Overview window 

 

 

RELATED INFORMATION  

Watch Lists 

Accessing Real Time Market Data 
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Custom Watch Lists 
 

INTRODUCTION  

Egyptian users will be able to view and access custom Watch lists termed 

EGX70, EGX30, EGX100, T+0, GDR symbols and OTC symbols. These 

Watch Lists come with pre-defined symbols. You can add and remove 

Symbols from these Watch lists and also rename them if required. 

 

The following custom Watch Lists are available: 

 EGX70 - Is an Index in the Egyptian Stock Exchange and this Watch List 

includes all symbols of this index. 

 EGX30 - Is an Index in the Egyptian Stock Exchange and this Watch List 

includes all symbols of this index. 

 EGX100 - Is an Index in the Egyptian Stock Exchange and this Watch 

List includes all symbols of this index. 

 T+0 - Includes symbols of the Egyptian Stock Exchange for which the 

settlement date is T+0. 

 GDR Symbols - The GDR symbols Watch List includes symbols that are 

listed and traded in the London Stock Exchange (LSE). As these symbols 

are traded at the LSE, trading hours of these GDR symbols depend on 

the open and closing times of LSE. By default the data for GDR symbols 

is delayed by 15 minutes and if you want to subscribe to see real time 

GDR data please contact customer support. (A Global Depositary Receipt 

or GDR is a security issued by a Depository Bank in place of the foreign 

shares (issued by an Egyptian issuer) held in trust by that bank. This 

facilitates the trading of those Egyptian shares in the form of GDRs by 

international investors, on global markets). 

Note: 

  If you use Mubasher Pro as a delayed user and want to log in as a real time 

user, you must first delete the existing user profile data to be able to view 

GDR symbols in the GDR Symbols Watch List. User profile data files can be 

found in the Mubasher installation directory. 
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In windows Vista -  

C:\Users\<user name>\AppData\Roaming\Mubasher\Mubasher Pro 

9\MetaStock 

In Windows 7 -  

C:\Users\<user name>\AppData\Roaming\Mubasher\Mubasher Pro 

9\MetaStock 

In windows XP -  

C:\Documents and Settings\<user name>\Application 

Data\Mubasher\Mubasher Pro 9\MetaStock 

**In the above given paths, <user name> is your computer user name. 

  For GDR symbols Watch List, all columns that have data are given by default 

when the Watch List is opened. Data will not be displayed for any other 

column you add through the column settings option to this Watch List. 

 OTC Symbols - The OTC (Over the Counter) symbols Watch List 

includes some predefined symbols which are traded over the counter. 

 

RELATED INFORMATION:  

Watch Lists 
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Create Watch Lists 
 

INTRODUCTION  

This section guides you on how you can create Watch Lists as required. 

Create a personalized Watch List with your favorite symbols as required or 

create Conditional Watch Lists using the options available in Mubasher Pro.  

 

TOPICS IN THIS SECTION  

Create a Personalized Watch List 

Create Conditional Watch Lists 

 

RELATED INFORMATION:  

Accessing Real Time Market Data 

Watch Lists 

Watch List Customization 
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Personalized Watch List 
 

INTRODUCTION  

Mubasher Pro comes with two pre-created Watch Lists termed Watch List 1 

and Watch List 2 and also gives you the ability to create new Watch Lists. 

Both the pre-created and user defined Watch Lists, are displayed under My 

Stocks in the Watch List menu.  You can add and remove Symbols and 

Indexes from these Watch Lists. Though they are pre-created, you can 

also delete or rename these Watch Lists. One Watch List can have symbols 

from one or many Exchanges giving you the ability to keep track of your 

favorite symbols as required.  

 

TOPICS IN THIS SECTION  

Create a Watch List 

Add Symbols to a Watch List 

Remove symbol  

Right Click menu - Watch List options 

 

RELATED INFORMATION:  

Create Watch Lists 

Accessing Real Time Market Data 
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Create a New Watch List  
 

INTRODUCTION  

You may create your own Watch List using one of the following methods. 

 

PROCEDURE  

To Create a Watch List: 

Method 1 

 Go to File menu > Select New option > Select Watch List option. The 

Create New View window opens. 

 

Method 2 

 Go to Watch List menu > Select My Stocks option > Select New 

option. The Create New View window opens. 

 

In the Create New View window: 

1. Enter the new Watch List‟s Name and select the Type from the Select 

Type drop down menu. The columns available by default in the watch 

list you create depends on the type selected here. You can add more 

columns to your watch list, using the Column Settings option.  

The views in the Select Type* drop down menu can be described as 

follows: 

 Bond Market View - Contains columns relevant to the Bond 

Market. e.g.: Date of issue, Maturity Date. 

 Mutual Fund View - Contains columns relevant to Mutual Funds. 

e.g.: Yearly Risk, Fund Size. 

 Graphical View - Contains columns which are in Graphical 

Format e.g.: % Spread Map, % Range Map, OHLC. 

 Cash Flow View - Contains columns with Cash Flow information 

e.g.: Bid Trades, Bid Trades Turnover, Offer Trades, Offer trades 

Turnover. 
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 Index View - Can be used to see information relevant to 

Indices. Contains columns such as Last, Total Volume and 

Turnover. 

 Equity View - These are normal Watch Lists. This is selected by 

default. Contains the most commonly used Columns.  

 Full Market View - Contains default columns available for the 

Egyptian market.  

* The options available in Select Type depends on your subscription. 

2. Click on the OK button. 

3. Upon specifying a new name, the new Watch List is added in the My 

Stocks sub option in the Watch List menu and an empty Watch List is 

displayed on your workspace. 

  Note: 

  You can add and remove symbols to the newly created Watch List according 

to your requirement. Mubasher Pro gives you the facility to Add a Single 

Symbol or to Add Multiple Symbols to your Watch Lists, in one go. The 

symbols added can be from a single exchange or from multiple exchanges. 

Tip: 

  When you double click on certain Columns of Watch Lists a function window 

will be displayed. Please refer to the section given under Watch List topic for 

more information.  

 

RELATED INFORMATION  

Creating a Personalized Watch List 

Add Symbol to Watch List 
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Add Symbols to Watch List 
 

INTRODUCTION  

Since Watch List 1 and Watch List 2 are pre-created, all you have to do is 

to add the symbols of your choice to it and they are ready to be 

monitored. Mubasher Pro gives you the facility to Add a Single Symbol or 

to Add Multiple Symbols to your Watch Lists, in one go. The symbols can 

be added from a single exchange or from multiple exchanges.  

Add a Single Symbol 

Add Multiple Symbols to your Watch Lists using symbol search 

 

PROCEDURE  

ADD A SYMBOL 

1. Select and open the required Watch List.   

 

Figure 1 - Adding symbols to Watch List in Edit Mode 

 

 

2. In the Watch List window, simply click on the symbol column of an 

empty row to activate the Edit Mode (See Figure 1). 

3. In the Edit Mode, enter the required Symbol Code. E.g.:DIC in the 

space provided and press Enter key. 
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If you have entered the symbol code correctly, it will be added to the 

Watch List. 

 

Tips: 

  You can also search for the required symbol code when in Edit Mode, 

simply click on the drop down and the Symbol Search window is displayed. 

  You can move symbols up and down within a watch List simply by selecting 

the symbol and dragging it to the position required while keeping the CTRL 

key pressed.  

 

 

ADD SYMBOLS USING SYMBOL SEARCH 

Using the Symbol Search feature, you can search for the required symbol 

and then add it to the Watch List. The symbol search method should be 

used if you want to search and add multiple symbols to the Watch List in 

one go. 

To search and add a symbol to a watch list:  

1. Open the required Watch List and Right Click on it. 

2. Go to Right Click menu > Select Add Symbols option. The Symbol 

Search window opens.  
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1. Specify the Symbol / Description, Exchange and Type. 

 Specify symbol details by entering the required symbol code / 

company name. 

 Select the relevant Exchange from the Exchange drop-down menu 

(Selecting ALL will include all subscribed Exchanges). 

 Specify the instrument type by selecting from the options below in the 

Type drop-down menu (Selecting ALL will include all instrument types). 

The following instrument types maybe available to you: 

 Quote 

 Index 

 Options 

 Mutual Fund 

 Forex 

2. Click on the Search button.  

3. Once the search is complete the symbols found are displayed in the 

results area.  

4. Select symbols from the search results and add them to your Watch 

List.  

Notes: 

  To add symbols to your selection: 

1. Click on the symbol, or range of symbols that you are interested in. 

2. Click on the  button. This will include the symbols in the selected 

list. 

  To remove symbols from your selection: 

1. Click on the company or range of companies that you want to remove. 

2. Click on the  button. This will remove the symbols from your 
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selection. 

 

5. Click on the OK button. 

Note: 

  You may click on the required Column Heading to sort the data in Ascending 

or Descending order. However, if you perform a search using the Exchange 

and Type fields (as shown in the above), by default the search results appear 

with S.Description sorted in Ascending order. Adding multiple Indexes to a 

Watch List can be carried out in the same manner. 

 

Other methods to add symbols to your Watch List include: 

Send to Watch List 

Drag and Drop from the Sidebar 

 

RELATED INFORMATION  

Creating a Personalized Watch List 

Add Symbols to Watch Lists 

Remove Symbols 

Manage Watch List 

 
 
 
Remove Symbol  
 

INTRODUCTION  

Mubasher Pro gives you the facility to Remove a Single Symbol or to 

Remove Multiple Symbols from your Watch Lists, in one go. The symbols 

removed can be from a single exchange or from multiple exchanges. 

Removing Symbols and Indexes from the pre-created Watch Lists and the 

user defined Watch Lists can be carried out in the same manner. 

 



© 2002-2010 DirectFN Ltd Page 120 

 
 

To Remove a Single Symbol: 

1. Open the required Watch List and right click on the required symbol. 

2. Go to Right Click menu > Select Remove Symbol option. 

3. A Confirmation Message is displayed. 

4. Click on the Yes button. 

To Remove Multiple Symbols:  

1. Open the required Watch List and select the range of symbols 

required*. 

2. Right click on the selected symbols. 

3. Go to Right Click menu > Select Delete option. 

4. A Confirmation Message is displayed. 

5. Click on the Yes button. 

Tips: 

  *To select multiple symbols in a Watch List,  

Method 1: Select a symbol > Click and Drag the mouse up or down to 

highlight and select the data rows required. 

Method 2: Select a symbol > Press shift key and select the required 

rows using the up & down arrow keys. 

RELATED INFORMATION  

Creating a Personalized Watch List 
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Manage Watch List via Right Clcik menu 
 

INTRODUCTION  

Mubasher Pro provides you with the following Right Click menu options to 

manage Watch Lists created by you: 

Add Symbols to Watch Lists 

Remove Symbol 

Send to Watch List 

Change View Name 

Delete View  

Decimal Places 

Unsort 

 

 

SEND TO WATCH LIST  

You can send symbols from Full Market / Watch List / Conditional Watch 

List windows, to another Watch List / Conditional Watch List window. 

 

To Send to Watch List: 

1. Open  Full Market / Watch List / Conditional Watch List window 

> Select required symbol and Right Click on it.  

2. Go to the Right Click menu > Select Send to Watch List option. 

3. Select the required Watch List to add the symbol to.  

The selected symbols will be added to the Watch List selected. 
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CHANGE VIEW NAME  

You can rename a Watch List at any given time.  

 

To rename a Watch List: 

1. Open the relevant Watch List from the Watch List menu > Right 

Click on your Watch List. 

2. Go to the Right Click menu > Select Change View Name option (See 

Figure 1).  

 

Figure 1 - Rename Watch List 

 

 

Note: 

  When you rename a Watch List, you need to specify a new name and an 

existing Watch List name cannot be used.  

 

DELETE VIEW  

You can delete a Watch List with symbols, at any given time.  

 

To delete a Watch List: 

1. Open the relevant Watch List from the Watch List menu > Right 

Click on your Watch List. 

2. Go to the Right Click menu > Select Delete View option.  

3. This displays a Confirmation Message.  

4. Click on the Yes button. 
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DECIMAL PLACES  

You can change the number of decimal places for your numerical data on 

your Full Market / Watch List windows. By default, Mubasher Pro displays 

two decimal places, for all Watch Lists windows. However, you can change 

the Decimal Places using the Right Click option.  

 

To change the number of decimal places: 

1. Open the relevant Watch List from the Watch List menu > Right 

Click on your Watch List. 

2. Go to the Right Click menu > Select Decimal Places  option > Select 

the number of decimal places as required.  

 

 

UNSORT  

Unsort is a feature used to reset the sorting order of a selected Watch List 

window to the default column order. 

 

To Unsort a Watch List window: 

1. Go to My Stocks. 

2. Open Watch List and Right Click on it. 

3. Go to Right Click menu > Select the Watch List option > Select the 

Unsort option. 

 

Note: 

  This feature is unique to the Watch List option and is not available in the 

Market Watch window. 

 

RELATED INFORMATION  

Create Watch Lists 
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Conditional Watch List 
 

INTRODUCTION  

You can create a Conditional Watch Lists to monitor symbols that match 

the criteria you require by applying conditions as required.  

 

 

TOPICS IN THIS SECTION  

Create a Conditional Watch List 

Edit Conditions 

Delete a Condition 

Delete a Conditional Watch List 

 

RELATED INFORMATION:  

Create Watch Lists 

Accessing Real Time Market Data 
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Create Conditional Watch List 
 

INTRODUCTION  

Follow the steps given below to create a Conditional Watch List . 

 

PROCEDURE  

To create a new Conditional Watch List: 

Method 1 

 Go to File menu > Select New option > Select Conditional Watch 

List. The Function Builder window opens.  

 

Method 2 

 Go to Watch List menu > Select Conditional Watch Lists option > 

Select New option. The Function Builder window opens.  

 

Figure 1 - Adding Conditions to Function Builder 
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1. Enter the Conditional Watch List Name. 

2. Click on the Add Condition link (See Figure 1). This opens the Add 

Condition window. 

3. In the Add Condition window, Specify the Exchange, Field, 

Condition and Value. 

4. Click on the OK button.  

5. Repeat steps 2 to 4 to add multiple conditions to the Function 

Builder.  

6. Click on the OK button in the Function Builder window to auto-load a 

Watch List which meets the condition/s specified.  

 

Note: 

  You cannot use Special Characters such as ~!#&*(),:;/ when creating a 

Watch List Name. 

 

RELATED INFORMATION  

Create Conditional Watch Lists 

Edit Conditions 

Delete a Condition 

Delete a Conditional Watch List 
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Edit Conditions 
 

INTRODUCTION  

You can Edit Conditions specified in a Conditional Watch List while creating 

the Conditional Watch List or after creating the Conditional Watch List. 

 

PROCEDURE  

Method 1: 

To Edit Conditions while Creating the Conditional Watch List: 

1. Click on the Edit icon  in the Function Builder. The Edit Condition 

window opens.  

 

Method 2 

To Edit Conditions from Conditional Watch List: 

1. Right Click on the Conditional Watch List. 

2. Go to Right Click menu > Select Edit Condition option. The Function 

Builder window opens.  

3. Click on the Edit icon  in the Function Builder. The Edit Condition 

window opens.  

 

Figure 1 - Editing Conditions in Edit Condition window 

 

 

4. In the Edit Condition window, Edit the Exchange, Field, Condition and 

Value in the Edit Condition window (See Figure 1). 
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5. Click on the OK button to add your new modified condition to the 

condition list.  

 

RELATED INFORMATION  

Create Conditional Watch Lists 

Delete Conditions 

 
 

Delete a Condition 
 

INTRODUCTION  

Once you have created conditions you can delete them as required.  

 

PROCEDURE  

To Delete Conditions from the Function Builder window: 

1. Click on the Delete icon  in the Function Builder window.  

2. When you click on the Delete button you will be prompted with a 

Confirmation Message.  

3. Click on the Yes button to delete the condition. 

 

Delete a Conditional Watch List (Delete View) 

 You can delete a Conditional Watch List along with its symbols and 

conditions at any given time. 

 

To delete a Conditional Watch List: 

1. Right Click on the Conditional Watch List. 

2. Go to Right Click menu > Select Watch List options > Select Delete 

View option.  
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  Tip:  

  If you Right click outside the symbols area, the Delete View option will 

be available as an option directly from the right click menu.  

3. This displays a Confirmation Message.  

4. Click on Yes button to delete the Watch List. 

 

 
 

RELATED INFORMATION  

Create Conditional Watch Lists 

Edit Conditions 

 

 
 
 

Column Definition Guide 
 

INTRODUCTION  

Tabled below is a brief introduction of the different columns / fields used with the application. 
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A 

Data 

Column 
Description Applicable to 

Action The price movement and volume of a stock or 

overall market. 

Order Search 

Order List 

Basket Orders 

Amount Quantity or value, as in a transaction or account 

balance. 

Deposit/ 

Withdrawal 

Status 

AMC Asset Management Company Full Market 

Asset 

Country 

Fund originated Ccuntry Full Market 

Avg. Cost Average cost of a security bought. (Share Price 

per stock + Commission per stock) 

Portfolio 

Simulator 

Portfolio 

Avg. Cost 

Share 

The average price spent for the particular set of 

shares. 

Order Search 

Avg. Price The average cost is found by taking the total cost 

of all the shares and dividing by the total number 

of shares owned. 

Order List 

Avg. 

Volume 

Average volume is the total volume for a selected 

period, divided by the number of trading days of 

the same period. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Back to Top 
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B           

     

Data Column Description Applicable 

to 

B.End 

Load 

Paid percentage to the Fund manager at the Mutual 

fund selling 

Full Market 

Watch List 

Balance The remaining value of that portfolio. Portfolio 

Bid The highest price a buyer is willing to pay for a stock 

in the market. When combined with the ask price 

information, it forms the basis of a stock quote. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Money flow 

Detail Quote 

Bid/Offer The ratio of the Bid price and the Offer price. Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Bid/Offer 

Map 

Graphical view of the Bid/offer value. Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Bid Qty The total number of shares available for buying (can 

be from multiple orders). 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Full Quote 

Market Depth 
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By Price 

Market Depth 

By Order 

Special Order 

Book 

Bid Price The price at which a buyer is willing to buy a 

security. 

 

Full Quote 

Market Depth 

By Price 

Market Depth 

By Order 

Special Order 

Book 

Book 

Keeper 

Keeping records of Trading and the transactions. Order Search 

Order List 

Basket 

Orders 

Bollinger 

Lower 

This is one of the most popular technical analysis 

techniques (A type of a Bollinger Band & Charting 

Indicator). The closer the prices move to the lower 

band, the more oversold the market. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Bollinger 

Middle 

This is one of the most popular technical analysis 

techniques (A type of a Bollinger Band & Charting 

Indicator). A middle band being a N-period simple 

moving average. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Bollinger 

Upper 

This is one of the most popular technical analysis 

techniques (A type of a Bollinger Band & Charting 

Indicator). The closer the prices move to the upper 

band, the more overbought the market. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Buy Date Buying date of a Mutual Fund. Full Market 
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Watch List 

Conditional 

Watch List 

Sector Watch 

Buy 

Pending 

The total amount spent to buy the shares in that 

portfolio, that has not executed yet. 

Portfolio 

 

Back to Top 

C           

   

Data Column Description 
Applicable 

to 

Cash 

Dividends 

A dividend/distribution that is paid in cash to 

stockholders, normally out of the corporation's 

current earnings or accumulated profits.  

Portfolio 

Simulator 

Cash Flow 

Index 

Cash in as opposed to Cash Out. (Cash In/Cash 

Out) 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

% Cash Map % Cash Map represents the Cash In percentage 

from the total turnover ([Cash In/(Cash In + Cash 

Out)]*100). The cash in and cash out percentages 

are represented graphically, where the green area 

represents the Cash In percentage and the red 

area represents the Cash Out percentage. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Chaikin AD An oscillator created by subtracting a 10-day EMA 

(Exponential Moving Average) from a 3-day EMA of 

the accumulation/distribution line. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 
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Watch 

Chg./Change The difference of price between the current price 

and the previous close price. (Last Price - Previous 

Close) 

Full Market 

Market 

Indices 

Top Stocks 

Symbol 

Trading 

Summary 

Market Time 

& Sales 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Full Quote 

Company 

Name 

Name of the company which represent that symbol. Symbol 

Trading 

Summary 

Commission A service charge assessed by a broker or 

investment advisor in return for providing 

investment advice and/or handling the purchase or 

sale of a security.  

Order 

Search 

Order List 

Company 

Code 

The short description name for a given symbol. Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Portfolio 

Simulator 

Portfolio 

Conv. Rate The Currency conversion rate. (Symbol currency to Portfolio 
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Portfolio Simulator currency) Simulator 

Portfolio 

Cost Basis The cost for the stocks.  [(Avg. Cost * 

Quantity)]*Conv. Rate 

Portfolio 

Simulator 

Portfolio 

Currency The currency which the price data are shown. (Eg:-

egp for Egypt) Currency is the basis for trade. 

Portfolio 

Simulator 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Portfolio 

Order List 

Deposit/ 

Withdrawal 

Status 

% Change The percentage change. The percentage of the 

difference between the last price and previous 

closed price divided by the previous closed price. 

[(Last Price -Previous Close)/Previous Close]*100.  

 

 

Full Market 

Market 

Indices 

Top Stocks 

Symbol 

Trading 

Summary  

Market Time 

& Sales 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Full Quote 

% Change The percentage change in graphical format. Full Market 
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Map Percentage change = [(Last Price -Previous 

Close)/Previous Close]*100.  

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Back to Top 

 

D 

Data 

Column 
Description 

Applicable 

to 

Daily 

Margin Due 

The amount daily basis which has exceeded the 

percentage of the purchase price of securities (that 

can be purchased on margin) that the investor 

must pay for with his or her own cash or 

marginable securities. 

Portfolio 

Date The current date. News 

Order Search 

Order List 

Basket 

Orders 

Description The name of the security. Alert 

Manager 

History 

Analyzer 

Top Stocks 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Order Search 

Order List 
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Disclosed The released relevant information. Order List 

DOWNs Shows number of securities with negative price 

change for the day. 

Market 

Summary 

Daily Market 

Summary 

Back to Top 

 

E 

Data 

Column 
Description Applicable to 

EPS Earnings Per Share. The portion of a company's 

profit allocated to each outstanding share of 

common stock. EPS serves as an indicator of a 

company's profitability. 

 

 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

End Price The closing price. History Analyzer 

Exchange A marketplace in which securities, commodities, 

derivatives and other financial instruments are 

traded.  

Announcements 

Portfolio 

Simulator 

Alert Manager 

History Analyzer 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Order Search 

Portfolio 

Order List 

Basket Orders 
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Expiry 

Date/ Exp. 

date 

The date at which an option contract expires. 

This means that the option can't be exercised 

after that date. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Alert Manager 

EXP M. Avg. A type of moving average that is similar to a 

simple moving average, except that more 

weight is given to the latest data. It is known as 

"exponentially weighted moving average." 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Back to Top 

F 

Data 

Column 
Description 

Applicable 

to 

F. End 

Load 

Minimum amount to be bought at the MFD (Mutual 

Fund) buying. 

Full Market 

Watch List 

Fast 

Stochastic 

The fast stochastic oscillator compares two lines called 

the %K and %D lines to predict the possibility of an 

uptrend or a downtrend. In price charts, the %K line 

typically appears as a solid line, and the %D line 

appears as a dotted line. The fast stochastic oscillator 

can be used effectively to monitor daily, weekly or 

monthly periods. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Field Field of use - Restrictions that are placed on a license 

granted for the use of an existing patent. Field of use 

restrictions limit the use of a patent to a certain 

industry, or even a specific product. These restrictions 

aim to protect patents against overuse or reckless 

use, and are a factor in the fees that are charged to 

patent licensees. 

Alert 

Manager 
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Filled 

Quantity 

The total number of orders which is in the status 

“Filled”. 

Order 

Search 

Order List 

From Date The begin date of a selected time period. History 

Analyzer 

Fund Size Net asset value for MFD (Mutual fund) Full Market 

Watch List 

Fund 

Value 

The monetary value of a fund, calculated by adding up 

the value of its underlying assets/ The price of units in 

a unit trust, for instance, is worked out from the value 

of all its holdings in other quoted companies, adding 

them together, and dividing the sum by the number 

of units issued. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Back to Top 

G 

Data 

Column 
Description 

Applicable 

to 

Gain/ Loss A gain or loss from a qualifying investment owned 

for longer than 12 months and then sold.  

Portfolio 

Simulator 

Portfolio 

Gain/ Loss 

(Today) 

A gain or loss from a qualifying investment owned 

for today. Gain or Loss as per Today‟s change 

(Change * Quantity holding) 

Portfolio 

Simulator 

Portfolio 

Good Till The period for which you want your order to be 

valid till.  

Order Search 

Order List 

Basket 

Orders 

% G/L A gain or loss from a qualifying investment owned 

for longer than 12 months and then sold as a 

Portfolio 

Simulator 
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percentage. Portfolio 

% G/L 

(Today) 

Gain or Loss as a percentage of average cost 

(Change/Avg. Cost)*100 

Portfolio 

Simulator 

Portfolio 

Back to Top 

H 

Data 

Column 
Description Applicable to 

High The Highest trade value of a particular symbol/ 

security executed during a trading session. 

 

Full Market 

Symbol Trading 

Summary  

History Analyzer 

Market Indices 

Watch List 

Conditional 

Watch List 

Sector Watch 

High A The Highest Ask value of a particular symbol for a 

given time frame. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Holding The total number of shares in a portfolio Portfolio 

Simulator 

% 

Holding 

Stock valuation as a percentage of the Total 

(Stock Valuation/Total Valuation)* 100 

Portfolio 

Simulator 

Portfolio 

Back to Top 
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I 

Data 

Column 
Description 

Applicable 

to 

Index A statistical measure of the state of the stock market, 

based on the performance of stocks.  

Market 

Indices 

IMI The IMI (intraday momentum index) is a ratio of the 

total magnitude of the up day candle bodies to the 

total magnitude of the down day candle bodies over 

the past x-days.  

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

ISIN 

Code 

International Securities Identification Number, a 12-

digit code used to uniquely identify securities.  

 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Back to Top 

 

J 

There are no terms that begin with this letter 

Back to Top 

K 

There are no terms that begin with this letter 

Back to Top 
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L 

Data 

Column 
Description Applicable to 

Last Price at which the symbol was last traded (the 

most recent trade in a particular security) at a 

given time frame. 

Full Market 

Top Stocks 

symbol Trading 

Summary 

Watch List 

Conditional 

Watch List 

Sector Watch 

Last Bid 

Price 

 

The last price which the symbol has bids for, at 

given time frame. A market maker will buy shares 

at this price provided quantity does not exceed 

market size. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Last Bid 

Qty. 

The quantity of the last bid of a given symbol. Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Last 

Offer 

Price 

The last price which the symbol has offers for, at 

given time frame. A market maker will sell shares 

at this price provided quantity does not exceed 

market size. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Order List 

Last 

Offer 

Qty. 

The quantity of the last offer, of a given symbol. Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 
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Last Qty. The quantity traded at the given last traded price. Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Listed 

Shares 

Also called as Listed Stock. Total number of listed 

shares of the stock. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Lot Size Exchange permitted trading unit number. Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Low The Lowest trade value of a particular symbol/ 

security which executed during a trading session. 

Full Market 

Symbol Trading 

Summary Watch 

List 

Conditional 

Watch List 

Sector Watch 

History Analyzer 

Market Indices 

Low B The Lowest Bid value of a particular symbol for a 

given time frame. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Lowest 

Qty 

The minimum amount of shares available. Order List 

L.T. Date The date which a symbol has had the last trade. Full Market 
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Watch List 

Conditional 

Watch List 

Sector Watch 

L.T. Price The price which a symbol has traded in its last 

trade. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Back to Top 

M 

Data Column Description 
Applicable 

to 

MACD A trend-following momentum indicator that 

shows the relationship between two moving 

averages of prices. The MACD is calculated 

by subtracting the 26-day exponential 

moving average (EMA) from the 12-day EMA.  

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Margin Due The amount which has exceeded the 

percentage of the purchase price of securities 

(that can be purchased on margin) that the 

investor must pay for with his or her own 

cash or marginable securities. 

Portfolio 

Market Name of the Exchange. A place for the 

trading company stock, and derivatives of 

same; both of these are securities listed on a 

stock exchange as well as those only traded 

privately. Also can say as the name of 

exchange. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Full Quote 

Market Time 

and Sales 
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Market 

Summary 

Market Price A security's last reported sale price (if on an 

exchange) or its current bid and ask prices (if 

Over-the-Counter); i.e. the price as 

determined dynamically by buyers and sellers 

in an open market. Also called market value. 

Portfolio 

Max Price The maximum price at which the symbol can 

be traded. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Method The method/ way of transaction E.g. Cash, 

Bank Transfer, Cheque  

Deposit/ 

Withdrawal 

Status 

Min Price The minimum price at which the symbol can 

be traded. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Min.Init.Purchas

e 

Minimum initial purchase Watch List 

Mkt. Cap /1000 This is the company‟s total shares x last price 

divided by 1000. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Mkt. Price The last reported price at which a security Portfolio 
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was sold or the current quote. Simulator 

Mode A statistical term referring to the most 

frequently occurring term in a set of 

numbers. 

Alert 

Manager 

Money Flow 

Index 

A momentum indicator that is used to 

determine the conviction in a current trend 

by analyzing the price and volume of a given 

security.  

 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Mubasher ID The identification number issued by 

Mubasher. 

Order Search 

Order List 

Back to Top 

N 

Data 

Column 
Description 

Applicable 

to 

NAV A mutual fund's price per share or exchange-traded 

fund's (ETF) per-share value. In both cases, the per-

share dollar amount of the fund is derived by dividing 

the total value of all the securities in its portfolio, less 

any liabilities, by the number of fund shares 

outstanding. 

 

In terms of corporate valuations, the value of assets 

less liabilities equals net asset value (NAV), or "book 

value". 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Net Chg. The difference between the closing price of a security on 

the day's trading and the previous day's closing price. 

Net change can be positive or negative and is quoted in 

terms of dollars. This is what the newspaper stock 

History 

Analyzer 
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tables quote. 

Net 

Money 

Flow 

This is calculated using the following formula: 

Net Money Flow = (Bid Trades Turnover – Offer 

Trades Turnover ) 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

No 

Change 

Shows number of securities with no price change for the 

day. 

Market 

Summary 

Daily Market 

Summary 

No Of 

Bids 

The number of bids that a particular symbol has had, 

for a given time frame. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

No Of 

Offers 

The number of offers that a particular symbol has had, 

for a given time frame. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector 

Watch 

Back to Top 

O 

Data 

Column 
Description 

Applicable 

to 

Offer The lowest price at which someone is willing to sell 

the security. When combined with the bid price 

information, it forms the basis of a stock quote. The 

offering price is often the highest the buyer will pay to 

Full Market 

Watch List 

Conditional 

Watch List 
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purchase an asset and the lowest that the seller will 

accept. 

Sector Watch 

Money flow 

Detail Quote 

Offer 

Price 

The price at which a new or secondary distribution of 

securities is sold to investing public--also called 

"public offering price". 

Full Quote 

Market 

Depth By 

Price 

Market 

Depth By 

Order 

Special 

Order Book 

Offer 

Qty. 

The number of shares available for selling is called 

Offer Quantity. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Full Quote 

Market 

Depth By 

Price 

Market 

Depth By 

Order 

Special 

Order Book 

OHLC Short for "Open, High, Low, Close chart." This is a 

securities chart that clearly shows the opening, high, 

low and closing prices for a security. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Open 

The price of a security when market opens in the 

morning. An unexecuted order that is still valid or 

the start of trading on a securities exchange. 

Symbol 

Trading 

Summary 
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Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Market 

Indices 

Operator CPO - Persons or limited partnerships responsible for 

investing a commodity pool's assets in commodity-

futures and options positions. 

Alert 

Manager 

Open Buy A term used by many brokerages to represent the 

opening of a long position in option transactions. 

Portfolio 

Open Int. The net open positions of a futures or option contract. Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Open Sell A phrase used by many brokerages on the street to 

represent the opening of a short position in option 

transactions. 

Portfolio 

Order No The specific number assigned to the order.   Order Search 

Order List 

Order 

Quantity 

The total amount of stock in that order. Order Search 

Order List 

Order 

Value 

The market worth or estimated worth of shares in that 

particular order. 

Order List 

Owned Shares which are in the possession of a lender as a 

result of foreclosure or forfeiture. 

Portfolio 

Back to Top 
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P 

Data 

Column 
Description 

Applicable 

to 

P-B Ratio The Price-to-book ratio, or P/B ratio, is a financial 

ratio used to compare a company's book value to its 

current market price. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

P-E Ratio P/E Ratio - Float Quoted Market Value / Aggregate 

Earnings Pool. 

The relationship between a stock's price and its 

earnings per share 

  

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Pending The orders which are in the status “Pending”. The 

Orders which are not executed. 

Order Search 

Order List 

Pending 

Stocks 

Stocks that are pending in the portfolio. Portfolio 

Pledged The stocks that are transferred to a lender for the 

purpose of securing debt. The lender of the debt 

maintains possession of the pledged asset, but does 

not have ownership unless default occurs. 

Portfolio 

Portfolio A grouping of financial assets such as stocks, bonds 

and cash equivalents, as well as their mutual, 

exchange-traded and closed-fund counterparts. 

Portfolios are held directly by investors 

and/or managed by financial professionals. 

Deposit/ 

Withdrawal 

Status 

Portfolio 

No. 

The specific number assigned to the portfolio for 

identification.   

Portfolio 

Order List 

Prev. This is a value defined for a given symbol by the Full Market 
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Closed exchange, at the closing of particular trading day. 

This value is based on the last traded value of that 

symbol. 

Watch List 

Conditional 

Watch List 

Sector Watch 

Market 

Indices 

Price This is the market price for that specific symbol. Full Quote 

Time and 

Sales 

Summary 

Market Time 

and Sales 

Order Search 

Basket 

Orders 

Price 

ROC 

Price Rate of Change - A technical indicator that 

measures the percentage change between the most 

recent price and the price of "n" periods in the past. 

 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Provider The global information provider. The news 

agency provides text, graphics, video and pictures to 

subscribers around the world, including general and 

economic news. 

News 

Back to Top 

Q 

Data 

Column 
Description Applicable to 

Quantity The total number of 

stocks. 

Full Quote 

Time and Sales Summary 

Market Time and Sales 

Basket Orders 
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Back to Top 

R 

Data 

Column 
Description 

Applicable 

to 

Range A security's/ stock's, or the general market's, 

highest and lowest price in which it has traded over 

a specified time--usually a rolling 52 week time 

period.  

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Realized 

Gain/Loss 

Gain or Loss at the selling of stocks  

(Selling Price – Avg. Cost)*Selling Quantity 

Portfolio 

Simulator 

Rejected The orders which are in the status “Rejected”. Order Search 

Order List 

Reference The reference number for the relevant Deposit 

Notification or Withdrawal Request. 

Deposit/ 

Withdrawal 

Status 

Ref Price An interest rate benchmark upon which a floating-

rate security or interest rate swap is based.  The 

reference rate will be a moving index such as 

LIBOR, the prime rate or the rate on benchmark 

U.S. Treasuries.   

 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Reject 

Reason 

Reason to reject the relevant Deposit Notification or 

Withdrawal Request. 

Deposit/ 

Withdrawal 

Status 

RSI Relative Strength Index is a technical analysis 

indicator which measures the magnitude of gains 

over a given time period against the magnitude of 

losses over that period. This is done in an attempt 

to determine overbought and oversold conditions of 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 
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an asset.  

% Range Percentage of Difference between the highest trade 

and lowest trade price of a symbol.  

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

% Range 

Map 

The Graphical view of the percentage of the 

difference between the highest trade and lowest 

trade price, at a given time. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Back to Top 

S 

Data Column Description Applicable to 

% Spread Percentage of the the difference between the 

buying (bid) and selling (offer) price of the 

symbol.  

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

% Spread Map The Graphical view of the percentage of the 

difference between the buying (bid) and 

selling (offer) price. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

S. Avg. A A moving average that gives equal weight to 

each day's Ask price data. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

S. Avg. B A moving average that gives equal weight to Full Market 
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each day's Bid price data. Watch List 

Conditional 

Watch List 

Sector Watch 

Sector Name of the sector. Sector is an area of the 

economy in which businesses share 

the same or a related product or service. It 

is a group of securities in the same industry 

or market. 

Daily Market 

Summary 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Sell Pending The total amount of Sell orders in that 

portfolio which has not executed yet. 

Portfolio 

Sell Date Sell date of a mutual fund. Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Set Date Settlement Date is the date when a 

securities buyer must pay for a purchase or 

a seller must deliver the securities sold. 

Settlement must be made on or before the 

third business day following the transaction 

date in most cases. 

Alert Manager 

Side The Buy or Sell side of an order placed. Market Time and 

Sales 

Full Quote 

Simp. M Avg. A simple, or arithmetic, moving average 

that is calculated by adding the closing price 

of the security for a number of time periods 

and then dividing this total by the number of 

time periods. Short-term averages respond 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 
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quickly to changes in the price of the 

underlying, while long-term averages are 

slow to react. In other words, this is the 

average stock price over a certain period of 

time. 

Slow 

Stochastic 

The Stochastic Oscillator compares where a 

security's price closed relative to its price 

range over a given time period. Slow 

Stochastic is a type of Stochastic Oscillator 

variable %K Slowing Periods. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Source The original news source from which news 

items are retrieved. 

News 

Splits Number of Orders at each Bid/Offer Price 

level. 

Full Quote 

Market Depth By 

Price 

Market Time and 

Sales 

Splits (Bid 

Quantity) 

The number of orders placed at the quoted 

bid price (may be from multiple orders). 

Full Quote 

Splits (Offer 

Quantity) 

The number of orders placed at the quoted 

offer price (may be from multiple orders).  

Full Quote 

Spread The bid/offer spread. The difference between 

the buying (bid) and selling (offer) price of 

the same transaction/ a stock. 

Full Market  

Watch List 

Conditional 

Watch List 

Sector Watch 

Start Price The specific date defined the beginning a of 

certain time period. 

History Analyzer 

Status Status of Exchange i.e. pre-open, close, 

open, etc 

Market 

Summary 

Alert Manager 

Order Search 
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Order List 

Basket Orders 

Deposit/ 

Withdrawal 

Status 

Strike Price The price the owner of an option can 

purchase or sell the underlying security.  

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Sub Market The extension of the main market. Full Quote 

Market Time and 

Sales 

Subs Purchase Subsequent purchase, is the minimum 

amount of repurchasing funds 

Full Market 

Watch List 

Symbol A one-character to three-character, 

alphabetic root symbol/ unique Code used to 

denote a particular company/ security which 

are traded in the exchange. This is a unique 

ID assigned for trading purposes. 

Full Market 

Market Time & 

Sales 

Market Indices 

Top Stocks 

Portfolio 

Simulator 

Announcements 

Alert Manager 

Watch Lists 

Conditional 

Watch Lists 

Sector Watch 

History Analyzer 

News 

Symbol Trading 

Summary 

Full Quote 

Order Search 

Portfolio 

Order List 
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Basket Orders 

Market 

Summary 

Symbol 

Descriptions / 

S. Description 

The description of a symbol. Full Market 

Top Stocks 

Watch Lists 

Conditional 

Watch Lists 

Sector Watch 

Portfolio 

Simulator 

Portfolio 

Back to Top 

T 

Data Column Description Applicable to 

T. Value/ 

Turnover/ 

Value 

Traded 

Cumulative value of shares traded during the 

day. 

Market Summary 

Symbol Trading 

Summary 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Daily Market 

Summary 

Market Indices 

T. Volume The total amount of shares traded as at a 

given time. 

Full Market 

Symbol Trading 

Summary  

Daily Market 

Summary 

Watch List 

Conditional 

Watch List 
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Sector Watch 

Tick Price fluctuation (up/down/equal) of the most 

recent trade. 

Market Time and 

Sales 

Full Quote 

Time The time the symbol was traded. Market Time and 

Sales 

Announcements 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Full Quote 

Title The title of an announcement/news News 

Announcements 

To date The specific date that defines the end of a 

certain time period. 

History Analyzer 

Today’s 

Close 

Closing price is the final price at which a 

security is traded on a given trading day 

(Today). The closing price represents the most 

up-to-date valuation of a security, till trading 

commences again on the next trading day. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Tot. Asset Total number of assets Full Market 

Watch List 

Tot. Asset 

Date 

Total assets calculated date Full Market 

Watch List 

Tot. Bid Qty. The total quantity of all the bids for a given 

symbol at a given time frame. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 
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Total 

Gain/Loss 

Total Unrealized and Realized Gain or Loss 

(Unrealized Gain/Loss + Realized Gain/Loss) 

Portfolio 

Simulator 

Tot. Offer 

Qty. 

The total quantity of all the Offers for a given 

symbol at a given time frame. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Trades The number of securities traded for the day. Full Market 

Market Summary 

Top Stocks 

Daily Market 

Summary 

Watch List 

Conditional 

Watch List 

Sector Watch 

Time and Sales 

Summary 

Trend Arrow An indicator based on the difference between 

the previous change and the current change of 

given symbol. Shows an UP arrow for positive 

trends and DOWN arrow for negative trends. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Trig. Value The total value of orders which triggered. Alert Manager 

Triggered The triggered orders. Alert Manager 

Type The type of the order. Order Search 

Order List 

Basket Orders 

Deposit/ 

Withdrawal 

Status 

Back to Top 
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U 

Data Column Description Applicable to 

Unrealized 

Gain/Loss 

Gain or Loss at the buying of stocks  

[((Mkt. Price – Share Price)*Quantity) + 

Commission] *Conv. Rate 

Portfolio 

Simulator 

Portfolio 

% Unrealized 

G/L 

Percentage Gain or Loss at the buying of 

stocks  

(Gain or Loss per Stock/Avg. Cost)*100 

Portfolio 

Simulator 

Portfolio 

Ups Shows number of securities with positive 

price change for the day.  

Market Summary 

Daily Market 

Summary 

Back to Top 

V 

Data 

Column 
Description Applicable to 

Valuation The current worth of an asset or company. 

Valuation of the stocks at the market price [(Mkt. 

Price * Quantity)]*Conv. Rate 

Portfolio 

Simulator 

Portfolio 

Valuation 

Method 

The process of determining the current worth of an 

asset or company.  

History 

Analyzer 

Value Stated value is a value that is assigned to a stock 

for accounting purposes instead of being par 

value. Stated value has no relation to market 

price. 

Alert Manager 

Market Indices 

Volume Total Volume for the Index Stocks. The number of 

shares or contracts traded in a security or an 

entire market during a given period of time. 

Market Indices 

Top Stocks 

Daily Market 

Summary 

Market 

Summary 
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Symbol 

Trading 

Summary 

Volume 

Change % 

(Previous Volume – Last Volume)/Previous Volume Full Market 

Watch List 

VWAP Volume-Weighted Average Price, the ratio of the 

value traded to total volume traded over a 

particular time period. 

Market Time 

and Sales 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Full Quote 

Back to Top 

W 

Data 

Column 
Description 

Applicable 

to 

W. Avg. A A weighted average is any average that has 

multiplying factors to give different weights to 

different data points. W. Avg A is based on Ask price 

and Ask quantity. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

W. Avg. B A weighted average is any average that has 

multiplying factors to give different weights to 

different data points. W.Avg B is based on Bid price 

and bid quantity. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Weighted 

Index 

A type of market index whose individual components 

are weighted according to their market 

capitalization, so that larger components carry a 

larger percentage weighting.   

Market 

Indices 

Wgt. M. A type of moving average in which greater weight is Full Market 
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Avg. given to the latest data, and less weight is given to 

older data. 

Watch List 

Conditional 

Watch List 

Sector Watch 

Back to Top 

X 

There are no terms that begin with this letter 

Back to Top 

Y 

Data 

Column 
Description Applicable to 

Yearly 

Risk 

The calculated yearly risk for MFD (Mutual 

Funds). 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Yield The rate of return the holder earns on a financial 

instrument or security. 

 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

YTD The period starting January 1 of the current year 

and ending today.  

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Back to Top 

Z 

There are no terms that begin with this letter 

Back to Top 
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Others 

Data Column Description Applicable to 

7D Volume Weekly avg. of the volume for traded stocks Full Market 

Watch List 

7D Volume 

Chg% 

Percentage of Today‟s volume as opposed to 

7D average 

Full Market 

Watch List 

30D Volume Monthly avg. of the volume for traded stocks Full Market 

Watch List 

30D Volume 

Chg% 

Percentage of Today‟s volume as opposed to 

30D average 

Full Market 

Watch List 

90D Volume Quartely avg. of the volume for traded stocks Full Market 

Watch List 

90D Volume 

Chg% 

Percentage of Today‟s volume as opposed to 

90D average 

Full Market 

Watch List 

52 Week 

High 

The highest price at which a stock has traded in 

the past 12 months, or 52 weeks. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

52 Week 

Low 

The lowest price at which a stock has traded in 

the past 12 months, or 52 weeks. 

Full Market 

Watch List 

Conditional 

Watch List 

Sector Watch 

Back to Top 

 

RELATED INFORMATION  

Accessing Real time Market Data 
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Watch List Options  
 

INTRODUCTION  

The Right Click menu contains Watch List options which are accessible 

from Watch List windows with Tabular Market data. 

 

The Watch List options are listed here: 

Add Symbol using Symbol Search 

Remove Symbol 

Change View Name 

Delete View 

Decimal Places 

Unsort 

 

RELATED INFORMATION:  

Accessing Real Time Market Data 
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Watch List and Market Watch Indicators 
 

INTRODUCTION  

In Watch Lists/Market Watch views, special indicators are used to 

indicate a symbol‟s status, minimum/52 week low and maximum/52  week 

high trade price. 

Price Indicators 

Suspended Symbols 

 

PRICE INDICATORS   

The symbols are highlighted in specific colours based on conditions. The 

conditions and their defined colours are as follows (See Figure 1); 

 Minimum Price (If the last trade price of the symbol has reached the 

minimum price) - The row is highlighted in Red and font colour is 

Black. 

 52 Week Low (If the lowest price for the day is the lowest for that 

symbol in 52 weeks) - The row is highlighted in Red and font colour is 

White. 

 Maximum Price (If the last trade price of the symbol has reached the 

maximum price) - The row is highlighted in Green and font colour is 

Black. 

 52 Week High (If the highest price for the day is the highest for that 

symbol in 52 weeks) - The row is highlighted in Green and font colour 

is White. 
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Figure 1 - A Watch List with Price Indicators 

 

 

SUSPENDED SYMBOLS  

Symbols that are suspended for trading by the Exchange are indicated 

with a line across it as shown in figure 2 below. Trading on these symbols 

can be resumed only when the suspension is disabled by the Exchange. 

 

Figure 2 - Suspended symbols 

 

RELATED INFORMATION  

Accessing Real time Market Data 

Watch List Customization 
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Common Functions 
 

INTRODUCTION  

When you right click on a symbol in a watch list a shortcut menu appears. 

It lists the features relevant to the symbols in that watch list. 

 

TOPICS IN THIS SECTION  

Trade 

Graph 

Time & Sales 

Time & Sales Summary 

Detail Quote 

Snap Quote 

Full Quote 

Performance Map 

Cash Flow Detail Quote 

Market Depth By Price 

Market Depth By Order 

Market Depth Odd Lot 

Special Order Book 

Order Book Calculator 

Announcements 

News 

Edit Alias 

Send to Watch List 

Watch List options 

Set Alert 

Right Click Functions for an Index* 
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Watch Lists can also contain Index Sectors. However, the Right Click menu 

option from Index Sector does not contain symbol related functions such 

as Trade, Snap Quote, Full Quote, Market Depth By Price, Market Depth by 

Order, Special Order book and Order Book Calculator. 

 

RELATED INFORMATION  

Accessing Real Time Market Data 

 

Trade 
 

INTRODUCTION  

Trade options such as Buy, Sell and Rapid Order are accessible from 

any Full Market / Watch List List window‟s Right Click menu in Trading 

enabled Markets. 

  

PROCEDURE  

To view Trading options from the Right Click menu: 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select  Trade option > Select Buy / Sell / 

Rapid Order option. 

 

Note: 

  The Trade option will be enabled only in Exchanges where Trading is 

activated. 

 

 

RELATED INFORMATION:  

Common Functions 

Trading Help 
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Graph 
 

INTRODUCTION  

The Graph option gives you the intraday & historical graphical 

presentation of a selected symbol. 

  

PROCEDURE  

To view the Graph for a selected symbol: 

Method 1 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select Graph option. The Graph is displayed 

for the selected symbol. (See Figure 1). 

Method 2 

Select the required symbol > Double click on OHLC column of the Watch 

List to display the Graph for the selected symbol.  

Method 3 

 Press F3 Hotkey. This opens the Graph for the selected symbol.  

Figure 1 - Stock Graph for selected Symbol - Intraday Mode 
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CUSTOMIZING THE CHART  

By default the chart is in Intraday mode. Use the Right Click menu within 

the chart window to customize its features. 

  

To Customize features of the Graph: 

1. Right Click on the Graph. 

2. Go to Right Click menu > Select the feature that you need to change. 

E.g.: To change the Style of the Graph: 

1. Right Click on the Graph > Select the Style option. 

2. Select the required style type (E.g. Bar) (See Figure 2).  

Figure 2 - Stock Graph for selected Symbol – Bar style 

 

A charting option ProChart is included within the Right Click menu of the 

Graph window which has advanced features such as Chart Comparison, 

Technical analysis and advanced Zooming options (See: Pro Chart Help). 

To open Graph in ProChart: 

 Open graph for selected symbol > Go to Right Click menu > Select Send 

to ProCharts option. 

 RELATED INFORMATION  

Common Functions 
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Time & Sales 
 

INTRODUCTION  

Time & Sales gives you all the Time & Sales details for the selected 

symbol when the market is open and displays trades from the time you 

open the window.   

  

PROCEDURE  

To view Time & Sales information for a symbol: 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select the Time & Sales option. The Time 

and Sales window opens (See Figure 1). 

 

Figure 1 - Time & Sales for a symbol 

 

RELATED INFORMATION  

Common Functions 

Time & Sales Right Click options 
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Time & Sales Summary 
 

INTRODUCTION  

Time & Sales Summary gives you Time & Sales details for the selected 

symbol grouped by price, for a particular period of time when the Market 

is open.  It shows the cash in and cash out details for each price point for 

that symbol. 

 

PROCEDURE  

To view the Time & Sales Summary Symbol-wise: 

1. Right Click on the symbol from either the Full Market / Watch List. 

2. Go to Right Click menu > Select Time & Sales Summary. 

 

Note: 

  The Time & Sales Summary option is available only when the market is closed 

and will be disabled when the market is in open and pre-open status.  

 

The following information is displayed in this window: 

 Price - Trading price. 

 Quantity - The quantity traded at the given trading price. This can be 

from multiple trades. 

 # of Trades - The number of trades at the given price.  

 Cash In  

 # of Trades - Number of traded (bought) orders. 

 Volume - Traded (bought) volume for the day. 

 Turnover - Turnover for the traded (bought) stocks. 

 Cash Out  

 # of Trades - Number of traded (sold) orders. 
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 Volume - Traded (sold) volume for the day. 

 Turnover - Turnover for the traded (sold) stocks. 

 Net Value - Net Turnover value for the stock. 

 Percentage - Buyer‟s and Seller‟s gain of the trade as a percentage. 

(„Green‟-Buyer; „Red‟-Seller). 

 

RELATED INFORMATION  

Common Functions 
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Detail Quote  
 

INTRODUCTION  

The Detail Quote feature provides you with the ability, to look at a 

detailed view of a Symbol/Company based on the latest information from 

the respective Stock Exchange. It also gives you some important historical 

information such as 52 Wk. High/ 52 Wk. Lows with dates etc. The data 

displayed is arranged by grouping similar data together as shown in figure 

1 below.  

 

PROCEDURE  

To view Detail Quote: 

Method 1: 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right click menu > Select Detail Quote option. The Detail 

Quote window opens (See Figure 1). 

 

Method 2: 

 Double click on the selected symbol. The Detail Quote window opens 

(See Figure 1). 

 

  Notes: 

  The Red and Green colours show the Symbol‟s positive and negative 

performance, when the market is open. 

  Trade Details, Bid and Offer trade information are grouped together in 

the Detail Quote window and colours are used to highlight the respective 

information. (For E.g: Green – Bid Details, Pink – Offer Details) 
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Figure 1 - Detail Quote window 

 

 

RELATED INFORMATION  

Common Functions 
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Snap Quote  
 

INTRODUCTION  

The Snap Quote feature provides you with details about the 

Symbol/Company, based on the latest information from the respective 

Stock Exchange. It also gives you some important historical information 

such as 52 Wk. High/ 52 Wk. Lows with dates etc. The Market Depth by 

Price is also displayed for the selected symbol.  

 

PROCEDURE  

To view Snap Quote: 

 

Method 1 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select Snap Quote option. The Snap Quote 

window opens 

Method 2 

 Press F4 Hotkey. The Snap Quote window opens.  

Figure 1 - Snap Quote  

 

RELATED INFORMATION  

Common Functions 
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Full Quote 
 

INTRODUCTION  

The Full Quote feature provides you with some vital Symbol related 

information such as Open, High, Low and Change (from Detail Quote), 

detailed Market Depth information and Time & Sales. 

  

PROCEDURE  

To view Full Quote: 

 

Method 1 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select the Full Quote option. 

 

Method 2 

 Press F8 Hotkey. The Full Quote window opens. 

Figure 1 - Full Quote window 
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* This information may not be available for some symbols in certain markets. 

 

RELATED INFORMATION  

Common Functions 

 
 
Cash Flow Detail Quote 
 

INTRODUCTION  

The Cash Flow Detail Quote* option allows you to view details of orders 

that are triggered by a buy / sell transaction for the selected symbol. 

 

PROCEDURE  

To view Cash Flow Detail Quote for a symbol: 

 

Method1 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select the Cash Flow Detail Quote option. 

The Cash Flow Detail Quote window opens (See Figure 1). 

 

Method 2 

Select the required symbol > Double click on Cash Map column of the 

Watch List to open the Cash Flow Detail Quote window. 

Figure 1 - Cash Flow Detail Quote 
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* This may not be available for some symbols in certain markets. 

 

RELATED INFORMATION  

Common Functions 

Market Depth by Price  
 

INTRODUCTION  

Using Market Depth information, you can get more information about the 

performance of the selected symbol for the given day. 

 

Market Depth by Price option tracks and gives you the price and total 

volumes for each Buy and Sell price point. You can view the number of 

occurrences that have been requested in the market for a certain price 

from total number of bid/offer splits. You have an option to view the real-

time Bid/Offer quantity change per price point graphically presented. 

Hence this helps you to make a quick observation about the symbol at a 

glance when making investment decisions. 

   

PROCEDURE  

To view Market Depth by Price: 

Method 1 

1. Right Click on the relevant symbol from either Full Market / Watch 

List > Select the Market Depth by Price option.The Market Depth 

by Price window opens. (See Figure 1). 

Method 2 

1. Select the required symbol > Double click on Bid/Offer column of the 

Watch List. The Market Depth by Price window opens.  

Method 3 

1. Press F5 Hotkey. The Market Depth by Price window opens for the 

selected symbol. 
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In the Market Depth by Price window: 

2. Click on the Expand  icon at the top corner to view the chart for 

Quantity per price point.   

3. When you click on any part of the chart the relevant data row will be 

highlighted. 

4. Click on the Collapse  icon to close the chart. 

 

Figure 1 - Market Depth by Price 

 

 

Market Depth By Price can also be viewed in Combined Order Book mode 

(Learn More: Combined Order Book). 

RELATED INFORMATION  

Common Functions 

Combined Order Book 



© 2002-2010 DirectFN Ltd Page 181 

 
 

 
Market Depth by Order 
 

INTRODUCTION  

Market Depth by Order provides a queue of up to 10 levels of the 

highest offer prices for buyers and lowest bid prices for sellers. 

 

PROCEDURE  

To view Market Depth by Order: 

 

Method 1 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select the Market Depth by Order option. 

The Market Depth by Order window opens (See Figure 1). 

 

Method 2 

 Press F6 Hotkey. This opens the Market Depth by Order window for 

the selected symbol.  

Note: 

  You must subscribe to Market Depth by Order separately, as the Depth by 

Order feature is not supported by some stock exchanges. 
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Figure 1 - Market Depth By Order 

 

 
 

RELATED INFORMATION  

Common Functions 
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Market Depth Odd Lot 
 

INTRODUCTION  

The Market Depth Odd Lot option provides a queue of the bids and 

offers along with their quantities for the selected Odd Lot Market symbol. 

 

 

PROCEDURE  

To view Market Depth By Order: 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select the Market Depth Odd Lot option. 

 

RELATED INFORMATION  

Common Functions 
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Special Order Book 
 

INTRODUCTION  

The Special Order Book shows orders which match certain conditions 

specified at the Exchange. 

Moreover, the Special Order Book option will only be available if conditions 

are specified at the Exchange and there are Trades to match these 

conditions. 

  

PROCEDURE  

To view Special Order Book: 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select the Special Order Book option. 

Note: 

  The Special Order Book is displayed only if data is sent from the feed. This is 

not available for some markets. E.g:Saudi Stock Market. 

 

 

RELATED INFORMATION  

Common Functions 
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Order Book Calculator 
 

INTRODUCTION  

Mubasher Pro‟s Order Book Calculator gives you the facility to view the 

target bid/offer prices for a symbol before trading it, thereby enabling you 

to make a profitable investment decision. 

Order Book Calculator computes target bid/offer prices and the relevant 

commission for a selected order when the target quantity or value is 

entered. The weighted average target bid price and offer price values 

appear accordingly. 

 

PROCEDURE  

To make a calculation using the Order Book Calculator: 

1. Right Click on the relevant symbol from Full Market / Watch List. 

2. Go to Right Click menu > Select the Order Book Calculator option. 

The Order Book Calculator window opens (See Figure 1). 

Figure 1 - Order Book Calculator 
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3. In the Order Book Calculator window, Enter the requested data into 

the fields: 

 Side - Select Buy / Sell, depending on your requirement. 

 Target - Enter a Quantity or Value. 

 Type - Select Value or Quantity. 

Value - If Value is selected the total Value should be entered. 

E.g: If you want to buy $100 worth of shares, enter $100.  

Quantity - Quantity of shares you want to Buy / Sell.  

 Portfolio - This field will be activated if trading is enabled. Select the 

Portfolios from the list. 

 Commission Rate - The commission rate applicable for the 

transaction. 

4. Click on the Calculate button and the results are displayed in the 

results area based on the information entered. 

 

Note: 

  The trading options Portfolio and Buy / Sell button are enabled only if you 

have trading enabled. 

 

 

RELATED INFORMATION  

Common Functions 
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Edit Alias  
 

INTRODUCTION  

You can define short descriptions for symbols using the Edit Alias option. 

 

PROCEDURE  

To create a symbol’s short description: 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select Edit Alias option. The Edit Alias 

window opens (See Figure 1). 

 

Figure 1 - Edit Alias 

  

 

3. In the Edit Alias window, type in a short description in the Alias Field. 

4. Click on the OK button to save the new alias. 

Note: 

  After completing this you can select to Show the Alias you created using the 

Show Alias option. By default the Show Alias option is enabled. (To Show 

Alias, Go to Tools menu > Select Show Alias option).  
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Figure 2 - Watch List after defining Alias 

 

 

RELATED INFORMATION  

Common Functions 

Show Alias 

 
 
Set Alert 
 

INTRODUCTION  

You can Set Alerts at any given time for a selected symbol in order to be 

notified when the symbol meets criteria defined by you. When the symbol 

meets the set criteria, you will be alerted via a popup message. 

 

Although Alerts can be set at any given time, they are triggered when the 

alert condition specified is met and depends on the market status. Once 

you set an alert the alert condition will be monitored by the system when 

data is received from the relevant market and triggered when the 

condition is met. Therefore at market session times alerts are triggered 

immediately when the condition is met. When data is not received from 

the exchange the alert will remain in the pending list till the market re-

opens and will be triggered when the condition specified is met.  

Pre-Open - Alerts set during the Pre-Open status will be pending until the 

market is Open depending on the fields for which the Alert is set. If the 

Alert set during the pre-open state was specifically for Offer Qty, Offer 

Price, Bid Qty, Bid Price then the Alert is triggered immediately if the 

condition is met. Alerts set during the pre-open state for any other fields 

other than the fields mentioned above will only be triggered once the 

market is open. 
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PROCEDURE  

To Set Alerts: 

1. Right Click on the relevant symbol from either Full Market / Watch 

List. 

2. Go to Right Click menu > Select the Set Alert option. The Set Alerts 

window opens. 

 

RELATED INFORMATION  

Common Functions 

Alerts 
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General Options 
 

INTRODUCTION  

The Right Click menu contains General options which are accessible from 

all windows with Tabular Market data. These general options are listed 

below. 

 

TOPICS IN THIS SECTION  

Print 

Resize Columns to fit 

Column Settings 

Cell Selection 

Customize 

Currency 

Filter 

Decimal Places 

Copy / Copy with Headings 

Link to Excel / Link with Headings 

Hide Title 

 

Note: 

  Some of the options mentioned above can also be accessed from the mini-

toolbar which is available through the Right Click menu. 

 

RELATED INFORMATION  

Accessing Real Time Market Data 

 



© 2002-2010 DirectFN Ltd Page 191 

 
 

Print 
 

INTRODUCTION  

The Print feature allows you to print the contents of your window for 

future reference. 

 

PROCEDURE  

To print a windows contents: 

1. Right Click on the required window. 

2. Go to Right Click menu > Watch List Options > Select the Print 

option. The Print window opens. 

3. Specify your printing preference. 

4. Click on the Print button. 

Note: 

  Please note that you need to be connected to a printer to use this feature. 

 

 

RELATED INFORMATION  

General Options 

Accessing Real time Market Data 
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Resize Columns to Fit 
 

INTRODUCTION  

The Resize Columns to Fit feature automatically adjusts the column 

width to suit the width of data. The column width automatically expands or 

shrinks to accommodate the shortest or longest data in columns. 

  

PROCEDURE  

To apply the Resize Columns feature to any window: 

Method 1  

1. Right Click on the required window. 

2. Go to Right Click menu > Watch List Options > Select the Resize 

Columns to Fit option. 

 

Method 2 (Using the mini-toolbar) 

1. Right Click on the required window. The mini-toolbar is displayed. 

2. In the mini-toolbar, select the  icon . 

 

RELATED INFORMATION  

General Options 

Accessing Real time Market Data 

 



© 2002-2010 DirectFN Ltd Page 193 

 
 

Link to Excel/Link with Headings 
 

INTRODUCTION  

The Link to Excel facility allows you to link selected data from Mubasher 

Pro to Microsoft Excel from which you can view the market information 

being dynamically updated at market open times. This can be done for one 

data row or multiple data rows at a time as required. 

PROCEDURE  

To Link Columns to Excel: 

1. Select the data you want to link, from the required window. 

2. Right Click on the selected area. The mini-toolbar is displayed. 

3. In the mini-toolbar, click on the    icon > Select Link to Excel / 

Link with Headings option. 

 Link to Excel  - This will link only the selected rows to MS Excel. 

 Link with Headings - This will link the selected data with the 

column headings to MS Excel. 

4. Finally, open a new Microsoft Excel document and select the Paste 

option from the Edit menu and paste the symbol data onto the MS 

Excel sheet. 

Note: 

  If you select multiple rows in a given window, the Link to Excel / Link 

with Headings option is available via the Right Click menu.  

To select multiple data rows in a window:  

Method 1: Select a symbol > Click and Drag the mouse up or down to 

highlight and select the data rows required. 

Method 2: Select a symbol > Press shift key and select the required rows 

using the up & down arrow keys. 

RELATED INFORMATION  

General Options 

Accessing Real time Market Data 
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Copy/Copy with Headings 
 

INTRODUCTION  

The Copy facility allows you to copy selected data from Mubasher Pro to 

Microsoft Word, Microsoft Excel, Notepad or any other text editor of your 

choice. 

 

PROCEDURE  

To Copy data: 

1. Select the data you want to copy, from the required window. 

2. Right Click on the selected area. The mini-toolbar is displayed. 

3. In the mini-toolbar, click on the  icon > Select Copy / Copy with 

Headings option. 

 Copy - This will copy only the selected data rows. 

 Copy with Headings - This will copy the selected rows along 

with its headings. 

4. Finally, open a new document in Microsoft Word / Excel (or any other 

text editor of your choice) and select the Paste option from the Edit 

menu to paste the symbol data onto the selected application. 

Note: 

  If you select multiple rows in a given window, the Copy / Copy with 

Headings option is available via the Right Click menu.  

To select multiple data rows in a window:  

Method 1: Select a symbol > Click and Drag the mouse up or down to 

highlight and select the data rows required. 

Method 2: Select a symbol > Press shift key and select the required rows 

using the up & down arrow keys. 

RELATED INFORMATION  

General Options 

Accessing Real time Market Data 
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Column Settings 
 

INTRODUCTION  

Mubasher Pro provides you with a wide range of columns for your Full 

Market / Watch List windows and you can select these Columns using 

the Column Settings feature.  

 

Furthermore, for your convenience the different columns available in the 

application have been categorized as shown below.  

 Bond Market View - Contains columns relevant to the Bond Market. 

e.g.: Date of issue, Maturity Date. 

 Mutual Fund View - Columns relevant to Mutual Funds. E.g.: Yearly Risk, 

Fund Size. 

 Graphical View - Columns which are in Graphical Format. E.g.: % 

Spread Map, % Range Map, OHLC. 

 Cash Flow View - Columns with Cash Flow information. E.g.: Bid 

Trades, Bid Trades Turnover, Offer Trades, Offer trades Turnover. 

 Index View - Can be used to see information relevant to Indices. E.g.: 

Last, Total Volume and Turnover. 

 Equity View - These are normal Watch Lists. This is selected by default. 

Contains the most commonly used Columns.  

 All Columns - Displays all columns available in the application. 

 

PROCEDURE  

To Add Column/s to Watch List windows: 

Method 1 

1. Right Click on any Watch List window. 

2. Go to Right Click menu > Watch List Options > Select Column 

Settings option. The Select Columns window opens. 
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Method 2  (using mini-toolbar) 

1. Right Click on any Watch List window and the mini-toolbar is 

displayed. 

2. In the mini-toolbar, click on the  icon. The Select Columns 

window opens. 

 

Method 3 

 Right click on the column header of the window > Go to Right Click 

menu > Select Column Settings option. The Select Columns window 

opens. 

 

Figure 1 - Add and Remove Columns from Selection 

 

 

3. Select the column(s) from Unselected Items list and then click add 

symbol (>) button to add the symbols to the selection. 

4. Likewise, click remove symbol (<) button to remove already added 

fields from Selected Items list after marking the columns you need to 

remove. 

5. There are three (3) Apply To options, as follows: 
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 This Window Only: Changes will be applied only to the window that 

was customized 

 All Opened Windows: Changes will only be applied to all windows 

of this type (All Watch list windows and Volume Watcher window) 

that are open at the time. E.g. : If Watch List 01, Watch List 02 and 

two Conditional Watch List windows are open, changes are applied 

only to these four windows. The changes will not be applied to 

Windows of this type opened afterward. 

 All Windows: Changes will be applied to all windows of this type 

(All Watch list windows and Volume Watcher window) that are 

currently open and all windows of this type that are opened 

subsequently.  

6. Once you have finalized selecting the Columns to be displayed in your 

window, click on the Apply button to save the selection to the selected 

window. 

  Note: 

  Columns not belonging to the selected View Type will appear in red in 

the Selected items list. 

 

RELATED INFORMATION  

General Options 

Accessing Real-Time Market Data 
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Cell Selection 
 

INTRODUCTION  

The Cell Selection option lets you select how the data you select should 

be highlighted. Using this option you can set whether only the cell you 

select is to be highlighted when you click on a window or if the whole row 

is to be highlighted.  

 

PROCEDURE  

To select a cell or row: 

Method 1 

1. Right Click within the window. 

2. Go to Right Click menu > Watch List Options > Select the Cell 

Selection option > Select the Cell / Row option. 

 

Method 2 (using mini-toolbar) 

1. Right Click on the required window and the mini-toolbar is displayed. 

2. In the mini-toolbar, click on the   icon > Select Row / Cell option. 

 Select Row option to highlight a row when selected. 

 Select Cell option to highlight a cell when selected. 

 

RELATED INFORMATION  

General Options 

Accessing Real time Market Data 
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Customizing windows 
 

INTRODUCTION  

Mubasher Pro allows you to customize the colours, sizes, fonts, grids, 

highlighter text and headings for all types of windows and the main board. 

  

PROCEDURE  

To customize a window: 

Method 1 

 Go to Right Click menu > Watch List Options > Select the Customize 

option. The Customizer window opens. 

 

Method 2 

 Right Click on the column header of the window > Go to Right Click 

menu > Select Customize option. The Customizer window opens. 

 

Method 3 

 Right Click on a selected window > Click the Customize icon  on the 

mini toolbar. The Customizer window opens. 

  

RELATED INFORMATION  

General Options 

Accessing Real time Market Data 

Customize windows 
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Set as Default Settings 
 

INTRODUCTION  

Once you change the window settings i.e.: font colour, font size, window 

size, line space etc. you have the option to set it as the default setting for 

that window.  

 

PROCEDURE  

To make a window setting default (for a particular window): 

1. Change the required window setting from the Customizer option or 

from the options available in the mini toolbar. 

2. Go to Right Click menu > Select the Set as Default Settings* option 

from the mini toolbar. 

  Notes: 

  When this option is enabled, the changed window setting will be available 

only for the particular window. 

  *This option is not available for all windows. 

 

 

RELATED INFORMATION  

Customizing Windows 
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Reset to Default 
 

INTRODUCTION  

Use the procedures given below to revert the window settings back to its 

default state.  

 

PROCEDURE  

To restore windows font settings to default: 

1. Right Click on any area within the window. 

2. Go to Right Click menu > Select the Default icon * from the mini 

toolbar. 

Notes: 

  Only the Main Board Font will be restored to the default setting. The header 

font cannot be set back to the default setting. 

  *This option is not available for all windows. 

  To restore changes done to the custom settings of your windows, Open the 

Customizer window > clear the Enable Custom Settings check box (Refer 

Grid & Customize colours for details).  

 

 

RELATED INFORMATION  

Set as Default Settings 

Customizing Windows 

 



© 2002-2010 DirectFN Ltd Page 202 

 
 

Currency 
 

INTRODUCTION  

Using the Currency option, you can set a different currency for an 

Exchange. By default the system sets each exchange with the respective 

default currency. However, if you wish to set a different currency, you can 

do so using this feature.  

  

PROCEDURE  

To set a different Currency: 

Method 1 

1. Right Click on Full Market / Watch List window. 

2. Go to Right Click menu > Watch List Options > Select the Currency 

option > Select the required Currency from the list. 

3. Then all trades for the selected exchange appear in the selected 

Currency. 

 

Method 2 (using mini-toolbar) 

1. Right Click on the Full Market / Watch List and the mini-toolbar is 

displayed. 

2. In the mini-toolbar, select the  icon > Select the required currency 

from the list. 

E.g.: If you select US Dollars in a Watch List, then all trades, price details 

appear in US Dollars. 

Note: 

  The Default option will display the values in the Default Currency. 

 

RELATED INFORMATION  

General Options 

Accessing Real time Market Data 
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Filter 
 

INTRODUCTION  

The Filter function gives different options to filter the data displayed in 

Full Market / Watch List windows as listed below. 

 

Market Watch Filter  

Watch List (My Stocks) Filter 

  

MARKET WATCH FILTER  

The Filter option allows you to filter the Trades displayed in the Full Market 

window by Sectors, Asset Classes and Currencies. 

  

To filter your Full Market window: 

Method 1 

1. Right Click on any area. 

2. Go to Right Click menu > Watch List Options > Select the Filter 

option. The Market Watch Filter window opens. 

 

Method 2 (using mini-toolbar) 

1. Right Click on the Market Watch window and the mini-toolbar is 

displayed. 

2. In the mini-toolbar, select the Filter  icon. The Market Watch 

Filter window opens. 

 

In the Market Watch Filter window: 

3. Select the required Sectors, Asset Classes and Currencies from the 

respective lists. 

4. Click on the OK button. 
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Thereafter only the trades which match the criteria specified will be 

displayed in the selected exchange‟s Full Market. 

 

  Tip:  

  If you wish to load the default Filter options, simply click on the Reset 

button. 

  

 WATCH LIST (MY STOCKS) FILTER  

The Filter option for your personalized Watch Lists allows you to filter the 

symbols displayed in the Watch List window by Exchange and 

Currencies. By default, the filter option is not enabled. 

  

 To filter your Watch List window: 

1. Select any symbol and Right Click. 

2. Go to Right Click menu > Watch List Options > Select the Filter 

option. The Watch List Filter menu opens. 

 

Method 2 (using mini-toolbar) 

3. Right Click on the Watch List and the mini-toolbar is displayed. 

4. In the mini-toolbar, select the Filter  icon. The Watch List Filter 

menu opens. 

 

In the Filter menu: 

3. Select the required Exchange / Currencies. 

4. Click on the OK button. 

 Thereafter, only the trades which match the criteria specified will be 

displayed in the Watch List. 
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The following Filter Options are available: 

1. No Filter is the Default value. The data will not be filtered. 

2. Filter according to the selected exchanges, by ticking the required one 

or more Exchanges. 

3. Filter according to the selected Currency types, by ticking the required 

one or more Currencies. 

 

 
RELATED INFORMATION  

General Options 

Accessing Real time Market Data 
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Decimal Places 
 

INTRODUCTION  

The Decimal Places feature can be used to set the number of decimal 

places for the values displayed in the selected window.  

 

PROCEDURE  

To edit decimal places: 

Method 1 

1. Right Click on the required column. 

2. Go to Right Click menu > Select Watch List options > Select the 

Decimal places option > Select required Decimal Places from the 

list. 

 

Method 2 (Using mini-toolbar) 

1. Right Click on the Full Market / Watch List and the mini-toolbar is 

displayed. 

2. In the mini-toolbar, select the  icon > Select the required currency 

from the list. 

E.g.: Changing the values to four decimal places.        

Note: 

  Selecting the Default feature, will display the values with the default number 

of decimal places. 

 

 

RELATED INFORMATION  

General Options 

Accessing Real time Market Data 
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Heading Options 
 

INTRODUCTION  

The Right Click menu contains Heading options which are accessible from 

the column headings of all windows with tabular market data. 

  

TOPICS IN THIS SECTION  

Hide/Show Title 

Remove Column 

Column Settings 

Customize windows 

 

RELATED INFORMATION  

General Options 

Accessing Real time Market Data 
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Hide/Show Title 
 

INTRODUCTION  

The Hide Title feature is used to hide the title of any window. 

 

PROCEDURE  

To hide a window’s Title: 

1. Right Click on the required window (on the column heading). 

2. Go to Right Click menu > Select the Hide Title option. 

3. Once you hide the title, if you wish to view the title again, Go to Right 

Click menu > Select the Show Title option. 

 

RELATED INFORMATION  

Heading Options 
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Remove Column 
 

INTRODUCTION  

The Remove Column feature is used to remove a column in a particular 

window. 

  

PROCEDURE  

To remove a column: 

1. Right Click on the required column heading. 

2. Go to Right Click menu > Select the Remove Column option. 

Note: 

  If you wish to view the removed column again, select Column Settings from 

the same window‟s Right Click menu and add the required column to the 

selection. 

 

RELATED INFORMATION  

Heading Options 

Column Settings 
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Value Added Services 
 

INTRODUCTION Mubasher Pro gives you access to several value added services which is 

available for symbols as well as Exchanges. 

 

TOPICS IN THIS SECTION  

Value Added Services - Symbol wise - Available services symbol wise via 

the Watch List Right Click menu. 

Value Added Services - Exchange wise - Available services for selected 

Exchanges. 

 

RELATED INFORMATION  

Accessing Real Time Market Data 
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Value Added Services for Symbols 
 

INTRODUCTION  

Mubasher Pro gives you easy access to Value Added Services (VAS)* you 

have subscribed for, via the Right Click menu. This lets you view the 

required option symbol wise.  

The following VAS options are available with Watch List and Full Market 

windows: The options available depend on the markets you are subscribed 

to 

 Financial Ratios 

 Company Profile 

 Fair Values 

 Insider Trading 

Note: 

  * The availability of this option differs depending on your subscription. 

 

 

PROCEDURE  

To view a VAS option: 

1. Select the required symbol from Full Market / Watch List. 

2. Go to Right Click menu > Select the required VAS option. The selected 

information is displayed in a web page.  

 

Given below is a description of each VAS option available for 

symbols of Watch Lists and Full Market windows: 

 

 Financial Ratios - This is a method of evaluating the financial position 

of a company. 
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Profitability Ratio - This indicates how well a company is 

performing in terms of its ability to generate profit. 

Debt Ratio - This is the Debt capital divided by total assets. This 

will tell you how much the company relies on debt to finance 

assets. When calculating this ratio, it is conventional to consider 

both current and non-current debt and assets. 

Liquidity Ratios - This has two components: 

Current Ratio - An indication of a company's ability to 

meet short-term debt obligations; the higher the ratio, the 

more liquid the company is. Current ratio is equal to 

current assets divided by current liabilities. 

Quick Ratio - A measure of a company's liquidity and 

ability to meet its obligations. Quick ratio is obtained by 

subtracting inventories from current assets and then 

dividing by current liabilities. Quick ratio is viewed as a 

sign of company's financial strength or weakness (higher 

number means stronger, lower number means weaker). 

Market Value Ratios - Has two components: 

P/E Ratio - This is the price/earnings ratio. This is the 

most common measure of how expensive a stock is. 

P/B Ratio - This is the price to book ratio. Its a financial 

ratio used to compare a company's book value to its 

current market price. 

Asset Management Ratios - Asset management ratios are a 

set of ratios which can help illustrate how well a firm is managing 

its assets. It is a measurement tool which helps show how well a 

company is able to generate a sufficient amount of business. 

 Company Profile - Gives an overview of the company. The Company 

Profile page displays the performance of the symbol during the previous 

two trading days, an intraday price chart, key statistics of the company, 

announcements and news. 
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 Fair Values - A fair value is the value of a stock determined in a 

standard way that is reasonable to all parties involved. The Fair Values 

page displays the valuations provided by different sources for a selected 

symbol along with the respective dates and the stock price of that date. 

 Insider Trading - These are trades done by individuals inside the 

company. The Insider Trade page displays the internal trades of the 

selected symbol. It shows the date the trade was done, the respective 

Exchange and symbol name, the trade type (Buy/Sell) and the name of 

the insider. 

 

 

RELATED INFORMATION  

Right Click menu 

Value Added Services 
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Value Added Services  
 

INTRODUCTION  

Mubasher Pro connects you to Market experts via Value Added Services 

(VAS) which will also guide you to make sound investment decisions. The 

Value Added Services you are entitled to depends on your subscription. 

The VAS available in Mubasher Pro are. The options available to 

you depends on the markets you are subscribed to. 

 Research Material 

 Market Watch 

 Shariah Complaint List 

 News 

 Mubasher Radio 

 Sectors and Companies 

 Mutual Funds 

 Calendar 

 Liquidity Monitor 

 Investment Tools 

 Reports 

 Support and Resistance 

 Volume Watcher 

 Technical Scanner 

 Active Performance Comparison 

 Active Companies 

 Financial Ratios 

 

Note: 

  Shariah Compliant List is will have two options (Al SHEIKH Al SHOBILY & Al 

SHEIKH Al OSYMY). Clicking on these will direct you to their respective sites.  

 

PROCEDURE  

To view value added services exchange-wise: 

 Go to Services menu > Select the required option. 

  

To view value added services symbol-wise: 

1. Right Click on a symbol from a Full Market / Watch List window. 



© 2002-2010 DirectFN Ltd Page 215 

 
 

2. Go to Right Click menu > Select the VAS option required. (To learn 

more about these services available through the right click menu go to 

Value Added Services). 

 

 
RELATED INFORMATION  

Accessing Real Time Market Data 

Right Click Menu - Value Added Services 

 

 
Mubasher Pro Options 
 

INTRODUCTION  

The View menu gives you easy access to a wide range of options: 

 

TOPICS IN THIS SECTION 

Ticker 

Announcements 

News 

Market Indices 

Market Time & Sales 

Market Summary 

Investor Types 

Top Stocks 

Side Bar 

Currency Rates 

Global Market Summary 

 

RELATED INFORMATION  

Accessing Real Time Market Data 
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Ticker 
 

INTRODUCTION  

All trades for the selected exchange or selected symbols for multiple 

exchanges (using a Watch List) are displayed, in real-time Trade Tickers. 

The gaining symbols are displayed in Green and the losing symbols in 

Red. 

 

There are two Ticker types available in the application: 

Classic Ticker - Provides information about the symbols 

Advanced Ticker - Provides information about the symbols and has two 

additional tickers which display News and Announcements. 

 

RELATED INFORMATION  

Classic Ticker - Right Click menu 

Advanced Ticker - Right Click menu 
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View Classic Ticker 
 

INTRODUCTION  

The Classic Ticker displays information such as symbol description, Last 

Price and Qty for the symbols in the selected exchange or selected 

symbols of multiple exchanges (See Figure 1).  

 

PROCEDURE  

To enable/ disable the Classic Ticker: 

Method 1 

 Go to View menu > Select Classic Ticker. 

 

Method 2 

 Click on the  icon from the Icon Panel. 

 

The tape ticker plays trades as per your filters and the fields which are 

displayed in the ticker are: 

 Symbol or Symbol description 

 Last Price 

 Qty 

 Change or % change 

  

Min/Max Indicator 

The Ticker also displays a Min Max indicator. 

Max Indicator - A Green line is displayed above the symbol, indicating 

the symbol is traded at the maximum price value. 

Min Indicator - A Red line is displayed below the symbol, indicating the 

symbol is traded at the minimum price value. 
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Figure 1 - A Ticker with Min Max Indicators 

 

 

Note: 

  The Ticker is not available for non default markets. When a non default 

market is selected the ticker displays a message stating that ticker data is not 

available for the selected Exchange. 

 

 

RELATED INFORMATION  

Mubasher Pro Options 

Classic Ticker - Right Click options 
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Classic Ticker - Right Click Options 
 

INTRODUCTION  

Mubasher Pro gives you a wide range of options to customize your ticker. 

These options can be viewed by accessing the Right Click menu on the 

Ticker. 

  

The Classic Ticker‟s Right Click menu options are as follows: 

Show Trade Ticker 

Show Title / Hide Title 

Show Symbol 

Show Change 

Font 

Float 

Ticker Speed 

Filter 

Close 

 

SHOW TRADE TICKER  

The Trade Ticker will display the number of splits for symbols if it equals 

two or higher.  

Note: 

  This option will be enabled depending on your market subscription.  

 

To view the Trade Ticker: 

 Go to Ticker Right Click menu > Select Show Trade Ticker option. 

To change back to the Summary Ticker from Trade Ticker: 

 Go to Ticker Right Click menu > Select Show Summary Ticker option.   
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SHOW / HIDE TITLE  

To view the Ticker with the Title: 

 Go to Ticker Right Click menu > Select Show Title option. 

 

To hide the Ticker Title: 

 Go to Ticker Right Click menu > Select Hide Title option. 

     

SHOW SYMBOL CODE / SHOW DESCRIPTION  

Go to Ticker Right Click menu > Select Show Symbol / Show Symbol 

Description option. 

 

SHOW CHANGE/ PERCENTAGE CHANGE  

Go to Ticker Right Click menu >Select Show Change / Show Change 

Percentage option. 

 

FONT  

To customize Ticker by changing its Font Type, Style and Size: 

1. Go to Ticker Right Click menu > Select Font option. The Select a Font 

window opens. 

2. Specify the Font setting. 

3. Click on the OK button. 

 

FLOAT / FIX  

Fix - This option will stick the ticker under the Toolbar.  

Float - This option will make the ticker floatable so that it can be dragged 

within the workspace. 
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To Float / Fix the ticker : 

 Go to Ticker Right Click menu >Select Float / Fix option. 

 

TICKER SPEED  

To change the ticker speed: 

 Go to Ticker Right Click menu > Ticker Speed > Select the required 

speed. 

Slow 

Medium 

Fast 

  

 FILTER  

To select the ticker to play for all Trades in the selected exchange / for 

only Trades in your Watch List / Classic View: 

1. Go to Ticker Right Click menu > Filter > Select the required option 

(Play All / My Stocks / Classic View). 

 Play All - This option will  play all trades for the exchange 

selected in the Index Panel. (If a non default market is selected, 

a message is displayed in the ticker stating that the ticker data is 

not available for the selected exchange.) 

 My Stock - This will play trades for the symbols available in the 

Watch List you select. The Watch Lists created by you will be 

given here.  

 Classic View - This will play trades for the symbols available in 

the Classic View Watch List.You are required to specify the 

required Classic View Watch List. 

2. Click on the OK button. 
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CLOSE  

This option closes the Ticker. 

 Go to Ticker Right Click menu > Select Close option. 

 

RELATED INFORMATION  

Mubasher Pro Options 

Classic Ticker 

 
 
 

View Advanced Ticker 
 

INTRODUCTION  

The Advanced Ticker is a three row Ticker (Ticker 1, Ticker 2 and Ticker 

3) that displays News and Announcements in addition to the symbol 

information provided in the Classic Ticker. You can view the Detail Quote 

for any symbol by clicking on the required symbol in the Ticker.  

 

The three rows of the Advanced Ticker displays the following information 

by default* (See Figure 1);  

 Ticker 1 (Row 1) - Symbol information which includes Symbol, 

Quantity, Last Traded Price and %Change. 

 Ticker 2 (Row 2) - Latest Announcements released. 

 Ticker 3 (Row 3) -  Latest News information about the symbols.  

Note: 

  
*These are the settings selected by default and can be changed using the 

filter option in the Right Click menu. 
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PROCEDURE  

To enable / disable the Advanced Ticker: 

 Go to View menu > Select Advanced Ticker. 

Depending on your requirement, you have the option to display all three 

rows of the Advanced Ticker or you can enable / disable rows as required 

from the View menu.   

When displaying symbols you can select to Show All symbols or Only 

Traded symbols, and also opt to have the ticker moving when the market 

is closed through the filter option. 

 

To filter the symbol information displayed:  

1. Go to Right Click menu > Filter > Select the required option. 

The available options are: 

 Exchange - This option will allow you to select the Exchanges. By 

default all Exchanges are selected.  

- When displaying the symbols you have two options: 

 Show Traded - Show all the traded symbols of the selected 

exchange/s. This is selected by default. 

 Show all  - Show All symbols of the selected Exchange/s. 

You can view all the symbols in a selected Exchange / Watch 

List irrespective of whether an update has occurred or not.  

- Run Ticker on Market Close  - You can have the symbol 

information ticker running even when the market is closed using 

this option. 

 My Stocks - Information for symbols in the Watch Lists created by 

you can be selected to run on the Ticker as preferred using this 

option. 

2. Click on the OK button. 
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Figure  - Advanced Ticker  

 

 

Notes: 

  When the pointer is placed on any row of the ticker the relevant row stops 

moving until the pointer is moved again. 

  By default all Exchanges you are subscribed to will be selected to display 

data in the three tickers. To change this go to Filter option of the Right 

click menu.  

 

RELATED INFORMATION  

Mubasher Pro Options 

Advanced Ticker - Right Click options 
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Advanced Ticker - Right Click Options 
 

INTRODUCTION  

The Advanced Ticker Right Click menu gives you access to some useful 

options. 

 

The Advanced Ticker Right Click Options are as follows: 

Show / Hide Title 

Show Symbol - (Only applicable for symbol information row) 

Show Change - (Only applicable for symbol information row) 

Ticker Speed - (Only applicable for symbol information row) 

Font 

Float 

Fix 

Filter 

Close 

 

SHOW / HIDE TITLE  

To view the Ticker with the Title: 

 Go to Right Click menu > Select Show Title option. 

 

To hide the Ticker Title: 

 Go to Right Click menu > Select Hide Title option. 

 

SHOW SYMBOL  

Show Symbol Code / Show Description 

To switch between Show Symbol or Symbol Description options: 
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 Go to Ticker Right Click menu > Select Show Symbol / Show Symbol 

Description option. 

Note: 

  This is applicable only for Ticker 1 which shows symbol information. 

 

 

SHOW CHANGE  

Show Change / Percentage Change 

To switch between Showing Change and Percentage Change 

options: 

 Go to Ticker Right Click menu > Select Show Change / Show Change 

Percentage option. 

Note: 

  This is applicable only for Ticker 1 which shows symbol information. 

 

FONT  

To customize Ticker by changing its Font Type, Style and Size: 

1. Go to Right Click menu > Select Font option. The Select a Font 

window opens. 

2. Specify the Font setting. 

3. Click on the OK button.  

 

FLOAT  

This option will make the ticker floatable so that it can be dragged within 

the workspace. 

To Float ticker : 

 Go to Ticker Right Click menu > Select Float option. 



© 2002-2010 DirectFN Ltd Page 227 

 
 

 

FIX  

This option allows you to either place the ticker at the Top of the 

workspace of bottom of the workspace as required.  

To Fix ticker : 

 Go to Ticker Right Click menu > Select Fix option > Select Top / 

Bottom as required. 

 

 

TICKER SPEED  

This lets you select the speed you want the Ticker to play. To change the 

Ticker speed: 

 Go to Right Click menu > Ticker Speed > Select the required speed as 

slow, medium or fast. 

 

      

 FILTER  

The Filter option lets you select the ticker to display all trades in a selected 

exchange / for trades in your Watch List. You can also select to play News 

and Announcements for the selected exchange.  

1. Go to Right Click menu > Filter > Select the required option. 

The available options are: 

 Exchange - This option will allow you to select the Exchanges. By 

default all exchanges are selected. 

- When displaying the symbols you have two options: 

 Show Traded - Show all the traded symbols of the selected 

exchange/s. This is selected by default.  
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 Show All  - Show All symbols of the selected Exchange/s. 

You can view all the symbols in a selected Exchange / Watch 

List irrespective of whether an update has occurred or not.  

- Run Ticker on Market Close  - You can select to run the ticker 

even when the market is closed. 

 My Stocks - Symbols in the Watch Lists created by you can be 

selected to run on the Ticker as preferred using this option. 

 Announcement - This option will let you select the exchange for 

which you want the Announcements displayed. By default all 

Exchanges are selected.  

 News - This will let you play the latest news releases from the 

available sources. Select the required source to display news items. 

2. Click on the OK button. 

 

 

  CLOSE  

This option closes the selected row.  

 Go to Ticker Right Click menu > Select Close option. 

To reactivate, go to View menu > Ticker > Advanced Ticker > Tick the 

relevant ticker row. 

 

 

RELATED INFORMATION  

Mubasher Pro Options 

Advanced Ticker 
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News & Announcements 
 

INTRODUCTION  

Mubasher Pro gives you access to news and announcements made by 

companies enlisted in the stock exchanges you have subscribed for, to 

keep you well informed. 

 

TOPICS IN THIS SECTION 

 

Announcements 

News 

 

RELATED INFORMATION  

Mubasher Pro Options 

Set Outlook Reminder 
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Announcements 
 

INTRODUCTION  

The Announcement window displays all announcements from the 

subscribed exchanges. The latest announcements are displayed first in 

Blue in the Announcements list.  

These Announcements can be exported to Microsoft Outlook as a reminder 

to be activated when set criteria is met (Set an Outlook Reminder). 

 

PROCEDURE 

Use one of the following  methods to view the Announcements 

window: 

Method 1 

 Go to View menu > Select the Announcements option. 

  

Method 2 

 Click on the  icon from the Icon Panel. 

 

Method 3 

 Right Click on the relevant symbol from either Full Market / Watch 

List. Select the Announcements option.  

Depending on the specified symbol, a search is performed to locate the 

relevant Announcements and these are displayed in the Announcement 

Search window. 

 

Announcement Indicators (See Figure 1). 

Announcement Indicators are displayed as bulbs in Full Market / Watch 

List windows, beside the Symbol. 
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Green Bulb – Indicates it is a latest announcement. Double click on this 

to view the latest announcement. 

Orange Bulb – Indicates the announcement has been read. 

 

Figure 1 - Full Market window with Announcement Indicators 

 

 

  Tip:  

  Use the Exchange drop down to quickly filter the items in the 

Announcements window. 

 

RELATED INFORMATION  

News & Announcements 

Set an Outlook Reminder 
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Set Announcement Popup 
 

INTRODUCTION  

If you wish to enable or disable the announcement window popup with 

latest announcement, you have to set this option. 

 

PROCEDURE  

To Enable Announcement Pop up: 

1. Go to Customize menu > point to Preferences > Tick Popup New 

Announcements option. 

 

To Disable Announcement Pop up: 

 Go to Customize menu > point to Preferences > Disable Popup 

New Announcements by removing the tick. 

OR 

 Go to Announcement window > Tick Do not Auto Pop up 

Announcement option.  

 

RELATED INFORMATION  

Mubasher Pro Options 

Announcements 
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Announcement Search 
 

INTRODUCTION  

You can search for a particular announcement or a set of announcements, 

by using the Announcement Search option. 

  

PROCEDURE  

To search for announcements: 

1. Go to View menu > Select the Announcements option. The 

Announcement Search window opens. 

Figure 1 - Announcement Search window 

 

 

2. In the Announcement Search window (See Figure 1), Click on the 

Search tab. 

In the Search tab you can do the following: 

Basic Search  

Advance Search 

 

BASIC SEARCH  

The Basic Search consists of only two search criteria, Symbol and 

Exchange based on which the search will be performed. 

To perform a Basic Search do the following; 



© 2002-2010 DirectFN Ltd Page 234 

 
 

In the Announcement Search window - Search tab: 

1. Exchange – Select the required Exchange from the drop-down menu. 

2. Symbol - Enter all or part of a symbol code if you want to search for 

announcements of specific symbols.  

3. Click on Search button. 

 

 

ADVANCED SEARCH  

The Advanced Search consists of different search criteria which allows 

you to perform a more detailed search. 

 

To perform an Advance Search do the following; 

In the Announcement Search window - Search tab: 

1. Click on the Advance Search button. The Advance Search - 

Announcements window opens (See Figure 2). 

 

Figure 2 - Advance Search - Announcements window 

 

 

In the Advance Search - Announcements window; 

2. Exchange – Select the Exchange from the drop-down menu. 

3. Type - Select one of these options. 

 Symbol – Type Symbol or if you cannot remember the symbol, 

click on the Symbol Search button  to search for the symbol.  
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 Sector – Select the Sector from the drop down list. 

 Exchange – Select to search by Exchange. 

 All 

4. Language – Select the language of the announcements you want to 

search for. 

5. Period - Select the Period as 

 Pre defined –  Select a pre-defined period from the drop-down 

menu. 

 Custom – Specify a From Date and a To Date. 

6. Click on the Search button. The results are displayed in the 

Announcement Search window. 

  Tip:  

  Use the Previous and Next buttons to move through the search results.  

 
 
RELATED INFORMATION  

Mubasher Pro Options 

Announcements 
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News 
 

INTRODUCTION 

Use this to view all of the news items released by companies listed in the 

Stock Exchanges in your subscription. 

 

PROCEDURE 

Use one of the methods given below to view the News window: 

Method 1: 

 Go to View menu > Select News option. Double click on any news item 

to view it's details. 

Method 2: 

 Right Click on the relevant symbol from either Full Market / Watch List. Go to 

Right Click menu > Select the News option.  

Depending on the specified symbol, a search is performed to locate the relevant 

News items and these are displayed in the News Search window. 

News Indicators (See Figure 1) 

News Indicators are displayed as triangles in Full Market / Watch List 

windows, beside the Symbol. 

Red Triangle – Indicates it‟s the Latest News item. Double click on this to 

view the News item. 

Orange Triangle – Indicates the News item has been read.  

Figure 1 - News Indicators in a Watch List 
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RELATED INFORMATION  

News & Announcements 

 

News Filter 
 

INTRODUCTION  

The News window displays all announcements from the subscribed 

exchanges by default. However, this can be changed using the News Filter 

option, which is available in the News window's right click menu.  

 

The News Filter window has the following tabs: 

 Sources - Using this tab, you can select the source from which you wish 

to view News in the News window. E.g.: Dow Jones Business News 

 Symbols - Use this tab, to select the symbols for which you want news 

to be displayed. E.g.: News from all Symbols appearing in Watch List 01.  

 

PROCEDURE  

To filter News items: 

1. Go to View menu > Select News. The News window opens. 

2. In the News window, right click within the window, go to Right-Click 

menu > Select News Filter. This displays the News filter window (See 

Figure 1). 

 

In the News Filter window: 

3. Go to the relevant tab and enable / disable the required options. 

4. Click on OK button. 

 

RELATED INFORMATION  

Mubasher Pro Options 

News 
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News Search 
 

INTRODUCTION  

If you wish to search for a particular News item, you can do so using the 

Search tab which is available in the News window. For your convenience 

the various search criteria has been categorized as follows: 

 

 Basic Search 

 Advanced Search 

 

BASIC SEARCH  

The Basic Search only consists of two search criteria, namely Symbol and 

Keyword based on which the search will be performed. 

To perform a Basic News Search: 

1. Go to View menu > Select News > Click on Search tab. The News 

Search window opens (See Figure 1). 

2. In the News Search window, specify the Symbol Code. E.g.: DIC / 

Keyword E.g.: Google. 

If matching results are found, they are displayed in the search results 

area. 

Note: 

  If you are not familiar with the symbol code, click on the symbol drop down 

to perform a symbol search. 
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Figure 1 - News window - Basic Search 

 

 

ADVANCED SEARCH  

The Advanced Search consists of various different search criteria which 

allows you to perform a more detailed search. 

 

To perform an Advanced Search: 

1. Go to View menu > News > Click on Search tab. The News Search 

window opens. 

2. Click on the Advanced Search button.  

3. In the Advanced Search window specify the following: 

 Exchange – Select Exchange from the drop down list. 

 Symbol – Type Symbol code if known. However, if you are not 

familiar with the symbol code, perform a Symbol Search. 

 Keyword – Type a relevant keyword to narrow your search. 

 Provider – Select the News Provider. 

 Period – Select Pre Defined or Custom. For Pre defined select the 

period from the list and for Custom, specify the From Date and To 

Date. 

3. Click on the Search button. 
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Tip: 

  Use Previous and Next buttons to view already searched news results. 

 

RELATED INFORMATION  

Mubasher Pro Options 

News 

 
 

Market Time & Sales 
 

INTRODUCTION  

The Market Time & Sales window displays all trades, with tick by tick trade 

information for selected exchange, from the time you opened the Time & 

Sales window. All the latest trades related to the exchange are displayed 

on top of the window and as new trades occur, they are added to the top. 

 

The following sections will guide you on how to make most of the different 

options available in Time & Sales option: 

Time & Sales - Exchange Wise - Download and view time and sales 

information for a selected exchange. 

Historical Time & Sales - Download and view time and sales information 

for exchanges for selected dates.  

 

RELATED INFORMATION  

Time and Sales - To view time and sales information symbol wise. 

 



© 2002-2010 DirectFN Ltd Page 241 

 
 

Time & Sales - Exchange wise 
 

INTRODUCTION  

This option displays the Market Time & Sales for all the symbols of the 

selected exchange. 

 

PROCEDURE  

To view Market Time and Sales – Exchange-Wise: 

Method 1 

1. Go to View menu > Select Market Time & Sales. This displays a 

popup asking you to select the required Exchange (See Figure 1). 

 

 Method 2 

1. Press Function key F2. This displays the Exchange popup (See Figure 

1). 

 

Figure 1 - Select Exchange for Market Time & Sales Popup 

 

 

2. Select the Exchange. This displays Market Time and Sales for the 

selected exchange (See Figure 2). 
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Figure 2 - View Market Time & Sales for selected Exchange 

 

 

RELATED INFORMATION  

Mubasher Pro Options 

Export Time & Sales 

Historical Time and Sales 
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Manage Time & Sales data 
 

INTRODUCTION  

You can export the trade information available in the Market Time & Sales 

window and also filter the displayed information as required using the 

options available through the right click menu of the window. 

Export All Trades 

Filter 

  

EXPORT TRADES  

Using the Export All Trades option available in the Right Click menu, you 

can export all trades in TXT, DOC or CSV format. 

To Export Time and Sales: 

1. Go to Right Click menu > Select Export All Trades option. The Export 

to File window opens. 

2. Click on Customize button > Select the fields to be exported. 

3. Specify the location you want to export the file. 

4. Click on the Export button. 

Note: 

  By default all the fields are exported, however, the Export to File feature also 

allows you to customize and select the fields to be exported. 

     

 

 

 

 

 

 

 



© 2002-2010 DirectFN Ltd Page 244 

 
 

Figure 1 - Select fields to be exported  

 

 

FILTER   

Once you open the Market Time & Sales window for a selected 

Exchange, you can Filter the trades by specifying a condition and obtain 

the results. The main criteria to filter results are Price, Quantity & 

Turnover and records can be filtered using one or more of these criteria. 

 

To filter the information: 

1. Go to Right Click menu > Select Filter option. The Filter window 

opens (See Figure 2). 

2. Enter the required filter criteria as follows: 

 Price - Enter a Price range. E.g.: If you want to view all symbols 

within the Price Range of 1.0 - 2.0 Enter 1.0 in From Field and 2.0 in 

To field.  

 Quantity - Enter a range for Quantity in the fields as required. 

 Turnover - Enter a range for Turnover in the fields as required. 
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 In addition to the above filtering you can use the Above and Below 

fields in the Show Additional Mark section to specify an „upper 

indicator‟ (Above) and a „lower indicator‟ (Below) value to highlight 

the stocks above/below the specified value. This is available for 

Price, Quantity & Turnover. When filtering is done using this the 

relevant cell  in the filtered results is highlighted as applicable with 

the below colours as shown in figure 3; 

Green color – Stocks that are Above a specified figure in any 

criteria category (Price/Quantity/Turnover). 

Red color – Stocks that are Below a specified figure in any 

criteria category (Price/Quantity/Turnover). 

 If you have given conditions for more than one criteria, you have an 

option to select if all conditions should be matched or any one 

condition is to be matched when filtering.  

Match All Conditions – Tick this if you want the filter results to 

match all the conditions provided. For E.g. if you have given 

conditions for both Price and Quantity criteria, both conditions 

will be matched when displaying the results.  

Match any Condition – Tick this if you want the filter results to 

match any of the conditions provided. For E.g. if you have 

given conditions for both Price and Quantity criteria, if a 

record matches any one of the conditions this will be 

displayed in the results. 

 When the successive trades box is ticked all trades that happened 

one after the other is marked with a blue line next to the relevant 

symbol description (See Figure 3).  

 

  Notes: 

  
The Above and Below value fields will only be activated once you 

specify a boundary value in „From‟ and „To‟ text boxes.  

  
The Match All Conditions & Match Any Conditions options are disabled 

by default and will be activated only if more than one criteria is 



© 2002-2010 DirectFN Ltd Page 246 

 
 

selected. 

 

3. Click OK button. 

Figure 2 - Filter window 

 

 

Figure 3 - Time & Sales window after filtering 

 

RELATED INFORMATION  

Mubasher Pro Options 

Market Time & Sales 
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Market Summary 
 

INTRODUCTION  

Market Summary gives you the summary of trading activity of all the 

subscribed markets. 

 

PROCEDURE  

To view Market Summary: 

1. Go to View menu > Select Market Summary. The Market Summary 

window opens. 

 

Notes: 

  A detailed market summary is available for the Egyptian Exchange. 

  The columns Market, Volume, Turnover, Trades, Ups, Downs, No Chg., & 

Status will be displayed by default when you open the Market Summary 

window. The other columns given above can be added to the window as 

required through the Column Settings option of the Right Click menu.  

 

The Market Summary window has the following columns: 

 Market – Name of Exchange. 

 Volume – The total number or shares traded. 

 Turnover (Value Traded) – Cumulative value of shares traded during 

the day. 

 Trades – Cumulative number of trades during the day. 

 Ups – Shows number of securities with positive price change for the 

day.  

 Downs – Shows number of securities with negative price change for the 

day.  
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 No Chg. - Shows the number of securities with no price change for the 

day. 

 Status – Status of exchange, i.e. pre-open, close, open. 

 Net Cash % - [Cash Net/(Bid Total+ Offer Total)]*100 

 %Cash Map - A graphical representation of trades. The green area 

represents the Cash In percentage and Red represents the Cash Out 

percentage. 

 Main Index - The Main Index of the market. 

 Index Value - The total value of the index.  

 Change - The difference between the current price and the previous 

day's closing price. 

 % Change - The percentage difference between the current price and 

the previous day's closing price. 

 

 

RELATED INFORMATION  

Mubasher Pro Options 

Detailed Market Summary 
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Detailed Market Summary for EGX 
 

INTRODUCTION  

Use this procedure to view a detailed summary of different financial 

instruments of the Egyptian Exchange (EGX).  

 

A summary is given for the following instrument categories available in 

EGX: 

 

 Listed - Gives a summary of listed stock, PD bonds, other bonds and 

funds. 

 

 NileX - Gives a summary of the stocks listed in the NileX market. NileX 

is also knows as Nile Stock Exchange and is the Egyptian Exchange 

market for medium and small companies of the Middle East and North 

Africa (MENA) region.  

 

 OTC - Gives a summary of the orders for over the counter stocks or 

stocks that are unlisted.  

 

PROCEDURE  

To view Market Summary: 

1. Go to View menu > Point to Market Summary > Select Detailed 

Market Summary. 

 

RELATED INFORMATION  

Mubasher Pro Options 
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Market Indices 
 

INTRODUCTION  

Using the Market Indices window, you can view the overall Index 

Summary for a subscribed exchange/s as well as the Chart for the selected 

Market Indices. In addition to the indices of the subscribed exchanges, the 

Market Indices window displays any Custom Indexes you have created.  

 

The following sections will guide you on how to do the same: 

Access Market Indices 

View Indices (using the Exchange drop down) 

View a chart for an Index 

 

MARKET INDICES  

Method 1 

 Press F7 key.  

 

Method 2 

 Go to View menu > Select Market Indices option. 

 

VIEW INDICES (using the Exchange drop down)   

You can view Index information for all exchanges listed in the drop down 

menu.  

 

To view Index information using Exchange drop down: 

1. Open the Market Indices window (See Figure 1). 

2. Select the required Exchange from the drop down. 
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Figure 1 - Market Indices for a selected Market from Exchange drop down 

 

 

 

VIEW A CHART FOR AN INDEX  

You can view the Intraday graph for any given index/symbol using the 

right click menu. 

 

To view a chart for an Index/Symbol: 

1. Open the Market Indices window and right click on the required 

index/symbol. 

2. Go to Right Click menu > Select Graph option. 

  Tip:  

  Double click on a selected row to view the Detail Quote. 

 

RELATED INFORMATION  

Mubasher Pro Options 

Custom Index 
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Investor Types 
 

INTRODUCTION  

Investor Types provides detailed investor type information about the 

Egyptian market. This window displays the available investor types and 

the bid and offer turnover for each investor type along with the 

percentage figure. You have the option of viewing a graphical view of the 

data if required. The graphical view shows the Bid Turnover and Sell 

Turnover percentage details separately for each investor type in a chart 

making it easier to view the difference at a glance.  

The investor types are categorized as Individuals, Institutions, Domestic, 

Arab and Foreign. 

 

PROCEDURE  

To access Investor Types: 

 Go to View menu > Select Investor Types. This displays the Investor 

Types window (See Figure 1). 

 

Figure 1 - Investor Types window 
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In the Investor Types window: 

1. Click on the Hide Chart link provided to close the graphical view (See 

Figure 1). This section is opened by default and can be closed if 

required.  

2. Once closed if you want to view the chart again click on the Show 

Chart link (See Figure 2). 

 

For each investor type the following data is displayed: 

 

Field Description 

Buying Bid Turnover 

Buy % Bid Turnover percentage (Compared to the total bid turnover). 

Selling Offer Turnover 

Sell % Offer turnover percentage (Compared to the total offer turnover). 

Net Value Difference between the bid turnover and offer  turnover. 

 

Figure 2 - Investor Types window when the Chart is closed 

 

 

RELATED INFORMATION  

Mubasher Pro Options 
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Top Stocks 
 

INTRODUCTION  

Top Stocks provide the latest Top Market price information for the 

selected exchange. 

 

PROCEDURE  

To view Top Stocks: 

1. Go to View menu > Select Top Stocks. The Top Stocks window 

opens (See Figure 1). 

2. Select the required Exchange and relevant Top Market Information 

Criteria from the respective drop-down menus. 

 

Figure 1 - Top Stocks 

 

 

Most Active by Volume* – Shows the top most active companies by 

volume traded during the day. 

Most Active by # of Trades* – Shows the top most active companies by 

no. of trades during the day. 

Top Gainers by % Change* – Shows the companies with the largest 

positive % price change during the day. 
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Top Losers by % Change* – Shows the companies with the largest 

negative % price change during the day. 

Top Gainers by Value Change* - Shows the companies with the largest 

positive price value change during the day. 

Top Losers by Value Change* - Shows the companies with the largest 

negative price value change during the day. 

High reached 52 weeks High* - Shows the symbols that have reached 

its 52 week high price. 

Low reached 52 weeks Low* - Shows the symbols that have reached 

its 52 week low price. 

 

* Availability of this option depends on your subscription. 

 

RELATED INFORMATION  

Mubasher Pro Options 
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Side Bar 
 

INTRODUCTION  

The Side Bar gives a listing of the exchanges as well as the securities 

available in the exchanges, for quick reference. The Side Bar can be used 

to Search for a security and also gives you access to many functions 

through the Right Click menu. 

 

View the Side Bar 

Search for a security in the Side Bar 

View Detail Quote from the Side Bar 

To drag a Symbol to a Custom Watch List 

Configuring the Side Bar 

Link Groups 

 

PROCEDURE  

Method 1 

 Go to View menu > Click on Side Bar. The Side Bar opens on the left 

of the workspace. 

Method 2 

 Move the mouse pointer / cursor to the left of the screen and left click to 

open the Side Bar. 

 

SEARCH FOR A SYMBOL   

Enter (Full or Partial) Description or symbol code of Security in the Search 

text field and click on the Search Button . This will display the results 

of the search in the Side Bar. 
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TO VIEW DETAIL QUOTE  

Method 1 

 Double click on the selected symbol in the Side Bar. The Detail Quote 

for that Security is displayed.  

Method 2 

 Right Click on the symbol > Select Detail Quote.  

 

TO DRAG & DROP A SYMBOL TO A CUSTOM WATCH LIST 

1. Select the required Symbol from the Side bar. 

2. Click and drag the symbol to the required Watch List and drop. 

 

 

CONFIGURING THE SIDE BAR  

You can configure the way the symbol names are displayed in the Side Bar 

and also change the font settings as required.  

 

To configure the Side Bar: 

1. Press the Configurations icon . The Side Bar Configurations 

window opens (See Figure 1). 
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Figure 1 - Side Bar Configurations window 

 

 

 

2. In the Side Bar Configurations window select ONE of the following; 

 Symbol - If you want only the symbol code displayed. Tick the 

Include Short Description checkbox if you want the short 

description displayed along with the symbol code. For E.g. for the 

symbol ARMX, short description is ARAMEX. If Include Short 

Description is selected it is displayed as ARMX ARAMEX. 

 Short Description - If you want the Company Code of the symbol 

displayed. Tick the Include Symbol checkbox if you want the 

symbol code displayed along with the short description. For E.g. for 

the symbol ARMX, short description is ARAMEX. If Include Symbol 

is selected it is displayed as ARAMEX ARMX. 

 Long Description - If you want a detailed description of the symbol 

displayed. Tick the Include Symbol checkbox appearing alongside if 

you want the symbol code displayed along with the detailed 

description. For E.g. for ARMX symbol the detailed description is 

Aramex Co. If include symbol is selected it is displayed as Aramex 

Co. ARMX. 

3. To change the change the Font settings, In the Font Settings section: 
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 Select the font type from Type list. 

 Select the font size from Size list.  

 Select the font style from Style list. 

 Select font colour required from the Colour list. 

4. Click OK button.  

 

RELATED INFORMATION  

Mubasher Pro Options 

Link Groups 
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Link Group 
 

INTRODUCTION  

The Link Group option lets you link certain functions to all the symbols in 

the Side Bar / Watch List.   

After you link a function to a watch list or the side bar, you can simply 

click on a symbol in that watch list or side bar to view the specific function 

details. You can link several functions to a Watch List or the Side bar as 

required.  

 

PROCEDURE As an example to use the Link Group option to open the Detail Quote 

for symbols in the Side Bar / Watch List, do the following: 

1. Open the Side Bar / required Watch List. 

2. On the toolbar of the window, Click the Link Group ( ) icon. 

3. Select a Colour as required from the list. 

4. Open the Detail Quote window for a selected symbol in Side Bar / 

Watch List (To open through a Watch List, Right Click on a symbol in 

the Watch List > select the Detail Quote option). 

 

In the Detail Quote window: 

5. On the toolbar of the Detail Quote window, Click the Link Group ( ) 

icon. 

After you complete this, you can open the Detail Quote for any symbol in 

the Side Bar / Watch List simply by clicking on the required symbol. 

6. You can remove the link created by clicking the Link Groups icon and 

selecting the Remove Link option.  

  Note: 

  The Link Group option is not available for some functions available 

through the Right Click menu.  
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  You can link one function to several Watch Lists as required. Simply 

select the same link group colour for the function and the required 

Watch Lists. 

 

Figure 1 - The Detail Quote with the Link Group list open 

 

 

 

 

RELATED INFORMATION  

Mubasher Pro Options 

View Side Bar 
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Currency Rates 
 

INTRODUCTION  

Mubasher Pro gives you the ability to view current cross currency rates to 

convert prices. Furthermore, you have the option of selecting which 

currencies to view as well as edit the number of decimal places displayed. 

  

PROCEDURE  

To open currency rates window: 

Go to View menu > Select Currency Rates. The Currency window opens 

(See Figure 1). 

 

Figure 1 - Currency Rates 

 

 

To define the currencies: 

1. Go to the Currency window > Select the respective Currency from 

the Currency List drop down . 

2. The Currency Rates window displays the conversion rates for only the 

selected currencies. 

3. Set the number of Decimal places using the Decimals drop down. 3 

decimal places are shown by default.  

RELATED INFORMATION  

Mubasher Pro Options 
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Global Market Summary 
 

INTRODUCTION  

You can view market information from around the world using the Global 

Market Summary. It allows you to monitor key global market indicators 

such as major indices, Forex rates and commodity prices that are closely 

related to your local / regional markets. 

 Equities - This displays stock market information from international 

exchanges* (NASDAQ, NYSE etc) and the regional exchanges* 

(Tadawul, DFM etc). 

 Commodity Prices - Prices of some commodities are displayed in this 

section. 

 Forex - This displays information from the Foreign Exchange market for 

key currencies.  

  Note: 

  

Currencies displayed in the Forex section are relative to each 

other. Click on the desired base currency and the relevant 

exchange rate/s will be displayed. You can easily identify the 

base currency, as this will not appear underlined as the rest. 

 

* The availability of the exchanges depend on your subscription. 

PROCEDURE  

Go to View menu > Select Global Market Summary. The Global 

Market Summary window opens. 

 

 

RELATED INFORMATION  

Mubasher Pro Options 
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Mubasher Pro Tools 
 

INTRODUCTION  

Mubasher Pro gives you access to a wide range of Tools such as: 

 

TOPICS IN THIS SECTION  

What-If Calculator 

Media Player 

Outlook Reminder 

Portfolio Simulator 

Alerts 

Download Manager 

Custom Column 

Custom Index 

MetaStock 

Tabular Indicator Properties 

Export History 

Time Lag Indicator 

Analysis Tools 
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Portfolio Simulator 
 

INTRODUCTION  

Mubasher Pro Portfolio Simulator is a comprehensive investment tool 

that offers custom views, allocation analysis and financial information. 

Using the Portfolio Simulator you can setup a hypothetical portfolio to 

track the performance of symbols that you wish to monitor and also 

perform a wide range of functions. You will be prompted to create a new 

Portfolio when you select the Portfolio Simulator option if there are no 

defined Portfolios. 

 

PROCEDURE  

To Open Portfolio Simulator: 

Go to Tools menu > Select Portfolio Simulator.  

 

INTERFACE 
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A: Main Toolbar B: All C: Currency List D: Valuation Method E: Available 

Cash Balance and selected Currency 

Main Toolbar - Provides quick access to the many functions available in 

the Portfolio Simulator. Refer  Toolbars for details. 

All - This tab displays details from the different Portfolios that you have 

created in a categorical manner. Note: This tab will display the relevant 

Portfolio Name. This is displayed along with the total summary details for 

each Portfolio. 

Currency List - This list displays a list of available currencies in the 

application. You can select the required currency and your Portfolio 

information is displayed accordingly. However, by default the currency in 

which the portfolio was created would be displayed. E.g.: If you created a 

Portfolio in Saudi Riyals (SAR), the information here would be displayed in 

SAR. 

Valuation Method - This displays in which valuation method, the Portfolio 

is valuated. You can edit this by using the Tools menu.  

Available Cash Balance and selected Currency - This displays the 

available cash balance in the Selected Portfolio and Selected Currency 

(from Currency). 

TOPICS IN THIS SECTION  

Using Toolbars 

Creating a Portfolio 

Adding Transactions 

Setting Selling Method 

Importing History 

Exporting Transaction History 

Managing your Portfolio 

Viewing Options 

Print 

 

RELATED INFORMATION  

Mubasher Pro Tools 
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Using the Toolbars 
 

INTRODUCTION  

The following Toolbars are available in the Portfolio Simulator window: 

Main Toolbar 

Mini-Toolbar 

 

MAIN TOOLBAR  

The Main Toolbar is available the Portfolio Simulator window and gives 

you quick access to important functions. Listed here, is the list of icons, 

with a description of its function. The table below illustrates the function of 

each icon depicted in the Main Toolbar. 

 

 
Create Portfolio 

 
Valuation View 

 
Trans History View 

 
Add Transaction 

 
Apply Filter 

 
Remove Filter 

 
Include Cash Balance 

 
Portfolio Review Report 

 MINI TOOLBAR  

The Mini-Toolbar is a part of the Right-Click menu and is available in 

both Valuation View and Trans History View options. It contains vital 

functions relating to appearance of the window as well as column settings. 

Refer to the Mini Toolbar section of the main help for details.  

RELATED INFORMATION:  

Portfolio Simulator 
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Create a Portfolio 
 

INTRODUCTION  

You can create any number of Portfolios as required to track the 

performance of symbols. 

 

PROCEDURE  

To Create a new Portfolio:  

Method 1 

1. Go to File menu > Select Create Portfolio. The Create Portfolio 

window opens. 

Method 2 

1. Click on the   icon in the Portfolio Simulators' icon panel. The 

Create Portfolio window opens (See Figure 1). 

 

Figure 1 -  Create Portfolio window 

 

 

2. Enter a valid Portfolio Name. 

3. Select required Currency from drop down. 

4. Enter required Cash Balance. 
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5. Select required Commission Rate - You are required to select the 

required method on how the commission will be calculated. The 

following options are available: 

 Manual - When this option is selected,  you will have to enter the 

commission when placing an order via the  window. 

 User Defined Commission* - When this option is selected, your 

commission will be automatically calculated when placing orders via 

the Add Transaction window. Furthermore, User Defined 

Commissions can be created via the Add New Commission window. 

6. Click on Create button. 

 

Notes: 

  
If you have not already created a portfolio, you will be prompted to do so 

when you open the Portfolio window. 

  
To set the created portfolio as default, enable the option Set as Default 

Portfolio. 

  *This option is not available if you have not created a commission. 

 

After you create a Portfolio you can Add Transactions to it.  

 

 
RELATED INFORMATION:     

Portfolio Simulator 

Add Transactions 

Importing History 

Managing your Portfolio 
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Add Transactions to a Portfolio 
 

INTRODUCTION  

Once you have Created a Portfolio you can Add Transactions to it. A 

typical Portfolio may include transactions such as (but not limited to) buy, 

sell, withdrawals, deposits and much more. 

 

PROCEDURE  

To Add Transaction/s: 

Method 1 

1. Select the required tab (selecting the All* tab, will display all 

Portfolios). 

2. Go to Tools menu > Select Add Transaction. The Add Transaction 

window opens. 

Method 2 

1. Select the required tab (selecting the All* tab, will display all 

Portfolios). 

2. Click on the   icon in the Portfolio Simulator‟s icon panel. The Add 

Transaction window opens. 
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Figure 1: Add Transaction window for a Buy Order 

 

 

3. Enter Symbol  

4. Select Transaction Type  

5. Select the required Portfolio to which you wish to add the transaction/s 

from the Add to Portfolio* drop down. 

6. Enter required Transaction information as given below depending on 

the transaction type selected; 

 Specify the Date – This can be a date in the past or future. By 

default the current date is displayed. 

 Enter the Quantity – Enter the number of shares you wish to buy / 

sell. 

 Specify the Share Price – You can either enter a share price of your 

choice, or get closing share market price for the entered date. (To 

get Closing Share Market Price, click on the Get Price Button). 
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 Enter Deposits** / Refunds** / Withdrawals** / Cash 

Dividends** - You are required to enter data into this field 

depending on the Transaction Type selected.  

 Specify the Commission Rate – The commission rate associated 

with the selected portfolio will be displayed here. 

 Enter Total Commission – You are required to enter a value only if 

the option Manual is selected  as the commission rate (see previous). 

 Enter Memo – Select the drop down and enter required text. 

7. Perform any one of the following actions; 

 Click on OK button to add the existing transaction to the selected 

portfolio. 

 Click on Add Another button to add the current Transaction and 

start a fresh transaction. 

 

  Notes: 

  When you perform Transactions such as deposit / withdrawal / charges 

and refunds, the cash balance is adjusted according to the Transaction Type. 

(E.g.: If there is a Deposit of AED 1000 , the Portfolio cash balance would 

increase by AED 1000). 

  * When you select the All tab, the portfolio appearing in the drop down Add 

to Portfolio is the default that was specified at the time of creating the 

portfolio. 

  ** Depending on the Transaction Type selected, the fields enabled will differ. 

E.g.: If you select the Transaction Type - Deposits, the fields available to 

you are Date, Deposits and Memo.  

  Symbols you have disabled in Watch Lists to optimize the performance is still 

available for use in Portfolio Simulator although the data feed for those 

symbols are disabled in Watch Lists.  

RELATED INFORMATION:  

Portfolio Simulator 

Import History 
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Import History 
 

INTRODUCTION   

The Import History option facilitates you to import any data from an 

external source to a Portfolio of your choice. You have the option of 

importing data that have been saved in data formats such as Excel (CSV 

file format). The data can be imported either to an existing Portfolio or a 

new Portfolio which can be created. 

 

PROCEDURE:  

To import data to a Portfolio: 

1. Go to Tools menu > Select Import File menu. The Import File 

window opens (See Figure 1). 

2. Do one of the following; 

 Enter the Name, Currency and Cash Balance to import to a new 

Portfolio. 

OR 

 To import to an existing portfolio, Select the Use Existing check 

box, and then select the required Portfolio Name from the drop 

down list (The names of all the Portfolios you have created are listed 

here). 

3. Click the Next button. The File Location window opens (See Figure 

2). 

5. Select the file type as CSV,  

6. Browse and select the file in the Browse field.  

7. In the Exchange Type drop down select (This is to facilitate users who have 

subscribed to a single exchange or for users importing all transactions from 

one exchange): 

 Single Exchange Only –  The imported file is accepted without an 

Exchange column. 
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 Multiple Exchanges – The imported file is accepted with the Exchange 

column. 

8. Click the Next button. This opens the Numerical Validation window. (See 

Figure 3) 

 

Figure 1: The Import File window 

 

 

Figure 2: File Location window 

 

 

In the Numerical Validation window (See Figure 3):  

This phase of the import process checks for the numerical accuracy of the 

data you are importing. You have the option of selecting the default 

column name which corresponds to your column (Figure 3). You can select 

from which row you want to start the data validation process as required. 

Follow instructions given below to complete the process.  
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1. Select from which row you want to start validating the data before 

importing. Ideally row no 2 should be selected as row no 1 has the 

column names provided in the text file.  

2. Specify the Date format. 

3. Select Exchange field will be enabled if Single Exchange Only was 

selected in step 9. Select the relevant Exchange from the list. If 

Multiple Exchanges was selected in step 9 this field will be disabled.  

4. You have the option of changing the column names if required. Select 

the best suited name from the drop down (See Figure 3). 

5. Click the Next button. When you click Next, the validation process will 

add all buy and sell transaction values of the same symbol to determine 

the cumulative value for each symbol. For a symbol if the sell 

transactions exceed the buy transactions, the row is highlighted.  

6. Once all data is validated a Popup will be displayed confirming the 

successful completion of validation. 

7. The Imported Data will be displayed in the Portfolio selected.  

Note: 

  If there is an error in the data in any row the system will highlight this during 

the validation process and you will be prompted for the next action. If you 

select Yes the validation process will skip the row in question and continue. 

However, if you opt to select Cancel the import process is halted after which 

you can perform the required change to your data file and follow steps 1 to 17 

as mentioned above. (See Figure 5) 
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Figure 3 - Numerical Validation window with change column shown 

 

 

 

Figure 4 - Popup confirming Import 

 

 

Figure 5 - Error message dialog Box 

 

RELATED INFORMATION:  

Portfolio Simulator 
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Set Selling Method 
 

INTRODUCTION   

Using the Selling Method option, you are able to simulate how you wish 

to sell the stocks held in a given portfolio. Mubasher Pro Portfolio 

Simulator has two pre-defined Selling methods. 

 

TOPICS IN THIS SECTION  

Sell using Weighted Average  

Sell using First In First Out method (FIFO) 

 

By default any sell transaction made using the Portfolio simulator is done 

in the Weighted Average method. However, depending on your choice 

you can switch between the two methods as required. 

 

RELATED INFORMATION:  

Portfolio Simulator 

 



© 2002-2010 DirectFN Ltd Page 278 

 
 

Weighted Average 
 

INTRODUCTION   

With the Weighted Average Selling Method, the selected holding's 

Realized Gain / Loss value is calculated based on the average value that is 

obtained by calculating the Weighted Average method. By default the 

Selling Method selected within the Portfolio Simulator is the Weighted 

Average method.  

 

PROCEDURE  

To perform a Sell transaction using the Weighted Average Selling 

Method: 

1. Enable the Weighted Average option. Go to Tools menu > Selling 

Method > Select Weighted Average option. 

2. Open Add Transaction window (go to Tools menu > Select Add 

Transaction option).  

3. Enter the Symbol required. 

4. Select the Transaction Type as Sell. 

5. Select the required Portfolio from the Add to Portfolio drop down. 

6. Enter required Transaction information. 

 Specify the Date. 

 Enter the Quantity – Enter the number of shares you wish to sell. 

 Specify the Share Price. You can either enter a share price of your 

choice, or get closing share market price for the entered date. (To 

get Closing Share Market Price, click on the Get Price Button). 

 Specify the Commission Rate / Total Commission. 

 Enter Memo.  

7. Click on OK button to add the existing transaction to the selected 

portfolio. 

Once the transaction is placed via the simulator, you can inspect the 

transaction details via one of the Viewing Options. 
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Note: 

  When you are placing the sell order via the Add Transactions window, make 

sure to select the Transaction Type as Sell from the drop down. 

 

RELATED INFORMATION:  

Portfolio Simulator 

FIFO Selling method 

Viewing Options 

 
 

 

FIFO Selling Method 
 

INTRODUCTION  

Using the First In First Out (FIFO) Selling Method, you are able to 

perform a sell transaction based on the stocks which are acquired first. 

Furthermore, the calculations such as Realized Gain / Loss will also be 

adjusted to reflect the FIFO Selling Method.  

 

PROCEDURE  

To perform a Sell Transaction using the FIFO Selling Method: 

You have to first enable the FIFO method as given below; 

1. Go to Tools menu > Selling Method > Select FIFO option. 

2. Open the Add Transaction window (go to Tools menu > Select Add 

Transaction option). 
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Figure 1 - Add Transaction window - Sell Transaction using FIFO Selling method 

 

 

3. Enter the Symbol required. 

4. Select the Transaction Type as Sell. 

5. Select the required Portfolio from the Add to Portfolio drop down. 

6. Enter required Transaction information. 

 Specify the Date. 

 Enter the Quantity – Enter the number of shares you wish to sell 

and then click on the Advanced button. This displays a section with 

the different buy Transaction quantities for the selected symbol. 

Enter the required Sell Qty against the queue of buy quantities to 

determine how the Sell quantity needs to be constituted in 

accordance with FIFO principle. (See Figure 01).  
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 Specify the Share Price. You can either enter a share price of your 

choice, or get closing share market price for the entered date by 

clicking on the Get Price button. 

 Specify the Commission Rate / Total Commission. 

 Enter Memo  

7. Click on OK button to add the existing transaction to the selected portfolio. 

 

RELATED INFORMATION:  

Portfolio Simulator 

Add Transactions 

FIFO Selling method 

 
 
 
 

Export Transaction History 
 

INTRODUCTION   

The Export Transaction History option facilitates the export of 

transaction history data for a particular symbol, or for all symbols, of the 

selected portfolio. This is particularly useful if you wish to view the data 

using a different third party application such as a Text Editor. 

 

PROCEDURE   

To Export Transactions:  

1. Go to Tools menu > Select Export Transaction History. The Export 

Transactions window opens (See Figure 1). 
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Figure 1 - Export History 

 

 

2. Select the Portfolio from the Portfolio List. 

3. Select the required symbols from the list. You can either select one, 

multiple, or All symbols from the symbol drop down.  

4. Select the Time Range you require;  

 Complete History - Select if you want to export the complete 

history of transactions for the selected symbols. 

 Custom Date Range - Select this if you want to define a date range 

to export the transaction history of only the specified period. 

5. Select Export Type (CSV / Text / QIF Format). 

6. Specify the Export Location to export files, using the Export To drop 

down. 

7. Click on the Export button. 
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Once transactions are exported successfully a Confirmation Message is 

displayed indicating the number of records exported for the given criteria.  

  Tip:  

  If the transactions are exported in CSV format, you can view the exported 

data in an excel sheet. 

 

RELATED INFORMATION:   

Portfolio Simulator 

 
 
 

Valuation Method 

 
INTRODUCTION   

Mubasher Pro provides you with evaluation strategies to help you to 

evaluate your portfolio. 

 

 

PROCEDURE  

Go to Tools menu > Select Valuation Method > Select required method 

(VWAP / Last Price). 

 Last Price - All securities available in the Portfolio are valued using the 

Last Traded Price. When the exchange is closed, the securities will be 

valued at the previous day's Last Traded Price. 

 VWAP - All securities available in the Portfolio are valued using the 

Volume-Weighted Average Price (VWAP) method. Volume-Weighted 

Average Price is the ratio of the value traded to total volume traded over 

a particular time period. (VWAP = Total Value Traded / Total Volume 

Traded). 

By default the Last Price is the method selected. 

 

RELATED INFORMATION:  

Portfolio Simulator 
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Managing your Portfolio  
 

INTRODUCTION    

Once you have created a Portfolio Mubasher Pro offers various options for 

you to easily manage your Portfolio details. 

 

TOPICS IN THIS SECTION  

Edit Portfolio 

Delete Portfolio 

Add a new Commission 

Commission List 

Backup Transactions 

Restore Transactions 

Adjust Split Factor 

 

RELATED INFORMATION:  

Portfolio Simulator 
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Edit Portfolios 
 

INTRODUCTION   

A Portfolio once created can be edited at any given time depending on 

your requirements. 

 

PROCEDURE   

To Edit an existing portfolio: 

1. Select the required tab (selecting the All* tab, will display all 

Portfolios). 

2. Go to Manage menu > Select Edit Portfolio. The Edit Portfolio 

window opens (See Figure 1). 

 

Figure 1 - Edit Portfolio window 

 

 

2. Edit the required field/s. 

You are allowed to edit only the following fields: 

 Portfolio Name - You can edit the existing name and specify any 

new suitable name in this field. However, the name should not be the 

same as any existing portfolios. 

 Commission Rate - You can edit the existing rate on how the 

commission is calculated. The following options are available. 
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 Manual - When this option is selected, you will have to enter the 

commission when placing an order via the Add Transaction window. 

 User Defined Commission - When this option is selected, your 

commission will be automatically calculated when placing orders via 

the Add Transaction window. Furthermore, User Defined 

Commissions can be created via the Add New Commission window. 

 Set as Default - You can select / clear this check box. Hence, it will 

enable / disable the portfolio being the default.  

3. Click on Update button. 

Note: 

  *When the All tab is selected, you will only be able to edit the details of the 

Default Portfolio that you have specified. 

  

 
RELATED INFORMATION:  

Managing your Portfolio 

Portfolio Simulator 
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Delete Portfolios 
 

INTRODUCTION  

You can Delete the portfolios you have created, at any given time. 

However, if you delete a portfolio, all the transactions included in the 

portfolio will be deleted.  

 

PROCEDURE   

To Delete a portfolio: 

1. Select the required tab (selecting the All* tab, will display all 

Portfolios). 

2. Go to Manage menu > Select Delete Portfolio. A Confirmation 

Message is displayed. 

3. Click on Yes button. 

Note: 

  *When the All tab is selected, you will only be able to delete the default 

Portfolio that you have specified.  

 

 

RELATED INFORMATION:  

Managing your Portfolio 

Portfolio Simulator 
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Add a New Commission 
 

INTRODUCTION   

The application facilitates the calculation of commissions for your trades in 

Portfolio Simulator. Hence this option, enables you to create your own 

commission rate/s as per your requirement. Once you have created the 

required commission rates, they can be linked to the required Portfolio. 

Once the Portfolio is linked to the a required commission rate, you can 

place orders and other transactions easily via the Add Transactions 

window and the commission charged will be computed automatically. 

 

PROCEDURE  

To add a new commission rate: 

1. Go to Manage menu > Select Add New Commission. The Add New 

Commission window opens. 

 

Figure 1 - Add new Commission 

 

 

2. Enter required Name* for the commission rate. 

3. Enter required Minimum Price* -The commission will be calculated 

based on the amount entered here. If you do not wish to specify a 

minimum price , you are still required to enter zero (0) in this field as 

these fields are mandatory.  
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4. Enter required Commission Percentage* (%) - The commission 

percentage to be charged based on the transaction. If you do not wish 

to specify value here, you are still required to enter zero (0) in this 

field as these fields are mandatory.  

5. Click on OK button. 

Once you have successfully created the commission rate, you can 

view, edit and delete it via the Commission List window. 

Notes: 

  
The Minimum Price entered will be on the base currency on which you 

opened your portfolio. 

  *Indicates mandatory fields.  

 

  

RELATED INFORMATION:  

Managing your Portfolio 

Portfolio Simulator 

Commission List 
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Manage Commission Lists 
 

INTRODUCTION  

This window displays details of any commission rate/s created using the 

Add New Commission window. The following functions are available via the 

Commission List window: 

 

View commission list 

Edit commission rate 

Delete commission rate 

 

 VIEW COMMISSION RATES  

To view details of commission rate/s created:  

 Go to Manage menu > Select Commission List. The Commission List 

window opens (See Figure 1). 

 

Figure 1 - Commission List window 

 

 

TO EDIT COMMISSION RATES  

To edit an existing commission rate: 

1. Go to Manage menu > Select Commission List. This displays the 

Commission List window (See Figure 1). 

2. In the Commission List window, select the required record and click 

on the  icon. This displays the Edit Commission window. 
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In the Edit Commission window: 

3. Edit the required field - You can edit the fields Commission Rate 

Name, Minimum Price and Percentage. 

4. Click on OK button. 

Once the required change/s have been done, you can view the updated 

details via the Commission List window. 

 

TO DELETE  

To delete an existing commission rate: 

1. Go to Manage menu > Select Commission List. This displays the 

Commission List window (See Figure 1). 

2. In the Commission List window, select the required record and click 

on the corresponding  icon. 

3. This displays a Confirmation Message. Click on OK button.  

  

 
RELATED INFORMATION:  

Managing your Portfolio 

Portfolio Simulator 

Add New Commission 
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Backup Transactions 
 

INTRODUCTION  

The Backup Transaction option allows you to preserve a backup copy of 

your portfolio transactions, in case something happens to your active 

portfolio. The following options are available for you.  

Automatic Backup 

Manual Backup 

 

AUTOMATIC BACKUP  

Automatic Backup provides you the flexibility to specify the Backup 

location and a time frequency frame (e.g.: every 10 minutes, 15 minutes 

and in 30 minutes) to backup your transactions in the background, while 

you run the application. 

 

PROCEDURE  

To enable Automatic Backup: 

1. Go to Manage menu > Select Backup Transactions. The Backup 

Transactions window opens. 

 

Figure 1 - Backup Transactions window – Automatic Backup 

 

 

2. In the Backup Transactions window, Enable the Automatic Backup 

option (See Figure 1). 
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3. Click on the Set Backup Location drop down and this displays the 

Export To File window.  

4. In the Export To File window, specify the required Backup Location, 

File Name, Format and click Save button. This takes you back to the 

Backup Transactions window. 

5. Select the time frame from the drop down list (E.g.: every 10 

minutes, 15 minutes or 30 minutes). 

6. Click on the OK button. 

  

MANUAL BACKUP  

You can take a Manual Backup of your Portfolio Transactions at any 

given time. The Manual Backup can be done even if you have enabled the 

Automatic Backup option.  

 

PROCEDURE  

To take a Manual Backup: 

1. Go to Manage menu > Select Backup Transactions. The Backup 

Transactions window opens. 

 

Figure 2 - Backup Transactions window – Manual Backup 
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2. In the Backup Transactions window, Click on the Backup Now 

button in the Manual Backup section (See Figure 2). This displays the 

Export to File window. 

3. In the Export to File window, specify the required Backup Location, 

File Name, File Format and click Save button. This takes you back to 

the Backup Transactions window. 

4. Click on the OK button. 

 

 
RELATED INFORMATION:  

Managing your Portfolio 

Portfolio Simulator 
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Restore Transactions 
 

INTRODUCTION  

If you have previously backed up your portfolio transactions, you can 

retrieve / restore the same by using the Restore Transactions option.  

 

PROCEDURE  

To restore your backed up transactions: 

1. Go to Manage menu > Select Restore Transactions. The Import 

from File window opens (See Figure 1). 

 

Figure 1 - Import from File 

 

 

2. In the Import File window, specify the Folder Path and select the 

required file. 

3. Click on the Open button. 

 
 
RELATED INFORMATION:  

Managing your Portfolio 

Portfolio Simulator 
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Adjust Split Factor 
 

INTRODUCTION  

Use the Adjust Split Factor option to automatically adjust the stock held 

in a given portfolio based on a corporate action declared by the company. 

Mubasher Pro is equipped with a number of sources from which you can 

obtain information on corporate actions which include News, 

Announcements and Services. 

Once the adjustment has been done to the stock held in the portfolio, the 

various calculations such as Unrealized Gain / Loss, Valuation will be 

automatically computed and a more accurate picture of your Portfolio is 

depicted. You can opt to adjust the stock for a given symbol in a portfolio 

at any given time. However, once you make an adjustment to the stock in 

the Portfolio, it cannot be reverted back. Therefore we strongly suggest 

that you make a backup of the required transactions before applying a 

split. 

 

PROCEDURE  

To adjust stock held for a given symbol: 

1. Go to Manage menu > Select Adjust Split Factor. The Adjust Split 

Factor window opens (see Figure 1). 

 

Figure 1 - Adjust Split Factor window 

 

 

2. In the Adjust Split Factor window, Enter the required symbol code in 

the Symbol field. 
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3. Select the Split Date* from the drop down. 

* Note: The following conditions apply when selecting the split date; 

  The date should be a date after the initial transaction date for that 

symbol (I.e. the date the first buy transaction was placed for the 

symbol). 

  The split date cannot be a future date. It has to be the current market 

date or a date in the past (but cannot be a date older than the 

transaction date). 

 

4. Enter Split Factor which you received from a Corporate Action. 

5. Click on OK button. The Split Adjustment window opens (see Figure 

2). 

Figure 2 - Split Adjustment window 

 

 

6. In the Split Adjustment window, Amend the New Qty. field 

(optional). 

7. Click on OK button. 

The Stock adjustment (as per the Corporate Action) process is now 

complete. You can now view the adjusted stock details via the Valuation 

View screen. 

 
RELATED INFORMATION:  

Managing your Portfolio 

Portfolio Simulator 
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Viewing Options 
 

INTRODUCTION  

You can view your Portfolio Details through several views depending on 

your requirement.  

 

TOPICS IN THIS SECTION  

Set to Valuation View 

Set to Trans History View 

Show Zero Holdings 

Portfolio Review 

 

 
RELATED INFORMATION:  

Portfolio Simulator 
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Set to Valuation View 
 

INTRODUCTION  

The Valuation View option shows the latest valuation of the selected 

portfolio. If the market is open, the latest trading prices for the symbols 

will be used for valuation. Similarly, once the market is closed, closing 

prices for the day or last trading day will be used for valuations, until the 

market opens the next day. 

 

PROCEDURE  

To activate Valuation View:  

Method 1 

1. Select the required tab (Selecting the All tab will display details of all 

Portfolios). 

2. Go to View menu > Select Valuation View. This displays the 

Portfolios in Valuation View (See Figure 1). 

Method 2 

1. Select the required tab (Selecting the All tab will display details of all 

Portfolios). 

2. Click on the  icon from the Main Toolbar. This displays the Portfolios 

in Valuation View (See Figure 1). 

Figure 1 - Valuation View 
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RELATED INFORMATION:  

Viewing Options 

Portfolio Simulator 

Show Zero Holdings 

 
 
Right Click options 
 

INTRODUCTION  

The Average Cost Calculator is a unique option available in the Right 

Click menu of the Valuation View. It can be used to calculate the Volume 

Weighted Average Price (VWAP) or the Number of Shares to buy for a 

given symbol. 

The Average Cost Calculator has the following tabs: 

Shares to Buy 

Expected VWAP (Volume Weighted Average Price) 

You can also change set the Decimal Places of values in your Portfolio as 

required.  

 

EXPECTED VWAP  

Using this tab, you can compute the VWAP for a selected symbol, if you 

expect to purchase / sell for a given number of shares. 

 

To calculate the VWAP for a given number of shares: 

1. Select the required transaction from Valuation View. 

2. Go to Right-Click menu > Select Average Cost Calculator. The 

Average Cost Calculator window opens (See Figure 1). 
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Figure 1 - Average Cost Calculator - Expected VWAP 

 

 

3. In the Average Cost Calculator window, Select the Expected VWAP 

tab. 

4. Enter the required number of shares you wish to purchase/sell in 

Shares to buy field. 

5. Click on the Calculate button. 

 

SHARES TO BUY  

Using this tab, you can compute the number of shares that need to be 

purchased / sold so that the VWAP value of the symbol is the   required 

value specified (see Figure 2).  

To calculate the number of shares,  for a given VWAP (Volume Weighted 

Average Price) :  

1. Select the required transaction from Valuation View and right click on 

it. 

2. From the Right-Click menu > Select Average Cost Calculator.The 

Average Cost Calculator window opens(See Figure 2). 
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Figure 2 - Average Cost Calculator - Shares to Buy 

 

 

3. In the Average Cost Calculator window, Select the Shares to Buy 

tab. 

4. Enter the the required VWAP value in Expected VWAP field. 

5. Click on the Calculate button. 

 

  

DECIMAL PLACES  

Go to Right Click menu from selected Portfolio > Select Decimal Places > 

Select the required number of Decimal places from the list. 

 

 

RELATED INFORMATION:  

Set to Valuation View 

Viewing Options 

Portfolio Simulator 

Valuation Method 
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Set to Trans History View  
 

INTRODUCTION  

Using the Trans History view, you can track the performance of existing 

portfolios, i.e. you can use this feature to view all past transactions 

individually, including the opening balances, dividend, buy, sell 

transactions. Furthermore, many functions of the Trans History View 

window can be accessed from the window's right click menu. 

 

PROCEDURE  

To activate Trans History View:  

Method 1 

1. Select the required tab*. 

2. Go to View menu > Select Trans History View.  

Method 2 

1. Select the required tab*. 

2. Click on the  icon from the Portfolio Simulator‟s icon Panel. 

Note: 

  * Selecting the All tab will display details of all Portfolios created. The Trans 

History View is not available for Portfolio details appearing in this tab.  

 

RELATED INFORMATION:  

Viewing Options 

Portfolio Simulator 
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INTRODUCTION  

The Trans History View has the following Right-Click options: 

Edit Transaction 

Delete Transaction 

Filter Transaction History 

You can also change set the Decimal Places of values in you Portfolio as 

required.  

  

EDIT TRANSACTION  

Use this option if you wish to amend details of an existing transaction in 

your portfolio. You are allowed to edit the Date, Quantity, Share Price, 

Total Commission and Memo. 

 

To Edit Transaction: 

1. Select the required symbol and right click. 

2. Go to Right-Click menu > Select Edit Transaction. The Edit 

Transaction window opens (See Figure 1). 
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Figure 1 - Edit Transaction window 

 

 

3. In the Edit Transaction window, amend the required information.  

4. Click on the OK button. 

 

DELETE A TRANSACTION  

You can use this option to delete an existing transaction from your 

portfolio at any given time. 

To Delete Transactions: 

1. Select the required symbol and right click. 

2. Go to Right-Click menu > Select Delete Transaction. This displays a 

Confirmation Message. 

3. Click on the Yes button. 
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FILTER TRANSACTION HISTORY  

Use the Filter Transaction History to sort and filter the data available in the 

Trans History window. This option can be accessed from the right click 

menu or simply clicking on the  icon from the icon Panel of the window. 

 

To use Filter Transaction History: 

1. Select the required transaction and right click. 

2. Go to Right-click menu > Select Filter Transaction History. The 

Filter Transaction History window opens (See Figure 2). 

 

Figure 2 - Filter Transaction History 

 

 

3. In the Filter Transaction History window, Specify the Time Period, 

Symbol / Type as required. 

4. Click on the Apply Filter button.  

If matching results are found, they are displayed in the Trans History View 

window. To remove a filter and view all Transactions, simply click on the 

Remove Filter  icon (See Figure 3). 
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 Figure 3 - Trans History View window with Filter applied 

 

 

DECIMAL PLACES  

Go to Right Click menu from selected Portfolio > Select Decimal Places > 

Select the required number of Decimal places from the list. 

 

RELATED INFORMATION:  

Set to Trans History View 

Viewing Options 

Portfolio Simulator 
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Show Zero Holdings 
 

INTRODUCTION  

The Show Zero Holdings option (when enabled in the Valuation View 

window), will display details of symbols that are not held in the portfolio 

any longer. For an instance, if you decide to perform a sell transaction for 

all shares held for the symbol ABC, the quantity held in the portfolio is 

zero (0). When the Show Zero Holdings option is enabled, you are able to 

view the details of the symbol ABC although the quantity held in the 

portfolio is zero. 

 

PROCEDURE  

To show / hide details of symbols no longer held in a portfolio: 

1. Select the required tab (selecting the All tab, will display all Portfolios). 

2. Go to View menu > Select Show Zero Holdings option.  

Notes: 

  This option is available only in the Valuation View window. 

  The Show Zero Holdings option is disabled by default.  

 

RELATED INFORMATION:  

Viewing Options 

Portfolio Simulator 
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Portfolio Review 
 

INTRODUCTION  

Use the Portfolio Review option to view the Portfolio in a graphical 

manner. The data in your portfolio is sub divided into several categories 

and they are displayed in a graphical manner in a series of pie charts.  

 

PROCEDURE  

To view Portfolio Review Report:  

Method 1 

1. Select the required tab (Selecting the All tab will display details of all 

Portfolios). 

2. Go to View menu > Select Portfolio Review. The Portfolio Review 

Report window opens (See Figure 1). 

Method 2 

1. Select the required tab (Selecting the All tab will display details of all 

Portfolios). 

2. Click on the   icon in Portfolio Simulator window‟s toolbar. The 

Portfolio Review Report window opens (See Figure 1) 
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Figure 1 - Portfolio Review  

 

 

Tips: 

  Click on the Print button to generate the report required. 

  If you have multiple Portfolios, you are required to select  Portfolio you 

require from the Portfolio List and then generate this report. 

 

RELATED INFORMATION:  

Viewing Options 

Portfolio Simulator 
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Print  
 

INTRODUCTION  

The Portfolio Simulator allows you to Print any selected Portfolio at a 

given time. 

 

PROCEDURE  

To Print a portfolio:  

1. Select the required Portfolio, by selecting the required tab.  If you 

wish to print details of all Portfolios, select the All Tab. 

2. Go to File menu > Select Print. The Print dialog box opens. 

3. In the Print dialog box, select the printer and set the printing options 

as required and click OK. 

 

RELATED INFORMATION:  

Portfolio Simulator 
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Alerts 
 

INTRODUCTION 

Use the Alerts tool to monitor the market and to be notified when a 

symbol meets the criteria that you define.  

When the symbol meets the set criteria, you will be alerted via a popup 

message, SMS or e-mail depending on the options you have selected 

(Alert Modes SMS and e-mail are enabled based on your subscription). You 

can set alerts on every single symbol in your window, for different time 

periods and intervals so that you can know instantly when a trading 

opportunity arises based on your criteria.  

 

PROCEDURE 

To Set Alerts: 

1.  Open the Set Alerts window using one of the methods given below; 

 Go to Tools menu > Alerts > Select Set Alerts option. 

 Right Click on selected symbol > select Set Alert option.  

The Set Alerts window opens. 

2. In the Set Alerts window, enter the required symbol in the Symbol 

field. (Enter the symbol code or use the Symbol Search feature if the 

code is not known.) 

3. Click the Add Condition button. The Add Condition window opens. 

4. In the Add Condition window, enter the following and click OK. 

 The Parameter - the field to set the alert. 

 The Criteria for the alert condition. E.g.: greater than or less 

than. 

 The Value to trigger the alert as required. 

5. If you want to add another alert, repeat step 3-4.  

6. Select the required Notification frequency, Expiration period for the 

alert and the Alert Condition from the lists. 
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7. Select the Alert Mode*.  

8. Click Apply.  

9. Click View All button to open the Results window, which displays the 

status of the alerts. 

  Notes: 

  *The Alert Modes SMS / Email are enabled based on your subscription.  

  
Click Delete button  to delete an alert condition created. 

  Click Edit button  to edit the alert condition. When you click the  

button, the relevant Add Condition window opens. Edit the condition as 

required and click OK. 

  Click the Active Alerts for the selected symbol link to view/hide the 

alerts created for the given symbol. Expired alerts are not displayed.  

 

Figure 1 - Set Alerts window 

 

RELATED INFORMATION  

Mubasher Pro Tools 
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Alert Results 
 

INTRODUCTION 

The Alert Results window displays all active alerts for all symbols in a 

summarized manner. Once an alert condition is met for a symbol and the 

alert is triggered the status of the alert is displayed as Triggered.  

 

PROCEDURE 

To view Alert Results: 

Method 1 

 Go to Tools menu > Alerts > Select Alert Results option. The Alert 

Results window opens.  

Method 2 

 Click Alert Results button in the Set Alerts window. 

 

RELATED INFORMATION  

Alerts 

Mubasher Pro Tools 
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Download Manager 
 

INTRODUCTION 

The Download Manager gives you access to features that let you 

download historical and Intraday details of exchanges as required.  

 

TOPICS IN THIS SECTION 

Historical Time & Sales 

Historical Intraday 

Download History 

 

RELATED INFORMATION:  

Mubasher Pro Tools 
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Historical Time & Sales 
 

INTRODUCTION  

The entire Time & Sales files for historical data can be downloaded by 

using the Historical Time & Sales option. 

 

PROCEDURE  

To download Historical Time & Sales: 

1. Go to Tools menu > Download Manager > Select Historical Time & 

Sales option. The Historical Time & Sales window opens (See Figure 

1). 

 

Figure 1 - Historical Time & Sales window 
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2. In the Historical Time & Sales window, Select the required 

Exchange from the drop down. This displays a list of data available for 

download for the selected Exchange. 

3. From the list, select the required dates you want to download data.  

4. Click on the Download button. Once the selected Time & Sales 

History is downloaded, it is indicated by the Open status ( ) Icon. 

5. Once a download is complete, two Icons (  and ) will appear in the 

Status Field. These represent the following: 

  - Click on this icon to See Trade Information. Trade 

Information will open in the Detail Time & Sales window. 

  - Click on this icon to Export Trade Information. You can 

specify the location to save the Trade Information, and the format of 

the file (TXT, DOC or CSV format) to save. 

 

  Notes: 

  When a download is in progress, it is not possible to start another 

download. A message will be displayed indicating that another download is 

in progress. You will have to wait till the download is complete to start 

downloading more files. 

  To close the window while the download is in progress, click on the Hide 

button. This hides the window but the downloading process continues. To 

indicate that a download is in progress an animated arrow  will appear 

near the Main menu. If you place the mouse over the animated arrow you 

can view the download progress. To view the window again re-open 

through the Tools menu.  

 

RELATED INFORMATION:  

Download Manager 

Mubasher Pro Tools 

Market Time & Sales 
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Downloading Large Files 
 

INTRODUCTION  

If the file you want to download exceeds 1.5 MB, you have to Export the 

File to a different location and extract it using Notepad (in Microsoft 

Windows). 

 

PROCEDURE  

To download large Historical Time & Sales files: 

1. Go to Tools menu > Download Manager > Select Historical Time & 

Sales option. The Historical Time & Sales window opens. 

2. In the Historical Time & Sales window, Select the required 

Exchange from the drop down. This displays a list of data available for 

download for the selected Exchange. 

3. From the list, select the required dates you want to download data.  

4. Click on the Download button. If the file exceeds 1.5 MB you are 

notified via a Confirmation Message. 

5. In the Confirmation Message, click on No button and this displays a 

further Confirmation Message.  

6. Once again in the Confirmation Message, enable the option Open in 

Notepad after Extract option and click on Export Trades button. 

Note: 

  If you do not enable the Open in Notepad after Extract option, you can still 

open the downloaded data at any time by using Notepad. 

 

RELATED INFORMATION:  

Historical Time & Sales 

Mubasher Pro Tools 
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Filter History 
 

INTRODUCTION  

Once you have downloaded the Historical Time & Sales for the 

Exchange for a particular day, you can further Filter the results by 

specifying the Symbol, Price Range, Time Period, Quantity and Turnover. 

 

PROCEDURE  

To specify a filter: 

1. Do one of the following to open the Filter window. 

 Right click on any data row in the Detail Time & Sales window > 

Select Filter option. 

OR 

 Click on the filter link on the top panel of the downloaded Detail 

Time & Sales window. 

 

Figure 1 - Historical Market Time & Sales Filter 

 

 

2. In the Filter window, Enter the required filter criteria. You can select to 

enter one or more of the following criteria as required; 

 Symbol - Enter a specific symbol if required.  
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 Price - Enter a Price Range. E.g.: If you want to view all symbols 

within the Price Range of 1.0 - 2.0 Enter 1.0 in From Field and 2.0 in 

To field.  

 Time - If you want to view the sales that happened for a specific 

time period, specify the time period here. 

 Quantity - You can enter a value for Quantity, and the records 

filtered and displayed will be within that specified range. 

 Turnover - You can enter a value for Turnover, and the records 

filtered and displayed will be within that specified range. 

3. Click on OK button. 

 

Using the Export All Trades option available in the Right Click menu, you 

can export all trades in TXT, DOC or CSV format. 

 

RELATED INFORMATION:  

Historical Time & Sales 

Mubasher Pro Tools 
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Historical Intraday 
 

INTRODUCTION  

Use the Historical Intraday tool to download Intraday data. This allows 

you to download Open, High, Low, and Close (OHLC) data for the recent 

past i.e.: the last 30 days.  

 

PROCEDURE  

To download Historical Intraday for a given exchange: 

1. Go to Tools menu > Download Manager > Select Historical 

Intraday option. The Historical Intraday window opens (See Figure 

1). 

 

Figure 1 - Historical Intraday 
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2. In the Historical Intraday window, Select the required Exchange 

from the drop down. This displays a list of data available for download 

for the selected Exchange. 

3. From the list, select the required dates to download data.  

2. Click on the Download button.  

Once the selected Historical Intraday is downloaded, it is indicated by the 

Downloaded status (  Icon). 

 

  Notes: 

  When a download is in progress, it is not possible to start another 

download. A message will be displayed indicating that another download is 

in progress. You will have to wait till the download is complete to start 

downloading more files. 

  To close the window while the download is in progress, click on the Hide 

button. This hides the window but the downloading process continues. To 

indicate that a download is in progress an animated arrow  will appear 

near the Main menu. If you place the mouse over the animated arrow you 

can view the download progress. To view the window again re-open 

through the Tools menu.  

 

RELATED INFORMATION:  

Download Manager 

Mubasher Pro Tools 
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Download History 
 

INTRODUCTION  

Use the Download History tool to instantly download historical quotes of 

stocks. This option can be used if data corruption occurs or gaps are 

visible in History data. This is a rare occurrence since historical data 

download happens automatically once the user connects with  Application 

servers. The Historical data allows you to determine the market trend and 

is useful to you in your decision-making process as you can predict the 

future by analyzing the stock over a certain period of time.  

 

PROCEDURE  

To download History data: 

1. Go to Tools menu > Download Manager > Select Download 

History option. An Exchange list is displayed . 

2. Select an Exchange from the list to start downloading history for the 

selected Exchange. 

 

The History download is indicated via an animated arrow  near the 

Main menu. If you place the mouse over the animated arrow you can view 

the download progress (See Figure 1). 

 

Figure 1 - Download History arrow and status 

 

 

  Notes: 

  You can download only one exchange history at a time. When a download 

is in progress, it is not possible to start another download. A message will 

be displayed indicating that another download is in progress. You will have 

to wait till the download is complete to start downloading more files. 
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  Downloading Market History when the Market is open, may slow down 

other updates. Therefore it is recommended to download History when the 

market is closed. 

 

RELATED INFORMATION:  

Download Manager 

Mubasher Pro Tools 

 

Custom Columns 
 

INTRODUCTION  

Mubasher Pro gives you the flexibility to add your own personalized 

columns to Full Market / Watch List windows by specifying a financial 

formula to suit your need. 

The newly defined column will be added to all existing as well as Full 

Market / New Watch List windows, based on user‟s selection. 

 

TOPICS IN THIS SECTION  

The following sections will guide you on how to define and use Custom 

Columns: 

Create, Edit, Delete a Formula 

Managing Tools available in Custom Columns 

Insert Custom Column 

 

RELATED INFORMATION:  

Mubasher Pro Tools 
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Create, Edit, Delete a Formula 
 

INTRODUCTION  

The Formula menu allows you to create and manage a Custom Column. 

The following topics will guide you on how to do the same: 

 
 
 
TOPICS IN THIS SECTION  

Create a Custom Column 

Edit a Custom Column 

Delete a Custom Column 

 

RELATED INFORMATION:  

Custom Columns 

 



© 2002-2010 DirectFN Ltd Page 326 

 
 

Create a Custom Column 
 

INTRODUCTION  

You can create a formula and apply it to a Full Market / Watch List window 

as required. 

 

PROCEDURE  

To create a Custom Column: 

1. Go to Tools menu > Select Custom Column. The Formula Column 

Editor window opens (See Figure 1). 

 

Figure 1 - Create a Custom Column 

 

 

2. In the Formula Column Editor window, Enter the required Column 

Name. E.g.: 52WeekHigh% 

3. Write the formula using the relevant fields and operators. You can do 

this by either typing the formula directly into the Type your formula 

here section of the window or by selecting the required Fields and 

Operators from the list given. To add Operators to the formula simply 

click on the required Operator. To add fields, select the field from the 

fields list and double click on it. 
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4. Click on the Save button. This displays a pop-up menu with several 

save options. Select one of these Save options to save your Custom 

Column.  

 Save Only – This saves the Custom Column only. If you wish to add 

the Custom Column at a later time, you can do so by using the 

Column Settings option available in the  Right-Click menu / mini-

toolbar.   

 Save & Add To – This adds the Custom Column to Column Settings 

and the selected window. 

 Save & Add to Open Windows – This adds the Custom Column to 

Column Settings and to all relevant windows on the workspace. 

 Save & Add to all Windows – This adds the Custom Column to 

column settings and to all windows in the current workspace. 

 

To clear the contents of the Custom Column Editor using the Formula 

menu. Simply go to Formula menu > Select New.  

Once you have created a Custom Column using the Column 

Formula Editor, you can Insert it to windows using Insert Custom 

Column. 

 

 
RELATED INFORMATION  

Create, Edit, Delete a Formula 

Insert Custom Column 

Editing a Custom Column 

Deleting a Custom Column 
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Edit a Column Formula 
 

INTRODUCTION  

You can Edit a Custom Column‟s Formula at any given time.  

 

PROCEDURE  

To Edit a Custom Column Formula: 

Method 1 

1. Right click directly on the respective Custom Column from any Full 

Market / Watch List window. 

2. Go to Right Click menu > Select Edit Formula (See Figure 1). The 

Column Formula Editor window opens. 

3. In the Column Formula Editor window, edit the required fields. 

4. Click on the Save button. 

Figure 1 - Edit Custom Column from Full Market / Watch List window 

 

 

Method 2 

1. Open the Column Formula Editor window. 

2. Go to Formula menu > Modify > Select the required Formula (See 

Figure 2). 

3. Edit the fields as required. 

5. Click on the Save button. 

Once you have successfully edited the Custom Column, a confirmation 

message is displayed. Click OK button.  
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Figure 2 - Edit Custom Column using the Column Formula Editor window  

 

 

Notes: 

  You are allowed edit the Column Name and its formula. 

  When you edit a formula, you can add / delete operators / fields to it.  

 

 

RELATED INFORMATION  

Create, Edit, Delete a formula 

Creating a Custom Column 

Deleting a Custom Column 
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Delete a Custom Column 
 

INTRODUCTION  

You can delete a Custom Column at any given time.  

 

PROCEDURE  

To Delete a Custom Column Formula: 

Method 1 

1. Right click directly on the respective Custom Column from any Full 

Market / Watch List window. 

2. Go to Right Click menu > Select Delete Formula (See Figure 1). 

3. This displays the a Confirmation Message. Click on OK button. 

 

Method 2 

1. Open the Column Formula Editor window. 

2. Go to Formula menu > Delete > Select the required Formula (See 

Figure 2). 

3. This displays the a Confirmation Message. Click on OK button. 

 

Figure 1 - Delete Custom Column from Full Market / Watch List window 
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Figure 2 - Delete Custom Column using the Column Formula Editor window 

 

 

RELATED INFORMATION  

Create, Edit, Delete a formula 

Creating a Custom Column 

Editing a Custom Column 

 
 
Insert Custom Column 

 
INTRODUCTION  

Once you have Created a Custom Column using the Column Formula 

Editor, you need to add it to the Full Market / Watch List window using the 

Right Click menu / Mini-Toolbar.   

 

PROCEDURE  

To add a Custom Column to Full Market / Watch List window: 

1. Open the required Watch List / Full Market window. 

2. Go to Right Click menu > Watch List Options > Select Column 

Settings. 

 

or 

 

Right click, go to Mini-Toolbar and click on the Column Settings 

icon. The Select Columns window opens (See Figure 1). 
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Figure 1 - Add Custom Column/s to Watch List / Full Market 

 

 

3. In the Select Columns window, Search and Select the required 

Custom Column you wish to add from Unselected Items section. If 

you wish to select multiple Custom Columns simply select the required 

the columns while having the CTRL key pressed.  

4. Use the > button to add the required columns to Selected Items 

section (see Figure 1). 

5. Select the required apply criteria from Apply To. 

6. Click on Apply button. 

 

RELATED INFORMATION  

Create Custom Column 

Custom Columns 
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Managing Tools 
 

INTRODUCTION  

The following tools are available in the Formula Column Editor window: 

 

TOPICS IN THIS SECTION  

Import a Custom Column 

Export a Custom Column 

 

RELATED INFORMATION:  

Custom Columns 
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Import a Custom Column 
 

INTRODUCTION  

You can Import a Custom Column at any given time.  

 

PROCEDURE  

To import a Custom Column: 

1. Open the Column Formula Editor window by selecting Tools > 

Custom Column. 

2. In the Formula Column Editor window, go to Tools menu > Select 

Import. The Import User Data window opens. 

3. In Import User Data window, Locate and select the file you wish to 

import and click on Open button (See Figure 1). 

4. Finally, select the formula you wish to import from the displayed list 

and click on Import button (See Figure 2). 

Once the required formulas have been imported successfully to the 

application, you are prompted with a Confirmation Message. Click on OK 

button. 
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Figure 1 - Search for Custom Formula and Open 

 

 

Figure 2 - Select required Custom Column/s to Import 

 

 

 

RELATED INFORMATION  

Managing Tools 

 



© 2002-2010 DirectFN Ltd Page 336 

 
 

Export a Custom Column 
 

INTRODUCTION  

You can Export a Custom Column at any given time.  

 

PROCEDURE  

To export a Custom Column: 

1. Open the Column Formula Editor window by selecting Tools > 

Custom Column. 

2. In the Formula Column Editor window, go to Tools menu > Select 

Export. The Export User Data window opens.  

3. In Export User Data window, Select the formula / formulas you wish 

to export from the displayed list and click on Export button (see Figure 

1). This opens the Export to window. 

4. Select the location you wish to save the file and click on Save button 

(see Figure 2). 

Once the required formulas have been exported successfully from the 

application, you are prompted with a Confirmation Message. Click on 

OK button. 

 

Figure 1 - Select required Custom Column/s to Export 
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Figure 1 - Specify Export location 

 

 

RELATED INFORMATION  

Managing Tools 
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Custom Index 
 

INTRODUCTION  

Mubasher Pro gives you the luxury to create and add your own 

personalized Index, by selecting Index Symbols, Index type and other 

Index related factors, to suit your need. This unique feature provides you 

with the flexibility to choose between different valuation methods such as 

Price, Market Capitalization and much more. 

 

TOPICS IN THIS SECTION  

Create a Custom Index 

Modify a Custom Index 

Delete a Custom Index 

Import a Custom Index 

Export a Custom Index 

View a Custom Index 

 

RELATED INFORMATION:  

Mubasher Pro Tools 

 



© 2002-2010 DirectFN Ltd Page 339 

 
 

Create a Custom Index 
 

INTRODUCTION  

You can create an Index for the symbols you wish to monitor the market 

with. 

 

PROCEDURE  

To Create a Custom Index: 

1. Go to Tools menu > Select the Custom Index. The Custom Index 

Editor window opens (See Figure 1). 

 

Figure 1 - Create a Custom Index 

 

 

2. In the Custom Index Editor window, Enter Index Symbol (A name 

for the Index). 

3. Enter Index Description. 
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4. Select Valuation Method (Price Weighted / Market Cap Weighted / 

Custom Weighted) from the drop down  

5. Add the required symbol/exchange. 

 

Note: 

  Depending on the Valuation Method selected, the available fields may slightly 

differ from each other.  

 

5. Enter Starting Date and Initial Value (optional). 

6. Click on the OK button. 

When the index is successfully created, a confirmation message is 

displayed. Click on OK button. Once you have created the Custom Index, 

you can clear the contents of the Custom Index Editor using the Index 

menu. Simply go to Index > Select New. 

Once you have created the required Custom Index, you can view it 

using the Market Indices window.   

 
 

 

RELATED INFORMATION  

Custom Index 

Add / Remove Symbols to Custom Index 

Modify a Custom Index 

Delete a Custom Index 

Mubasher Pro Tools 
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Add / Remove Symbols to Custom Index 
 

INTRODUCTION  

When Creating a Custom Index, you can add/ remove one or more 

symbols from subscribed exchanges. Alternatively, you can add one or 

more exchanges. 

 

Add a symbol 

Add an exchange 

Remove a symbol / exchange 

 

ADD SYMBOL  

Depending on your requirement you can add one or more symbols from 

subscribed exchanges and create a Custom Index. Furthermore, you can 

use this method to add other types of instruments such as Index, Forex 

and Mutual Funds to your Custom Index. 

To add a Symbol: 

1. Click (or Right Click) on the add symbols area in the Custom Index 

Editor window. (see Figure 1) 
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Figure 1 - Add Exchange to a Custom Index 

 

 

2. Go to Add Symbols menu > Select Symbol. This displays the Search 

- Custom Index Editor window (See Figure 2). 

3. In the Search - Custom Index Editor window, search for the 

required symbol and click on OK button. 
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Figure 2 - Search Symbols window 

 

 

ADD AN EXCHANGE  

Depending on your requirement, you can add multiple sectors from 

subscribed exchange/s and create the required Custom Index.   

 

To add an Exchange: 

1. Click on the add symbols area. (See Figure 2) 

2. Select Exchange. This displays a list of subscribed exchanges. 

3. From the subscribed exchange list, select the required sector / index.  

Note: 

  Selecting the option All will select the symbols of the particular exchange. 
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REMOVE SYMBOL / EXCHANGE  

Use the Remove / Remove All option to  if you wish to remove one or all 

symbols / index / sectors from a Custom Index. 

To remove Symbols from a Custom Index: 

1. Click on the required symbol row in the add symbols area.  

2. Select  Remove / Remove All (See Figure 3). 

 

Figure 3 - Remove Symbol/s from Custom Index 

 

 

RELATED INFORMATION  

Create a Custom Index 

Custom Index 
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View a Custom Index 
 

INTRODUCTION  

Once you have created the required Custom Index, you can view it using 

the Market Indices window.   

 

PROCEDURE  

To view a Custom Index: 

1. Go to View menu > Select Market Indices. The Market Indices 

window opens. 

2. In the Market Indices window, From the Exchange drop down > 

Select Custom Index. This displays the relevant data in the Market 

Indices window.  

 

Figure 1 - Custom Index in Market Indices window 

 

 

 

RELATED INFORMATION  

Custom Index 

Create a Custom Index 

Mubasher Pro Tools 
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Modify a Custom Index 
 

INTRODUCTION  

You can Modify an existing Custom Index at any given time.  

 

PROCEDURE  

To modify a Custom Index:  

1. Go to Tools menu > Select Custom Index. The Custom Index 

Editor window opens. 

2. In the Custom Index Editor window, Go to Index menu > Modify > 

Select the required Custom Index from the list.  

3. Once the data is loaded to the Custom Index Editor window (See 

Figure 1), edit the required field. (Note: You cannot modify the Index 

Symbol field). 

4. Click on OK button. 

5. Once the changes are successfully modified, a Confirmation Message 

appears on the screen. Click on OK button. 

Note: 

  You are allowed to modify most fields within the Custom Index. This also 

includes adding / deleting any Symbol / Exchange from the given Custom 

Index. 

 

Figure 1 - Modify a Custom Index 

 

RELATED INFORMATION  

Custom Index 

Mubasher Pro Tools 
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Delete a Custom Index 
 

INTRODUCTION  

You can delete an existing Custom Index at any given time.  

 

PROCEDURE   

To delete a Custom Index: 

1. Go to Tools menu > Select Custom Index. The Custom Index 

Editor window opens. 

2. In the Custom Index Editor window, Go to Index menu > Delete > 

Select the required Custom Index from the list.  

3. A Confirmation Message appears on the screen. Click on Yes button. 

 

Figure 1 - Delete a Custom Index 

 

 

RELATED INFORMATION  

Custom Index 

Mubasher Pro Tools 
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Import a Custom Index 
 

INTRODUCTION  

You can Import a Custom Index at any given time.  

 

PROCEDURE  

To Import a Custom Index: 

1. Go to Tools menu > Select Custom Index. The Custom Index 

Editor window opens. 

2. In the Custom Index Editor window, go to Tools menu > Select  

Import. The Import User Data window opens (See Figure 1). 

 

Figure 1 - Locate and search for Custom Index and Open 

 

 

3. In the Import User data window, Locate and select the file you wish 

to Import and click on Open button (See Figure 1). 

4. Finally, select the required Custom Index you wish to import and click 

on Import button (See Figure 2). 
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5. Once the data  is successfully imported, you are prompted with a 

Confirmation Message. Click on OK button. 

 

Figure 2 - Select Custom Index to Import 

 

 

RELATED INFORMATION  

Custom Index 

Export a Custom Index 

Mubasher Pro Tools 
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Export a Custom Index 
 

INTRODUCTION  

You can Export a Custom Index at any given time.  

 

PROCEDURE   

To Export a Custom Index: 

1. Go to Tools menu > Select Custom Index. The Custom Index 

Editor window opens. 

2. In the Custom Index Editor window, go to Tools menu > Select  

Export. The Export User Data window opens. 

 

Figure 1 - Select Custom Index to Export 

 

 

3. In the Export User data window, From the displayed list, select the 

Custom Index you wish to Import and click on Export button. (See 

Figure 1) 

4. Finally, select the location where you wish to save the file and click on 

Save button. (See Figure 2) 
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Figure 2 - Specify location and save file 

 

 

RELATED INFORMATION  

Custom Index 

Mubasher Pro Tools 
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MetaStock 
 

INTRODUCTION  

MetaStock is a third-party charting and technical analysis tool. Mubasher is 

an authorized distributor of MetaStock software and has a seamless data 

link from Mubasher Pro to MetaStock (version 9.0 and above). MetaStock 

is a third-party charting and technical analysis tool. Data link works with 

both End of day and Professional versions of MetaStock. Mubasher Pro 

creates both Historical and Intraday Files in MetaStock format. 

Notes: 

  MetaStock software is not included with subscription and you will have to 

purchase the software separately. If you wish to purchase MetaStock 

software, please contact the Help Desk. 

  MetaStock supports only default markets. 

 

TOPICS IN THIS SECTION  

Open Chart Files in MetaStock 

Auto Update MetaStock 

Update MetaStock 

Open MetaStock folder 

 

RELATED INFORMATION:  

Mubasher Pro Tools 
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Open Chart Files in MetaStock  
 

INTRODUCTION  

Use the given instructions to open chart files in MetaStock. 

  

PROCEDURE  

To open chart files in MetaStock: 

1. Go to Tools menu > MetaStock > Select MetaStock option*. The 

MetaStock application is loaded. 

Note: 

  *This will be available only if you have installed MetaStock in your machine. 

The subscription to MetaStock software is not included with your subscription 

and you will have to purchase the software separately. If you wish to 

purchase MetaStock software, contact the help desk. 

 

In the MetaStock Application: 

2. Click on the Open option from toolbar. This loads the Open window. 

 All Mubasher Pro chart files can be found in Mubasher application data 

folder. 

i.e.:  

In windows Vista -  

C:\Users\<user name>\AppData\Roaming\Mubasher\Mubasher Pro 

9\MetaStock 

In Windows 7 -  

C:\Users\<user name>\AppData\Roaming\Mubasher\Mubasher Pro 

9\MetaStock 

In windows XP -  

C:\Documents and Settings\<user name>\Application 

Data\Mubasher\Mubasher Pro 9\MetaStock 
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**In the above given paths, <user name> is your computer user 

name. 

 There are two directories - History and Intraday (these can be opened in 

MetaStock Professional). MetaStock chart files for each symbol and 

Indexes are stored under each of these folders. 

Note: 

  For chart files to be available in the Intraday and History folders in the 

Metastock folder you have to first update MetaStock. Use one of the following 

options to update MetaStock. 

Update MetaStock 

Auto Update MetaStock 

 

3. Select a Chart of your choice. 

4. Click on the Open button to view the chart. 

 

  

RELATED INFORMATION:  

MetaStock 

Auto Update MetaStock 

Update MetaStock 

Open MetaStock folder 
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Auto Update MetaStock 
 

INTRODUCTION  

Use the Auto Update MetaStock option to update the Intraday OHLC 

data of a selected exchange automatically, on an incremental basis. 

 

PROCEDURE  

To Auto Update Metastock: 

1. Go to Tools menu > MetaStock > Select Auto Update MetaStock 

option. The Auto Update MetaStock window opens (See figure 1). 

 

Figure 1 - Auto Update MetaStock window 

 

 

2. In the Auto Update MetaStock window, Select the required 

Exchange. 

3. Click the OK button. 

4. Once you have finished enabling the Auto Update MetaStock feature, 

you need to activate it. 

To activate, close the application and reopen it. Once you re-start the 

application, the MetaStock database will be updated automatically. 
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  Notes: 

  Mubasher Pro updates the MetaStock database automatically every 

minute. 

  The Auto Update option updates the MetaStock database automatically 

from the day it is activated. However, if you need to download the 

Historical data i.e.: previous day data, you need to use the Update 

MetaStock Database option. 

 

 
RELATED INFORMATION  

MetaStock 

Update MetaStock 

Open MetaStock folder 
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Update MetaStock 
 

INTRODUCTION  

Use the Update MetaStock option to update the OHLC Intraday and 

History Data of a selected exchange, manually. 

 

PROCEDURE  

To update MetaStock database manually: 

1. Go to Tools menu >  MetaStock > Select Update MetaStock option. 

This displays a popup asking you to select the required Exchange. 

2. Click on the required Exchange from the popup. 

  Notes: 

  The Update MetaStock option updates the OHLC Intraday and History Data 

of the MetaStock database. This is a manual process. Hence you need to 

perform it on a regular basis if you have not enabled the Auto-Update 

MetaStock option. 

  In order to update MetaStock Database, you should wait till the history is 

completely downloaded.    

  MetaStock supports only default markets. 

 

RELATED INFORMATION  

MetaStock 

Auto Update MetaStock 

Open MetaStock folder 
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Open MetaStock Folder 
 

INTRODUCTION  

You can open the MetaStock folder using this option. The MetaStock folder 

has the History and Intraday directories which stores all the MetaStock 

chart files. 

 

PROCEDURE  

To open the MetaStock folder: 

 Go to Tools menu > Point to MetaStock > Select Open MetaStock 

Folder option. 

The MetaStock folder is saved in your application data folder. Please refer 

the paths given below for different operating systems; 

In windows Vista: 

C:\Users\<user name>\AppData\Roaming\Mubasher\Mubasher Pro 

9\MetaStock 

In Windows 7: 

C:\Users\<user name>\AppData\Roaming\Mubasher\Mubasher Pro 

9\MetaStock 

In windows XP -  

C:\Documents and Settings\<user name>\Application 

Data\Mubasher\Mubasher Pro 9\MetaStock 

**In the above given paths, <user name> is your computer user name. 

 

 

RELATED INFORMATION  

MetaStock 

Auto Update MetaStock 

Update MetaStock 
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Analysis Tools 
 

INTRODUCTION 

The Analysis menu gives you access to the following features: 

 

TOPICS IN THIS SECTION  

ProChart 

Volume Watcher 

Cash Flow Analyzer 

History Analyzer 

Performance Map 

Scanner 

Strategy Monitor 

 

RELATED INFORMATION  

Mubasher Pro Tools 
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Pro Chart  
 

INTRODUCTION  

Mubasher Pro comes with a powerful charting module known as ProChart, 

which is an ideal professional charting solution for stock market analysis. 

ProChart is accompanied by advanced features such as Chart Comparison, 

Technical Analysis, Line Studies, intelligent tool tips etc., while supporting 

interactive zooming and dynamic data update. 

 

PROCEDURE  

To view Pro Chart: 

 Go to Analysis menu > Select Pro Chart option. 

 

RELATED INFORMATION  

Analysis Tools 

Graph 

Pro Chart Help 
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Volume Watcher 
 

INTRODUCTION  

Using Volume Watcher you can get the volumes traded or purchased 

during a specific time period. Symbols are highlighted in specific colours 

based on conditions. The conditions and their defined colours are as 

follows; 

 Minimum Price (If the last trade price of the symbol has reached the 

minimum price) - The row is highlighted in Red and font colour is 

Black. 

 52 Week Low (If the lowest price for the day is the lowest for that 

symbol in 52 weeks) - The row is highlighted in Red and font colour is 

White. 

 Maximum Price (If the last trade price of the symbol has reached the 

maximum price) - The row is highlighted in Green and font colour is 

Black. 

 52 Week High (If the highest price for the day is the highest for that 

symbol in 52 weeks) - The row is highlighted in Green and font colour 

is White. 

 

PROCEDURE  

To view Volume Watcher window: 

1. Go to Analysis menu > Select Volume Watcher option. The Volume 

Watcher window opens (See Figure 1). 
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Figure 1 - Volume Watcher 

 

 

2. Select the required Exchange. 

3. Select the Criteria i.e.:7 day, 30 day or 90 day average volume. 

4. Enter the required Trigger Factor. 

5. The data displayed will change accordingly. 

Notes: 

  The Trigger Factor is a feature that filters the information to indicate the 

current volume as opposed to 7D Avg. Volume / 30D Avg. Volume / 90D 

Avg. Volume. You can specify the required percentage (50% /100% etc.) to 

filter the data set and the Volume Watcher window displays the relevant 

results accordingly. 

  You can get the Detail quote for a symbol by double clicking on the required 

symbol. 

 
RELATED INFORMATION  

Analysis Tools 

Quick Access to Functions 
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Cash Flow Analyzer 
 

INTRODUCTION  

Cash Flow Analyzer gives intraday details and history details for symbols 

of selected exchanges. You can switch between Intraday and History 

modes by selecting the required tab.  

 

PROCEDURE  

To view Cash Flow Analyzer: 

1. Go to Analysis menu > Select Cash Flow Analyzer option. This 

displays the Cash Flow Analyzer window.  

2. In the Cash Flow Analyzer window select the required tab to view 

Intraday or History details; 

 

Intraday Mode 

History Mode 

 

RELATED INFORMATION  

Analysis Tools 

 



© 2002-2010 DirectFN Ltd Page 364 

 
 

Intraday Mode 
 

INTRODUCTION  

The Intraday tab of the Cash Flow Analyzer window gives the intraday 

details for symbols of the selected exchange.  

 

PROCEDURE  

To view Cash Flow Analyzer: 

1. Go to Analysis menu > Select Cash Flow Analyzer option. The Cash 

Flow Analyzer window opens (See Figure 1).  

 

Figure 1 - Cash Flow Analyzer - Intraday Mode 

 

 

2. Select the Intraday tab to display the Intraday details.  

3. Select the required Exchange from the Exchange list. 

4. Select a sector to view details if required from the sector list. 

2. If you want to filter the data, In the Symbol Filter field (See Figure 1), 

enter part of the symbol code or description. Click  icon to filter the 

data displayed. 
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Open Cash Flow Detail Quote: 

 Double Click on a symbol to open the Cash Flow Detail Quote for the 

symbol.  

 

Right Click options in Intraday Mode: 

Right Click on required symbol and select any of the options: 

Unsort 

Trade 

Time & Sales 

Time & Sales Summary 

Detail Quote 

Snap Quote 

Cash Flow Detail Quote 

Order Book Calculator 

 

RELATED INFORMATION  

Analysis Tools 

Cash Flow Analyzer 
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History Mode 
 

INTRODUCTION  

The Cash Flow History tab of the Cash Flow Analyzer window allows you to 

get the net cash flow details for every symbol by volume, turnover, net 

cash flow and total for a selected time period such as 7 days, 30 days and 

90 days. 

 

PROCEDURE  

To view Cash Flow Analyzer: 

1. Go to Analysis menu > Select Cash Flow Analyzer option. The Cash 

Flow Analyzer window opens (See Figure 1).  

 

Figure 1: Cash Flow Analyzer - History 

 

 

2. Select the History tab to view details for a selected time period.  

3. Select the Exchange and Period (7d/30d/90d) from the drop down 

list as required.  

4. If you want to filter the data, In the Symbol Filter field (See Figure 

1), enter part of the symbol code or description. Click  icon to filter 

the data displayed. 

5. To open the Cashflow breakdown window, Double click on a selected 

symbol. 
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The Cashflow breakdown window has the following tabs: 

 Data tab: (See Figure 2). The columns in the Data tab are given in the 

table below; 

 

Table 1: Data tab columns 

Column Description 

Date Calendar day. 

Last Price Last traded price of the stock for the day. 

Cash 

In 

 

Orders No of traded (bought) orders. 

Volume Traded (bought) volume for the day. 

Turnover  Turnover for the traded (bought) stocks. 

Cash 

Out 

Orders No of traded (sold) orders. 

Volume Traded (sold) volume for the day. 

Turnover  Turn over for the traded (sold) stocks. 
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Net Value Net Turnover value for the stock. 

Percentage Buyer‟s and Seller‟s gain of the trade as a 

percentage. („Green‟-Buyer; „Red‟-Seller). 

 

Figure 2: Cashflow breakdown -Data tab 

 

 

 Chart Tab: (See Figure 3) 

This displays a graphical interpretation of the data displayed in the Data 

tab. The following graphs are displayed; 

Table 2: Chart tab columns 

Data 

Column 
Description 

Net 

Turnover 

Graph depicts the net turnover for bids and offers for a 

symbol on each day. 

Net orders Graph depicts the net number of bids and offers traded on 

each day for a symbol. Bids are in Green and Offers in Red. 

Net 

Volume 

Graph depicts the net volume of the bids and offers on 

each day for a symbol.  
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Figure 3: Cashflow breakdown - Chart tab  

 

 

RELATED INFORMATION  

Analysis Tools 

Cash Flow Analyzer 
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History Analyzer 
 

INTRODUCTION  

Use the History Analyzer to calculate the present Net Change Price of 

a selected symbol. Net change is the difference between the closing price 

of the symbol on the current days trading and the previous days closing 

price. This can be a positive or negative value. The Net Change of the 

symbol for the selected date range is calculated and shown in the Net Chg. 

column of the History Analyzer window.  

 

 

PROCEDURE  

To Analyze History for a Symbol: 

1. Go to Analysis menu > Select History Analyzer option. The History 

Analyzer window opens (See Figure 1). 

 

Figure 1 - History Analyzer window 

 

 

2. In the History Analyzer window, Specify the Symbol - Double click 

on the symbol field and type the symbol / Use Symbol Search to find 

the symbol. 

3. Specify From Date - Click on the From Date field and select the date. 

The start price is shown accordingly. Start Price is the previous close 

price of the selected From Date. 

4. Specify To Date - Click on the To Date field and select the date. The 

End price is shown accordingly. End price is the closing price of the 

selected To Date. 
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Once you specify the above details, you can view the Net Change value 

for the given symbol. Depending on the performance of the symbol, a 

booming symbol is shown in green, while a losing symbol is shown in red.  

  Notes: 

  By Default the present date is given for the From Date and To Date and 

the Net Change Price will be calculated for the present date (The Net 

change given is the difference between the previous days closing price and 

the current days closing price.) But if you specify a different Date Range, 

the Net Change Price is calculated based on the Date Range specified. 

  When you load History Analyzer for the first time it would be empty. Once 

you add Symbols to it and save your workspace, the History Analyzer 

loads with your last saved symbol lists. 

 

 

RELATED INFORMATION:  

Analysis Tools 

Mubasher Pro Tools 

History Analyzer - Right Click Options 
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History Analyzer - Right Click options 
 

INTRODUCTION  

The History Analyzer window‟s Right Click menu has many options.  

Most of these options are common to all windows. However, the following 

options are unique to the History Analyzer window. 

Valuation Method 

Delete 

 

VALUATION METHOD  

Using the Valuation Method option, you can specify the Valuation 

formula for the selected Symbol. This is indicated in the Valuation Method 

column. 

Currently Mubasher Pro supports two methods as follows: 

 Last Price - Symbols are valued using the Last Traded price. Incase the 

exchange is closed on a given day, the previous day's Last Traded Price 

is used. 

 VWAP (Volume Weighted Average Price) - Symbols are valued using the 

VWAP method. It is a measure of the price at which the majority of a 

given day's trading of a given symbol took place. VWAP is the ratio of 

the value traded to total volume traded over a particular time period. 

(VWAP = Total Value Traded / Total Volume Traded). 

By default the Last Price is selected.  

To set the Valuation method: 

1. Select any row and Right Click. 

2. Go to Right Click menu > Valuation Method > Select Last Price or 

VWAP. 

Depending on the method selected, the data in the window is changed. 

DELETE  

Use this to remove a symbol from the History Analyzer window. 

To remove a symbol: 
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1. Select the required symbol and Right Click. 

2. Go to Right Click menu > Select Delete option. This displays a 

Confirmation Message. 

3. Click on Yes button. 

 

RELATED INFORMATION:  

Mubasher Pro Tools 

History Analyzer 

 
 
 
Performance Map 
 

INTRODUCTION  

The Performance Map lets you watch important stock market 

information by helping you to spot dynamic movements in the market, at 

a glance via colour changes. The significant colour changes show symbols 

which are booming and symbols which are declining and helps you to 

identify the current market trend of a selected exchange. Performance 

Map for a Watch list provides the market information for symbols, in the 

Watch List. Each coloured cell in the map represents an individual symbol. 

The colour codes show the symbol performance. The lowest values are 

displayed in red and the highest values are displayed in blue or green 

depending on the theme selected. 

 

 Red indicates that the value is dropping. 

 Green/Blue indicates that the value is booming. 

 White indicates a neutral value. 

E.g.: Cells with a positive price change i.e. rise of the price, displayed in 

green/blue and cells while a negative price change displayed in red. 
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Note: 

  If you open the performance Map from a Full Market / Watch List window's 

Right Click menu, the Performance Map displays all symbols of the Full 

Market / Watch List window that has market depth information and has had 

at least one price movement, i.e: All symbols with a bid or offer is displayed. 

E.g.: If you access the Performance Map from Watch List 01, the symbols in 

the Performance Map will be the symbols of Watch List 01 that has a bid or 

offer. 

  Double clicking on the symbol will open a symbol‟s Detail Quote.  

 

PROCEDURE  

1.  Open The Performance Map using one of the following methods; 

Method 1 

 Go to Analysis menu > Select Performance Map. The 

Performance Map window opens. 

Method 2 

 Go to Right Click menu of any Watch List > Select Performance 

Map option. The Performance Map window opens for the selected 

Watch List (See Figure 1). 
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Figure 1 - Performance Map 

 

 

2. In the Performance Map window, Select the Criteria from the drop-

down list. 

3. Select the Exchange from the drop-down list. 

 

The Performance Map Criteria available are as follows and is 

available to select through a drop down menu: 

 P/E Ratio - Float Quoted Market Value / Aggregate Earnings Pool. The 

relationship between a stock's price and its earnings per share 

 % Change - The Percentage difference between the last traded value 

and the previous close values (set by the exchange). 

 Market Cap – Millions - This is the company‟s total shares multiplied 

by the last price and divided by one Million. 

 # Trades - The number of trades for the day. 

 Volume ‘000 - The number of shares or contracts traded in a security 

during a given period of time.  
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 Bid/Offer ratio - The ratio of the Bid price and the Offer price. 

 Range - The difference between a security's/ stock's highest and lowest 

price in which it has traded over a specified time. 

 % Range - Percentage of the difference between the highest trade and 

lowest trade price of the same transaction, at a given time. 

 Spread -  Difference between the buying (bid) and the selling (offer) 

price of the same transaction at a given time. 

 % Spread - Percentage of the difference between the buying (bid) and 

the selling (offer) price of the same transaction at a given time. 

 Money Flow Index - A momentum indicator that is used to determine 

the conviction in current trend by analyzing the price and volume of a 

given security. 

 

 

RELATED INFORMATION  

Analysis Tools 

Mubasher Pro Tools 

Customize Performance Map 

Column Definition Guide 
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Customize Performance Map 
 

INTRODUCTION  

Mubasher Pro allows you to customize the Performance Map to suit your 

needs. Tabled below are the icons in the toolbar and its corresponding 

option. Click on the  required item for further details. 

 

 
Color Theme 

 
Sort By 

 
Edit Number of 

Columns 

 
Edit View 

 
Cell Width 

 
Hide value 

 
Print 

 

COLOUR THEME   

Use this option to edit the displayed colors of the Performance Map. 

To change the Colour theme of the Performance Map: 

 Select the required color theme from the Color Theme drop down list in 

the Performance Map window. 

 

SORT BY   

You can sort the Performance Map in ascending, descending order and 

symbol wise. 

To change the Sort Order of the Performance Map: 

 Select the required value (ascending / descending / symbol wise) from 

the Sort By drop down list in the Performance Map window. 
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COLUMNS  

You can Edit the number of columns displayed in the Performance Map 

thereby increase or decrease its viewable area. 

To change the number of columns displayed in the Performance Map: 

 Select the required value (e.g. 10 columns) from the Columns drop 

down list in the Performance Map window 

 

EDIT VIEW  

You can set the layout of the Performance Map to Tile Vertically or Tile 

Horizontally. 

To change the view (layout) of the map: 

Method 1 

1. Select any cell in the Performance Map. 

2. Go to the Right Click menu >Select required option (Tile Horizontally 

/ Tile Vertically). 

Method 2 

Click on the Layout drop down list and select the required option (Tile 

Horizontally / Tile Vertically). 

 

Restore to Default (Main View) 

Once you have edited the layout of the Performance Map and wish to 

restore it to the default, use this option. 

To restore the Performance Map window to the normal state (from Tile 

Vertical / Tile Horizontal state): 

1. Click on any cell in the Performance Map. 

2. Access the Right Click menu and select Main View option. 
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EDIT COLUMN WIDTH   

You can adjust the with of columns displayed in the Performance Map. 

To Edit the Column width of the Performance Map: 

 Use the Column Width Settings drop down list to change the default 

width of the columns in the Performance Map. 

 

SHOW / HIDE VALUES   

You can select the show/hide details icon located in the bottom of the map 

to show / hide the values i.e.: PE Ratio, % change etc. in the 

Performance Map. 

Note: 

  By default, when the Performance Map window is open, the icon is inactive 

and details are displayed on the map. To hide the details simply click on the 

icon. 

 

PRINT   

Click on the Print button located in the toolbar to print a Performance 

Map. 

 

RELATED INFORMATION 

Performance Map 

Mubasher Pro Tools 
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Scanner 
 

INTRODUCTION  

The Scanner option allows you to very quickly scan the fluctuations for all 

enlisted stocks in a selected exchange on a defined set of criterion helping 

you to track the performance of symbols. When performing a scan a 

formula is applied to the symbols of the selected exchange and results are 

displayed based on the filter criteria you specify for that formula. The 

Scanner has been categorized as follows:  

 

PRICE SCANS   

The following Price Scans are available (See Figure 1): 

Breakouts 

Volume 

Volume Gainers 

Volume Losers 

Gap Ups 

Gap Downs 

Island Tops 

Island Bottoms 

Gainers 

Losers 

52 Week High 

52 Week Low 
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Figure 1 - Scanner window 

 

 

Tab Panel - Shows all the performed scans as tabs. Right click options 

available through the tab panel are as follows: 

 Close Tab - Close selected tab. 

 Close All but this - Closes all other tabs leaving only the selected 

one open. 

 Close All - Close all opened tabs. 

  Tip:  

  Use the Scanner to quickly scan the price fluctuations for your favourite 

symbols in Watch List 01 / Watch List 02. 

 

RELATED INFORMATION  

Analysis Tools 

Mubasher Pro Tools 
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Breakouts 
 

INTRODUCTION  

This will show all the securities with Breakouts within the given 

parameters. Breakout is a term used to describe a rise in a security's price 

above a resistance level which is the inability of a stock to rise above a 

certain price (usually its previous high), or drop below a support level 

which is a price level the stock has had difficulty falling below (usually its 

previous low). This is usually followed by heavy volume and increased 

volatility. Traders will buy stocks when the price breaks above a level of 

resistance and sell when it breaks below support.   

 

PROCEDURE  

To Perform a Breakout Scan: 

1. Go to Analysis menu > Select Scanner. The Scanner window opens. 

2. In the Scanner window, Select the required Exchange from the 

exchange list. Selecting All, scans all the exchanges you are subscribed 

to. 

3. Select Breakouts from the list of Price Scan options. 

4. Enter the Breakout Properties: 

 Enter the Type - High or Low. 

 Enter the Price Field - Specify the price field to be considered when 

scanning from High, Low or Closing price. 

 Enter the No of Days - The number of days you want to perform the 

scan for starting from the current day. Select from 5, 20 or 50 days. 

If other is selected,  the number of days should be entered in the 

Specify Field. 

5. Click on Scan button. This will display the Breakouts, given the 

parameters specified. 
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RELATED INFORMATION  

Scanner 

Analysis Tools 

Mubasher Pro Tools 

 
 
 

Volume 
 

INTRODUCTION  

This will show all the securities where the Volume traded is above 

average (depending on the parameters given). 

 

PROCEDURE  

To Create a Volume Scan 

1. Go to Analysis menu > Select Scanner. The Scanner window opens. 

2. In the Scanner window, Select the required Exchange from the 

exchange list. Selecting All, scans all the exchanges you are subscribed 

to. 

3. Select Volume from the list of Price Scan options. 

4. Enter the Volume Properties: 

 Enter the Type you want to match the trading volume to - Average 

Volume or Highest Volume.    

 Enter the No of Times - The minimum number of times the trading 

volume matches the Average / Highest volume (Depending on what 

you selected for Type.) 

 Enter the No of Days - The number of days you want to perform the 

scan for starting from the current day. Select from 5, 20 or 50 days. 

If other is selected,  the number of days should be entered in the 

Specify Field. 

5. Click on Scan button. This will display the results, given the 

parameters specified. 



© 2002-2010 DirectFN Ltd Page 384 

 
 

 

RELATED INFORMATION  

Scanner 

Analysis Tools 

Mubasher Pro Tools 

 
 
 

Volume Gainers / Volume Losers 
 

INTRODUCTION  

Volume Gainers scan shows the the stocks of an exchange that had the 

highest volume over a given period whereas the Volume Losers scan 

shows the the stocks of an exchange that had the lowest volume over a 

given period depending on the parameters selected for the scan. 

 

PROCEDURE  

To Create a Volume Gainers / Volume Losers Scan: 

1. Go to Analysis menu > Select Scanner. The Scanner window opens. 

2. In the Scanner window, Select the required Exchange from the 

exchange list. Selecting All, scans all the exchanges you are subscribed 

to. 

3. Select Volume Gainers or Volume Losers from the list of Price Scan 

options. 

4. Enter the Volume Gainers / Volume Losers Properties: 

 Enter the Type - Average Volume or Highest Volume. 

 Enter the No of Times - The minimum number of times the trading 

volume matches the Average / Highest volume (Depending on what 

you selected for Type.) 

 Enter the No of Days - The number of days you want to perform the 

scan for starting from the current day. Select from 5, 20 or 50 days. 

If other is selected,  the number of days should be entered in the 

Specify Field. 
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5.  Click on Scan button. This will display the Volume Gainers or Volume 

Losers, given the parameters specified. 

 

 

RELATED INFORMATION  

Scanner 

Analysis Tools 

Mubasher Pro Tools 

 
 
 

Gap Ups / Gap Downs 
 

INTRODUCTION  

A gap is a break between stock prices that occurs when the price of the 

stock makes a sharp move up or down with no trading occurring in 

between. The Gap Ups and Gap Downs scans will scan for all symbols that 

had a price fluctuation and display symbols accordingly (As per the 

parameters specified by you).  

Gap Up - A Gap Up occurs when there is sharp rise in stock price. A Gap 

Up forms when the low for a period (usually a day) is higher than the 

previous periods high. 

Gap Down - Gap Down occurs when there is a sharp drop in stock price. 

A Gap Down forms when the high for a period (usually a day) is lower than 

the previous periods low. 

PROCEDURE  

To Create a Gap Ups / Gap Downs Scan: 

1. Go to Analysis menu > Select Scanner. The Scanner window opens. 

2. In the Scanner window, Select the required Exchange from the 

exchange list. Selecting All, scans all the exchanges you are subscribed 

to. 

3. Select Gap Ups or Gap Downs from the list of Price Scan options. 

4. Enter a value for Gap Up % / Gap Down % as required. 
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  Gap Up % - The percentage increase in price as required. For e.g: Enter 

1 if you require to see symbols that had a price fluctuation of 1% or more 

upwards. 

  Gap Down % - The percentage decline in price as required.  For e.g: 

Enter 1 if you require to see symbols that had a price fluctuation of 1% or 

more downwards. 

5. Click on Scan button. This will display the Gap Ups or Gap Downs, 

given the parameters specified. 

RELATED INFORMATION  

Scanner 

Analysis Tools 

Mubasher Pro Tools 

 
 
Island Tops / Island Bottoms 
 

INTRODUCTION  

These show the securities which have had Island Tops and Island Bottoms. 

An Island Top occurs when the price of the stock gaps above (Gap Up) a 

price range specified by you and then the price of the stock gaps down to 

the initial range. This is when a stock price will gap up, trade at the Gap 

Up price or at a higher price and then Gaps down to the initial price range. 

Island Tops scan will show these symbols depending on the Gap Up % and 

Gap Down % specified by you.  

An Island Bottom occurs when the price of a stock gaps below (Gap 

Down) a price range specified by you and then Gap Up to the initial price 

range. This is when a stock price will gap down, then trade at the Gap 

Down price or at a lower price and then Gap Up to the initial price range.  

Island Bottoms scan will show these symbols depending on the Gap Down 

% and Gap Up % specified by you.  

(See: Gap Ups / Gap Downs to learn more about Gap Up and Gap Down 

prices). 
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PROCEDURE  

To Create a Island Tops / Island Bottoms Scan: 

1. Go to Analysis menu > Select Scanner. The Scanner window opens. 

2. In the Scanner window, Select the required Exchange from the 

exchange list. Selecting All, scans all the exchanges you are subscribed 

to. 

3. Select Island Tops or Island Bottoms from the list of Price Scan 

options. 

4. Enter the Island Tops / Island Bottoms Properties: 

 For Island Tops -  

 Gap Up % & Gap Down % - The percentage increase in 

price as required for Gap Up % and the percentage decrease 

in price as required for Gap Down %. For E.g: Enter 2 for Gap 

Up % and 1 for Gap Down % - If you require to see symbols 

that had a price fluctuation of 2% or more upwards, traded at 

that price and then had a price fluctuation of 1% or more 

downwards.  

 For Island Bottoms -   

 Gap Down % & Gap Up % - The percentage decline in price 

as required for Gap Down % and percentage increase in price 

as required for Gap Up %.  For E.g: Enter 2 for Gap Down % 

and 1 for Gap Up % - If you require to see symbols that had a 

price fluctuation of 2% or more downwards, traded at that 

price and then had a price fluctuation of 1% or more upwards.  

5. Click on Scan button. This will display the Island Tops or Island 

Bottoms, given the parameters specified.  

 

 
RELATED INFORMATION  

Scanner 

Analysis Tools 

Mubasher Pro Tools 
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Gainers / Losers 
 

INTRODUCTION  

These scans show the top gainers and top losers for the day. 

 

PROCEDURE  

To Create a Gainers / Losers Scan: 

1. Go to Analysis menu > Select Scanner. The Scanner window opens. 

2. In the Scanner window, Select the required Exchange from the 

exchange list. Selecting All, scans all the exchanges you are subscribed 

to. 

3. Select Gainers or Losers from the list of Price Scan options. 

4. Enter the Gainers / Losers Properties: 

 Display Top - 5, 20, 50 or other. If other is selected,  the number 

you require should be given in the Specify Field. 

5. Click on Scan button. This will display the Top Gainers or Losers, given 

the parameters specified. 

 

RELATED INFORMATION  

Scanner 

Analysis Tools 

Mubasher Pro Tools 
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52 Week High / 52 Week Low 
 

INTRODUCTION  

This will show the securities that have traded at 52 Week High / 52 

Week Low price. 

 

PROCEDURE  

To Create a 52 Week High / 52 Week Low Scan: 

1. Go to Analysis menu > Select Scanner. The Scanner window opens. 

2. In the Scanner window, Select the required Exchange from the 

exchange list. Selecting All, scans all the exchanges you are subscribed 

to. 

3. Select 52 Week High or 52 Week Low from the list of Price Scan 

options.  

4. Click on Scan button. This will display all symbols that have traded at 

52 Week High price or 52 Week low price.  

 

RELATED INFORMATION  

Scanner 

Analysis Tools 

Mubasher Pro Tools 
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Strategy Monitor 
 

INTRODUCTION 

Use this feature to capture the profitability of symbols in a selected 

exchange by performing a market scan. The scan is based on buy and sell 

signals generated for selected strategies. The selected exchange is 

scanned over a selected time period based on these strategies. You can 

set the interval (time period) and strategy as preferred using the Settings 

option. 

Colours are used to highlight the %Profit Gain/Loss (The percentage profit or 

loss) column to indicate whether it is unrealized or realized. A tooltip is also 

given in addition to having the cells highlighted. A minus value indicates a loss. 

 Yellow - Indicates the %Profit Gain/Loss is unrealized. An unrealized 

Gain/Loss is formed when the last signal generated from the strategy for 

that selected time frame is a buy signal. Till a sell signal is generated for 

each buy signal it remains as an unrealized Gain/Loss. If the only signal 

for that time frame is a Buy signal then too the %Profit Gain/Loss is 

unrealized.  

 Blue - Indicates the %Profit Gain/Loss is realized. An realized 

Gain/Loss is formed when there is a buy signal  and a sell signal within 

the selected time frame. If each Buy signal has a sell signal then the 

%Profit Gain/Loss is realized. For E.g:- Buy/Sell/Buy/Sell  

 

PROCEDURE 

To perform a scan using Strategy Monitor: 

1. Go to Analysis menu >  Select Strategy Monitor option. The 

Strategy Monitor window opens. 

2. In the Strategy Monitor window, Select the required Exchange from 

the Exchange list provided.  

3. Change Settings as required. The scan is performed for the selected 

exchange based on the settings selected. 
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To Change settings: 

1. Click the Settings button in the Strategy Monitor window. The 

Settings window opens. 

2. In the Settings window, Select the Interval from the list provided. A 

maximum of three can be selected at one time*.  

3. Select the required Strategies from the strategies list. A maximum of 

three can be selected at one time*.  

 

  Notes: 

  *For time intervals as well as strategies the maximum number that can be 

selected at one time is three. In each list when three are selected, the 

others in that list will be automatically disabled. To enable them again 

deselect one of the selected options. 

  The scan results for each time interval selected is given in separate tabs. 

For E.g.: If time intervals of 5 minutes and 10 minutes is selected, the 

market will be scanned for the last five minutes and results displayed in 

one tab with the scan results for the last 10 minutes displayed in another 

tab.  

  If an interval of 5 minutes is selected the market is scanned for the 

past 5 minutes from the time the window is opened. For E.g.: If you open 

the window at 11.30, the scan will be done for the time period 11.25 to 

11.30. The screen is updated and data is refreshed automatically each 

minute when you have the window opened. 

  The scan results for each strategy selected is given in different sections 

for each Radar interval. 

 

 The following columns are given: 

 Symbol - The symbol code. 
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 Stock Name - The symbol name. 

 Last - Last traded price. 

 Change - The difference between the last traded value and the previous 

close values (set by the exchange). 

 % Change - The percentage difference between the last traded value 

and the previous close values (set by the exchange). 

 % Cash Map - Represents the Cash In percentage from the total 

turnover ([Cash In/(Cash In + Cash Out)]*100). The cash in and cash 

out percentages are represented graphically, where the green area 

represents the Cash In percentage and the red area represents the Cash 

Out percentage. 

 Average Buy Price - The average buying price. 

 Average Sell price - The average selling price. 

 %Profit Gain/Loss - The percentage profit or loss. A minus value 

indicates a loss. 

 

RELATED INFORMATION 

Analysis Tools 

Mubasher Pro Tools 
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What-If Calculator 
 

INTRODUCTION  

Use the What-If Calculator to calculate the profit / loss you would have 

gained / lost if you bought stocks of a selected symbol on a particular 

trading day. When you enter the symbol and date as required the 

Profit/Loss is generated and displayed. 

   

PROCEDURE  

To calculate the Profit / Loss: 

1. Go to Tools menu > Select What-If Calculator option.  The What-If 

Calculator window opens (See Figure 1). 

 

Figure 1 - What if Calculator 

 

 

In the What-If Calculator window (See Figure 1):  

2. Select Symbol* - Select the required symbol (use the symbol search 

facility if required). The Current Value field is automatically updated 

with the current market price of the selected symbol. 

3. Select Date** - Select the date you require from the drop down. The 

Open Value field is automatically updated with the market price of the 

symbol on the selected date. 
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4. Quantity - Enter the required Quantity for which you want to calculate 

profit / loss. 

This computes a Profit / Loss value based on the Current value, Open 

Value and Quantity entered and is displayed in the Profit / Loss field. If the 

Current value is less than the Open Value a Loss will be displayed while a 

profit will displayed if the Current value is higher. A minus value reflects a 

Loss. 

 

  Notes:  

  

* The What-if Calculator works only on historical data. As history data is 

not available for symbols of the KSE forward market, the what if 

calculator will not work for these symbols.  

  **The date has to be a historical date – i.e.: Date before today‟s date. 

  
History data has to be downloaded for the symbols selected for the What 

if Calculator to work (Go to > Historical Time & Sales). 

 

RELATED INFORMATION:  

Mubasher Pro Tools 

Download History 

Historical Intraday 

Historical Time & Sales 
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Media Player 
 

INTRODUCTION  

The Media Player provides an easy-to-use interface for you to play 

selected channels as required. You can select from already saved channels 

and also add new channels by entering the URL. 

 

Open the Media Player 

Edit Channels 

Delete Channels 

Add Channels 

Detach the Media Player 

 

TO OPEN MEDIA PLAYER  

1. Go to Tools menu > Select Media Player option. The Media Player 

opens. 

2. In the Media Player window, Click the Select Channel drop down and 

select the channel as required from the list (See Figure 1). 

Figure 1 - Media Player 
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TO EDIT CHANNELS  

You can Edit the URL path or name of the saved channels as required.  

1. Click Edit Channel icon  to edit the URL or name of the selected 

channel. The Edit Channel dialog box opens. 

2. In the Edit Channel dialog box, Edit the Caption or the name of the 

channel in the Caption field. 

3. Edit the URL path in the URL field.  

4. Click the Save button.  

 

TO DELETE CHANNELS  

1. Click the Delete Channel icon  appearing next to the required 

channel. 

2. Click Yes when the confirmation message is displayed.  

 

TO ADD CHANNELS 
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1. Click the Select Channel drop down arrow.  

2. Scroll down to the bottom of the list and select the Add Channel 

option. The Add Channel dialog box opens. 

3. In the Add Channel dialog box, Enter a name for the Channel in the 

Caption field. 

4. Enter the URL path for the channel in the URL field.  

5. Click Save button. 

 

DETACH MEDIA PLAYER  

You can use the detach option provided to separate the media player from 

the application and to view the player when the application is minimized. 

When it is in detached mode it is displayed as a separate window on the 

taskbar. 

 

To Detach the Media Player: 

 Click the Detach icon . You will see that the Media Player is 

displayed as a separate window. 

 

To restore the player back to its normal state: 

 Close the window and re-open through the application. 

 

RELATED INFORMATION:  

Mubasher Pro Tools 
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Outlook Reminder 
 

INTRODUCTION  

Use the Outlook reminder option, to set a reminder / alert for an event 

or a task. This alert will be activated (triggered) depending on the criteria 

that you have set even when you are not using the application / in offline 

mode. However, you need to have Microsoft Outlook version 2003 or 

higher installed in your PC for this option to work. 

 

PROCEDURE  

To add an Outlook Reminder: 

Method 1 

1. Go to Tools menu > Select Outlook Reminder option. The Reminder 

window opens (See Figure 1). 

Method 2 

1. Go to View > Announcements > Select required Announcement > 

Right Click > select Outlook Reminder. The Reminder window opens 

(See Figure 1). 

Figure 1 - Outlook Reminder 

 



© 2002-2010 DirectFN Ltd Page 399 

 
 

 

2. In the Reminder window, Enter Title - Give a Title for the Reminder 

as required. 

3. Enter Location - Enter the location details.  

4. Enter Note - Specify the reminder details as required. 

5. Enter the required Reminder Criteria; 

 Start Time - Date and time the given Reminder task/event is due to 

start. 

 End Time - Date and time the Reminder Task/event is due to end.  

 Remind Me Before - Set the criteria to specify before how long you 

want to be reminded of the set task/event. 

6. Click on the OK button. 

 

RELATED INFORMATION  

Mubasher Pro Tools 
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Tabular Indicator Properties 
 

INTRODUCTION  

Tabular Indicator Properties is an option using which you can change 

the Data interval and Time periods of Chart Indicator columns of Market 

Watch and Watch List windows. You can apply Chart Indicators to the 

Market Watch or Watch List windows. Different Chart Indicators have 

different Data Intervals and Time Periods and you can set these options 

according to your requirement. 

 

PROCEDURE  

To change a Chart Indicator column’s Data Interval and Time 

Period: 

1. Go to Tools > Select Tabular Indicator Properties option. The 

Tabular Indicator Properties window opens. 

2. In the Tabular Indicator Properties window, Select the Chart 

Indicator from the list displayed. 

3. Set the properties in the relevant section for the selected indicator. 

4. Click on the OK button. 

After you change the tabular indicator properties as required you can add 

the indicator to Watch Lists as a column if required. 

To add the indicator to the Watch List / Market Watch window: 

5. Go to Column Header right click menu > Select Column Settings 

option. 

6. Select the added Indicator from the Unselected Items list, Click the 

> button to add it to the Selected Items List. 

7. Click on OK button to view the Indicator in the Market 

Watch/Watch List. 

RELATED INFORMATION  

Mubasher Pro Tools 

Insert Custom Columns 
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Export History 
 

INTRODUCTION  

Use the Export History to export Historical data symbols in CSV / 

MetaStock TXT / DOC formats. Mubasher Pro gives you the facility to 

export the History of a symbol or a range of symbols. You can download 

either the entire history or history for a particular time period. 

 

PROCEDURE  

To export a Symbol’s History: 

1. Go to Tools menu > Select Export History option.  The Export 

History window opens (See Figure 1). 

 

Figure 1 - Export Symbol History Data 

 

 

2. In the Export History window, Select Symbols - Click the drop down 

arrow and Select the required Symbol/s using the Symbol Search 

facility. 

4. Select the Time Range you require; 

 Complete History - Select if you want to export the complete 

history of transactions for the selected symbols. 
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 Custom Date Range - Select this if you want to define a date to 

export the transaction history of only the specified period. 

3. Select the Export Type (CSV / MetaStock Txt / DOC format*). 

4. Specify the file location using the Export To drop down. 

5. Customize button - If you want to select which columns to export. 

Click the Customize button and Select / Unselect columns as 

required. BY default all the fields are exported. 

6. Click on the Export button. 

Note: 

  By default all the fields are exported. However, you can customize and select 

the fields to be exported, by clicking on the Customize  button and selecting 

the required fields. 

* If you select MetaStock TXT as the Export Type the Customize button is 

disabled.  

 

RELATED INFORMATION:  

Mubasher Pro Tools 
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Time Lag Indicator 
 

INTRODUCTION  

The Time Lag Indicator shows you the Time Delay between the 

Application Server and your Mubasher Pro Client. Usually the time lag is 

less than a second, but by looking at the Time Lag Indicator you can verify 

the exact Time Lag. 

 

PROCEDURE  

To view the Time Lag Indicator: 

 Go to Tools menu > Select Time Lag Indicator option. 

 

Refer to Optimizing Performance section to learn how to improve 

the performance of the application and reduce the time delay.  

 

RELATED INFORMATION  

Mubasher Pro Tools 

Optimizing Performance 
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Generating Reports 
 

INTRODUCTION  

Mubasher Pro generates reports with up-to-the minute market summary 

information and history information with dynamic updates throughout the 

day from subscribed markets. The reports generated are available via the 

Reports menu. 

 

 

TOPICS IN THIS SECTION 

The reports generated are: 

Symbol Trading Summary 

Daily Market Summary 

 

The following options will guide you on how to use the options in 

the Report window: 

Refresh Reports 

Print Reports 

View Current Report 
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Symbol Trading Summary  
 

INTRODUCTION  

Symbol Trading Summary report gives you details of all symbols traded 

during a given period.  

 

PROCEDURE  

To view the Symbol Trading Summary Report: 

1. Go to Reports menu > Select Symbol Trading Summary option. The 

Reports window opens. 

2. In the Reports window, Select the required Exchange. 

3. Select the required Date from the Report Date option. 

 

Note: 

  By default the Symbol Trading Summary option displays the current day's 

trading summary details. By using steps 2 and 3, you can obtain past Symbol 

Trading Summary Reports. 

 

RELATED INFORMATION  

Generating Reports 

Refresh Reports 

View Current Report 

Print Reports 
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Daily Market Summary 
 

INTRODUCTION  

Daily Market Summary report gives you up-to-date information of: 

 Market/Sector Summary 

 Index Summary 

 Top Gainers 

 Top Losers 

 Most Active By Volume 

 Most Active By # of Trades 

 

PROCEDURE  

To view the Daily Market Summary: 

1. Go to Reports menu > Select Daily Market Summary option. The 

Reports window opens. 

2. In the Reports window, Select the required Exchange. 

3. Select the required Date from the Report Date option. 

Note: 

  By default the Daily Market Summary option displays the current day's 

trading summary details. By using steps 2 and 3, you can obtain past Daily 

Market Summary Reports. 

 

RELATED INFORMATION  

Generating Reports 

Refresh Reports 

View Current Report 

Print Reports 
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Refresh  Reports 
 

INTRODUCTION  

Use the Refresh option to refresh the data in the report. 

 

PROCEDURE  

To refresh a report: 

1. Go to Reports menu > Select the required Report. The Reports 

window opens. 

2. In the Reports window, click on the Refresh option. 

 

RELATED INFORMATION  

Generating Reports 

Symbol Trading Summary 

Daily Market Summary 

View Current Report 

Print Reports 
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View Current Report 
 

INTRODUCTION  

Use the Current Report option to view the most recent / today's trading 

report details. 

 

PROCEDURE  

To view a report for the current day: 

1. Go to Report menu > Select the required report. The Reports window 

opens. 

2. In the Reports window, click on the Current Report option to display 

the relevant report for the current day. 

 

RELATED INFORMATION  

Generating Reports 

Symbol Trading Summary 

Daily Market Summary 

Refresh Reports 

Print Reports 
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Print Reports 
 

INTRODUCTION  

Use the Print Report option to Print report details. 

 

PROCEDURE  

To print a Report: 

1. Go to Reports menu > Select the required report. The Reports 

window opens. 

2. In the Reports window, Click on Print option. This displays the Print 

dialog.  

3. In the Print dialog, select the required options and click OK button. 

 

 
RELATED INFORMATION  

Generating Reports 

Symbol Trading Summary 

Daily Market Summary 

Refresh Reports 

View Current Report 
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ProChart Help 
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ProChart 
 

Mubasher Pro comes with a powerful charting module known as ProChart, which is an ideal 

professional charting solution for convenient stock market analysis. ProChart is packed with a 

variety of advanced features such as Chart Comparison, Technical Analysis, Line Studies, 

Chart customization, intelligent tool tips and many more, while supporting interactive 

zooming, dynamic data updates and history/intraday data analysis. 

 

 

The Work Area  

 

Setting up Chart Display 

 

Working with Charts  

 

Technical Analysis 
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Exploring the Work Area 
 

INTRODUCTION  

The ProChart workspace lets you view any required Chart with various 

Chart properties. The workspace also has most of the common 

operations placed in the toolbars so that you can have quick access to 

whatever functionality you need to carry out with charts. 

The workspace has an integrated layout consisting of Menu bar, Main 

Toolbar, Bottom toolbar, Symbol Search Panel, Navigation Bar and the 

Chart Window integrated into a single application window.  

The following figure illustrates the main parts of the ProChart window: 

 

Figure 1 - Work Area 

 

 

A: Menu Bar - Contains the Main Menus for performing various tasks.  

B: Main Toolbar - Contains quick access icons for the main chart features.  

C: Symbol Search Panel - Allows you to search for a symbol. 

D: Navigation Bar -Displays and allows access to all the symbols of the 

subscribed markets. 

E: Chart Window - Displays the current chart as you create and edit it. 
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F: Bottom Toolbar - Contains quick access icons for graphical objects and 

zoom tools. 

 

 
TOPICS IN THIS SECTION 
 

ProChart Toolbars 

ProChart Tools 

Using the Navigation Bar 

 

ProChart Toolbars 
 

INTRODUCTION  

The Pro Chart window has a Main toolbar as well as a Bottom toolbar 

with various icons that give you quick access to important chart 

properties, tools as well as the various features available with 

ProChart.  

 

TOPICS IN THIS SECTION 
 

Main Toolbar 

Bottom Toolbar 

Customizing the Bottom Toolbar 
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Main Toolbar  
 

INTRODUCTION  

ProChart‟s Main Toolbar has a wide range of icons to give you quick 

access to various important properties and functions.  The Table below 

displays all the available icons and their relevant tool tips. 

 
 

Table 1  - Main Toolbar icons 

Icon Tool Tip 

 
 Opens a New Chart  

 
Open a previously saved Chart 

 
Saves a chart with a .cht extension 

 
Displays the Print dialog box where you can set the required 

parameters and print a chart. 

 
Displays the Chart Navigation Bar on the left side of the 

workspace 

 
Hides the Chart Navigation Bar 

 
Displays a chart in intraday Mode 

 
Displays a chart in History Mode 

 

 or 

  

Allows you to select a required Period for which you  need to 

view the Chart 

( This will Vary based on History or Intraday Mode) 

 

or   

 

Allows you to select a required Interval for which you  need 

to view the Chart 

( This will Vary based on History or Intraday Mode) 

 
Displays a chart in the chart style - Line 

 
Displays a chart in the chart style - Bar 
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Displays a chart in the chart style - HLC 

 
Displays a chart in the chart style - OHLC 

 
Displays a chart in the chart style - Candle 

 
Displays  the Volume chart for a selected base chart 

 
Hides the Volume chart  

 
Displays  the Volume by Price chart for a selected base chart 

 
Hides the Volume by Price chart 

 
Displays the Turnover chart for a selected base chart 

 
Hides the Turnover chart 

 
Displays the Data Window 

 
Hides the Data Window 

 
Displays Cross Hair 

 
Hides Cross Hair 

 
Draws comparison chart in indexed price 

 
Draws comparison chart in absolute price 

 Displays the unadjusted graph 

 Displays the adjusted graph 

 
Displays chart Splits 

 
Hides chart Splits 

 
Displays Announcements 

 
Hides Announcements 

 
Displays Description 

 
Hides Description  
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Applies vertical and horizontal grids on the chart area 

 
Applies horizontal grids on the chart area 

 
Applies vertical grids on the chart area 

 
Displays no grid on the chart area 

  
Enables Data Mode 

 
Enables Chart Mode 

 
Displays Current Price Line 

 
Hides Current Price Line 

 
Displays Intraday Support & Resistance Line 

 
Hides Intraday Support & Resistance Line 

 
Displays Bid-Ask tags 

 
Hides Bids-Ask Tags 

 
Displays Min/Max Lines 

 
Hides Min/Max Lines 

 
Disables Snap to price  

 
Enables Snap to price 

 
Enables Multi-Selection 

 
Disables Multi-Selection 

 
Enables Eraser 

 
Disables Eraser 

 
Enables the Fibonacci Calculator 

 
Disable Fibonacci Calculator 

 
Displays Snap Ball 
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Hides Snap Ball 

 
Allows you to Show/Hide indicators, strategies and patterns 

applied on a chart 

 

 
 
RELATED INFORMATION 
 

Bottom Toolbar 

Customize the Bottom Toolbar 

ProChart Toolbars 

 
 

BottomToolbar 
 

INTRODUCTION  

ProChart‟s Bottom Toolbar holds a wide range of icons to give you quick 

access to frequently used tools. The following table displays all tools 

available in the Bottom Toolbar together with their relevant tool tip. 

 

Table 2  - Bottom Toolbar icons 

Ico

n 
Tool Tip 

 Allows you to view the chart for Previous/ Next Symbols 

 Allows you to draw a Trend Line anywhere on a chart 

 
Allows you to draw an Arrow Headed Trend Line anywhere on a chart 

 Allows you to insert a  Horizontal Line anywhere on a chart 

 Allows you to insert a Vertical Line anywhere on a chart 

 Allows you to draw a Rectangle anywhere on a chart 

 Allows you to draw an Ellipse anywhere on a chart 

 Allows you to place a Text Note anywhere on a chart 

 Allows you to draw a Regression Line anywhere on a chart 
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Allows you to select a required Sign from the Sign Palette and place it 

anywhere on a chart 

 Allows you to draw Fibonacci Arcs anywhere on a chart 

 Allows you to draw Fibonacci Fans anywhere on a chart 

 Allows you to draw Fibonacci Retracements anywhere on a chart 

 Allows you to draw Fibonacci Price Extensions anywhere on a chart 

 Allows you to draw Fibonacci Time Zones anywhere on a chart 

 
Allows you to draw a Zig Zag Line anywhere on a chart 

 
Allows you to draw an Arc anywhere on a chart 

 
Allows you to place a Cycle Line on a chart 

 Allows you to draw a Standard Error Channel anywhere on a chart 

 Allows you to draw a Raff Regression Channel anywhere on a chart 

 Allows you to draw a Standard Deviation Channel anywhere on a chart 

 Allows you to draw a Equidistance Channel anywhere on a chart 

 Applies short term template for the currently opened chart 

 Applies medium term template for the currently opened chart.  

 Applies long term template for the currently opened chart.  

 
Allows you to draw a Gann Line anywhere on a chart 

 
Allows you to draw a Gann Fan anywhere on a chart 

 
Allows you to draw a Gann Grid anywhere on a chart 

 Enables Background Dragging 

 
Allows you to apply smart zoom on a chart 

 Allows you to zoom in a chart 

 
Allows you to zoom out a chart 
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 Allows you to apply Box Zoom on a chart 

 Allows you to apply Drag Zoom on a chart 

 Allows you to Reset Y-Axis Zoom 

 Allows you to Reset X-Axis Zoom 

 Allows you to Reset Zoom 

 
Displays all the Tools available with ProChart in a categorized manner.  

 
Shows the previous and next Toolbars 

 

RELATED INFORMATION  

 
Customize the Bottom Toolbar 

Main Toolbar 

ProChart Toolbars 

 

 

Customize the Bottom Toolbar 
 

INTRODUCTION  

You can customize ProCharts Bottom Toolbar based on your preference 

simply by adding required tools to the toolbar or removing unnecessary 

tools from toolbar as and when needed. 

 

PROCEDURE  

To Customize the Bottom Toolbar: 

1. Click on the Drawing Tools icon   on the Bottom toolbar.This 

displays the ProChart Tools Palette  
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Figure 1 - ProChart Tools Palette 

 

On the ProChart Tools Palette: 

2. Click on the Customize Button .This displays the Customize Bottom 

Toolbar tab of the Chart Options window. 

In the Customize Bottom Toolbar tab: 

3. Select the required group of tools from the available drop down list. 

  Note: 

  Selecting All Tools will list all tools available with ProChart. 

4.  Select the required Tool from the Unselected Tools section and click 

on the Add button to move it to the Selected Tools section. 

5. Click on the Save button to Save the changes. 

  Tip: 

  To remove a Tool from the Selected Tools section, simply select the tool 

and click on the Remove button. 
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Figure 2 - Chart Options window 

 

 

RELATED INFORMATION  

Main Toolbar 

Bottom Toolbar 

ProChart Toolbars 
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ProChart Line Studies 
 

INTRODUCTION  

Lines Studies such as Trend lines, Fibonacci lines, Fibonacci fans, Gann 

lines, Gann fans, channels etc can be added to a chart at any given time 

as a method of customizing a chart in order to identify and highlight 

support and resistance levels, overbought/oversold levels as well as trends 

in prices. Line Studies serve as visual guides and can be placed almost 

anywhere on a chart. There are several Line Studies available with 

ProChart and these are categorized as follows under the ProChart Tools 

Palette: 

Drawing Tools 

Fibonacci Tools 

Channels 

Gann Tools 

 

 

PROCEDURE  

To add a Line Study from the Bottom Toolbar: 

1. Create / Open the required chart. 

2. Select the required Line Study from the Bottom toolbar. 

3. Position the mouse on the required location on the chart. 

4. Click and drag the mouse to draw the Line Study. 

  Note: 

  For Text Note object, text input dialog box appears automatically. After 

you drag the object onto the chart, you can enter the required text on it. 

  To add a Sign onto the chart, first select a sign from the sign palette 

and then place it on the Chart. 
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  Tip: 

  Multiple instances of any line study can be added to the chart if the CTRL 

key is pressed and held while clicking on the button, and while adding 

the object.  

To add multiple instances of the same object, Press and hold the CTRL 

key, select the object to be added from the toolbar, add the objects as 

you please and release the CTRL key. 

To resize a line study: 

 When the cursor is on a selected point of a line study, dragging will 

resize the object. 

To move a line study: 

 When the cursor is on the object in any area except the corner handles, 

dragging moves the object. 

  Note: 

  You cannot resize a Horizontal or Vertical Line or a Sign object 

hence they always move when dragged. 

 

To remove a Line Study: 

Method I 

1. Click on the required line study on the chart. 

2. Press the Delete Key on the Keyboard. 

 

Method II 

1. Click on  the Enable Eraser icon on the Main toolbar. 

2. Click on the line study to be deleted. 

RELATED INFORMATION  

Zoom Tools 

Customize the bottom Toolbar 
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Drawing Tools 
 

INTRODUCTION  

There are several different Drawing Tools which can be used to draw and 

highlight technical details such as support and resistance levels, trends as 

well as overbought/oversold levels. The Drawing Tools available with 

ProChart are as follows. 

 

 Trend Line - Trend Lines can be drawn anywhere in the chart area, and 

can be at any gradient or any length. 

 Arrow Headed Trend Line - Arrow headed trend lines also can be 

drawn anywhere in the chart area with any gradient or any length. The 

only difference  between Arrow headed trend lines and trend lines is that 

the Arrow headed trend lines shows the direction by an arrow head. 

 Horizontal Lines - Horizontal lines can be drawn on the chart to 

represent a single price value (or threshold) that you can set. The price 

value of the horizontal line will be displayed as a label above the line and 

will be displayed on both the left and right of the line. You can click and 

drag a horizontal line up or down according to your need (The tool tip 

will show the exact value of the horizontal position) 

 Vertical Lines - Vertical Lines can be drawn to represent a certain time 

on the chart. The time that is represented will be displayed on the right 

side of the chart, to the top of the chart area, for clarity. You can click 

and drag a vertical l ine towards the left or right to adjust the time. (The 

tool tip will help you decide the exact time that you are setting) 

 Rectangle - This draws a Rectangle, which can be of any height and 

any width, and can be placed anywhere in the chart. 

 Ellipse - This draws an Ellipse, which can be placed anywhere in the 

chart 

 Text Note - This is a Text Note which can be placed anywhere in the 

chart 

 Regression Line - Regression Lines can be drawn anywhere on the 

chart, where the regression is automatically calculated from the starting 

time to the end time. The gradient of this line will change according to 

the values of the chart within the time range given.  
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 Zig Zag Line - Zig zag Lines can be drawn anywhere on a chart to 

compare relative price movements.  

 Arc - Using this object you can draw an arc by simply selecting three 

control points as required and you can also edit a drawn arc by dragging 

these control points as needed. 

 Cycle Line - This tool can be used to draw cycles displaying equal time 

intervals along the time line.You also can extend the time interval by 

clicking and dragging the control point to the right as well as reduce the 

time interval by dragging to the left. 

 

PROCEDURE  

To use a Drawing Tool from the ProChart Tools Palette: 

1. Go to the Bottom toolbar > Click on Drawing Tools. This displays 

the ProChart Tools Palette. 

2. Select the required tool from the Drawing Tools category.    

3. Position the mouse on the required location in the chart. 

4. Click and drag the mouse to draw the Line Study.  

 

 

RELATED INFORMATION  

Fibonacci Tools 

Channels 

Terms 

Gann Tools 

Customize the bottom Toolbar 
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Customize Trendlines 
 

INTRODUCTION  

You can change any of the Trend Line properties based on your preference 

as and when needed.  

 

PROCEDURE  

To change Trend Line properties: 

1. Double click on the required Trend Line. This displays the property 

dialog box.  

In the property dialog box: 

2. Set the General and Parameter properties as required.  

In the General tab: 

 Line Colour - You can select  a required line color from the options given 

under the available drop down list. 

 Line Style - You can select  a required line style from the options given 

under the available drop down list. 

 Line Thickness - You can select  a required line thickness from the 

options given under the available drop down list. 

 Free Style - Tick this checkbox if you need to draw a trend line without 

the obstruction of getting snapped to the nearest data points. 

 

  Notes: 

  You can change the general properties as required and then set the 

changed settings as default by checking the Set as default checkbox.

  

  When the customized properties are Set as default , in the next Trend 

Line drawn the customized  properties will appear as the default 

properties. 

 



© 2002-2010 DirectFN Ltd Page 427 

 
 

 

 

In the Parameters tab: 

 Extend Left - Tick this checkbox if you need to extend the Trend Line 

infinitely towards the left.  

 Extend Right - Tick this checkbox if you need to extend the Trend Line 

infinitely towards the right.  

 Show Net Change - Tick this checkbox to display the net change in 

price between the two boundary points of  the Trend Line. 

 Show Pct Change - Tick this checkbox to display the change in price as 

a percentage between the two boundary points of the Trend Line. 

 Show Bar Count - Tick this checkbox to display the net change in time, 

with respect to the number of intervals (bars) between the two 

boundary points of the Trend Line. 

 Angle - Tick this checkbox to position a Trend Line based on a specified 

angle value. 

 Start and End boundary values - You can specify the required Date, 

Time and Price values for the Start and End points of a Trend Line, in 

order to change the Trend Line position according to your requirement.    

  Notes: 

  Once you extend the Trend line by ticking the Extend Left checkbox, 

you cannot specify the Price value for the Start point.  

  Once you extend the Trend line by ticking the Extend Right checkbox, 

you cannot specify the Price value for the End point. 

 

In the Alert tab: 

 Trigger Alert - Tick this checkbox if you need to set an alert for the 

Trend Line.  

 Alert Message - Enter an appropriate message to be displayed when 

the Alert is triggered.  
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  Note: 

  The default Alert Message displayed is "Trend Line Alert Triggered". You 

can replace this with a required message. 

 

3. Click on Ok to apply the changes. 

  Notes: 

  You can change your default properties to system default properties by 

clicking on Reset. 

  You cannot specify a Start/End time when the chart is in Historic mode. 

  Once you tick the Angle checkbox all Start and End boundary values get 

disabled. 

  When Snap to price is enabled, you cannot specify a Start/End price for 

the Trend Line. 

 

Trend Line properties dialog box - General tab 

 

 



© 2002-2010 DirectFN Ltd Page 429 

 
 

 

 

 

Trend Line properties dialog box - Parameters tab 

 

 

Trend Line properties dialog box - Alert tab 

 

 

RELATED INFORMATION 

Drawing Tools 
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Fibonacci Tools 
 

INTRODUCTION  

Fibonacci analysis is the study of potential support and resistance levels in 

the future based on past price trends and reversals. Fibonacci ratios can 

be applied on Stock charts using any of the following analysis tools based 

on your requirement. The Following Fibonacci Tools are available with 

ProChart. 

 

 Fibonacci Arcs - Fibonacci arcs are created by first drawing an invisible 

trend line between two points  (usually the high and low in a given 

period), and then three curves that intersect this trend line at the key 

Fibonacci levels of 38.2%, 50% and 61.8%. Transaction decisions are 

made when the price of the asset crosses through these key levels.  

 Fibonacci Fans - Fibonacci fans are created by first drawing a trend line 

through two points (usually the high and low in a given period), and 

then by dividing the vertical distance between the two points by the key 

Fibonacci ratios of 38.2%, 50% and 61.8%. The result of these divisions 

each represent a point within the vertical distance. The three 'fan' lines 

are then created by drawing a line from the leftmost point to each of the 

three representing a Fibonacci ratio.When a Fibonacci fan is drawn on a 

chart, the corresponding angle values are displayed next to the lines. 

 Fibonacci Price Extension Lines - Fibonacci Price Extension Lines are 

used to measure future Fibonacci targets based on previous movements. 

Constructing Fibonacci Price Extension Lines requires defining three 

points, namely, the starting point of the trend, the ending point of the 

trend (which is a starting point for the correction or counter move) and 

an ending point for the correction or counter move. (See Adding 

Fibonacci Price Extension Line) 

 Fibonacci Retracements - Fibonacci retracement is a very popular tool 

used by many technical traders to help identify strategic places for 

transactions to be placed, target prices or stop losses. The retracement 

lines thus drawn can be customized according to your preference. (See 

Customizing Fibonacci Retracements) 
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 Fibonacci Time Zones - Fibonacci Time Zones is a sequence of vertical 

lines having Fibonacci intervals of 1, 2, 3, 5, 8, 13, 21, 34, etc. 

Significant price changes are considered to be expected near these 

lines.To build this instrument, it is necessary to specify two points to 

determine the length of a unit interval. All other lines are built on base 

of this unit interval according to Fibonacci Numbers. 

 

PROCEDURE  

To use a Fibonacci Tool from the ProChart Tools Palette: 

1. Go to the Bottom toolbar > Click on Drawing Tools. This displays 

the ProChart Tools Palette. 

2. Click on the required tool under the Fibonacci Tools category.    

 

RELATED INFORMATION 

 

Drawing Tools 

Channels 

Terms 

Gann Tools 

Customize the bottom Toolbar 

 
 
Add and customize Fibonacci Price Extension Lines 
 

INTRODUCTION  

Fibonacci Price Extension Lines are used to predicted the future 

Fibonacci price targets based on previous  price movements.  

Three points have to be defined in order to draw the Fibonacci 

extension lines, namely, 

1. Starting point for the trend 

2. Ending point for the trend, which is also a starting point for 

the correction or counter-move against this trend. 

3. Ending point for this correction or counter-move. 
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  Notes: 

  Correction - Upward movement in the trend  

  Counter-Move - Downward movement in the trend 

 

PROCEDURE  

To add Fibonacci Price Extension Lines: 

1. Click on the Fibonacci Price Extension Lines icon on the 

Bottom toolbar. 

2. Add the three points on the chart according to your need. The 

three points can be drawn anywhere within the chart area. 

3. The Fibonacci Price Extension Lines will be drawn based on 

the three points added. 

 

RELATED INFORMATION 

Fibonacci Tools 

 
 
Customize Fibonacci Retracement Lines 
 

INTRODUCTION  

Fibonacci Retracement Lines can be customized as and when required by 

changing the Percentage value,  Line Color, Line Style and Line Thickness 

based on your preference. 

 

PROCEDURE  

To Customize Fibonacci Retracement Lines: 

1. Using the Fibonacci Retracement tool draw a trendline to create the 

relevant Fibonacci Retracement Lines on a chart. 

2. Double-click on the Retracement lines to view the Set Properties for 

Fibonacci Retracements window. 

3. Change the following parameters based on your requirement: 
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 Percentage: This is the percentage value at which the line will be 

drawn. You can enter a value of your preference in decimal format 

here. 

 Line Color: The Line color is displayed in RGB format in this box. 

You can customize this by clicking on the Line Color box, which will 

bring up the color picker window. Select the required Color from the 

Color Picker window and click on Ok. 

 Line Style: Select the Line Style from the Line Style drop down 

menu of each line. The Line Styles available are Solid, Dot, Dash, 

DashDot and DashDashDot. 

 Line Thickness: Select the required Line Thickness from the Line 

Thickness drop down menu of each line. The Line thicknesses 

available are 1.0, 1.5, 2.0, 3.0 and 5.0, in pixels 

 Use the following color, style and line width for all lines:  Tick 

this checkbox if you need to set a preferred style for all the lines.  

 Free Style: By default, the trendline that creates Fibonacci 

Retracement Lines snaps to the closest data points. To 

avoid this automatic snapping,  tick this checkbox. (See 

Figures 1 and Figure 2) 
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Figure 1 - Fibonacci Retracement Lines when the Free Style checkbox is ticked  

       

  

 

Figure 2 - Fibonacci Retracement Lines when the Free Style checkbox is not 

ticked  
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4. You can change the existing settings as required and then set 

the changed settings as default by checking the Set as 

default checkbox.  

5. Click Ok to apply the changes. 

  Notes: 

  When the existing settings are customized and the customized settings 

are Set as default , in the next visit the customized settings will appear 

as the default settings. 

  You can change your default settings to system default settings by 

clicking on Reset. 

 

Figure 3 - Customizing Fibonacci Retracement Lines Window 

 

RELATED INFORMATION 

Fibonacci Tools 
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Channels 
 

INTRODUCTION  

Trend channels are used to track the momentum of a trend, with 

peaks (or highs) frequently respecting the upper trend channel 

and troughs (or lows) respecting the lower trend channel. The 

different Channels  available with ProChart are as follows. 

 

 Standard Error Channel - A Standard Error Channel is 

created by drawing parallel lines, based on a number of 

standard errors, above and below the Linear Regression Trend 

Line. 

 Raff Regression Channel - Raff Regression Channels show 

the range prices can be expected to deviate from a Linear 

Regression Trend Line. The Regression Channel provides a 

quantitative way to define a price trend and its boundaries. 

The Regression Channel is constructed by plotting two parallel, 

equidistant lines above and below a Linear Regression Trend 

Line. Raff Regression Channels contain price movement, with 

the bottom channel line providing support and the top channel 

line providing resistance. Prices may extend outside of the 

channel for a short period of time. However, if prices remain 

outside the channel for a long period of time, a reversal in 

trend may be imminent.  

 Standard Deviation Channel - The Standard Deviation 

Channel consists of two parallel lines on either side of the 

Linear Regression Trend Line. The lines are spaced x number 

of standard deviations above and below the Linear Regression 

Trend Line. 
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 Equidistance Channel - Equidistant Channel represents two 

parallel trend lines connecting extreme maximum and 

minimum close prices. Market price jumps, draws peaks and 

troughs forming the channel in the trend direction. Early 

identification of the channel can give a valuable information 

including that about changes in the trend direction what allows 

to estimate possible profits and losses. It is necessary to give 

the direction of the channel and its width to build the 

instrument. 

 

PROCEDURE  

To use a Channel Tool from the ProChart Tools Palette :  

1. Go to the Bottom toolbar > Click on Drawing Tools. This 

displays the ProChart Tools Palette. 

2. Click on the required tool under the Channels category.  

 

 

RELATED INFORMATION 

  
Drawing Tools 

Fibonacci Tools 

Terms 

Gann Tools 

Customize the bottom Toolbar 
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Terms 
 

INTRODUCTION  

There are three Term available with ProChart, which are based on a pre-

defined template consisting of the chart in  candle style and the graphs for 

the indicators intraday Momentum Index, Relative Strength Index, Price 

ROC, MACD and Chaikin A/D Oscillator for a selected chart. When a Term 

is applied on a chart it displays the pre defined template for a particular 

time period depending on the selected Term. The Terms available with 

ProChart are as follows. 

 
 Short Term -  Displays the template for a period of one month.  

 Medium Term - Displays the template for a period of six months. 

 Long Term - Displays the template for the total period available. 

 

  Note: 

  A saved chart template has the file extension *.mct. 

  A chart template is not updated dynamically. If you wish to receive 

updates to your template, it needs to be saved as a Chart Layout. 

 

PROCEDURE  

To use a Term from the ProChart Tools Palette:  

1. Go to the Bottom toolbar > Click on Drawing Tools. This displays 

the ProChart Tools Palette. 

2. Click on the required Term under the Terms category. 

 

To apply a Term from the Right Click menu:  

1. Create/Open the required chart. 

2. Go to Right Click menu > Select the Apply Template option > Select 

the required Term from the list. 

3. The selected Term will be applied to the chart. 
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  Note: 

  To apply a saved template go to Right Click menu >  Select the Apply 

Template option > Select Other option. 

 

RELATED INFORMATION 

 
Create a New Template 

Create a default Template 

Saving Chart Layouts 

Drawing Tools 

Fibonacci Tools 

Channels 

Gann Tools 

Customize the bottom Toolbar 

 
 

Gann Tools 
 

INTRODUCTION  

There are several different Gann Tools available with ProChart which can 

be used to analyze the relationship between price and Time for various 

symbols. The available Gann Tools are as follows. 

 

 Gann Line - Gann Line is  a line drawn at the angle of 45 degrees. The 

line having the slope of forty-five degrees represents a long-term trend 

line (ascending or descending). While prices are above the ascending 

line it is believed that the stock prices would go up. If prices hold below 

the descending line, the prices are believed to be going down. 

Intersection of Gann Line usually signals of the basic trend break. When 

prices go down to this line during an ascending trend, time and price 

become fully balanced. Further intersection of Gann Line warns of a 

change in the trend.  
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 Gann Fan - Lines of Gann Fan are built at different angles from an 

important base or peak at the price chart. The trend line of 1*1 was 

considered by Gann the most important. The price curve located above 

this line, indicates an upward market while a price curve located below 

this line indicates a downtrend market. When a Gann fan is drawn on a 

chart, the corresponding angle values are displayed next to the lines. 

 Gann Grid - The Gann Grid is a grid of lines that is used to help in 

indicating the trends of a specific item. The grid is built with a set of 45 

degree angles. These are called Gann Lines. The goal is to show trends, 

each built at 45 degrees. The concept that was given by Gann says that 

any line that has a slope that is 45 degrees will represent a long term 

Trend Line. This can be either ascending or descending. Either way, this 

will show the market trend. 

 

  Note: 

  For those prices that hold at below the ascending line, the Gann 

concept says that this will predict a bull direction. If the prices hold 

below the descending line, it is more likely to be a bare market. When 

there is an intersection of the Gann lines, this shows that there is a 

breaking of the basic trend. When there is a further intersection of the 

Gann lines, this can show that there is a new trend happening. Still, it 

can show a fully balanced market when the prices go down to the line 

during the ascending trend – and price as well as time is then 

balanced. 

 

PROCEDURE  

To use a Gann Tool from the ProChart Tools Palette:  

1. Go to the Bottom toolbar > Click on Drawing Tools. This displays 

the ProChart Tools Palette. 

2. Click on the required Term under the Gann Tools category.    
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RELATED INFORMATION 

 
Drawing Tools 

Fibonacci Tools 

Channels 

Terms 

Customize the bottom Toolbar 

 

 
 

ProChart Zoom Tools 
 

INTRODUCTION  

ProChart provides you with a number of Zoom Tools to give you a detailed 

view of various points within a chart, and to move the chart along the 

horizontal axis in order to view a required section of any chart in detail. 

 

PROCEDURE  

To use a Zoom Tool from the ProChart Tools Palette: 

1. Go to the Bottom toolbar > Click on Drawing Tools. This displays 

the ProChart Tools Palette. 

2. Click on the required Zoom tool under the Zoom Tools category.    

 
 

TOPICS IN THIS SECTION  

 
Background Dragging (Panning) 

Smart Zoom 

Box Zoom 

Drag Zoom 

Slider 

Reset Zoom 

RELATED INFORMATION 

  
ProChart Line Studies 

Customize the bottom Toolbar 
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Background Dragging (Panning) 
 

INTRODUCTION  

The Background Dragging (or Panning) tool lets you drag a zoomed chart 

along the horizontal axis, within the given range. 

 

PROCEDURE  

To use Background Dragging: 

1. Go to Bottom toolbar > Click on the Enable Background Dragging 

icon . The mouse pointer will be displayed as a hand.  

2. Click and drag the pointer along the horizontal axis in order to pan the 

chart within the range of the original chart (before zooming)  

  Note: 

  A chart has to be zoomed in order to enable background dragging. 

To ensure that a chart is already zoomed, check the slider below the 

chart. If the slider does not cover the whole horizontal axis, it shows 

that the chart is already zoomed. 

 

 

RELATED INFORMATION 

 
Smart Zoom 

Box Zoom 

Drag Zoom 

Slider 

Reset Zoom 

Zoom Tools 
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Smart Zoom 
 

INTRODUCTION  

The Smart Zoom tool helps you to expand (zoom in) or shrink (zoom out) 

a given chart, by adjusting the X (Time) axis. Once you click on the Smart 

Zoom icon the Smart Zoom tool is displayed on the bottom of the chart 

area. The given time range for the Smart Zoom tool can be either pre-

defined or customized. 

 

PROCEDURE  

To activate the Smart Zoom tool: 

 Go to Bottom toolbar > Click on the Smart Zoom icon  . 

 

To use the Smart Zoom tool: 

 Click on the icon ( ) to change the Period to be viewed. 

 

Figure 1 -  Smart Zoom tool (Default state) 
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Figure 2 - Smart zoom tool 

 

 

RELATED INFORMATION 

 
Pre-defined Data Range 

Custom Data Range 

Background Dragging (Panning) 

Box Zoom 

Drag Zoom 

Slider 

Reset Zoom 

Zoom Tools 
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Pre-defined Data Range 
 

INTRODUCTION  

ProChart provides you with the following pre-defined time ranges enabling 

you to view the graphical movement of a symbol for a selected time 

period: 

 1 day (today's performance) 

 6 days 

 1 month 

 3 months 

 6 months 

 Year-to-date 

 1 year 

 18 months 

 2 years 

 3 years 

 5 years 

 10 years 

 All 

PROCEDURE  

To use the Pre-defined Date Range: 

1. Create / Open the required chart 

2. Click on the Smart Zoom icon . This displays the Smart Zoom tool.  

In the Smart Zoom tool: 

3. From the pre-defined Date Range, click on the required date and the 

chart is displayed accordingly. (See below) 
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Note: 

  When a chart is opened in Intraday mode, only 1d, 6d and all buttons are 

active. In order to activate the other buttons the chart should be opened in 

History mode. 

 

Refer the example below on How to view the performance of a 

symbol for a particular time period. 

Click on the 5Y button to view the performance of a symbol for a period of 

5 years. 

Figure 1 - Pre Defined Data Range 

 

 

RELATED INFORMATION 

 
Custom Data Range 

Smart Zoom 
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Custom Data Range 
 

INTRODUCTION  

The Interactive Slider and the Date drop down menu allows you to amend 

the Date Range of a given chart to suit your need. 

 

PROCEDURE  

To define a custom time range, using the interactive slider: 

1. Create / Open the required chart 

2. Click on the Smart Zoom icon . This displays the Smart Zoom tool. 

In the Smart Zoom Tool: 

3. Set the Begin and End times using the Left Interactive Slider and End 

Time Interactive Slider. (See Figure 1) 

4. Drag the left / right interactive sliders to define the custom date range. 

The chart is displayed accordingly. 

Notes: 

  When using the Interactive Slider, the Slider located at the bottom of 

the graph also changes accordingly. 

  The Begin Time Interactive Slider remains on the exact Begin Date of 

the chart. If you wish to plot the chart with an earlier Begin Date, refer 

to plotting a Historical Data Chart. 

  The range of Begin and the End Dates available on the X-axis, depends 

on the availability of historical data within the application.  
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Figure 1 - Smart Zoom using the Interactive Slider 

 

 

 

To define a custom time range, using the date drop down menu: 

1. Create / Open required chart. 

2. Click on the Smart Zoom icon . This displays the Smart Zoom tool. 

In the Smart Zoom tool: 

3. Click on the Date drop down menu. 

4. Enter /Select the required Date from the drop down menu. The chart is 

displayed accordingly. (See Figure 2) 
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Figure 2 - Select Date range from drop down menu 

 

 

RELATED INFORMATION 

 
Pre-defined Data Range 

Smart Zoom 

 
 
Box Zoom 
 

INTRODUCTION  

Use the Box Zoom tool to view a particular area of the chart in detail.  

 

PROCEDURE  

To zoom into the chart using the Box Zoom tool:  

1. Go to Bottom toolbar > Click on the Box Zoom icon . 

2. Using the mouse, click on the required area and draw a box to view 

details of the selected area.  

3. This zooms into the graph, providing further details on both vertical 

and horizontal axis of the required area. 
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Figure 1 - Box Zoom 

 

 

RELATED INFORMATION 

 

Background Dragging (Panning) 

Smart Zoom 

Drag Zoom 

Slider 

Reset Zoom 

Zoom Tools 
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Drag Zoom 
 

INTRODUCTION  

The chart is always drawn to fit in the available area. Using the Drag Zoom 

icon on the Main toolbar, the chart can be zoomed in and out 

(horizontally) without changing the Begin and End time limits.  

 

PROCEDURE  

To zoom into the chart using the Drag Zoom tool:  

1. Go to the Bottom toolbar > Click on the Drag Zoom icon . 

2. Click on the graph and drag the mouse pointer. This will zoom into the 

graph horizontally. 

Note: 

  While dragging the selected area is highlighted in Green. 

 

Figure 1 - Drag Zoom 
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RELATED INFORMATION 

 
Background Dragging (Panning) 

Smart Zoom 

Box Zoom 

Slider 

Reset Zoom 

Zoom Tools 

 
 
 
Slider 
 

INTRODUCTION  

The chart can be zoomed from its original size using the Slider, which is 

located at the bottom of the chart. The Slider zooms into the chart by 

increasing the timescale between each time (i.e. points on the X-axis of 

the graph are increased to provide more detail).  

 

PROCEDURE  

To zoom into the chart using the Slider: 

1. Move the cursor over to the required  end of the slider (left / right 

corner). 

2. When the cursor changes to a two sided arrow  , drag the Slider 

across until the graph is zoomed as required. 

 Note: 

  During this process you will notice the length of the slider decreasing. 

3. Now move the slider left or right as needed to navigate the entire 

chart. In this case the slider acts as a scrollbar. You can also use the 

scroll wheel in the mouse to navigate through the chart. 
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Figure 1 - The Slider 

 

 

RELATED INFORMATION 

Background Dragging (Panning) 

Smart Zoom 

Box Zoom 

Drag Zoom 

Reset Zoom 

Zoom Tools 
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Reset Zoom 
 

INTRODUCTION  

Once you use the zooming options on a chart and when you need to view 

the chart back in its original setting or if you need to reset either the 

horizontal or vertical axis to their original setting you can use the Reset 

Zoom tools.  

 

PROCEDURE  

To Reset Zoom: 

Method I 

 Go to the Bottom toolbar > Select  ( )  to reset only the X axis 

 Go to the Bottom toolbar > Select  ( )  to reset only the Y axis 

 Go to the Bottom toolbar > Select  ( )  to reset both X and Y axis  

 

Method II 

 Right click on chart > Select Reset Zoom > Select the required Reset 

Zoom option. 

The available Reset Zoom options are: 

  Reset Horizontal Zoom  - To Reset the X axis 

  Reset Vertical Zoom - To Reset the Y axis  

  Reset All - To reset both X and Y axis 

 

RELATED INFORMATION 

 
Background Dragging (Panning) 

Smart Zoom 

Box Zoom 

Drag Zoom 

Slider 

Zoom Tools 
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ProChart Navigation Bar 
 

INTRODUCTION  

ProChart's Navigation Bar gives a listing of all the subscribed Exchanges 

and Watch Lists as well as the securities under each of them. The 

Navigation Bar also has the Search Symbol Panel integrated in it, which 

lets you search for symbols by typing your search criteria in the Search 

Bar.The subscribed securities listing is organized in a tree structure where 

each parent node represents either a subscribed Exchange or a watch list 

and the child nodes represent the securities under each subscribed 

Exchange or watch list. 

  Note: 

  You can open/close the Navigation Bar as and when needed. 

 

 

PROCEDURE  

To view the Navigation bar: 

Method I 

 Go to the Insert menu > Select Navigation Bar. This displays the 

Navigation Bar on the left of the workspace. 

Method II 

 Move the mouse pointer / cursor to the left edge of the window and 

click.This displays the Navigation Bar on the left of the workspace. 

Method III 

 Go to the Main toolbar  > Select  - Show Chart Navigation Bar 

icon.  

 

To open a chart using the Navigation Bar: 

1. Expand an Exchange or a Watch List by clicking on its name. 

2. Click on a required Symbol to view the relevant Chart. 
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To Search for a Security using the Symbol Search Panel: 

1. Enter the search criteria which can be either the full or partial 

Description or symbol in the Search Bar. 

2. Click on the Search  button. This will display the symbol/symbols 

that satisfy the search criteria in the navigation bar. 

 

 

RELATED INFORMATION 

 Navigation Bar Configuration  
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Navigation Bar Configuration 
 

INTRODUCTION  

You can configure the way the symbol names are displayed in the 

Navigation bar and also change the font settings by changing the required 

settings based on your preference. 

 

PROCEDURE  

To Configure the Navigation Bar: 

1. Click on the Configurations  icon. This displays the Chart 

Navigation Bar Configurations window. 

On the Chart Navigation Bar Configurations window: 

 Select the Display properties based on your requirement from the 

Display Properties section 

Symbol - If you want only the symbol code displayed. You can tick the 

Include Short description checkbox if you want the Short description 

displayed along with the symbol. 

Short Description - If you want the Company Code of the symbol 

displayed. You can tick the Include Symbol checkbox if you want the 

symbol code displayed along with the short description.  

Long Description - If you want a detailed description of the symbol 

displayed. You can tick the Include Symbol checkbox if you want the 

symbol code displayed along with the long description.  

 

 Select the required Font settings, from the Font Settings section 

Select the font type from Type list. 

Select the font size from Size list.  

Select the font style from Style list. 

Select font colour required from the Colour palette. 

2. Click Ok to apply the settings. 
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Figure 1 - Chart Navigation Bar Configurations window 

 

 
 

RELATED INFORMATION  

Using the Navigation Bar  
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Working with Charts 
 

INTRODUCTION  

Charts provide an easy-to-read graphical representation of data and make 

it easy to spot the effect of key events on a security's price and 

performance over a period of time. 

This section describes the basic steps on how to get started with charts. 

 

TOPICS IN THIS SECTION   

Add a New Chart 

Open a Chart 

Save a Chart 

Detach a Chart window 

Print a Chart 

Navigate between charts 

Compare Charts 

Close a Chart 

Multiple Windowed Templates 
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Add a New Chart  
 

INTRODUCTION  

You can open a New Chart on the ProChart workspace using any of the 

following methods.   

 

PROCEDURE  

To open a New chart : 

Method I 

1. Go to the File menu > Select New > Select Chart . This displays the 

Symbol Search window. 

 

Method II 

1. Go to the Main toolbar and click on the New icon   > Select Chart. 
This displays the Symbol Search window.  

 
 

Figure 1 - Symbol Search Window 

 

 

In the  Symbol Search window (figure 1): 

2. Specify the Symbol / Description, Exchange and Type. 

 Specify symbol details by entering the required symbol code / 

company name. 

 Select the relevant Exchange from the Exchange drop-down menu 

(Selecting ALL will include all subscribed Exchanges). 
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 Specify the instrument type by selecting the required option from the 

given drop-down menu (Selecting ALL will include all instrument 

types). The options given in the drop down menu are: 

 Quote 

 Index 

 Options 

 Mutual Fund 

 Forex 

3. Click on the Search button. Once the search is complete the symbols 

that satisfy the search criteria will be displayed in the results area.  

4. Select the required Symbol and click on the  button. This will 

include the symbol in the selected list. 

5. Click on Ok. This displays the chart for the selected Symbol. 

Note: 

  To remove symbols from your selection: 

1. Click on the symbol to be removed from the selected list. 

2. Click on the  button. This will remove the symbol from the 

selected list 

 

 

To open multiple charts simultaneously: 

 

1. Open the Navigation Bar.  

2. Keep the CTRL key pressed and click on the required symbols. 

This opens the Charts for all selected symbol in the chart window. 
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RELATED INFORMATION  

Open a Chart 

Save a Chart 

Detach a Chart window 

Print a Chart 

Navigate between charts 

Compare Charts 

Close a Chart 

Multiple Windowed Templates 

Open the Navigation Bar 

Working with charts 

 
 

Open a Chart  
 

INTRODUCTION  

You can Open a previously saved Chart in the ProChart workspace using 

any of the following methods. 

 

PROCEDURE  

To Open Chart: 

Method I 

1. Go to File menu > Select Open Chart. This displays the Open Chart 

dialog box. 

 

Method II 

1. On the Main toolbar click on the Open Chart icon . This displays 

the Open Chart dialog box. 
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Figure 1 - Open Chart dialog box 

 

 

In the Open Chart dialog box (figure 1): 

2. Select the file format as Static Chart. 

3. Select the File you need to open. 

4. Click on the Open button. 

  Note: 

  You can open multiple charts within the ProChart window. 

 

RELATED INFORMATION  

Add a New Chart 

Save a Chart 

Detach a Chart window 

Print a Chart 

Navigate between charts 

Compare Charts 

Close a Chart 

Multiple Windowed Templates 

Open the Navigation Bar 
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Working with charts 

Open a Layout 
 

INTRODUCTION  

You can open any previously saved Chart Layout for your reference or to 

edit the layout as and when needed.  

 

PROCEDURE  

To open a Chart Layout: 

Method I 

1. Go to File menu >  Select Open Chart option. This displays the Open 

Chart window. 

In the Open Chart window: 

2. Select the file format as Chart Layout. 

3. Select the File you want to open. 

4. Click on the Open button. 

Method II 

1. Go to the Main toolbar > Click on Open Chart icon > This displays 

the Open Chart window. 

In the Open Chart window: 

2. Select the file format as Chart Layout. 

3. Select the File you want to open. 

4. Click on the Open button. 

  Note: 

  You can open multiple layouts within the ProChart window. 

 

RELATED INFORMATION 

Create a New Layout 

Add a New Chart 
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Saving Chart Layouts 

Save a Chart 
 

INTRODUCTION  

All chart files are saved with a .cht extension . The current date, time and 

price details are saved in the chart and the next time you open the chart, 

it will open with the saved details. You can Save a Chart  using any of the 

following methods. 

 

PROCEDURE  

To save a new chart: 

1. Go to File menu > Click on the Save command. This displays the Save 

dialog box. 

In the Save dialog box: 

2. Specify the folder / location to save the file.  

3. Select the File format > Enter the File Name. 

4. Click on the Save button. 

 

To save a Chart with a New Name (Save As): 

1. Go to File menu > Select the Save As command. This displays the 

Save As dialog box. 

In the Save As dialog box:  

2. Specify the folder / location to save the file. 

3. Enter the File Name > Select the required File Format. 

4. Click on the Save button. 

 

To save a Chart along with its Indicators: 

 Click on the Save & Exit button on the Warning confirmation 

message box displayed when you exit the application. 
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  Note: 

  If you want dynamic data updates on your Chart for the saved symbol, 

you can save it as a Chart Layout. 

  To retain the current chart settings with Indicators and apply it to 

another symbol, save the chart as a Chart Template. 

 

RELATED INFORMATION  

Add a New Chart 

Open a saved chart 

Detach a Chart window 

Print a Chart 

Navigate between charts 

Compare Charts 

Close a Chart 

Multiple Windowed Templates 

Open the Navigation Bar 

Working with charts 
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Detach a Chart window 
 

INTRODUCTION  

ProChart provides the facility to detach a Chart at any given time. 

Detaching a chart window is advantageous when you have only limited 

workspace because a detached chart takes less space and can be easily 

tiled with other windows.   

 

PROCEDURE  

To detach a Chart window: 

1. Right click on a chart opened in ProChart.  

2. On the Right Click menu > Select the Detach command. 

  Note: 

  When you open a Chart outside ProChart, it displays in detached mode. 

(E.g.: When you click on an index displayed on the main-board OR when 

you select  a chart from a watch list using its Right Click menu.) 

  When the chart is in detached mode send it to ProChart, from the 

detached graph‟s Right Click menu > Select Send To Pro Chart 

command. 

  All the features and functionalities are common to charts either opened 

inside ProChart window or in detached mode. However, adding line 

studies, quick menu and toolbar options, etc. are possible only when the 

chart is inside ProChart. 

 

RELATED INFORMATION  

Add a New Chart 

Open a saved chart 

Save a Chart 

Print a Chart 

Navigate between charts 

Compare Charts 

Close a Chart 
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Multiple Windowed Templates 

Open the Navigation Bar 

Working with charts 

 
 

Print a Chart 
 

INTRODUCTION  

You can take a print-out of a chart at any given time using the Print Chart 

command. 

 

PROCEDURE  

Method I 

1. Go to File menu > Select the Print Chart command. This displays the 

Print dialog box. 

 

 

Method II 

1. Right Click on the required chart > Select the Print Chart command. 

This displays the Print dialog box. 

In the Print dialog box: 

2. Select the Printer and set the Required Parameters. 

3. Click on the Print button. 

  Notes: 

  Always set the correct paper size and required margins in the print 

Properties before printing the chart. 

  Chart Layouts and Templates can also be printed in the manner 

described above. 

 

RELATED INFORMATION 

Add a New Chart 

Open a saved chart 
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Save a Chart 

Detach a Chart window 

Navigate between charts 

Compare Charts 

Close a Chart 

Multiple Windowed Templates 

Open the Navigation Bar 

Working with charts 

 
 
Navigate between Charts 
 

INTRODUCTION  

ProChart allows you to navigate between charts as and when required. 

 

PROCEDURE  

To navigate between charts: 

 Click on the Previous or Next icons located on the Bottom toolbar 

(Figure 1). 

Figure 1 - Previous and Next icons on the Bottom toolbar 

 

 

  Notes: 

  Any settings configured using the set default option or apply template 

remains static while navigating between symbols. 

  The chart is displayed for all the symbols that appear in the Full Market 

/ Watch List in alphabetical order.  
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RELATED INFORMATION 

Add a New Chart 

Open a saved chart 

Save a Chart 

Detach a Chart window 

Print a Chart 

Compare Charts 

Close a Chart 

Multiple Windowed Templates 

Open the Navigation Bar 

Working with charts 

 
 

Compare Charts 
 

INTRODUCTION  

ProChart gives you the ability to compare two or more charts, with the 

Compare Charts feature.  

 

PROCEDURE  

To compare charts: 

Specify the Base Symbol and one or more Compare With Symbols, where: 

 Base Symbol is the Symbol of the Base Chart, with which the other 

charts (Comparison Charts) will be compared. There can be only one 

Base Symbol at a given point of time. 

 Compare With Symbol is the Symbol/s of the chart/s that will be 

compared against the Base Symbol. There can be any number of 

Compare With Symbols. 

 

  Note: 

  The comparison charts show the relative rise and/or fall of the 

Compare With Symbol against the Base Symbol. At the beginning 
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of the period displayed, both charts will be at the same position 

vertically (i.e.: the Comparison Chart has been scaled to be at the 

same level as the Base Chart). 

 

To Specify the Base Symbol: 

Method I 

To use a symbol currently available in the Base Symbol sub menu 

list : 

1. Go to Insert menu > Base Symbol sub-menu. This sub-menu will 

contain the symbol of the chart currently opened plus any other 

symbols that have previously been used as base symbols.  

2. To use a symbol currently in the list, Click on the symbol in the list. 

 

To use a symbol currently not available in the Base Symbol sub 

menu list : 

1. Go to Insert menu > Base Symbol sub-menu > Search command. 

This displays the Symbol Search window. 

In the Symbol Search window: 

2. Search for the symbol (See Add a New Chart for details) 

3. The Base Chart will be drawn and the Base Symbol selected will be 

added to the list of symbols in the Base Symbol sub-menu. 

Method II  

To Change the Base Symbol Using the Base Symbol text field in the 

Bottom toolbar:   

 

1. Enter the Symbol in the Base Symbol text field 

   OR 
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2. Search for the Symbol by clicking the  button next to the Base 

Symbol text field and search for the Symbol from the Symbol Search 

Window. The Base Chart will be drawn and the Base Symbol selected 

will be added to the list of symbols in the Base Symbol sub-menu. 

To Specify A Comparison Chart: 

Method I 

To use a symbol currently available in the Compare With sub menu 

list : 

1. Go to Insert menu > Compare With sub-menu. This sub-menu will 

contain any symbols that have been previously used  as comparison 

symbols.  

2. To use a symbol currently in the list, Click on the symbol in the list. 

 

 

To use a symbol currently not available in the Compare With sub 

menu list : 

1. Go to Insert menu > Compare With sub-menu > Search command. 

This displays the Symbol Search window. 

In the Symbol Search window: 

2. Search for the symbol (See Add a New Chart for details) 

3. The Comparison Chart will be drawn and the Compare With Symbol 

selected will be added to the list of symbols in the Compare With 

Symbol sub-menu. 

 

Method II 

To add Comparison Charts Using the Compare with text field in the 

Bottom toolbar : 

 Enter the Symbol in the Compare with text field OR Search for the 

Symbol using the  button next to the Compare with text field and 

search for the Symbol from the Symbol Search Window. The Comparison 

Chart will be added to the chart area and the Compare With Symbol will 

be added to list of symbols in the Compare With Symbol sub-menu. 
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  Note: 

  You can add multiple Comparison Charts. 

 

 

To remove a Comparison Chart: 

Method I 

 Go to Insert menu > Select the Compare with sub menu > Click on 

the Symbol you need to remove. 

 

Method II 

 Select the Comparison chart by clicking on it > Press the Delete key 

on the keyboard. 

 

RELATED INFORMATION 

Add a New Chart 

Open a saved chart 

Save a Chart 

Detach a Chart window 

Print a Chart 

Navigate between charts 

Close a Chart 

Multiple Windowed Templates 

Open the Navigation Bar 

Working with charts 
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Close a Chart 
 

INTRODUCTION  

You can either close a single chart or all charts currently opened in the 

ProChart window in one go.  

 

PROCEDURE  

To close a single Chart: 

Method I 

1. Click on the Close button of the respective Chart. 

 

Method II 

1. Go to File menu > Select the Close Chart command. 

2. This closes the currently active Chart window.  

 

To close multiple Charts: 

Method I 

1. Go to File menu > Select the Close All Charts command. 

 

Method II 

1. Go to the ProChart window > Click on the Close button. 

2. This closes all the Charts as well as the ProChart window. 

 

RELATED INFORMATION 

 
Add a New Chart 

Open a saved chart 

Save a Chart 

Detach a Chart window 
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Print a Chart 

Navigate between charts 

Compare Charts 

Multiple Windowed Templates 

Open the Navigation Bar 

Working with charts 

 
 

 

Multiple Windowed Templates 
 

INTRODUCTION  

You can use the Link group icon  to group multiple chart windows and 

the Navigation bar in order to view multiple chart windows with multiple 

Patterns, Strategies and Indicator, and can have the same view for 

different symbols by changing the base symbol from the Navigation bar.  

 

PROCEDURE  

To create a multiple windowed template: 

1. Add multiple charts to the ProChart window as required. 

2. Add necessary Indicators, Patterns and Strategies for the Opened 

charts. 

3. Group the chart window/windows and the Navigation bar with the same 

Link group color. 
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Figure 1 - Multiple windowed template 

 

 

  Notes: 

  The Base symbol of all grouped chart windows change accordingly 

based on the selected symbol on the Navigation bar. 

  The Indicators, Strategies and Patterns added for the grouped charts 

also change based on the selected symbol on the Navigation bar. 

  You can have multiple charts with the same base symbol opened if you 

need to view multiple Indicators,Patterns and Strategies for the same 

chart simultaneously. 

 

RELATED INFORMATION  

Add a New Chart 

Open a saved chart 

Save a Chart 
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Detach a Chart window 

Print a Chart 

Navigate between charts 

Compare Charts 

Close a Chart 

Open the Navigation Bar 

Working with charts 
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Setting up Chart Display 
 

INTRODUCTION  

ProChart  provides  a wide range of display tools to help you view the 

chart more closely and accurately which thereby assists you to make 

profitable decisions. The Chart Display tools can be applied to any chart,  

even when Trend Lines or Indicators are placed on the chart. 

 

AVAILABLE CHART PROPERTIES 

Set Chart Mode 

Set Chart Period  

Set Chart Interval 

Set Chart Style  

Show/Hide Volume Graph 

Show/Hide Volume by Price 

Graph 

Show/Hide Turnover Graph 

Show/Hide Data window 

Show/Hide Cross Hair  

Set Graph Index  

View Unadjusted Graph  

View Announcements 

View Splits 

Set Grid Style 

Set Data Mode 

Show/Hide Current Price Line 

Show/Hide Previous Close Price Line 

Show/Hide Support and Resistance Line 

Show/Hide Bid-Ask Tags 

Show/Hide Min-Max Lines 

Enable/Disable Snap to Price 

Enable/Disable Multi Selection 

Enable/Disable Fibonacci Price 

Retracement Calculator 

Enable/Disable Snap Ball 

Show/Hide ISP 

Show/Hide VWAP Values 

View the chart in Semi-Log Scale 

Manage Chart Display 

Set Chart Options 
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Set Chart Mode 
 

INTRODUCTION  

You can switch between Intraday or History modes as required simply by 

changing the chart mode setting. 

 

PROCEDURE  

To switch between Intraday and History mode: 

Method I 

 On the Main toolbar > Click on the History Mode icon  or  Intraday 

Mode icon  based on your requirement. 
 

Method II 

 Go to Properties menu > Click on Mode > Select the History/ 
Intraday option based on your requirement. 

 

Method III 

1. Right click on a chart already opened inside ProChart. 

2. On the Right Click menu > Select the Mode option > Select History/ 

Intraday option based on your requirement. 

  Note: 

  By default a chart is plotted in Intraday mode. 

 

 

RELATED INFORMATION 

Set Chart period 

Set chart interval 

Set Defaults 

Setting up Chart Display 
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Set Chart Period  
 

INTRODUCTION  

Using this option you can set the period for which you wish to view the 

Chart. The pre-defined periods vary, depending on the mode. (i.e. History 

or Intraday modes) 

History Mode predefined periods are as follows:  

 1 month 

 3 months 

 6 months 

 YTD (Beginning of the Year to date) 

 1 year 

 2 years 

 3 years 

 5 years 

 10 years 

 All (Graph displayed for the total period for which data is available)  

 Other (User defined custom time period) 

       

Intraday Mode predefined periods are as follows:  

 1 day 

 6 days 

 All (Graph displayed for the total period for which intraday data is 

available) 

 Other (User defined custom time period, maximum limit 6 days) 
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PROCEDURE  

To set the period: 

Method I 

1. Go to the Main toolbar.  

2. Click on the Period drop down (The relevant pre defined periods are 

shown according to the selected mode).  

3. Select the required period. 
 

Method II 

 Go to the Properties menu >Select the Period option > Select the 

required period. 

 

Method III 

 Go to Right Click menu > Select the Period option. > Select the 

required period. 

 

Figure 1 - Chart with selected Period (1 Day) 
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To set a Custom Period: 

Method I 

1. Go to Properties menu > Select the Interval > Select the option 

Other. This displays the Set Period window. 

 

In the Set Period window: 

2. Define the Custom Intervals of your choice > Click on ok. 

 

Method II 

1. Right click on any chart.  

2. Select the Interval option > Select the option Other. This displays the 

Set Period window. 

In the Set Period window: 

3. Define the Custom Intervals based on your preference 

4. Click on ok. 

Set Period window 
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RELATED INFORMATION 

Set chart mode 

Set chart interval 

Set Chart style 

Set Defaults 

Setting up Chart Display 

 
 
Set Chart Interval 
 

INTRODUCTION  

Using this option you can set the Interval for which you wish to view 

the Chart. The pre-defined intervals vary, depending on the mode. (I.e. 

History or Intraday modes) 

History Mode Charting Intervals are as follows:   

 Daily  

 Weekly  

 Monthly 

 Other 

 

Intraday Charting Intervals are as follows:  

 Every minute 

 Every 5 minutes 

 Every 10 minutes 

 Every 15 minutes 

 Every 30 minutes 

 Every 60 minutes 

 Other (Custom Intervals) 
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PROCEDURE  

To set the Interval: 

Method I 

1. Go to the Main toolbar.  

2. Click on the Interval drop down (The relevant pre defined intervals 

are shown according to the selected mode).  

3. Select the  required interval. 

 

Method II 

 Go to Properties menu > Select the Interval option> Select the 

required interval. 

 

Method III 

 Go to Right Click menu > Select Interval option > Select the required 

interval. 

 

Figure 1 - Chart with the selected Interval (Every 5 minutes) 
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To set a Custom Interval: 

Method I 

1. Go to Properties menu > Select the Interval > Select the option 

Other. This displays the Set Interval window. 

In the Set Intervals window: 

2. Define the Custom Intervals > Click on ok.  

 

Method II 

1. Right Click on any chart.  

2. Select the Interval option > Select the option Other. This displays the 

Set Interval window. 

In the Set Intervals window: 

3. Define the Custom Intervals > Click on ok.  

Set Interval window 

 

 

 

RELATED INFORMATION 

Set chart mode 

Set Chart period 

Set Chart style 

Set Defaults 

Setting up Chart Display 
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Set Chart Style 
 

INTRODUCTION  

Pro chart provides five different chart styles which serves its own 

unique purpose and can be selected based on your trading style.  

 

Line 

A line chart is the simplest type of chart. In a line chart, a single line 

represents the security's closing price on each day. Dates are displayed 

along the (X) axis (horizontal axis) and prices are displayed on the (Y) 

axis (vertical axis). It provides an uncluttered, easy to understand view 

of a security's price. Line charts are typically displayed using a 

security's closing prices. 

 

Bar 

The bar-chart (or column chart) is one of the most versatile of 

statistical diagrams. Each bar on a bar chart represents price 

performance for a specific period. These periods could be as long as a 

month or as short as one minute, depending on the purpose for which 

the chart is to be used. Daily bar charts are the most popular. 

 

HLC 

HLC stands for the 3 elements displayed on a typical price bar: 

 Highest Price  

 Lowest Price 

 Closing Price 

The movement of these three prices are diagrammatically displayed in 

HLC. 
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OHLC 

OHLC stands for the 4 elements displayed on a typical price bar: 

 Opening Price 

 Highest Price  

 Lowest Price 

 Closing Price 

This type of chart is often used to spot trends and view stock movements, 

particularly on a shorter term basis.  

 

 

 

Candle 

Candlestick bars also indicate the high-to-low range with a vertical 

line. However, in candlestick charting, the larger block in the middle 

indicates the range between the opening and closing prices.  

Traditionally, if the block in the middle is filled or colored in, then the 

stock closed lower than it opened. Thus for filled blocks, the top of the 

block is the opening price, and the bottom of the block is the closing 

price. If the closing price is higher than the opening price, then the 

block in the middle will be white or hollow or unfilled.   

There are many trading patterns based on candlestick charting.  
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PROCEDURE  

To change the Style of an opened Chart: 

Method I 

 Go to the Main toolbar > Click on the Style drop down list > Select the 

required style. 

 

Method II 

 Go to Properties menu > Select the Style option > Select the required 

chart style.  

 

Method III 

 Go to the Right Click menu > Select the Style option > Select the 

required style. 

 

Method IV 

1. Double-click on any point on the chart. This displays the Set 

Properties dialog box.   

In the Set Properties dialog box: 

2. Select the required Chart Style. 

3. Click on Ok. 

  Note: 

  In both intraday and history mode charts, you can see the last candle 

updating dynamically as the last price changes. This dynamic change is 

clearly visible when the chart style is either HLC/OHLC/Candle.  
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Figure 1 - Chart Style Dialog box 

 

To change the default Style for Charts: 

1. Go to the Tools menu >Select Chart Options. This displays the Chart 

Options dialog box.   

In the Chart Options dialog box: 

2. Go to the Set defaults tab. 

3. Select the required Chart Style under the Base Chart tab in the 

Chart Properties section. 

4. Click on the Save button. 

 

RELATED INFORMATION 

Set chart mode 

Set chart interval 

Set Chart period 

Set Defaults 

Setting up Chart Display 
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View Volume Graph 
 

INTRODUCTION  

You can view the Volume graph for any base chart simply by enabling the 

Show volume option. 

 

PROCEDURE  

To view the Volume graph for an opened chart:  

Method I 

 Go to the Main toolbar > Click on the Show volume icon . 
 
 

Method II 

 Go to the Properties menu > Select Show volume option by ticking 

the box.  
 

Method III 

 Go to Right Click menu > Set the Show volume option by ticking the 

box. 

 

  Notes: 

  
Click on the Hide Volume icon  to hide the Volume Graph. 

  Volume Graph supports both Line and Bar chart styles. 

  The label  displayed on the Y axis of the Volume Graph symbolizes that 

the values in the graph are in the range of thousands, and the label  

symbolizes that the values are in the range of millions. 
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Figure 1 - Base Chart with its Volume chart 

 

 

 

RELATED INFORMATION 

View Volume by Price Graph 

View Turnover Graph 

Change Default Volume Chart Properties 

Setting up Chart Display 
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View Volume by Price Graph 
 

INTRODUCTION  

The Volume by Price graph for a base chart can be viewed by clicking on 

Show Volume by Price. You can view the volume by price graph based on 

any one of the following options. 

 Net change  

 Percentage Change 

 Total 

 

PROCEDURE  

To view the volume by price graph for a given chart: 

Method I 

1. On the Main toolbar > Click on the Show Volume by Price icon  . 

2. Click on the arrow next to the Show Volume by Price icon. This displays 

the three options available to view volume by price   

3. Tick the required option from the three options available. 

 

Method II 

 Go to Properties menu > Select the Show Volume by Price option by 

ticking the box.  
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  Notes: 

  Select the Show Volume by Price option from the Properties menu  

to  view the Volume by Price based on the option ticked under the 

Show Volume by Price drop down list on the Main toolbar. 

  Click on the Hide Volume by price icon  to hide the Volume by price 

Graph. 

 

Net change (see Figure 1) - displays the volume depicting the number of 

trades with an uptrend on the right Y-Axis (in Green) and the volume 

depicting the number of trades with a downtrend on the left Y-Axis (in 

Red).   

Percentage Change (see Figure 2) - displays the volume as a percentage 

depicting the number of trades with an uptrend on the right Y-Axis (in 

Green) and the volume depicting the number of trades with a downtrend 

on the left Y-Axis (in Red). 

Total (see Figure 3) - displays the total volume traded (in Blue) at a given 

price range.  
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Figure 1 - Chart with Volume by Price - by Net Change 

 

 

Figure 2 - Chart with Volume by Price - by Pct Change 
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Figure 3 - Chart with Volume by Price - Total 

 

 

 

RELATED INFORMATION 

View Volume Graph 

View Turnover Graph 

Change Default Volume Chart Properties 

Setting up Chart Display 
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View Turnover Graph 
 

INTRODUCTION  

You can view the Turnover chart for any base chart simply by clicking on 

the Show Turnover icon. 

 

PROCEDURE  

To view the turnover graph for a given chart: 

Method I 

 Go to the Main toolbar > Click on the Show Turnover icon . 

 

Method I 

 Go to the Properties menu > Select the Show Turnover option by 

ticking the box.  

 

Method III 

 Go to Right Click menu > Set the Show Turnover option by ticking the 

box. 

  Notes: 

  Click on the Hide Turnover icon  to hide the Turnover Graph. 

  The label  displayed on the Y axis of the Turnover Graph symbolizes 

that the values in the graph are in the range of thousands, and the label 

 symbolizes that the values are in the range of millions. 
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Figure 1 - Base Chart with its Turnover chart 

 

 

RELATED INFORMATION 

View the Volume Graph 

View the Volume by Price Graph 

Change Default Chart Properties 

Setting up Chart Display 
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View Data window 
 

INTRODUCTION  

You can view the OHLC (Open, High, Low, and Close), Volume and Value 

data for a selected date/time for any base chart simply by enabling the 

Show Data Window option. 

 

PROCEDURE  

To show/ hide Data window: 

 Go to the Main toolbar > Click on Show Data window icon . This 

displays the Data window. 

  Tip: 

  Move the mouse pointer over the required date /time point to view the 

real time OHLC, Volume and Value data for the particular point.  

 

Figure 1 - Chart with Data window 
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Data Table Window 

The Data Table Window can be accessed from the Show Data Table icon 

 on the Data Window. (See Related information for more details) 

 

RELATED INFORMATION 

Data table window 

Setting up Chart Display 

 
 
View Data Table Window 
 

INTRODUCTION  

The Data Table window displays OHLC information, Volume and Net 

Change information for a particular chart and allows you to track the 

movements of the symbol graphically as well as numerically. 

There are two options available with the Data Table Window to 

dynamically track the movements of the symbol: 

 Table Row Highlighting - allows you to view the data pertaining to a 

point of time in the chart. 

 Snap to Date in Chart  - allows the inverse of Table Row Highlighting. 

 

PROCEDURE  

To view the Data Table Window: 

1. Go to the Main toolbar > Click on Show Data window icon. This 

displays the Data window. 

On the Data window: 

2. Click on the Show Data Table icon . This will convert the Data 

Window into the Data Table Window. 
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  Note: 

  To change back into the Data window, click on the Show Data window 

icon on the Data Table. 

 

To use the Table Row Highlighting tool: 

1. Click the Enable Table Row Highlighting icon in the toolbar. You will 

notice that the mouse pointer will change. 

2. Click on the chart. This will place a vertical line on the chart. 

3. Click and drag the vertical line left or right to see the row of the data 

table pertaining to the value at that time highlighted. 

 

To use the Snap to Date in Chart tool: 

1. Click the Enable Snap to Date in Chart icon in the toolbar. 

2. Click on a row in the Data Table. You will notice a Dashed Vertical Line 

appearing on the chart.  

3. You can click on any row to view this line move to the position in the 

chart, or drag it up and down the rows of the table in order to move 

the vertical line along the chart. 

 

RELATED INFORMATION 

Show/Hide Data window 

Setting up Chart Display 

 



© 2002-2010 DirectFN Ltd Page 501 

 
 

View Cross Hair 
 

INTRODUCTION  

The Show Cross Hair feature helps you to navigate through 

every point of a chart using the mouse pointer. You can enable / 

disable this feature at any given time based on your 

requirement. 

  

PROCEDURE  

To enable / disable Show Cross Hair: 

 Go to Main toolbar > Click on the Show Cross Hair icon . 

When cross hair is enabled, you can navigate through the 

entire Chart by moving the mouse pointer. 

  Note: 

  Click on the Hide Cross Hair icon to hide the Cross hair. 

 

Show Cross Hair Options: 

Show Cross Hair can be set to Cross Hair, Snap Price Ball or High 

& Low Options. The required option can be selected from the 

Drop Down List available under Show Cross Hair. 

 

To Select an Option from the List:  

1. Click on the Down Arrow next to the Show Cross Hair icon. 

2. When the List is displayed , select the required Option by 

clicking on it. 

 

Functionality of each option in the drop down list is as 

follows: 

 Cross Hair - Shows Cross Hair along the entire Chart when 

you navigate by moving the mouse pointer. 
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Figure 1 - Chart with Cross Hair 

  

 

 Snap Price Ball - Shows Snap Ball combined with Cross Hair 

along the entire Chart when you navigate by moving the 

mouse pointer. 

Figure 2 - Chart with Snap Ball  
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 High & Low - Shows two dotted lines marking the High and 

Low values of a candle in the chart 

Figure 3 - Chart with High & Low 

  

  Note: 

  Date & Price labels are displayed on the corresponding axis area, for all 

three options under the  Show Cross Hair icon. 

 

RELATED INFORMATION 

Enable/Disable Snap Ball 

Setting up Chart Display 

 



© 2002-2010 DirectFN Ltd Page 504 

 
 

Set Graph Index 
 

INTRODUCTION  

Chart comparison can be done either in absolute price or in indexed price.  

 

PROCEDURE To set the indexed option: 

Method I 

 Go to the Main toolbar > Click on the Indexed ON icon . 

 

Method II 

 Go to the Properties menu > Select the Indexed option by ticking the 

box.  

 

Method III 

 Go to the Right Click menu > Set the Indexed option by ticking the 

box. 

  Note: 

  By default all comparison graphs are drawn indexed, with the first price 

value for the selected period in the Base graph. Therefore, the tool tip 

values for Compare with charts, may not match with the price scale as it 

represents only the Base graph prices. Thus, the Comparison Graph can 

be considered as multiplied by a fixed factor. However you can get the 

price information correctly from the tool tip of that chart. 

  When the indexed option is set off, base and compare prices are absolute 

and therefore all the price values on the tool tips should tally with the 

price axis scale. 

 

RELATED INFORMATION 

Compare Charts 

Setting up Chart Display 
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View Unadjusted graph 
 

INTRODUCTION  

The Unadjusted graph option lets you view required graphs in an 

unadjusted manner based on various corporate actions so that you can 

see the gaps on the graph due to the selected corporate actions.  

The corporate actions for which the Unadjusted graph can be viewed are: 

  Stock Dividend 

  Rights Issue  

  Stock Split 

  

PROCEDURE  

To view the Unadjusted graph for a required corporate 

action/actions: 

1. On the Main toolbar click on the Unadjusted graph icon  .  

2. Select the required corporate action/actions by ticking the relevant 

check box/boxes available under the Unadjusted graph drop down list. 

This displays the Unadjusted graph based on the selected corporate 

actions. 

 

To view the Adjusted graph: 

 On the Main toolbar click on the Adjusted graph icon . 

 

RELATED INFORMATION 

View Splits 

Setting up Chart Display 
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View Splits 
 

INTRODUCTION  

You can view splits if they exist on any particular chart as and when 

required. 

 

PROCEDURE  

To view Split: 

1. Go to the Main toolbar > click on Show Splits icon . This indicates 

the available splits via the indicator   (See Figure 1) 

2. Rest the mouse pointer on any split indicator. This displays the Date 

and Value of the Stock Split as a tool tip. 

  Note: 

  Stock Splits can be viewed only in History Mode. 

  
Click on the Hide Splits icon   to hide the displayed splits. 

 

Figure 1 - Chart with Stock Split 
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RELATED INFORMATION 

View Unadjusted Graph 

View Announcements 

Setting up Chart Display 

 
 
View Announcements 
 

INTRODUCTION  

Announcements made by companies can be viewed on the relevant pro 

chart simply by clicking on the announcement indicators. 

  

PROCEDURE  

To view Announcements: 

1. Go to the Main toolbar  > click on Show Announcements icon . 

This indicates the available announcements via the indicator  (See 

Figure 1) 

2. Rest the mouse pointer on any Announcements indicator. This displays 

the relevant announcement. 

  Note: 

   The Announcements can be viewed only in History Mode. 

  
Click on the Hide Announcements icon   to hide the displayed 

announcements. 
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Figure 1 - Chart with Announcements 

 

 

RELATED INFORMATION 

View Splits 

Setting up Chart Display 
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Set the Grid Style 
 

INTRODUCTION  
ProChart supports four grid styles which can be applied as required.  Keep 

pressing the Grid Style icon on the Main toolbar to switch among the four 

available grid styles. 

The four grid styles and the relevant icons are as follows: 

 Both (Both Horizontal and Vertical grid lines) -  

 Horizontal (Horizontal grid lines only) -  

 Vertical (Vertical grid lines only) -  

 None (No grid lines ) -  

 

PROCEDURE  

To set a required Grid style: 

 Go to the Main toolbar > Click on the Grid Style icon until the required 

Grid Style is displayed. 

  Note: 

  Vertical grid lines are drawn mapping the markings on the time axis.  

  The default Grid Style is No Grid. 

 

 

RELATED INFORMATION 

Main toolbar 

Setting up Chart Display 
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Set Data Mode 
 

INTRODUCTION  

You can view a Chart in Data Mode with up-to-date dynamic data as and 

when required..  

 

PROCEDURE  

To view the Chart in data mode: 

Method I 

 Go to Main toolbar > Click on the Data mode icon . 

Method II 

 Go to Right Click menu > Select the Data mode option. 

 

RELATED INFORMATION 

Main toolbar 

Setting up Chart Display 
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View Current Price Line 
 

INTRODUCTION  

The Current Price Line feature displays a horizontal line along the last 

traded price of the symbol indicating the price at the right end of the line. 

 

PROCEDURE  

To view the Current Price Line: 

Method I 

 Go to Main toolbar > Click on the Show Current Price Line icon . 

 

Method II 

 Go to Properties menu > Select the Show Current Price Line option 

by ticking the box.  

 

Method III 

 Go to Right Click menu > Set the Show Current Price Line option by 

ticking the box.  

  Note: 

  
Click on the Hide Current Price Line icon  to hide the current price 

line.  
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Figure 1 - Chart with Current Price Line 

 

 

RELATED INFORMATION 

Setting up Chart Display 

 
 
View Previous Close Price Line 
 

INTRODUCTION  

A horizontal line is displayed along the previous close price of the symbol. 

The price is indicated at the end of the line. 

 

PROCEDURE  

To view the Current Price Line: 

Method I 

 Go to Main toolbar > Click on the Show Previous Close Price Line 

icon. 
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Method II 

 Go to Properties menu > Select the Previous Close Price Line option 

by ticking the box.  

 

 

Method III 

 Go to Right Click menu > Set the Previous Close Price Line option by 

ticking the box.  

  Note: 

  Click on the Hide Previous Close Price Line icon in the Upper toolbar 

to hide the line.  

 

 

Figure 1 - Chart with Previous Close Price Line 

 

 

RELATED INFORMATION 

Setting up Chart Display 
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View Support and Resistance Lines 
 

INTRODUCTION  

Resistance and Support Lines indicate certain levels at which the price 

tends to resist increasing (in the form of resistance lines) or decreasing (in 

the form of support lines). 

ProChart shows three levels of resistance as well as three levels of 

support. 

 

PROCEDURE  

To view Resistance Lines: 

 Go to the Main toolbar > Click on the Show Resistance Lines icon 

. This displays the resistance and support lines for the selected chart. 

  Note: 

  
Click on the Hide Resistance Lines icon  to hide the resistance and 

support lines. 

 

Figure 1 - Chart with Resistance Line 

 

 

RELATED INFORMATION 

Setting up Chart Display 
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View Bid-Ask Tags 
 

INTRODUCTION  

The Bid-Ask Tags feature when enabled, displays a tag on the best Bid and 

Ask prices on your Chart.  

 

PROCEDURE  

To view Bid-Ask Tags: 

Method I 

 Go to the Main toolbar > Click on the Show Bid-Ask Tags icon . 

 

Method II 

 Go to the Properties menu > Select the Show Bid-Ask Tags option by 

ticking the box.  

 

Method III 

 Go to the Right Click menu > Set the Show Bid-Ask Tags option by 

ticking the box.  

  Note: 

  Click on the Hide Bid-Ask Tags icon to hide the Bid-Ask tags. 
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Figure 1 - Chart with Bid-Ask Tags 

 

 

RELATED INFORMATION 

Setting up Chart Display 

 
 

View Min-Max Lines 
 

INTRODUCTION  

The Show Min-Max Lines option shows the highest and lowest price range 

defined by the exchange. ProChart automatically adjusts the scale of the 

y-axis to accommodate the Min-Max line in the viewable area. The Max 

price is in Green and Min Price is in Red colour. When you disable the Min-

Max lines, the chart reverts to the previous scale. 

 

PROCEDURE  

To view Min-Max Lines: 

Method I 

 Go to the Main toolbar > Click on the Show Min-Max Lines icon . 
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Method II 

 Go to the Properties menu > Select the Show Min-Max Lines option 

by ticking the box. 

  

Method III 

 Go to the Right Click menu > Set the Show Min-Max Lines option by 

ticking the box. 

  Note: 

  
Click on the Hide Min-Max Lines icon  to hide the displayed Min-

Max lines. 

 

Figure 1 - Chart Showing Min-Max Lines 

 

 

RELATED INFORMATION 

Setting up Chart Display 
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Enable/Disable Snap to Price 
 

INTRODUCTION  

The Snap to Price feature allows you to 'stick' the Trend Line drawn to 

OHLC values of the chart.  

 

PROCEDURE  

To enable Snap to Price: 

 Click on the Set Snap to Price on icon  on the Main Toolbar.  

  Note: 

  
Click on the Set Snap to Price off icon  to disable trend lines  from 

sticking to OHLC values. 

Snap to Price options: 

 Snap to Price can be set to Auto, Open, High, Low or Close values of the 

chart. The required option can be selected from the drop down list 

available under Set Snap to Price. 

 Functionality of each option in the drop down list is as follows: 

  Auto  - Snaps to any two price points (Open,High,Low or Close) 

closest to the two ends of the trend line 

  Open - Snaps to the two Open price points closest to the ends of 

the trend line 

  High  - Snaps to the two High price points closest to the ends of the 

trend line  

  Low   - Snaps to the two Low price points closest to the ends of the 

trend line 

  Close - Snaps to the two Close price points closest to the ends of 

the trend line 

 

  Tip: 
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  To enable snap to price on a trend line already drawn on a chart (with 

Snap to Price disabled), simply enable Snap to Price and click on the 

trend line. This will snap the trend line to the relevant price values. 

  To switch between OHLC values (e.g. : Open to Close or High to Close 

etc) for a trend line, simply change the value as required from the menu 

and click on the required trend line. 

 

RELATED INFORMATION 

Setting up Chart Display 

 
 
 

Enable/Disable Multi Selection 
 

INTRODUCTION  

The Multiple selection tool is used to select multiple graphical objects 

simultaneously in order to delete the selected objects. 

 

PROCEDURE  

To enable Multi Selection: 

 Go to the Main toolbar > Click on Enable Multi Selection icon . 

 

To use Multi Selection for deleting several objects: 

 With Multi Selection enabled, click and drag the mouse pointer over 

enclosing the required chart area. This will select all graphical objects 

placed within the selected area. Press the Delete key on the keyboard in 

order to delete the selected objects. 

 

To disable Multi Selection: 

 Go to the Main toolbar > Click on  the Disable Multi Selection icon . 

 

RELATED INFORMATION 
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Setting up Chart Display 

Enable/Disable Fibonacci Calculator 
 

INTRODUCTION  

The Fibonacci calculator can be used to calculate a set of predicted 

retracement values based on an existing trend. 

 

PROCEDURE  

To Enable the Fibonacci Calculator: 

1. On the Main toolbar click on the Enable Fibonacci Price 

Retracement Calculator  icon . 

2. Click on three points anywhere on the chart area.The Fibonacci 

Calculator will display the three price points selected, as well as the 

predicted retracement values based on the trend of the selected price 

points. 

Figure 1 - Fibonacci Price Retracement Calculator  
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  Note: 

  The Print button can be used to print the content displayed in the 

Fibonacci Calculator window whereas the Copy button can be used to 

copy the content in the window and paste it in an Excel sheet or word 

document. 

RELATED INFORMATION 

Fibonacci Tools 

Setting up Chart Display 

 
 
 

Enable/Disable Snap Ball 
 

INTRODUCTION  

The Snap Ball option, when enabled displays the Snap Ball along the entire 

chart as you navigate along the chart by moving the mouse pointer. This 

also displays the corresponding Date and price on the right side of the 

chart legend based on the location of the  snap ball. 

 

PROCEDURE  

To enable Snap Ball: 

 On the Main toolbar click on the Enable Snap Ball icon . 

 

To disable Snap Ball: 

 On the Main toolbar click on the Disable Snap Ball icon . 

 

RELATED INFORMATION 

Show/Hide Cross Hair 

Setting up Chart Display 
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View ISP 
 

INTRODUCTION  

The Show/Hide ISP option can be used to Show/Hide indicators, strategies 

and patterns as and when required when they are applied on charts. When 

an indicator/strategy/pattern is applied on a chart it gets added to the 

Show/Hide ISP drop down list. By default the checkbox next to the 

indicator/strategy/pattern name is ticked. 

 

PROCEDURE  

To display an applied Indicator/Strategy/Pattern: 

1. On the Main toolbar click on the Show/Hide ISP icon .This 

displays the list of all indicators, strategies and patterns applied on 

a chart. 

2. Tick the checkbox next to the indicator/strategy/pattern name that 

you need to view. 

  Note: 

  By default the relevant check boxes are ticked for a applied 

indicator/strategy/pattern.  

 

 

To Hide an applied Indicator/Strategy/Pattern: 

1. Click on the Show/Hide ISP icon .This displays the list of all 

indicators, strategies and patterns applied on a chart. 

2. Clear the checkbox next to the indicator/strategy/pattern name that 

you need to Hide.  

  Note: 

  When an applied indicator/strategy/pattern is removed from a chart, it 

also gets removed from the  Show/Hide ISP drop down list.  
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To Hide all applied Indicators/Strategies/Patterns: 

3. Click on the  Show/Hide ISP icon .This displays the list of all 

indicators, strategies and patterns applied on a chart. 

4. tick the Hide All checkbox available under the Show/Hide ISP 

icon.  

 

RELATED INFORMATION  

Add technical indicators 

Apply Strategies 

Using Patterns 

Setting up Chart Display 
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View VWAP Values 
 

INTRODUCTION  

The Show VWAP Values option displays the Volume-Weighted Average 

Price (VWAP) for a given symbol on the chart. Volume-Weighted Average 

Price is the ratio of the value traded to the total volume traded over a 

particular period of time. 

 

This is calculated using the following formula: 

VWAP = Total Value Traded / Total Volume Traded 

  OR 

 

 

 where Σ Signifies summation 

 

PROCEDURE  

To view VWAP Values: 

 Go to the Properties menu > Select the Show VWAP Values option 

by ticking the check box. 
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  Note: 

  Disabling the Show VWAP Values option by clearing check box hides 

the VWAP Values. 

 

 

RELATED INFORMATION 

Setting up Chart Display 

 
 

 
View the chart in Semi-Log Scale 
 

INTRODUCTION  

Semi-Log scale allows you to set the Y axis (Price axis) on a logarithmic 

scale. This enables you to compare symbols with different quantitative 

changes on the same base level and  thereby allows easy analysis of price 

trend. 

 

PROCEDURE  

To view a chart in Semi-Log Scale: 

Method I 

1. Go to the Properties menu > Select the Semi-Log Scale option. This 

displays the Set Semi-Log Scale window. 

In the Set Semi-Log Scale window: 

2. Set the Semi-Log Scale option on, for the required symbol. 

 

Method II 

1. Right click on the chart > Select the Semi-Log Scale option. This 

displays the Set Semi-Log Scale window. 

In the Set Semi-Log Scale window: 

2. Tick the checkbox for the required symbol to view the chart in Semi-

Log Scale. 
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Figure 1 - Semi-log Scale window 

 

 

Figure 2 - Chart in Semi Log Scale 
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  Note: 

  When a chart is in Semi log scale and when a trend line is moved 

vertically, the length of the trend line changes keeping the Net change 

constant. 

  To disable Semi-Log Scale for a required symbol clear the checkbox 

for the symbol in the Set Semi-Log Scale window. 

 

RELATED INFORMATION 

Setting up Chart Display 

 
 
Manage Chart Display 
 

INTRODUCTION  

You can select how you want the charts displayed when you have multiple 

charts open. The four options available are: 

Tile  

Tabbed 

Tile Horizontally 

Tile Vertically 
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TILE   

When this option is selected the charts will be displayed in separate 

windows and multiple charts can be viewed simultaneously. (See Figure 1) 

 

PROCEDURE  

Go to the Windows menu > Select Tile option. 

 

Figure 1 - Tile display 
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TABBED   

When this option is selected each chart you open will be displayed in a 

separate tab and can be viewed by selecting the required tab.  

 

 

PROCEDURE  

Go to the Windows menu > Select Tabbed option. 

 

Figure 2 - Tabbed display 
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TILE HORIZONTALLY   

When this option is selected the charts will be displayed in separate 

windows arranged horizontally and multiple charts can be viewed 

simultaneously.  (See Figure 3) 

 

PROCEDURE  

Go to the Windows menu > Select Tile Horizontally option. 

 

 

Figure 3 - Tile Horizontally display 
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TILE VERTICALLY  

When this option is selected the charts will be displayed in separate 

windows arranged vertically and multiple charts can be viewed 

simultaneously. (See Figure 4) 

 

PROCEDURE  

Go to the Windows menu > Select Tile Vertically option. 

 

Figure 4 - Tile Vertically display 

 

 

  Note: 

  The window type Tile is set by default . 

  You can change the default window type by selecting the required Default 

Window Tile Mode in the Chart Settings tab of the Chart Options 

window. 

RELATED INFORMATION 

Setting up Chart Display 

Chart Settings 
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Exploring Technical Analysis 
 

INTRODUCTION  

Technical Analysis is the forecasting of future financial price movements 

based on analysis of past price movements, and using technical analysis 

investors can anticipate what is likely to happen to prices over time, and 

thereby would know what stocks to invest on and when to do so. 

Technical analysis is applicable to stocks, indices, securities or any 

tradeable instrument where the price is influenced by the forces of supply 

and demand, hence this analysis provide a valuable insight to the relevant  

movements. 

 

TOPICS IN THIS SECTION 

Using Indicators 

Using Strategies 

Using Patterns 

Using Custom Indicator Builder 

Using Insert Analysis Techniques window 
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Using Indicators 
 

INTRODUCTION  

Indicators are a result of mathematical calculation, based on past prices or 

volume of a security. There is a vast number of technical indicators used 

in order to forecast future price levels as well as the price direction of a 

security. You can use the wide range of indicators available with ProChart 

in order to predict the future price levels, and thereby carry out profitable 

trading.  

 

 

TOPICS IN THIS SECTION 

ProChart indicators 

Apply indicators on a chart 

Add indicators on indicators 

Remove Technical indicators 

Set indicator properties 
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ProChart Indicators 
 

INTRODUCTION  

ProChart provides a wide range of Technical Indicators to help you analyze 

price movements and these indicators support online as well as offline 

analysis. In ProChart the available indicators are categorized as follows: 

 Averages  

 Bands 

 Market Indicators 

 Other Indicators 

 

RELATED INFORMATION 

Apply indicators on a chart 

Remove Technical indicators 

Set indicator properties 

Exploring Technical Analysis 

 



© 2002-2010 DirectFN Ltd Page 536 

 
 

Accumulation/Distribution  
 

DESCRIPTION 

A momentum indicator that attempts to gauge supply and demand by 

determining whether investors are generally accumulating (buying) or 

distributing (selling) a certain stock by identifying divergences between 

stock price and volume flow. When the Accumulation/Distribution indicator 

grows, it means accumulation (buying) of a particular share, and the main 

reason for the increase in the volume of  the share is its upward trend in 

price. When the indicator drops, it means distribution (selling) of the share 

and is mainly due to its  downward price movement. 

 

Figure 1 - Chart with Accumulation/Distribution indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Alligator 
 

DESCRIPTION 

Alligator indicator is based on moving averages and is used to identify 

market trends. It helps you to identify the presence and direction of a 

trend in the market or the absence of a trend.  

 

If the price for the symbol is above the alligator lines then it indicates that 

the price is in an uptrend. You can look into the possibility of buying.  

If the price for the symbol is below the alligator lines then it indicates that 

the price is in a downtrend. You should hold buying or look into the 

possibility of selling. 

If moving averages are entwined, then it is best to be out of the market as 

it indicates the absence of a trend.  

The Alligator is a combination of three lines. 

Blue line (Alligator's Jaw) - Plotted by placing the 13-period moving 

average of the mid price 8 points forward 

Red line (Alligator's Teeth) - Plotted by placing the 8-period moving 

average of the mid price 5 points forward 

Green line (Alligator's Lips) - Plotted by placing the 5-period moving 

average of the mid price 3 points forward 

  Note: 

  Mid price = (High + Low)/2 

  These Parameters are fixed and can not be changed. 
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Figure 1 - Chart with Alligator indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators 

 

RELATED INFORMATION 

Averages 

Bands 

Market Indicators 
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Aroon 
 

DESCRIPTION 

Aroon is an indicator used to determine if a stock is trending or not as well 

as to determine how strong the trend is.  

The Aroon indicator consists of two plots which oscillate between 0 and 

100.  

 Aroon(up)  - measures the number of periods since the most recent x-

period high  

 Aroon(down) -  measures the number of periods since the most recent 

x-period low 

 

This Indicator is used in the price technical analysis to indicate the 

moments of possible changes in trend. These changes are anticipated by 

measuring the number of periods that have passed since the most recent 

x-period high and x-period low. 

 

Figure 1 - Chart with Aroon indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 
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Average True Range 
 

DESCRIPTION 

The Average true range (ATR) determines a security's volatility over a 

given period. That is how frequently its share price varies.    

This indicator shows the enthusiasm of traders in the security. If this 

indicator is increasing it suggests a buildup in interest of the security. If 

the indicator is decreasing, it suggests waning interest. 

 

Figure 1 - Chart with Average True Range indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Bollinger Bands 
 

DESCRIPTION 

Bollinger Bands has evolved from the concept of trading bands and is 

plotted in and around the price structure. 

Bollinger Bands consist of: 

 A middle band being a N-period simple moving average 

 An upper band at K times a N-period standard deviation above the 

middle band 

 A lower band at K times a N-period standard deviation below the 

middle band 

Typical values for N and K are 20 and 2, respectively. 

Bollinger Bands allow comparing volatility and relative price levels over a 

period. It can be combined with price action to generate signals and 

foreshadow significant moves. 

Main Functions of Bollinger Bands: 

 To identify periods of high and low volatility 

 To identify periods when prices are at extreme, and possibly 

unsustainable, levels. 

 To arrive at rigorous buy and sell decisions. 
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Figure 1 - Chart with Bollinger Bands indicator 

 

This indicator falls under the Bands category of ProChart indicators. 

RELATED INFORMATION 

Averages 

Other indicators 

 
 

Chaikin A/D Oscillator 
 

DESCRIPTION 

The Chaikin A/D Oscillator is a moving average oscillator based on the 

concept of the Accumulation/Distribution Line. The basic principle of the 

Chaikin Oscillator (and the A/D Line) is that the degree of buying or selling 

can be calculated by the location of a close relative to the high and low for 

the corresponding period. There is buying pressure when a stock closes in 

the upper half of a period's range and there is selling pressure when a 

stock closes in the lower half of the period's trading range. 

The Chaikin Oscillator is created by subtracting a 10-period exponential 

moving average of the Accumulation/Distribution Line from a 3-period 

exponential moving average of the Accumulation/Distribution Line. 
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Figure 1 - Chart with Chaikin A/D Oscillator  

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Chaikin Money Flow 
 

DESCRIPTION 

The interpretation of the Chaikin Money Flow indicator is based on the 

assumption that increased interest in a security is usually accompanied by 

prices closing in the upper half of their daily range with increasing volume. 

Likewise, decreased interest in a security is usually accompanied by prices 

closing in the lower half of their daily range with increasing volume.  

If  the indicator is positive (i.e., above the zero line), it indicates that there 

is buying pressure in the security. Conversely, if the indicator is negative 

(i.e. below the zero line), it indicates that there is selling pressure in the 

security. 

 
Figure 1 - Chart with Chaikin Money Flow indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Chande Momentum Oscillator 
 

DESCRIPTION 

The Chande Momentum Oscillator determines the momentum of price data 

by comparing the size of negative price changes to the size of positive 

price changes. The resultant value is normalized from -100 to 100 where 

negative values indicate larger negative cumulative price changes and 

positive values indicate larger positive cumulative price changes. 

There are two different ways that this oscillator is used as a trading signal. 

The first is to measure overbought (greater than 50%) or oversold (less 

than -50%) levels for a given security. The second method is to buy when 

the oscillator crosses above its moving average line and to sell when the 

oscillator crosses below its moving average line. 

 

Figure 1 - Chart with Chande Momentum Oscillator  

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Commodity Channel Index 
 

DESCRIPTION 

The Commodity Channel Index (CCI) is a momentum  indicator designed 

to identify cyclical turns in commodities. The assumption behind the 

indicator is that commodities (or securities) move in cycles, with highs and 

lows coming at periodic intervals. It  is often used for detecting 

divergences from price trends as an overbought/oversold indicator.    

The CCI typically oscillates above and below a zero line. Normal 

oscillations will occur within the range of +100 and -100. Readings above 

+100 imply an overbought condition, which indicates that the security's 

price might start to decrease soon. While readings below -100 imply an 

oversold condition, which indicates that the security's price might start to 

move up soon. 

 

Figure 1 - Chart with Commodity Channel Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Coppock Curve 
 

DESCRIPTION 

The Coppock indicator is a long term momentum indicator used on indexes 

to identify the commencement of a bull market. It provides a signal when 

a bear market has reached its lowest point and when a bull market begins.  

The signal is formed when there is an upturn in the curve as this indicates 

the end of a bear market and the beginning of a bull market.  

 

Figure 1 - Chart with Coppock Curve Market Indicator 

 

This indicator falls under the Market Indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 

 



© 2002-2010 DirectFN Ltd Page 548 

 
 

DEMA 
 

DESCRIPTION 

The Double Exponential Moving Average or DEMA is a unique smoothing 

indicator that consists of a single exponential moving average and a 

double exponential moving average. Its main advantage is that it provides 

a diminished amount of delays (lag time) than if the two moving averages 

had been used individually. 

When price crosses the moving average and increases, a continuing 

uptrend can be predicted. It is possible to use the Double Exponential 

Moving Average in the same way as the Simple Moving Average or 

Exponential Moving Average. 

 

Figure 1 - Chart with Double Exponential Moving Average indicator 

 

This indicator falls under the Averages category of ProChart indicators. 

 

RELATED INFORMATION 

Bands 

Other indicators 
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Commodity Channel Index (COPY) 
 

DESCRIPTION 

The Commodity Channel Index (CCI) is a momentum  indicator designed 

to identify cyclical turns in commodities. The assumption behind the 

indicator is that commodities (or securities) move in cycles, with highs and 

lows coming at periodic intervals. It  is often used for detecting 

divergences from price trends as an overbought/oversold indicator.    

The CCI typically oscillates above and below a zero line. Normal 

oscillations will occur within the range of +100 and -100. Readings above 

+100 imply an overbought condition, which indicates that the security's 

price might start to decrease soon. While readings below -100 imply an 

oversold condition, which indicates that the security's price might start to 

move up soon. 

 

Figure 1 - Chart with Commodity Channel Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Detrended Price Oscillator 
 

DESCRIPTION 

The Detrended Price Oscillator (DPO) is an indicator that aims to eliminate 

intermediate or long term trends and show variations around that trend so 

that shorter-term information can be studied.  

This indicator smoothes the trend in prices, allowing easy identification of 

cycles and overbought/oversold levels.If you think of long-term cycles as 

made up of a series of short-term cycles, then analyzing these shorter 

term components can be helpful in identifying major turning points. 

The Detrended Price Oscillator calculation is quite simple. You simply 

center an x-period moving average by shifting it back x/2 + 1 periods. 

This centered moving average is then subtracted from the close. The 

result is an oscillator that crosses above and below zero.  

 

Figure 1 - Chart with Detrended Price Oscillator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 
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Directional Movement +DI 
 

DESCRIPTION 

+DI is a key  factor in the calculation of the popular average directional 

index and is used to measure the presence of an uptrend. When the +DI is 

sloping upwards, it is a signal that the uptrend is getting stronger.  

 

Figure 1 - Chart with Directional Movement +DI indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Directional Movement -DI 
 

DESCRIPTION 

-DI is a component of the average directional index (ADX) and is used to 

measure the presence of a downtrend. When the -DI is sloping upwards, it 

is a signal that the strength of the downtrend is increasing. This indicator 

is almost always plotted with the positive directional indicator. 

 

Figure 1 - Chart with Directional Movement -DI indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Directional Movement ADX 
 

DESCRIPTION 

The ADX is a lagging indicator used to assess the strength of a trend. This 

indicator can be used on any trading time frame to determine key turning 

points in the market. In addition to identifying trending markets and 

pivots, the ADX is also used to identify choppy markets. The ADX ranges 

from 0 to 100. ADX values above 40 generally imply trending markets, 

while readings below 20 indicate flat trading. 

 

Figure 1 - Chart with Directional Movement ADX indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Directional Movement ADXR 
 

DESCRIPTION 

The Average Directional Movement Index Rating measures momentum 

change in the ADX. ADXR is calculated by adding the current ADX value 

and ADX value n periods back, then dividing the sum by two. This serves 

to smooth the ADX values. As with the ADX, a rising ADXR reflects a 

strong underlying trend and likely continuation while falling ADXR suggests 

a weakening trend and possible trend reversal. 

 

Figure 1 - Chart with Directional Movement ADXR indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Directional Movement DX 
 

DESCRIPTION 

DX also known as DMI is an indicator developed for identifying whether a 

definable trend is present for a security. That is, the DX tells whether a 

security is trending or not. 

 

Figure 1 - Chart with Directional Movement DX indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Ease of Movement  
 

DESCRIPTION 

The ease of movement indicator calculates the ease at which prices move 

and shows a ratio of price movement over volume. The larger the price 

move and lighter the volume, the easier the movement. 

The raw ease of movement value is usually smoothed with an exponential 

moving average. And this indicator is particularly useful for assessing the 

strength of a trend. 

 

Figure 1 - Chart with Ease of Movement indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Envelopes 
 

DESCRIPTION 

A trading band composed of two moving averages, one of which is shifting 

upwards and the other shifting downwards. 

These trading bands are used by technical analysts to define a stock's 

upper and lower boundaries. Signals to sell occur when the stock price 

reaches the upper band, and buy signals are generated when the price 

reaches the lower band.  

 

The reasoning behind the sell and buy signals is that stock prices tend to 

bounce off the bands. Even though buyers and sellers will temporarily 

force a stock's price to its extremes, it should re-stabilize to more realistic 

levels found within the envelope. 

 

Figure 1 - Chart with Envelops indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 
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Forecast Oscillator 
 

DESCRIPTION 

The forecast oscillator is an extension of the linear regression based 

indicators and shows deviation between today's closing price and an N-day 

linear regression forecast of that close. The deviation is expressed as a 

percentage of the close. 

The N day price for the linear regression starts from yesterday's close, and 

the forecast value is the line extended out to today. When the forecast 

price and the current price are equal, the oscillator makes a zero. The 

oscillator is above zero when the forecast price is greater than the actual 

price. Conversely, it is less than zero if it is below. Current prices that are 

constantly over the forecast price suggest higher prices ahead and prices 

that are constantly under the forecast price suggest lower prices ahead. 

 

Figure 1 - Chart with Forecast Oscillator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 
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Ichimoku Kinko Hyo 
 

DESCRIPTION 

Ichimoku Kinko Hyo which is a Japanese term that means "Chart 

Equilibrium at a glance” is used to determine momentum along with future 

areas of support and resistance. The Ichimoku indicator is comprised of 

five lines called the tenkan-sen, kijun-sen, senkou span A, senkou span B 

and chickou span. This indicator was developed so that a trader can 

interpret a security‟s trend, momentum as well as support and resistance 

points without the need of any other technical indicator.  

When defining the dimension of parameters, four time intervals of 

different lengths are used. The values of individual lines composing this 

indicator are based on these intervals:  

Tenkan-sen shows the average price value during the first time interval 

defined as the sum of maximum and minimum within this time, divided 

by two; 

Kijun-sen shows the average price value during the second time 

interval; 

Senkou Span A shows the middle of the distance between two previous 

lines shifted forwards by the value of the second time interval; 

Senkou Span B shows the average price value during the third time 

interval shifted forwards by the value of the second time interval.  

Chinkou Span shows the closing price of the current candle shifted 

backwards by the value of the second time interval.  
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Figure 1 - Chart with Ichimoku Kinko Hyo indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Intraday Momentum Index 
 

DESCRIPTION 

The Intraday Momentum Indicator is calculated like the Relative Strength 

Index (RSI) but uses the relationship between the intraday opening and 

closing prices of the share to determine whether the day is up or down. 

When the close price of the security is above the open price, it is an up 

day and is signified by white candlesticks. If the close price is below the 

open it is a down day and is signified by black candlesticks. 

As with the RSI, overbought conditions are indicated when the index rises 

above 70, signaling a potential decrease in a security's price ahead. Values 

below 30 indicate a potential oversold situation signaling a potential 

increase in a security's price ahead. Remember, as with all 

overbought/oversold indicators, you should first quantify the trendiness of 

the market before acting on any signals. 

 

Figure 1 - Chart with Intraday Momentum Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 
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Klinger Oscillator 
 

DESCRIPTION 

The Klinger oscillator is based on cumulative volume and was developed to 

be sensitive enough to signal short-term tops and bottoms, yet accurate 

enough to reflect the long-term flow of money into and out of a security. 

Here the volume is added or subtracted according to the direction of 

typical price and weighted by a certain daily range calculation.  

The Klinger oscillator is based on the following factors: 

Price range (i.e. High - Low) is a measure of movement and volume is the 

force behind the movement. The sum of High + Low + Close defines a 

trend. Accumulation occurs when today's sum is greater than the previous 

day's. Conversely, distribution occurs when today's sum is less than the 

previous day's. When the sums are equal, the existing trend is maintained. 

Volume produces continuous intraday changes in price reflecting buying 

and selling pressure. The KO quantifies the difference between the number 

of shares being accumulated and distributed each day as "volume force." A 

strong, rising volume force should accompany an uptrend and then 

gradually contract over time during the latter stages of the uptrend and 

the early stages of the following downtrend. This should be followed by a 

rising volume force reflecting some accumulation before a bottom 

develops. 
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Figure 1 - Chart with Klinger Oscillator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Linear Regression Indicator 
 

DESCRIPTION 

The Linear Regression Indicator is a line based on the trend of a share 

price over a specified time period. The trend is determined by calculating a 

linear regression Trend Line using the least squares fit method.  

The interpretation of a Linear Regression Indicator is similar to a moving 

average. However, the Linear Regression Indicator has two advantages 

over moving averages.  

 Unlike a moving average, a Linear Regression Indicator does not exhibit 

as much delay. Since the indicator is fitting a line to the data points 

rather than averaging them, the Linear Regression line is more 

responsive to price changes.  

 The indicator is actually a forecast of the next periods (tomorrow‟s) price 

plotted today. The Forecast Oscillator plots the percentage difference 

between the forecast price and the actual price. When prices are 

persistently above or below the forecast price, prices can be expected to 

snap back to more realistic levels. In other words the Linear Regression 

indicator shows where prices should be trading on a statistical basis. 

Figure 1 - Chart with Linear Regression indicator 

 

This indicator falls under the Averages category of ProChart indicators. 

RELATED INFORMATION 

Bands 

Other indicators 
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MACD 
 

DESCRIPTION 

MACD which is an acronym for Moving Average Convergence Divergence is 

a trend-following momentum indicator that shows the relationship 

between two moving averages.  The MACD is calculated by subtracting the 

26-day exponential moving average (EMA) from the 12-day EMA. A nine-

day EMA of the MACD, called the signal line, is then plotted on top of the 

MACD, functioning as a trigger for buy and sell signals.  

 When the MACD indicator is chosen, 2 lines appear.  

 MACD Line – is the difference between the 26 day exponential moving 

average (EMA) and the 12-day EMA. 

 Signal Line– is the 9-day EMA of the MACD.   

 When the MACD line falls below the Signal line it suggests possible 

downward momentum in the share price and is an indication to sell the 

share and vice-versa.  

 Also note movement above or below the zero line because this signals 

the position of the short-term average relative to the long-term average. 

When the  MACD Line is above zero it signals an upward momentum. 

The opposite is true when the MACD Line is below zero.   

 

MACD Histogram 

The MACD Histogram is useful for anticipating changes in trend. 

 The MACD Histogram (MACD-H) consists of vertical bars showing the 

difference between the MACD line and its signal line 

 A change in the MACD-H will usually precede any changes in MACD 

 Signals are generated by direction, zero line crossovers and divergence 

from MACD 

 As an indicator of an indicator, MACD-H should be compared with MACD 

rather than with the price action of the underlying market.  
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How to use: 

The MACD Histogram represents the difference between MACD and it's 

signal line (usually the 9-day Exponential Moving Average (EMA) of the 

MACD). Whenever MACD crosses the signal line, MACD-H crosses the zero 

line. 

 If the MACD line is above the signal line, the histogram is positive, and 

the bars are drawn above the zero line.  

 If the MACD line is below the signal line, histogram is negative, and the 

bars are drawn below the zero line.  

Sharp increases in the MACD-H indicate that MACD is rising faster than its 

9-day EMA and upward momentum is strengthening. Sharp declines in the 

MACD-H indicate that MACD is falling faster than its moving average and 

downward momentum is increasing.  

Divergences between MACD and MACD-H are the main tool used to 

anticipate crossovers. A positive divergence in the MACD-H indicates that 

MACD is strengthening and could be on the verge of a bullish moving 

average crossover. A negative divergence in the MACD-H indicates that 

MACD is weakening and can act to foreshadow a bearish moving average 

crossover in MACD. 

 

Signals 

The main signal generated by the MACD-Histogram is a divergence from 

MACD followed by a zero-line crossover.  

 A bullish signal is generated when a positive divergence forms and there 

is an upward zero line crossover.  

 A bearish signal is generated when there is a negative divergence and a 

downward zero line crossover.  

When the histogram is above its zero line (positive) but starts to fall, the 

uptrend is weakening. Conversely, when the histogram is below its zero 

line (negative) and starts to rise, the downtrend is losing momentum. 
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These turns of the histogram provide early warnings that the current trend 

is losing momentum, and the buy or sell signal is given when the 

histogram crosses the zero line. 

 

 

Figure 1 - Chart with MACD indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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MACD Volume Adjusted 
 

DESCRIPTION 

MACD Volume adjusted is very much identical to MACD, and the only 

difference is it uses Volume Adjusted Moving Average instead of the 

Exponential Moving Average. 

 

Figure 1 - Chart with MACD Volume Adjusted indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Market Facilitation Index 
 

DESCRIPTION 

The Market Facilitation Index synthesizes both price and volume data in an 

effort to improve trading accuracy. The Market Facilitation Index simply 

divides the day's range (high to low) by the total volume. The result shows 

the efficiency of price movement by quantifying the price movement per 

unit of volume. 

 

Figure 1 - Chart with Market Facilitation Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Mass Index 
 

DESCRIPTION 

The MASS index is based on daily trading range and was  designed to 

identify reversals in trend by measuring the narrowing and widening of the 

average range between the high and low prices. As the range widens, the 

Mass Index increases. As the range narrows, the Mass Index decreases. 

The Mass Index is calculated by summing an exponentially smoothed 

moving average of the daily ranges (High-Low) over a default 25 periods. 

 

Figure 1 - Chart with Mass index  

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Median Price 
 

DESCRIPTION 

The Median Price function calculates the midpoint between the high and 

low prices for the day, which is sometimes also referred to as the mean or 

average price. 

The median price provides a simplified view of the trading prices for the 

day. It can be used to smooth out some of the volatility of the closing 

price since it includes information for the entire trading day rather than 

specifically for the end of the day. 

The median price can be used anywhere a closing price or other single 

price field would be used. 

 

Figure 1 - Chart with Median Price indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Momentum 
 

DESCRIPTION 

Momentum is a calculation of the difference between the current market 

price of a security and the price of the same security a certain number of 

days ago.Momentum measures the rate of change in closing prices and is 

used to detect trend weakness and likely reversal points and this indicator 

is useful if  comparing past times when prices levels were much higher or 

lower than now.  

 

Figure 1 - Chart with Momentum indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Money Flow Index 
 

DESCRIPTION 

The Money Flow Index ("MFI") is a momentum indicator that measures the 

strength of money flowing in and out of a security. It is a volume-weighted 

variant of the Relative Strength Index and it compares the value traded on 

up-days to value traded on down-days and anticipates trend weakness as 

well as any points of reverse shift. . The MFI is used as a measure of the 

strength of money going in and out of a security and It ranges between 0 

and 100. 

 

The interpretation of the Money Flow Index is as follows: 

If the MFI is above 80 then it is an indication that the security has been 

overbought and that its price might start to decrease. Conversely if MFI is 

below 20 then it is an indication that the security has been oversold and 

that its price might start to increase.   

 

Figure 1 - Chart with Money Flow Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Moving Average 
 

DESCRIPTION 

A stock is deemed to be in an uptrend when the price is above a moving 

average and the average is sloping upward. Conversely, a trader will use a 

price below a downward sloping average to confirm a downtrend. 

Also a strong upward momentum is seen when shorter-term averages are 

located above longer-term averages and the two averages are diverging. 

Conversely, when the shorter-term averages are located below the longer-

term averages, the momentum is in the downward direction. 

Described below are the types of Moving Averages available with ProChart. 

 

 Simple Moving Average 

A simple, or arithmetic, moving average that is calculated by adding 

the closing price of the security for a specified number of time 

periods and then dividing this total by the specified number of time 

periods. Equal importance (weighting) is given to each daily price. 

 

 Exponential Moving Average (EMA) 

A type of moving average that is similar to a simple moving average, 

except that more importance (weight) is given to the more recent 

price fluctuations relative to older share price movements.  

 

 Triangular Moving Average 

A triangular moving average is similar to exponential and weighted 

moving averages except a different weighting scheme is used. 

Exponential and weighted moving averages assign the majority of 

the weight to the most recent data. Simple moving averages assign 

the weight equally across all the data. With a triangular moving 

average, the majority of the weight is assigned to the middle portion 

of the data.  
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 Variable Moving Average 

A type of moving average that gives importance (weight) to the most 

volatile price changes. 

 
 

 Volume Adjusted Moving Average 

A type of moving average that gives importance (weight) to the    

the days with the most volume. 

 

 Time Series Moving Average  

The time series moving average is calculated using linear regression 

techniques. Rather than plotting a straight linear regression line, a 

time series moving average plots the last point of the line. It does 

this using the specified number of periods for each day.  The 

individual points are then connected together with a line to form a 

time series moving average. 

This moving average is sometimes referred  to as a "moving linear 

regression" study or a "regression oscillator." 

 

 Weighted  Moving Average 

An average in which each quantity to be averaged is assigned a 

weight. This weighting determines the relative importance of each 

quantity on the average. Weightings are the equivalent of having 

that many like items with the same value involved in the average. 
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Figure 1 - Chart with Simple Moving Average indicator 

 

This indicator falls under the Averages category of ProChart 

indicators. 

 

RELATED INFORMATION 

Bands 

Other indicators 
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Negative Volume Index 
 

DESCRIPTION 

The Negative Volume Index (NVI) tracks closing price changes that occur 

on days with lower volume than the previous day.The principle behind NVI 

is that when volume decreases from the previous day, the NVI is adjusted 

by the percentage change in the security's price 

The NVI is constructed so it only displays changes on days when volume 

decreases from the previous day. Because falling prices are usually 

associated with falling volume, the NVI will usually trend downwards. 

 

Figure 1 - Chart with Negative Volume Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 
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On Balance Volume 
 

DESCRIPTION 

On-balance volume (OBV) is a running total of daily volume. On Balance 

Volume attempts to measure the level of accumulation or distribution by 

comparing volume to price movements.  

On Balance Volume is calculated by adding the day's volume to a 

cumulative total if the security's closing price moves up, and subtracting 

the day's volume if the security's closing price moves down. No 

adjustment is made if the closing price is unchanged. 

 

Figure 1 - Chart with On Balance Volume indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 



© 2002-2010 DirectFN Ltd Page 579 

 
 

 

Parabolic SAR 
 

DESCRIPTION 

Parabolic SAR (PSAR) sets trailing price stops for long or short positions.  

Parabolic SAR Indicator was developed mainly for analyzing the trending 

markets. The indicator is constructed on the price chart. This indicator is 

similar to the Moving Average Indicator with the only difference that 

Parabolic SAR moves with higher acceleration and may change its position 

in terms of the price. The indicator is below the prices on the bull market 

(Up Trend), and when the market is bearish (Down Trend), it is above the 

prices. 

This indicator provides clear levels where securities are set to have a 

change in trend and this indicator can be used as a trailing stop for open 

positions. 

 

Figure 1 - Chart with Parabolic SAR indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 
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Performance 
 

DESCRIPTION 

This indicator displays a security's price performance as a percentage. This 

is sometimes called a "normalized" chart.The numeric value of the 

Performance indicator is the percentage that the security has changed 

since the first period loaded. 

 

Figure 1 - Chart with Performance indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Positive Volume Index 
 

DESCRIPTION 

The Positive Volume Index is the companion of Negative Volume Index. 

The two are used to identify bull and bear markets. 

The Positive Volume Index (PVI) tracks closing price changes that occur on 

days with higher volume than the previous day. The principle behind PVI is 

that when volume increases from the previous day, the PVI is adjusted by 

the percentage change in the security's price 

The PVI is constructed so it only displays changes on days when volume 

increases from the previous day. Because rising prices are sually 

associated with rising volume, the PVI will generally trend upward. 

 

Figure 1 - Chart with Positive Volume Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Price Channels 
 

DESCRIPTION 

Price Channels are similar in concept to other types of bands and are 

plotted by finding the highest high over the specified number of periods 

and plotting the result above the current price to form the top channel. 

The bottom channel is formed by plotting the lowest low over the specified 

number of periods. The resulting plot consists of two lines representing the 

recent highest and lowest prices. The two lines of a price channel 

represent support and resistance and they are constantly adjusted to 

reflect recent new highs and new lows. Price Channels show trend 

direction for any time frame and can be up, down or sideways.   

 

Figure 1 - Chart with Price Channels indicator 

 

This indicator falls under the Bands category of ProChart indicators. 

 

RELATED INFORMATION 

Averages 

Other indicators 
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Price Oscillator 
 

DESCRIPTION 

The Price Oscillator displays the difference between two moving averages 

of a security's price.  The Price Oscillator is almost identical to the Moving 

Average Convergence – Divergence (MACD), except that the Price 

Oscillator can use any two user-specified moving averages and can 

express the difference between the two moving averages either in points 

or percentages. (The MACD always uses 12 and 26-day moving averages, 

and always expresses the difference in points). When the Price Oscillator is 

above zero it indicates an upward trend in a security's price and vice-

versa. 

 

Figure 1 - Chart with Price Oscillator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Price ROC 
 

DESCRIPTION 

The Price Rate-of-Change (ROC) is a momentum indicator that displays 

the difference between the current price and the price x-time periods ago. 

The difference can be displayed in either points or as a percentage. The 

ROC displays the wave-like motion in an oscillator format by measuring 

the amount by which prices have changed over a given time period.  As 

prices increase, the ROC rises and as prices fall, the ROC falls. The greater 

the change in prices, the greater the change in ROC.  

A value greater than zero indicates an increase in upward momentum and 

an increase in buying pressure. Conversely a value less than zero indicates 

a downward momentum and an increase in selling pressure. However, 

some of the most valuable signals are generated when the security's price 

and the ROC are heading in opposite directions (known as divergence). For 

example, if the security's price is increasing and the ROC is sloping 

downward, it is generally an early indication that a sharp decline may be 

on the way. 

 

Figure 1 - Chart with Price Rate of Change indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 
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Price Volume Trend 
 

DESCRIPTION 

Price and Volume Trend (PVT) is a running total of daily volume, with each 

day's volume added or subtracted according to the percentage change of 

the day's closing price over the previous day‟s closing price.  

PVT is similar to On-balance volume but accumulates only a portion of the 

volume.  

PVT adds only a portion of the daily volume. The amount of volume added 

to the PVT is a function of the amount by which prices rose or fell relative 

to the previous day's close. 

The PVT is calculated by multiplying the day's volume by the percentage 

change of the underlying security and adding this value to a cumulative 

total. 

 

Figure 1 - Chart with Price Volume Trend indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Qstick 
 

DESCRIPTION 

This is an indicator used to determine the strength or weakness of a share 

over a given period of time. The Qstick indicator first takes the difference 

between the opening and closing prices of a security and creates a moving 

average out of it.  

 
The interpretation of Q-stick is as follows: 
 

1. A Q-stick value above zero is a bullish signal indicating a possible 

increase in a security's price. Conversely a Q-stick value below zero is 

a bearish signal indicating a possible decrease in a security's price. 

2. Crossovers - When the indicator crosses above the zero line from 

below it, it is a buy signal. The reverse holds true when the indicator 

crosses below the zero line from above it. 

3. Extreme Levels - When the Qstick indicator is at an extremely low 

level and turning up, it is a buy signal. When the Qstick indicator is at 

an extremely high level and turning down, it is a sell signal. 

4. Divergences - When the Qstick indicator is moving up and the 

security's price is coming down, it is a buy signal. Similarly when the 

Qstick indicator is moving down and the security's price is going up, it 

is a sell signal.  You may want to consider waiting for the price to 

confirm the new direction before placing the trade. 
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Figure 1 - Chart with Qstick indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Relative Momentum Index 
 

DESCRIPTION 

This indicator is used to gauge overbought/oversold levels. When this 

indicator goes above the 70 level it is an indication that the stock is 

overbought and when this indicator goes below the 30 level it‟s an 

indication that the stock is oversold. However when the markets are in a 

strong trend, the RMI will stay at overbought or oversold levels for a long 

period.  

The RMI is similar to the RSI but it does not count up and down days from 

close to close as in RSI, insted it counts up and down days from the close 

relative to a close n-days ago (where n is not limited to 1 as required by 

the RSI). 

 

Figure 1 - Chart with Relative Momentum Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Relative Strength Index 
 

DESCRIPTION 

Relative Strength Index (RSI) is a popular oscillator, which compares the 

magnitude of a security‟s recent gains to the magnitude of its recent 

losses and turns that information into a number that ranges from 0 to 

100. It takes a single parameter, the number of time periods to use in the 

calculation. The Relative Strength Index compares upward movements in 

closing price to downward movements over a selected period. The 

recommended time period is the 14 period, but 7 and 9 periods are 

commonly used to trade the short cycle and 21 or 25 periods for the 

intermediate cycle. RSI is formulated to fluctuate between 0 and 100. A 

security is deemed to be overbought once the RSI approaches the 70 

level, meaning that the chances are high that it will fall soon whereas, if 

the RSI approaches 30, it is deemed oversold and the chances are high 

that the price will rise soon. 

 

Figure 1 - Chart with Relative Strength Index  

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Relative Volatility Index 
 

DESCRIPTION 

The Relative Volatility Index (RVI) is used to measure the direction of 

volatility of share prices.  The calculation is identical to the Relative 

Strength Index (RSI) except that the RVI measures the standard deviation 

of daily price changes rather than absolute price changes. 

The relative volatility index was designed not as a standalone indicator, 

but as a confirmation for trading signals. That is it can be used to confirm 

buy/sell signals given by other basic indicators. The RVI is most widely 

used in conjunction with moving average crossover signal.  

The basic rules to be followed when using this indicator are: 

 Buy if RVI > 50 

 Sell if RVI < 50 

 If you miss the first RVI buy signal buy when RVI > 60 

 If you miss the first RVI Sell signal sell when RVI < 40 

 Close a long position when the RVI falls below 40 

 Close a short position when the RVI rises above 60 
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Figure 1 - Chart with Relative Volatility Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Standard Deviation 
 

DESCRIPTION 

Standard deviation is an indicator that provides a good indication of 

volatility. This is a measure of the dispersion of a security's closing price 

from its mean closing price over a selected period. The more variations in 

the security's price, the higher the deviation.   

Standard Deviation is typically used as a component of other indicators, 

rather than as a stand-alone indicator. For example, Bollinger  are 

calculated by adding a security's Standard Deviation to a moving average. 

High Standard Deviation values signify high volatility, which means the 

price of the security being analyzed is deviating from its moving average 

significantly. Similarly, low Standard Deviation values signify low volatility; 

that is the security being analyzed  is remaining closer to its moving 

average.  

Many analysts agree that major tops are normally accompanied with high 

volatility and major bottoms are generally accompanied with low volatility. 

 

Figure 1 - Chart with Standard Deviation indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 
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Standard Error 
 

DESCRIPTION 

The Standard Error indicator is based on how closely the price of a security 

falls from the Linear Regression Trendline. The closer the prices are to the 

Linear Regression Trendline, the stronger the trend. The more variance 

from the regression line the larger the standard error and less reliable the 

trend. 

High Standard Error values indicate that the price is quite volatile. Any 

changes in the prevailing trend are usually preceded by a rapidly 

increasing standard error. However, be aware that changes in trend does 

not necessarily mean that an upward trend will reverse to a downward 

trend. Sideways movement is also considered a change. 

 

Figure 1 - Chart with Standard Error indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Stochastic Momentum Index 
 

DESCRIPTION 

The Stochastic Momentum Index is a smoother version of the Stochastic 

Oscillator. It is constructed by comparing the price to the average of the 

high-low price range over a given period.  

How to interpret price trends using the Stochastic momentum 

index: 

Extremes - When the Stochastic Momentum Index line rises to an 

extreme high level (e.g. 40), it is an indication that share prices are likely 

to fall in the future. Likewise, if the Stochastic Momentum Index line falls 

below an extreme low level (e.g. -40), it is an indication that share prices 

are likely to rise in the future. 

Divergences - When a decreasing Stochastic Momentum Index 

accompanies increasing prices, its an indication the share prices might fall 

in the future. Likewise, if an increasing Stochastic Momentum Index 

accompanies decreasing prices, its an indication the share prices might fall 

in the future.  

 

Figure 1 - Chart with Stochastic Momentum Index 
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This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 

 

Stochastic Oscillator 
 

DESCRIPTION 

The Stochastic Oscillator is a momentum indicator that compares the 

closing price of a security to its price range over a given time period. 

Closing levels that are consistently near the top of the range indicate 

accumulation (buying pressure) and those near the bottom of the range 

indicate distribution (selling pressure).  

The indicator consists of two lines: 

• Stochastic Oscillator Line -%K compares the latest closing price to the 

recent trading range. 

• Signal Line - % D is a signal line calculated by smoothing %K. 

The number of periods used in the indicator can be changed based on the 

purpose for which the Stochastic is used.  

When the Stochastic Oscillator Line is below 20, the security is considered 

oversold and when it is above 80 it is considered overbought. A share can 

continue to rise after the Stochastic Oscillator line has reached 80 and can 

continue to fall after the Stochastic Oscillator line has reached 20. Some of 

the best signals occur when the Stochastic Oscillator line moves from 

overbought territory back to below 80 and from oversold territory back to 

above 20.  

Buy and sell signals can also be given when the Stochastic Oscillator line 

crosses above or below the Signal Line (%D) line. However, crossover 

signals are quite frequent and can result in a lot of whipsaws.  
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One of the most reliable signals is to wait for a divergence to develop from 

overbought or oversold levels. Once the oscillator reaches overbought 

levels, wait for a negative divergence to develop and then a cross below 

80. This usually requires a double dip below 80 and the second dip results 

in the sell signal. For a buy signal, wait for a positive divergence to 

develop after the indicator moves below 20. This will usually require a 

trader to disregard the first break above 20. After the positive divergence 

forms, the second break above 20 confirms the divergence and a buy 

signal is given.  

 

Figure 1 - Chart with Stochastic Oscillator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 

 



© 2002-2010 DirectFN Ltd Page 597 

 
 

 

 

Swing Index 
 

DESCRIPTION 

The Swing Index compares the relationships between the current prices 

(open, high, low, and close) and the previous period's prices to isolate the 

"real" price of a security. The Swing Index is primarily used as a 

component of the Accumulation Swing Index as by itself it generates an 

erratic plot. 

 

Figure 1 - Chart with Swing Index 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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TEMA 
 

DESCRIPTION 

"Moving averages have a detrimental lag time that increases as the 

moving average length increases. The solution is a modified version of 

exponential smoothing with less lag time." 

TEMA is an acronym that stands for Triple Exponential Moving Average. 

However, the name of this smoothing technique is a bit misleading in that 

it is not simply a moving average of a moving average of a moving 

average. It is a unique composite of a single exponential moving average, 

a double exponential moving average, and a triple exponential moving 

average that provides less lag than either of the three components 

individually. 

TEMA can hence be used in place of traditional moving averages. You can 

use it to smooth price data or other Indicators with better predictive 

capability. 

 

Figure 1 - Chart with Triple Exponential Moving Average indicator 

 

This indicator falls under the Averages category of ProChart indicators. 

 

RELATED INFORMATION 

Bands 

Other indicators 
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Time Series Forecast 
 

DESCRIPTION 

"Moving averages have a detrimental lag time that increases as the 

moving average length increases. The solution is a modified version of 

exponential smoothing with less lag time." 

TEMA is an acronym that stands for Triple Exponential Moving Average. 

However, the name of this smoothing technique is a bit misleading in that 

it is not simply a moving average of a moving average of a moving 

average. It is a unique composite of a single exponential moving average, 

a double exponential moving average, and a triple exponential moving 

average that provides less lag than either of the three components 

individually. 

 

Figure 1 - Chart with Time Series Forecast indicator 

 

This indicator falls under the Averages category of ProChart indicators. 

 

RELATED INFORMATION 

Bands 

Other indicators 
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TRIX 
 

DESCRIPTION 

TRIX is a momentum indicator that displays the percent rate-of-change of 

a triple exponentially smoothed moving average of a share‟s closing price. 

Oscillating around a zero line, TRIX is designed to filter out price 

movements that are insignificant to the larger trend of the share. The user 

selects a number of periods (such as 15) with which to create the moving 

average, and those cycles that are shorter than that period are filtered 

out. 

The TRIX is a leading indicator and can be used to anticipate turning 

points in a trend through its divergence with the share price. Likewise, it is 

common to plot a moving average with a smaller period (such as 9) and 

use it as a signal line to anticipate where the TRIX is heading. TRIX line 

crossovers with its signal line can be used as buy/sell signals as well.  

Since TRIX measures the rate-of-change of closing prices, a positive TRIX 

value is interpreted as a steady rise in the closing price of a security. A 

positive TRIX is thus akin to a positive trending price, allowing the 

indicator to act as a buy signal whenever it crosses up above the zero line. 

Similarly, crossing below the zero line suggests the price is tending to 

close down at the end of each period, which can be a sell signal.  

The signal line mentioned earlier is also a useful buy/sell indicator. Since 

the signal line period is shorter, a cross above it suggests that recent 

stock prices are closing much higher. A buy signal is triggered when TRIX 

crosses above its signal line, and a sell signal is triggered when TRIX 

crosses below its signal line. This method can generate false signals during 

sideways price movements, so it works best when prices are trending. It is 

therefore wise to use TRIX in tandem with other indicators for 

confirmation.  
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Figure 1 - Chart with TRIX indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Typical Price 
 

DESCRIPTION 

The Typical Price indicator calculates the average of the high, low, and 

closing prices for the day via a simple, single-line plot. In comparison with 

other price adjustment indicators, the typical price provides a simplified 

view of the trading prices for the day. It can be used to smooth out some 

of the volatility of the closing price since it includes information for the 

entire trading day rather than specifically the end of day. 

The Typical Price can be used anywhere a closing price or other single 

price field would be used. For example, it could be compared to a moving 

average of its value to determine when a security is trending upward or 

downward. The Typical Price is a building block of the Money Flow Index. 

The Typical Price indicator is calculated by adding the high, low, and 

closing prices together, and then dividing by three.  

 

Figure 1 - Chart with Typical Price indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Vertical Horizontal Filter 
 

DESCRIPTION 

The Vertical Horizon Filter illustrates whether a security‟s prices are in a 

trending phase or a congestion phase. Thereby it helps to display whether 

the security is following a trend or a trading range. 

The vertical horizontal filter (VHF) expresses the range of closing prices as 

a fraction of total close-to-close movement over a given N-day period.  

The longstanding problem for many trading systems is their inability to 

determine if a trending or trading range market is at hand. The Vertical 

Horizon Filter indicator attempts to remedy this by measuring the 

"trendiness" of a market. 

 

Figure 1 - Chart with Vertical Horizontal Filter indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Volatility (Chaikin's) 
 

DESCRIPTION 

The Chaikin Volatility Indicator is the difference between two moving 

averages of a volume weighted accumulation-distribution line. By 

comparing the spread between a security's high and low prices, it 

quantifies volatility as a widening of the range between the high and the 

low price. 

One interpretation of these calculations assumes that market tops are 

frequently accompanied by increased volatility and the latter stages of a 

market bottom are generally accompanied by decreased volatility. An 

increase in the Volatility Indicator over a relatively short time period 

indicates that a bottom is near and a decrease in volatility over a longer 

time period indicates an approaching top. 

To calculate Chaikin Volatility first, calculate an exponential moving 

average (normally 10 days) of the difference between High and Low for 

each period and then, calculate the percentage change in the moving 

average over a further period (normally 10 days) 

 

Figure 1 - Chart with Volatility(Chaikin's) indicator 
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This indicator falls under the Other indicators category of ProChart 

indicators. 

RELATED INFORMATION 

Averages 

Bands 

 

Volume Oscillator 
 

DESCRIPTION 

The Volume Oscillator identifies whether the volume trend is increasing or 

decreasing by using the difference between a longer and a shorter moving 

average of volume.  

When the Volume Oscillator rises above zero the shorter-term volume 

moving average has risen above the longer-term volume moving average. 

This means that the short-term volume trend is higher than the longer-

term volume trend. If prices are rising along with increased volume 

(Volume oscillator > 0 ), it is a bullish signal. If prices are falling along 

with increased volume (Volume Oscillator >0), it is a bearish signal.  

When the Volume Oscillator falls below zero the shorter-term volume 

moving average has fallen below the longer-term volume moving average. 

This means that the short-term volume trend is lower than the longer-

term volume trend. If prices are rising along with decreased volume 

(Volume oscillator < 0 ), it is a bearish signal. If prices are falling along 

with decreased volume (Volume Oscillator < 0), it is a bullish signal.  
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Figure 1 - Chart with Volume Oscillator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 

 



© 2002-2010 DirectFN Ltd Page 607 

 
 

Volume ROC 
 

DESCRIPTION 

Volume ROC (Rate of Change) is mathmatically identical to Price ROC and 

the only difference is that it displays the ROC of the security's volume 

rather than that of its closing price. 

The Volume ROC shows the speed at which volume is changing. This can 

be quite informative as almost every significant chart formation (tops, 

bottoms, breakouts, etc.) is accompanied by a sharp increase in volume. 

The Volume ROC indicator is calculated by dividing the amount that 

volume has changed over the last n periods by the volume n periods ago. 

The result is the percentage that the volume has changed in the last n 

periods. When the volume is higher today than it was n periods ago, a 

positive number will result. If the volume is lower today than it was n 

periods ago, the ROC will be negative.  

 

Figure 1 - Chart with Volume Rate of Change indicator 
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This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 

 
 
Weighted Close 
 

DESCRIPTION 

The Weighted Close indicator calculates an average of each day's price. Its 

name comes from the fact that twice as much weight is given to the 

closing price as is given to the sum of the daily high and daily low.  

In comparison with other price adjustment functions, the Weighted Close 

provides a simplified view of the day. It can be used to smooth out some 

of the volatility of a chart of closing prices as it includes information for 

the entire trading day.  

The Weighted Close indicator provides a single line chart of the average 

price. 
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Figure 1 - Chart with Weighted Close indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Wilders Smoothing 
 

DESCRIPTION 

Wilder's Smoothing is similar to an exponential moving average, which 

means that it retains a decreasingly smaller percentage of all historical 

data in the series in order to smooth out price movements and thereby 

reveal  underlying trends.  

 

Figure 1 - Chart with Wilders Smoothing indicator 

 

This indicator falls under the Averages category of ProChart indicators. 

 

RELATED INFORMATION 

Other indicators 

Bands 
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Williams % R 
 

DESCRIPTION 

This indicator is similar to Stochastic Oscillator with the difference that 

Williams %R has an upside down scale while Stochastic Oscillator has 

internal smoothing. 

It is usually used to find overbought and oversold levels in non-trending 

markets. The value of William %R is static 0 to -100. Readings below -20 

are considered overbought and readings above - 80 are considered 

oversold. The usual time period is 14-days for this indicator. Note that 

when conducting your analysis you shouldn‟t pay attention to the minus in 

the %R value. 

Readings in the range of 80 to 100% (remember to ignore the minus 

symbol) indicate that the market is oversold, while readings in the 0 to 

20% range suggest that the market is overbought. 

As with all overbought/oversold indicators, it is best to wait for the 

security's price to change direction before placing your trades. For 

example, if an overbought/oversold indicator (such as the Stochastic 

Oscillator or Williams' %R) is showing an overbought condition, it is wise 

to wait for the share price to turn down before selling the share. (The 

MACD is a good indicator to monitor the change in Share price.) It is not 

unusual for overbought/oversold indicators to remain in an 

overbought/oversold condition for a long time period as the share price 

continues to climb/fall. Selling simply because the share appears 

overbought may take you out of the share long before its price shows 

signs of deterioration. An interesting phenomenon of the %R indicator is 

its uncanny ability to anticipate a reversal in the underlying share price. 

The indicator almost always forms a peak and turns down a few days 

before the share price peaks and turns down. Likewise, %R usually creates 

a trough and turns up a few days before the share price turns up. 
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Figure 1 - Chart with Williams %R indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Williams Accumulation/Distribution 
 

DESCRIPTION 

Williams' Accumulation/ Distribution indicator aims to reflect whether the 

market is controlled by buyers (accumulation) or by sellers (distribution). 

Williams Accumulation Distribution is traded on divergences. 

 Prices making a new low along with the A/D indicator failing to reach a 

new low suggests that accumulation is taking place and creates a buy 

signal.  

 Prices making a new high and the indicator failing to make new highs 

suggests distribution is taking place and creates a sell signal. 

To calculate Williams' Accumulation/Distribution indicator, first determine 

the True Range High ("TRH") and True Range Low ("TRL"). Today's 

accumulation/distribution is then determined by comparing today's closing 

price to yesterday's closing price.  

The Williams' Accumulation/Distribution indicator is a cummulative total of 

these daily values.  

 

Figure 1 - Chart with Williams Accumulation/Distribution indicator 
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This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 

 

Zig Zag 
 

DESCRIPTION 

The zig zag is a very basic indicator which attempts to reduce the amount 

of "noise" in a trending security. The aim of the zig zag indicator is to 

assist traders with staying in a winning position and avoid the urge to 

close positions on minor reactions. Users can set the percentage move 

that will generate a change in the zig zag signal. The default value for the 

zig zag is 5%. This means that any counter move less than 5% will not 

generate a signal on the chart. Hence a trader will be able to ignore the 

countless minor moves that have no affect on the primary trend. 

Zig Zag indicator is calculated by placing imaginary points on the chart 

when prices reverse by at least the specified amount. Straight lines are 

then drawn to connect these imaginary points.  
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Figure 1 - Chart with Zig Zag indicator 

 

This indicator falls under the Other indicators category of ProChart 

indicators. 

 

RELATED INFORMATION 

Averages 

Bands 
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Apply Technical Indicators 
 

INTRODUCTION  

An indicator can be applied on a chart in order to help determine the 

future price movements of symbols so that you can make profitable 

trading decisions. 

 

PROCEDURE  

To apply a Technical Indicator on a chart: 

Method I 

1. Go to the Indicators menu on the Menu Bar.   

2. Click on the required sub menu.  

3. Select the required indicator from the available list. This displays the 

relevant property dialog box.  

In the Property dialog box: 

4. Set the parameters and General properties as required. 

5. Click on ok. The indicator will be  added on the main chart window or on a 

separate split window below the chart, depending on the selected indicator. 

 

Method II 

1.  Right Click on a chart.  

2.  In the Right click menu > select the Indicators option. 

3. Select the required Indicator category from the available categories. 

This displays the relevant indicators under the selected category. 

4. Click on the required indicator. This displays the relevant property 

dialog box for the selected indicator.  

In the Property dialog box: 

5. Set the parameters and General properties as required. 
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6. Click on ok. The indicator will be  added on the main chart window or on a 

separate split window below the chart, depending on the selected indicator. 

 

Method III 

 Use the Insert Analysis Technique window. (See Insert Analysis 

Techniques for details on how to use it) 

 

  Note: 

  Moving Average, Bollinger Bands and the Linear Regression Indicators 

are closely related with the shape of the base graph. Indicator points 

fall in the similar value range as the base chart. Therefore these three 

indicators are drawn on the main chart window whereas the others 

which are normally outside the chart bounds, are drawn on a separate 

split window.  

 

 
RELATED INFORMATION 

Remove Technical indicators 

ProChart Indicators 

Show/ Hide ISP 

Exploring Technical Analysis 
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Apply Indicators on Indicators 
 

INTRODUCTION  

ProChart allows you to apply an indicator on an existing indicator.  

The indicators which can be applied on existing indicators are:  

 Bollinger Bands 

 Chande Momentum Oscillator 

 DEMA 

 Envelopes 

 Linear Regression Indicator 

 Moving Average 

 Relative Momentum Index 

 Relative Strength Index 

 Standard Deviation 

 TEMA 

 Time Series Forecast 

 TRIX 

 Vertical Horizontal Filter 

 Wilder Smoothing 

 Zig Zag 

 

PROCEDURE  

To apply an indicator over an existing indicator: 

Method I 

1. Go to the Tools menu > Select Insert Analysis Techniques. This 

displays the Insert Analysis Techniques window. 
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Method II 

1. Double click on the required chart/indicator window. This displays the 

Insert Analysis Techniques window. 

In the Insert Analysis Techniques window: 

2. Double click on the required indicator. This displays the relevant Set 

Properties window. 

 

  Note: 

  Indicators which can be applied on existing indicators show the 

Sources and Destination tabs on their respective Set Properties 

window. 

 

In the Set Properties window: 

 

3. Click on the Sources tab > Select the Source indicator on which you 

need to apply the selected indicator. 

4. Click on the Destination tab > Select the Destination window where 

you need to open the selected indicator.  

 

  Note: 

  Tick the On new window checkbox if you need to open the selected  

indicator in a new window. 

. 

5. Click on Ok. 
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Figure 1 - Set properties window - Sources tab 

 

 

 

Figure 2 - Set properties window - Destination tab 

 

 

RELATED INFORMATION 

Add technical indicators 

Remove Technical indicators 

Set indicator properties 

ProChart Indicators 

Show/ Hide ISP 

Exploring Technical Analysis 
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Remove applied Technical Indicators 
 

INTRODUCTION  

You can remove an applied Indicator from a chart as and when required.  

 

PROCEDURE  

To remove an applied Indicator: 

If the indicator is drawn on the chart window:  

1. Select the required Indicator on the chart by clicking on any point on 

the indicator. 

2. Press the Delete key on the keyboard.  

 

If the indicator is drawn on a seperate window:  

1. Close the window of the indicator you need to remove. 

  Note: 

  Removing the center band of Bollinger bands remove the remaining two 

bands as well, but a side band can be removed without affecting the 

others.  

  Removing an indicator removes all the objects and indicators related to 

it. 

 

RELATED INFORMATION 

Apply indicators on charts 

Set indicator properties 

ProChart Indicators 

Show/ Hide ISP 

Exploring Technical Analysis 
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Set Indicator Properties 
 

INTRODUCTION  

You can edit required indicator properties at any given time.  

 

PROCEDURE  

To edit indicator properties:  

1. Double click on the Indicator. This displays the Set property dialog box 

for the selected indicator.  

2. The indicator property edit dialog boxes of indicators consist of General 

properties and Parameters.  

 General properties 

Price field, Line colors, Sizes and Styles. Chart style for indicators 

is restricted to 'Line'. General properties are common for all the 

indicators.   

 

 Parameters 

This consists of different value input components depending on 

the indicator. Usually the time period to use in average 

calculations can be input in this tab. For Moving average and 

Bollinger bands the averaging method can be selected based on 

your preference. Also for Bollinger bands and Standard deviation 

you can set the Number of deviations using the 'Deviations' spin 

edit box.   

 

  Tip: 

  You can make sure the cursor is on the indicator if only the tool tip 

for that indicator pops up.  

 

 
RELATED INFORMATION 

Apply indicators on charts 

Remove Technical indicators 

ProChart Indicators 
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Show/ Hide ISP 

Exploring Technical Analysis 

 

 
Using Strategies  
 

INTRODUCTION  

Strategies are a result of a set of logical expressions that forecasts the 

future price direction of securities and which thereby assist in making 

profitable investment decisions based on the market conditions. 

 

PROCEDURE  

To apply a strategy on a chart: 

1. Create / Open the required chart. 

2. On the Menu Bar go to the Strategies Menu  > Select the required 

Strategy. This displays the relevant Set Properties dialog box. 

In the Set Properties dialog box: 

3. Set the properties for the selected strategy based on your requirement. 

4. Click on Ok. This applies the selected strategy for the relevant chart. 

 

RELATED INFORMATION 

Show/Hide ISP 

ProChart Strategies 

Using Indicators 

Using Patterns 

Using Custom Indicator Builder 

Using Insert Analysis Techniques window 

Exploring Technical Analysis 
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ProChart Strategies  
 

INTRODUCTION  

ProChart provides you with various strategies that interpret possible 

buy/sell signals for a symbol based a set of logical expressions that 

forecast the future price direction. You can apply any of these strategies 

as and when required on any chart in order to decide if you should buy, 

sell or hold a symbol. 

 

The strategies available with ProChart are: 

 Moving Average - 2 Line (5,10) 

 MACD (12-26,9) 

 Parabolic SAR (0.02,.0.2) 

 Bollinger Bands (20, Simple, 2) 

 Momentum (12) 

 Money Flow Index (5) 

 Relative Strength Index (14) 

 Slow Stochastics (5,3) 

 Fast Stochastics (5,1) 

 Chaikin A/D Oscillator 

 Chaikin Money Flow (21) 

 Chande Momentum Oscillator (Close,20) 

 Commodity Channel Index (5) 

 DEMA (Close,5) 

 TEMA (Close,21) 

 Williams %R (5) 

 Trix (5) 

 Volume Oscillator (2,5,Exponential) 

 Price Oscillator (Close,1,25,Simple) 
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 Price Rate of Change (Close,7,Price) 

 QStick (5) 

 Intraday Momentum Index (14) 

 Relative Momentum Index (8,4) 

 Relative Volatility Index (5) 

 Stochastic Momentum Index (5,3,3) 

 

RELATED INFORMATION 

Using Strategies 

Using Patterns 

Using Indicators 

 
 
 

Moving Average - 2 Line (5,10)  
 

DESCRIPTION 

This trading strategy is based on two simple moving averages, namely 5 

day simple moving average and 20 day simple moving average. When this 

strategy is applied on a chart possible Buy Sell signals for a stock are 

interpreted based on the crossovers of the plotted 5 day simple moving 

average and 20 day simple moving average. 
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Figure 1 - Chart with Moving Average 2 Line (5,10) 

 

 

This strategy is built based on the Moving Average indicator logic. 

 

 

RELATED INFORMATION 

ProChart Strategies 
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MACD (12-26,9)  
 

DESCRIPTION 

This is a trading strategy which is based on 3 exponential moving 

averages, namely 26 day exponential moving average, 12 day exponential 

moving average and 9 day exponential moving average. Here the 9 day 

exponential moving average is called the signal line and the 26 day 

exponential moving average subtracted by the 12 day moving average is 

called the MACD line. 

When this strategy is applied on a chart, the Signal line is plotted on top of 

the MACD line and probable buy/sell signals are determined based on 

those two plotted lines. 

 

Figure 1 - Chart with MACD (12-26,9) 

 

This strategy is built based on the MACD indicator logic. 

 

RELATED INFORMATION 

ProChart Strategies 

 



© 2002-2010 DirectFN Ltd Page 628 

 
 

Parabolic SAR (0.02,0.2) 
 

DESCRIPTION 

A trading strategy that uses the trailing stop and reverse method called 

SAR (Stop and Reverse). In this strategy two parameters are set as given 

below in order to control the shape, slope and speed of SAR. 

 Increment that the Acceleration Factor (AF) can change when a new 

price high or low is made -> set to 0.2 

 Maximum Acceleration Factor (AF) -> set to 0.02 

When this strategy is applied on a chart, the SAR is plotted based on the 

parameter values specified above and the Buy Sell signals for a stock are 

determined by the movement of price with respect to the plotted SAR. 

 

Figure 1 - Chart with Parabolic SAR(0.02,0.2) 

 

This strategy is built based on the Parabolic SAR indicator logic. 

 

RELATED INFORMATION 

ProChart Strategies 
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Bollinger Bands (20, Simple, 2)  
 

DESCRIPTION 

This is a strategy where a 20 day simple moving average is plotted as the 

Middle band and where the upper band and lower band are plotted as 2 

times standard deviation upwards and 2 times standard deviation 

downwards respectively from the middle band. Here the buy sell signals 

for a stock are interpreted based on these plotted bands.  

 

Figure 1 - Chart with Bollinger Bands (20, Simple, 2) 

 

This strategy is built based on the Bollinger Bands indicator logic. 

 

RELATED INFORMATION 

ProChart Strategies 
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Momentum (12)  
 

DESCRIPTION 

A trading strategy that interprets buy/sell signals for a stock based on the 

movement of the stock‟s momentum in price above or below the plotted 

level 100. Here the momentum in price of a stock is calculated by 

comparing the day‟s closing price with the closing price 12 days before. 

 

Figure 1 - Chart with Momentum (12) 

 

This strategy is built based on the Momentum indicator logic. 

 

RELATED INFORMATION 

ProChart Strategies 
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Money flow index (5) 
 

DESCRIPTION 

This is a trading strategy based on the measure of the strength of money 

going in and out of a security and can range between 0 and 100. 

If the Money flow index is above 80 then it is an indication that the 

security has been overbought and that its price might start to decrease. 

Conversely if Money flow index is below 20 then it is an indication that the 

security has been oversold and that its price might start to increase. 

Hence this strategy interprets the possible buy/sell signals based on the 

crossovers that occur above or below the 80 and 20 threshold levels 

respectively. 

 

Figure 1 - Chart with Money flow index(5) 

 

This strategy is built based on the Money flow index indicator logic. 

 

RELATED INFORMATION 

ProChart Strategies 
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Relative Strength Index (14)  
 

DESCRIPTION 

This strategy is designed to follow the momentum of price as an oscillator 

that ranges between o and 100. Here a smoothing period of 14 is set and 

this strategy determines probable buy/sell signals for a stock based on the 

movement of momentum of price above or below the 70 and 30 threshold 

levels respectively. 

 

Figure 1 - Chart with Relative Strength Index (14) 

 

This strategy is built based on the Relative Strength Index indicator logic. 

 

RELATED INFORMATION 

ProChart Strategies 
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Slow Stochastics (5,3)  
 

DESCRIPTION  

A trading strategy based on the theory that prices move back and forth in 

waves between an overbought and oversold level. When applied on a 

stock chart, this strategy plots a stochastic line with the Time Period 

parameter set to 5 and the Slowing period parameter set to 1 and also 

plots a signal line which is a 3 day simple moving average of the 

stochastic line. This strategy interprets the possible buy/sell signals based 

on the crossovers that occur above or below the 80 and 20 threshold 

levels respectively. 

 

Figure 1 - Chart with Slow Stochastics (5,3) 

 

This strategy is built based on the Stochastic Oscillator indicator logic. 

 

RELATED INFORMATION 

ProChart Strategies 
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Fast Stochastic (5,1) 
 

DESCRIPTION  

A trading strategy based on the theory that prices move back and forth in 

waves between an overbought and oversold level. When applied on a 

stock chart, this strategy plots a stochastic line with the Time Period 

parameter set to 5 and the Slowing period parameter set to 3 and also 

plots a signal line which is a 3 day simple moving average of the 

stochastic line. This strategy interprets the possible buy/sell signals based 

on the crossovers that occur above or below the 70 and 30 threshold 

levels respectively. 

 

Figure 1 - Chart with Fast Stochastics (5,1) 

 

 

This strategy is built based on the Stochastic Oscillator indicator logic. 

 

RELATED INFORMATION 

ProChart Strategies 
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Chaikin A/D Oscillator 
 

DESCRIPTION  

The Chaikin Oscillator is created by subtracting a 10-period exponential 

moving average of the Accumulation/Distribution Line from a 3-period 

moving average of the Accumulation/Distribution Line. 

The Accumulation/Distribution momentum indicator determines whether a 

stock is primarily being bought (accumulated) or sold (distributed) during 

a trading day. It is based on the closing price relative to the midpoint of 

the high and low prices for the day. If the closing price is higher than the 

midpoint, it is assumed that more shares were bought during the day than 

were sold.  

The price value is multiplied by the volume and added to the momentum 

from the previous day. The volume is used to factor in how much of the 

market was behind the relative price change. 

The Chaikin Oscillator primarily detects trends in the 

Accumulation/Distribution indicator, which is a measurement of the 

momentum of a financial data series. Values above zero indicate that the 

security is being bought (accumulated). Values below zero indicate that 

the security is being sold (distributed). The farther the value is from zero, 

the more volume and larger price movements that are taking place. 

The peaks and troughs of the oscillator can be used to detect when the 

market is changing direction. 
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Figure 1 - Chart with Chaikin A/D Oscillator 

 

 

This strategy is built based on the Chaikin A/D Oscillator indicator logic. 
 
 

 
RELATED INFORMATION 

ProChart Strategies 
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Chaikin Money Flow (21) 
 

DESCRIPTION  

The Chaikin Oscillator is created by subtracting a 10-period exponential 

moving average of the Accumulation/Distribution Line from a 3-period 

moving average of the Accumulation/Distribution Line. 

The Accumulation/Distribution momentum indicator determines whether a 

stock is primarily being bought (accumulated) or sold (distributed) during 

a trading day. It is based on the closing price relative to the midpoint of 

the high and low prices for the day. If the closing price is higher than the 

midpoint, it is assumed that more shares were bought during the day than 

were sold.  

The price value is multiplied by the volume and added to the momentum 

from the previous day. The volume is used to factor in how much of the 

market was behind the relative price change. 

The Chaikin Oscillator primarily detects trends in the 

Accumulation/Distribution indicator, which is a measurement of the 

momentum of a financial data series. Values above zero indicate that the 

security is being bought (accumulated). Values below zero indicate that 

the security is being sold (distributed). The farther the value is from zero, 

the more volume and larger price movements that are taking place. 

The peaks and troughs of the oscillator can be used to detect when the 

market is changing direction. 
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Figure 1 - Chart with Chaikin Money Flow (21) 

 

 

This strategy is built based on the Chaikin Money Flow indicator logic. 
 

 
 

RELATED INFORMATION 

ProChart Strategies 

 

 

Chande Momentum Oscillator (Close,20) 
 

DESCRIPTION  

Chande Momentum Oscillator is created by calculating the difference 

between the sum of all recent gains and the sum of all recent losses and 

then dividing the result by the sum of all price movement over the period. 

In ProChart the number of bars of data to include in the calculation of the 

strategy is set at 20. 

With a high number of "up" days for 20 days, the value of the CMO will 

increase. Values above 50 typically indicate an overbought condition while 

values below -50 tend to signify oversold levels. 
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Figure 1 - Chart with Chande Momentum Oscillator (21) 

 

 

This strategy is built based on the Chande Momentum Oscillator indicator 
logic. 
 
 

RELATED INFORMATION 

ProChart Strategies 

 
 
 
Commodity Channel Index (5) 
 

DESCRIPTION  

The Commodity Channel Index is a means by which the variation of a 

security's price is calculated from its statistical mean. The default period 

for the CCI strategy is set as 5. 

Much like the Average Directional Movement Index, the CCI can help give 

a valuable measurement of the overall trendiness of a market. The faster 

the CCI is accelerating, the more strongly the market is trending. While it 

is perhaps mathematically possible for the CCI to move upward while the 

market does not, this is unlikely. 
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Typically oscillating between +100 and -100, a CCI reading above +100 

implies an overbought condition (and a pending price correction) while 

readings below -100 imply an oversold condition (and a pending rally).  

 

Figure 1 - Chart with Commodity Channel Index (5) 

 

 

This strategy is built based on the Commodity Channel Index indicator 
logic. 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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DEMA (Close, 5) 
 

DESCRIPTION  

Double Exponential Moving Average (DEMA) consists of a single 

exponential moving average and a double exponential moving average. It 

applies the weighting of the closing price decreasing exponentially over 5 

days period. When price crosses the moving average and increases, a 

continuing uptrend can be predicted. The basic MACD trading rule is sell 

when the MACD falls below its signal line and buy when the MACD rises 

above it. It is also common to buy/sell when the MACD goes above/below 

zero.  

 

Figure 1 - Chart with DEMA (Close,5) 

 

 

This strategy is built based on the DEMA indicator logic. 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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TEMA (Close, 21) 
 

DESCRIPTION  

TEMA (Triple Exponential Moving Average) is not simply a moving average 

of a moving average of a moving average, but it is a composite indicator 

using a single exponential moving average, a double exponential moving 

average, and a triple exponential moving average.  

In ProChart TEMA is plotted based on the closing price over a period of 21 

days.  

 

Figure 1 - Chart with TEMA (Close,21) 

 

 

This strategy is built based on the TEMA indicator logic. 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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Williams %R (5) 
 

DESCRIPTION  

The Williams' %R function calculates the difference between the current 

closing price of a security and its highest high price, relative to its lowest 

low price for a given period of time.The number of bars for calculating this 

strategy in ProChart is set at 5.   

The Williams' %R indicator is typically used to determine 

overbought/oversold levels. Values above -20 indicate the security may be 

overbought. Values below -80 indicate the security may be oversold. 

 

Figure 1 - Chart with Williams %R(5) 

 

 

This strategy is built based on the Williams' %R indicator logic. 
 

 
 

RELATED INFORMATION 

ProChart Strategies 
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Trix (5) 
 

DESCRIPTION  

Trix displays the percent rate-of-change of a triple exponentially smoothed 

moving average of the security's closing price. In other words, an 

exponential moving average of the data is taken for the given period. 

Then, an exponential moving average is taken of that result for the same 

period, followed by another for the second result. The percentage change 

in value of the third moving average is then returned as the value of the 

Trix.  

It is a momentum indicator which moves up over and under a zero line. A 

movement above indicates a long opportunity, while a movement below 

indicates a short opportunity. 

 

Figure 1 - Chart with Trix (5) 

 

 

This strategy is built based on the Trix indicator logic. 
 
 

RELATED INFORMATION 

ProChart Strategies 
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Volume Oscillator  (2,5,Exponential) 
 

DESCRIPTION  

A Volume Oscillator measures volume by measuring the relationship 

between two moving averages. The Volume Oscillator indicator calculates 

a fast and slow volume moving average. The difference between the two 

(fast volume moving average minus slow volume moving average) is then 

plotted as a histogram. 

 

When the Volume Oscillator rises above zero the shorter-term volume 

moving average has risen above the longer-term volume moving average. 

This means that the short-term volume trend is higher (i.e., more volume) 

than the longer-term volume trend. Bullish signals stem from rising prices 

coupled with increased volume, and falling prices coupled with decreased 

volume. Alternatively, if volume increases as prices fall, or volume 

decreases as prices rise, the market is thought to be showing signs of 

underlying weakness. 

Figure 1 - Chart with Volume Oscillator (2,5,Exponential) 

 

 

This strategy is built based on the Volume Oscillator indicator logic. 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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Price Oscillator  (Close,1,25,Simple) 
 

DESCRIPTION  

The Price Oscillator shows the difference between two moving averages. It 

is basically a MACD but the Price Oscillator can use any time periods. A 

buy signal is generated when the Price Oscillator rises above zero and a 

sell signal when it falls below zero.  

 

Figure 1 - Chart with Price Oscillator (Close,1,25,Simple) 

 

 

This strategy is built based on the Price Oscillator indicator logic. 
 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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Price Rate of Change (Close,7, Price) 
 

DESCRIPTION  

The Price Rate-Of-Change (ROC) indicator (percent method) is calculated 

by dividing the price change over the last x-periods by the closing price of 

the security x-periods ago. The result is the percentage that the security's 

price has changed in the last x-periods.  

If the security's price is higher today than 7 periods ago, the ROC will be a 

positive number. If the security's price is lower today than 7 periods ago, 

the ROC will be a negative number. 

 

Figure 1 - Chart with Price Rate of Change (Close,7,Price) 

 

 

This strategy is built based on the Price ROC indicator logic. 
 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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QStick (5) 
 

DESCRIPTION  

The Qstick determines the strength or weakness of a security over a x-

period. When plotted as a strategy, ProChart sets the period for this as 5. 

The Qstick indicator represents the moving average of the difference 

between the opening and closing prices of a security. A positive value 

means the security has had more up days over the 5 days, while a 

negative value means the security has had more down days over the  

period plotted. 

QStick values falling below zero indicate a majority of black candlesticks 

over the time periods under observation and provide a bearish bias for the 

security. Conversely, values above zero indicate a bullish bias. 

 

Figure 1 - Chart with QStick (5) 

 

 

This strategy is built based on the Qstick indicator logic. 
 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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Intraday Momentum Index (14) 
 

DESCRIPTION  

The calculation of the Intraday Momentum Index is very similar to the RSI, 

except it uses the relationship between the intraday opening and closing 

prices to determine whether the day is “up” or “down.” If the close is 

above the open, it is an up day. If the close is below the open it is a down 

day. In ProChart the number of bars of data to include in the calculation of 

the strategy is set at 14.  

Values above 70 indicate a potential overbought situation with lower prices 

ahead. Values below 30 indicate a potential oversold situation with higher 

prices ahead. 

 

Figure 1 - Chart with Intraday Momentum Index (14) 

 

 

This strategy is built based on the Intraday Momentum Index indicator 
logic. 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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Relative Momentum Index (8,4) 
 

DESCRIPTION  

The Relative Momentum Index (RMI) is based on a ratio of the average 

upward changes to the average downward changes over a given period of 

time. The individual changes are calculated for the given number of days. 

This is an extension of the Relative Strength Index. The RMI is used with a 

8 trading day time period against the closing price of a security. The more 

days that are included in the calculation, the less volatile the value. The 

momentum period is plotted at 4.  

 

The function has a range of 0 to 100 with values typically remaining 

between 30 and 70. Higher values indicate overbought conditions while 

lower values indicate oversold conditions. 

 

Figure 1 - Chart with Relative Momentum Index (8,4) 

 

 

This strategy is built based on the RMI indicator logic. 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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Relative Volatility Index (5) 
 

DESCRIPTION  

The Relative Volatility Index (RVI) is identical to the Relative Strength 

Index, except that it uses a period standard deviation of high and low 

prices. The RVI measures the direction of volatility on a scale from zero to 

100. Readings >50 indicate that the volatility is more to the upside. 

Readings <50 indicate that the direction of volatility is to the downside. 

 

Figure 1 - Chart with Relative Volatility Index (5) 

 

 

This strategy is built based on the RVI indicator logic. 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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Stochastic Momentum Index (5,3,3) 
 

DESCRIPTION  

The Stochastic Momentum Index (SMI) is a smoother version of the 

Stochastics Oscillator. It is constructed by comparing the price to the 

average of the high-low price range over a given period. ProChart 

Stochastic Momentum Index is drawn on three parameters: 5 as the 

number of periods for the high-low price computation, 3 as the number of 

periods for the smoothing averages and 3 as the number of periods for the 

signal line.  

 

Buy signals are issued when the SMI crosses above its signal line and sell 

signals are issued when the SMI crosses below its signal line. The price is 

expected to follow the SMI if a divergence occurs. 

 

Figure 1 - Chart with Stochastic Momentum Index (5,3,3) 

 

 

This strategy is built based on the SMI indicator logic. 
 
 
 

RELATED INFORMATION 

ProChart Strategies 
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Using Patterns 
 

INTRODUCTION  

Patterns (also known as Trading Patterns) are distinctive formations that 

are created by the movement of security prices and chart pattern analysis 

can be used to make short-term or long-term forecasts based on the price 

direction of securities. 

 Hammer 

 Hanging Man 

 Shooting Star 

 Inverted Hammer 

 Doji 

 Bullish Engulfing 

 Bearish Engulfing 

 Pierce Line 

 Dark Cloud Cover 

 Bullish Harami 

 Bearish Harami 

 Morning Star 

 Morning Doji Star 

 Evening Star 

 Evening Doji Star 

 Three White Soldiers 

 Three Black Crows 
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PROCEDURE  

To insert a pattern on a chart: 

1. Create / Open the required chart. 

2. On the Menu Bar go to the Patterns Menu  > Select the required 

Pattern. This displays the relevant Set Properties dialog box. 

In the Set Properties dialog box: 

3. Set the properties for the selected pattern based on your requirement. 

4. Click on Ok. This applies the selected pattern on the relevant chart. 

 

RELATED INFORMATION 

ProChart Patterns 

Using Strategies 

Using Indicators 

Using Custom Indicator Builder 

Using Insert Analysis Techniques window 

Show/Hide ISP 

Exploring Technical Analysis 
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ProChart Patterns 
 

INTRODUCTION  

There are 17 patterns available with ProChart. You can apply any of these 

patterns as and when required on any chart in order to interpret the 

direction of movement of the price of a security once the pattern is 

complete. 

 

 

THE DESCRIPTIONS OF ALL PROCHART PATTERNS ARE GIVEN BELOW: 

 

Hammer   

There is a sharp sell off after the market opens during a downtrend. 

However, by the end of the trading day, the market closes at or near its 

high for the day. This signifies a weakening of the previous bearish 

sentiment; especially if the real body is white (the close is higher than the 

open price). Since the certainty for a Hammer indicator is low, the trend 

reversal can be confirmed by a higher open and an even higher close on 

the next trading day. If the open and close are identical the indicator is 

considered a Dragonfly Doji. 

                                                                          

• The long lower shadow is about two to three times of the real body. 

• Little or no upper shadow. 

• The real body is at the upper end of the trading range. 

• The color of the real body is not important. 

Trend: Bullish 

Reliability: Low/Moderate     

Hammer 

 

          

 Back to top 
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Shooting Star 

The market gaps open above the previous day‟s close in an uptrend. It 

rallies to a new high then loses strength and closes near its low: a bearish 

change of momentum. Confirmation of the trend reversal would by an 

opening below the body of the Shooting Star on the next trading day. If 

the open and the close are identical, the indicator is considered a 

Gravestone Doji. The Gravestone Doji has a higher reliability associated 

with it than a Shooting Star.  

 The long lower shadow is about two to three times of the real body. 

 Little or no upper shadow. 

 The real body is at the upper end of the trading range.s 

 The color of the real body is not important. 

 

Trend: Bullish  

          

Reliability: Low/Moderate 

 

Shooting Star 

 

          

 Back to top 

 

Bearish Engulfing 

This pattern which accompanies an uptrend in a security, depicts a small 

white candlestick followed by a large black candlestick that engulfs the 

body (i.e. the range between the open and close) of the small white one. 

This pattern may provide an indication of a future bearish trend. 
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Trend:Bearish 

 

Reliability: Moderate  

 

Bearish Engulfing 

 

          

 Back to top 

 

Bullish Engulfing  

This pattern which accompanies a declining trend in a security depicts 

a small black candlestick followed by a large white candlestick that engulfs 

the body (i.e. the range between the open and close) of the small black 

one. This pattern may provide an indication of a future bullish trend. 

 

Trend: Bullish 

 

Reliability: Moderate 

 

Bullish Engulfing  

 

          

 Back to top 

 



© 2002-2010 DirectFN Ltd Page 658 

 
 

Pierce Line   

In a downtrend the market gaps open, but rallies strong to close above 

the previous day‟s midpoint. This pattern suggests an opportunity for the 

bulls to enter the market and support the trend reversal. The Piercing Line 

pattern is the opposite of the Dark Cloud Cover. 

• A long black body followed by a white body. 

• The white body pierces the midpoint of the prior white body. 

• Occurs in a downtrend. 

 

Trend: Bullish 

 

Reliability: Moderate  

 

Pierce Line  

 

          

 Back to top 

 

Three Black Crows    

In an uptrend three long black days occur with consecutively lower closes. 

This pattern suggests that the market has been at a high price for too 

long, and investors are beginning to compensate for it. 

• Three black days occur, each with a close below the previous day. 

• Each day opens within the body of the previous day. 

• Each day closes near or at the low of the day. 
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Trend: Bearish 

 

Reliability: High 

 

Three Black Crows 

 

          

 Back to top 

 

 

Three White Soldiers   

In a downtrend three long white days occur with consecutively higher 

closes. Generally this suggests future market fortitude, as a reversal is in 

progress that is building on moderate upward steps. 

• Three long white days occur, each with a higher close than the previous 

day. 

• Each day opens within the body of the previous day. 

• Each day closes near or at the high of the day. 

Trend: Bullish 

Reliability: High 

Three White Soldiers   

 

          

 Back to top 
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Bearish Harami   

After a long white day at the high end of an uptrend, a black candlestick 

opens lower than the previous day‟s close. Trading is typically light and 

the day ends with a close lower than the open and within body of the first 

day; a signal that the current uptrend is losing strength. The Harami 

indicator should be confirmed with the next trading day‟s candlestick 

following the reversal trend. 

• A long body followed by a shot body with opposite color. 

• A short body is completely within the prior day's long body. 

• The color of the second candle (the baby) is not important. 

Trend: Bearish 

 

Reliability: Low  

 

Bearish Harami   

 

          

 Back to top 

 

Bullish Harami   

After a long black day at the low end of a downtrend, a white candlestick 

opens higher than the previous day‟s close. The price is driven up, as 

many shorts are covered, which encourages further buy-ins. The Harami 

indicator should be confirmed with the next trading day‟s candlestick 

following the reversal trend. 

•  A long body followed by a short body with opposite color. 

•  A short body is completely within the prior day's long body. 
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•  The color of the second candle ( the baby) is not important. 

Trend: Bullish 

 

Reliability: Low  

 

Bullish Harami   

 

          

 Back to top 

Morning Doji Star 

In a downtrend, the market bolsters the bearish trend with a long black 

day and gaps open on the second day. However, the second day trades 

within a small range and closes at or near its open. This scenario generally 

shows the potential for a rally, as many positions have been changed. 

Confirmation of the trend reversal is given by the white third day. 

•  The first day is a black day which indicates the trend of the market. 

•  The second day must be a Doji day. 

•  The third day is a white day and supports the reversal of the trend. 

Trend: Bullish 

 

Reliability: High 

Morning Doji Star 

 

          

 Back to top 
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Dark Cloud Cover 

In an uptrend the market gaps open, but loses ground to fall below the 

midpoint of the previous day. The Dark Cloud Cover pattern suggests an 

opportunity for the shorts to capitalize on the next day‟s open: a warning 

sign to bullish investors. The Dark Cloud Cover pattern is the opposite of 

the Piercing Line pattern. 

•  A white body followed by a black body. 

•  The black body passes the midpoint of the prior white body. 

•  Occurs in an uptrend. 

Trend: Bearish 

Reliability: High 

 

Dark Cloud Cover 

 

          

 Back to top 

Doji 

Doji are important candlesticks that provide information on their own and 

as components of in a number of important patterns. Doji form when a 

security's open and close are virtually equal. The length of the upper and 

lower shadows can vary and the resulting candlestick looks like a cross, 

inverted cross or plus sign. Alone, doji are neutral patterns. Any bullish or 

bearish bias is based on preceding price action and future confirmation. 
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Ideally, but not necessarily, the open and close should be equal. While a 

doji with an equal open and close would be considered more robust, it is 

more important to capture the essence of the candlestick. Doji convey a 

sense of indecision or tug-of-war between buyers and sellers. Prices move 

above and below the opening level during the session, but close at or near 

the opening level. The result is a standoff. Neither bulls nor bears were 

able to gain control and a turning point could be developing. 

 

          

 Back to top 

Hanging Man 

The Hanging Man is a reversal pattern that can also mark a top or 

resistance level. Forming after an advance, a Hanging Man signals that 

selling pressure is starting to increase. The low of the long lower shadow 

confirms that sellers pushed prices lower during the session. Even though 

the bulls regained their footing and drove prices higher by the finish, the 

appearance of selling pressure raises the yellow flag. As with the Hammer, 

a Hanging Man requires bearish confirmation before action. Such 

confirmation can come as a gap down or long black candlestick on heavy 

volume. 

Trend: Bearish 

 

Reliability: Low 

 

The Hanging Man 

 

          

 Back to top 
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Evening Star  

In an uptrend, the market builds strength on a long white day and gaps 

open on the second day. However, the second day trades within a small 

range and closes at or near its open. This scenario generally shows an 

erosion of confidence in the current trend. Confirmation of the trend 

reversal is the black third day. 

• The first day is a long white day. 

• The second day gap higher from the first day. 

• The third day is a long black day and close below the midpoint of the 

first white day. 

 

Trend: Bearish 

 

Reliability: High 

 

Evening Star  
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Inverted Hammer 

This has small a real body (black or white), long upper shadows and small 

or nonexistent lower shadows. 

The Inverted Hammer looks exactly like a Shooting Star, but forms after a 

decline or downtrend. Inverted Hammers represent a potential trend 

reversal or support levels. After a decline, the long upper shadow indicates 

buying pressure during the session. However, the bulls were not able to 

sustain this buying pressure and prices closed well off of their highs to 

create the long upper shadow. Because of this failure, bullish confirmation 

is required before action. An Inverted Hammer followed by a gap up or 

long white candlestick with heavy volume could act as bullish confirmation. 

Inverted Hammer 

 

          

 Back to top 

 

 

 

Morning Star 

The morning star consists of three candlesticks:  

1. A long black candlestick. 

2. A small white or black candlestick that gaps below the close of the 

previous candlestick. This candlestick can also be a doji, in which case the 

pattern would be a morning doji star. 

3. A long white candlestick. 
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The black candlestick confirms that the decline remains in force and selling 

dominates. When the second candlestick gaps down, it provides further 

evidence of selling pressure. However, the decline ceases or slows 

significantly after the gap and a small candlestick forms. The small 

candlestick indicates indecision and a possible reversal of trend. If the 

small candlestick is a doji, the chances of a reversal increase. The third 

long white candlestick provides bullish confirmation of the reversal.  

 

Morning Star 

 

          

 Back to top 

 

 

Evening Doji Star 

A three day bearish reversal pattern similar to the Evening Star. The 

uptrend continues with a large white body. The next day opens higher, 

trades in a small range, then closes at its open (Doji). The next day closes 

below the midpoint of the body of the first day. 

 

Evening Doji Star 

 

          

 Back to top 

 

RELATED INFORMATION 

Using Patterns 
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Using Custom Indicator Builder 
 

INTRODUCTION  

The Indicator Builder window allows you to build your own Indicator 

(Custom Indicator), using the Scripting Language provided with ProChart. 

Once a custom Indicator is created, it can be saved for later use. 

  Note: 

  To use this feature, we recommend that you have basic programming 

knowledge and refer to the scripting language guide available in the 

Indicator Builder window to lookup syntax. 

  

TOPICS IN THIS SECTION 

Create / Edit  / Delete a Custom Indicator  

Load Text and Save Text 

Paste Formula 

 

RELATED INFORMATION 

Using Insert Analysis Techniques window 

Using Strategies 

Using Indicators 

Exploring Technical Analysis 
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Create / Edit  / Delete a Custom Indicator  
 

INTRODUCTION  

You can create indicators based on your requirement as well as edit 

already created indicators using the Indicator Builder window. 

 

PROCEDURE  

To create a New Custom Indicator: 

1. Go to the Tools menu > Select Custom Indicator Builder. This 

displays Indicator Builder window. 

Figure 1 - Indicator Builder window 

 

In the Indicator Builder window: 

2. Select the New button to create a new Custom Indicator.  

3. Enter a name for the new indicator on the Indicator Name field. (E.g.: 

Custom_Indicator_1) 

  Note: 

  The name given for any custom indicator has to start with a letter 

and can be followed by any alpha-numeric characters and spaces.  

4. Enter the scripting code in the Custom Indicator Formula area. 
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4. Click on the Test button  to compile the code. If the syntax is 

correct, it displays the text "Grammar Test - Result: Successful!" in 

the  Messages tab area. 

5. Click on the Build button . This displays the Set Default 

Properties for New Custom Indicator window. 

   In the Set Default Properties for New Custom Indicator window: 

6. Set the General properties for the new custom indicator based on your 

preference under the General tab. 

7. Enter a Short name for the created custom indicator and select the 

required Default insert window under the Advanced tab. 

 

 

To Edit a Custom Indicator: 

1. Go to Tools menu > Select Custom Indicator Builder. This displays 

Indicator Builder window. 

In the Indicator Builder window: 

2. Click on Edit. This displays the list of all created custom indicators.  

3. Click on the custom indicator you need to Edit. This displays the 

Scripting code of the selected indicator in the Custom Indicator formula 

area 

4. Edit the scripting code as required. 

5. Click on the Test button to compile the code. If the syntax is correct, it 

displays the text "Grammar Test - Result: Successful!" in the  

Messages tab area. 

6. Click on the Build button. This displays a Message on successful re- 

build. 

  Tips: 

  Use the Functions button to paste a pre-defined formula in the code 

area. 
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  Use the indicator builder right click menu to utilize the Cut, Copy, 

Paste and Delete options in the Custom Indicator Formula area. 

 

To Delete a Custom Indicator: 

1. Go to Tools menu > Select Custom Indicator Builder. This displays 

Indicator Builder window. 

In the Indicator Builder window: 

2. Click on Delete. This displays the list of all created custom indicators.  

3. Click on the custom indicator you need to Delete. This displays a 

Deletion confirmation message box. 

4. Click on Yes. This Deletes the selected custom indicator. 

  Note: 

  The Edit and Delete buttons get enabled only once you have created at 

least one Custom Indicator. 

 

 

 

RELATED INFORMATION 

Load Text and Save Text 

Paste Formula 

Using Custom Indicator Builder 
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Load Text and Save Text 
 

INTRODUCTION  

The Save Text and Load Text buttons located in the Indicator Builder 

window allows you to save and retrieve scripting language syntax to / 

from a text file. 

 

PROCEDURE  

To save the scripting language syntax as a text file: 

 Go to the Indicator Builder window > Click on Save Text . 

 

To retrieve scripting language syntax from a text file: 

 Go to the Indicator Builder window > Click on Load Text . 
 
 
 

RELATED INFORMATION 

Create / Edit  / Delete a Custom Indicator  

Paste Formula 

Using Custom Indicator Builder 

 
 
 
Paste Function 
 

INTRODUCTION  

This can be used to quickly paste an existing function of the correct 

format, or to refer to an available function.  

 

PROCEDURE  

To paste a formula / function: 

1. On the Indicator Builder window > Click on the Functions button. 

This loads the Paste Function window. 

In the Paste Function window: 

2. Select the required formula from the list > Click on Ok. 
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3. This pastes the relevant formula on the Custom Indicator Formula 

area. 

  Notes: 

  Pasted functions may contain parameters within <>. This indicates that 

you have to replace the expression given within <> with the desired 

expressions based on the given data type.  

  Some other functions like "min()" or "abs()" do not indicate the data 

type which goes inside the parentheses, as it should be a Data Array. For 

ease of use, the cursor is automatically placed between the parentheses 

instead. 

 

Figure 1 - Paste a formula 

 

 

RELATED INFORMATION 

Create / Edit  / Delete a Custom Indicator  

Load Text and Save Text 

Using Custom Indicator Builder 
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Using Insert Analysis Techniques window 
 

INTRODUCTION  

ProChart's Insert Analysis Techniques window displays all indicators, 

Patterns and Strategies available with ProChart as well as the custom 

indicators created by you. You can also add any of the required indicators, 

Patterns Strategies or Custom Indicators to favourites via the Insert 

Analysis Techniques window. You can also edit the scripting code of a 

required Analysis Technique and save it as a custom indicator by clicking 

on the Edit in Custom Indicator Builder button in the Insert Analysis 

Techniques window. 

 

TOPICS IN THIS SECTION 

Insert an Analysis Techniques  

Add an Analysis Technique to Favourites 

View definition of Analysis Techniques 

 

 
RELATED INFORMATION 

Using Indicators 

Using Strategies 

Using Patterns 

Exploring Technical Analysis 
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Insert an Analysis Techniques 
 

INTRODUCTION  

You can insert one or more analysis techniques onto the chart using the 

Insert Analysis Technique window.  

 

PROCEDURE  

To view the Insert Analysis Techniques window: 

Method I 

 Double click anywhere on the chart area. This will open the Insert 

Analysis Techniques window. 

 

Method II 

1. Right click anywhere on the chart area.  

2. On the right click menu select the Insert Analysis Techniques 

option. This will open the Insert Analysis Techniques window. 

 

Method III 

 Go to the Tools menu > Select Insert Analysis Techniques option. 

Figure 1 - Insert Analysis Techniques 
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To Insert an Analysis Technique to the chart: 

1. Open the Insert Analysis Technique window. 

2. Go to the required tab out of the following available tabs: 

 Indicators 

 Patterns  

 Strategies 

 Custom Indicators 

3. Double click on the required analysis technique listed. This displays the 

relevant property dialog box. 

4. Change the property fields under each tab as required. 

5. Click on Ok.  

 

To edit an analysis technique in the Custom Indicator Builder: 

This feature allows you to create a Custom Indicator based on an indicator 

already available. The formula for the indicator can be viewed and edited 

as follows: 

1. In the appropriate tab, click on the required analysis technique you 

want to see the formula of. This highlights the particular analysis 

technique. 

2. Click on the Edit in Custom Indicator Builder button. This will open 

up the Custom Indicator Builder window, with the formula for the 

selected analysis technique.  

3. Edit the formula as required.  

  Note: 

  You can only save the edited formula as a custom indicator. You can't 

change the formula of default indicators. 
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RELATED INFORMATION 

Add technical indicators 

Add an Analysis Technique to Favourites 

View definition of Analysis Techniques 

Using Insert Analysis Techniques window 

 

 
 
Add an Analysis Technique to Favourites 
 

INTRODUCTION  

The Insert Analysis Techniques window also allows you to add indicators, 

Patterns and Strategies to the respective lists of My favourites as and 

when required. 

 

 

PROCEDURE  

To add an analysis technique to favourites: 

1. Tick the checkbox under the Add to Favourites column in line with 

the required Indicator, Pattern or Strategy.  

2. Click on Ok. This will add the Analysis technique to the respective list of 

My Favourites. 

 

To remove an analysis technique from favourites: 

3. remove the tick on the checkbox under the Add to Favourites column 

in line with the required Indicator, Pattern or Strategy.  

4. Click on Ok. This will remove the Analysis technique from the 

respective list of My Favourites. 
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RELATED INFORMATION 

Insert an Analysis Techniques  

View definition of Analysis Techniques 

Using Insert Analysis Techniques window 

 

 

View definition of Analysis Techniques 
 

INTRODUCTION  

The definition of a required analysis technique can be viewed directly from 

the Insert Analysis Techniques window as and when required. 

 

To view the definition of an analysis technique: 

 In the appropriate tab, click on the View Definition icon  of the the 

required analysis technique. This will display the definition for the 

relevant analysis technique. 

 

RELATED INFORMATION 

Insert an Analysis Techniques  

Add an Analysis Technique to Favourites 

Using Insert Analysis Techniques window 
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Customizing ProChart Settings 
 

INTRODUCTION  

ProChart allows you to set General Settings, Chart settings, Chart themes 

as well as default settings based on your personal preference.  

 

 
 
TOPICS IN THIS SECTION 

Chart Theme 

Chart Settings 

Set Defaults 

General Settings 

  

 
RELATED INFORMATION 

Customize Bottom Toolbar 
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Customize Chart Theme 
 

INTRODUCTION  

The Chart Theme can be set based on your preference in the Chart Theme 

tab of the chart options window. 

 

PROCEDURE  

To change the Chart Theme: 

Method I 

1. Go to the Tools menu > Select Chart Options. This displays the Chart 

Options window. 

2. On the Chart Options window click on the Chart Theme tab. 

3. Set the required changes. 

4. Click on Save. 

 

Method II 

1. Go to the Right Click menu > Select Chart Options. This displays the 

Chart Options window. 

2. On the Chart Options window click on the Chart Theme tab. 

1. Set the required changes. 

2. Click on Save. 

 

The Chart Theme tab has the Chart Colors and Chart Fonts sections 

consisting of the settings relevant to each section. 

Chart Colors Settings:   

 By clicking on the Theme Colors options and clicking on the preview 

button, you can preview the particular chart colors associated with the 

current theme.  
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 By clicking on the Default Colors options and clicking on the preview 

button, you can preview the particular chart colors associated with the 

default theme.  

 The option Custom Colors gives you the ability to customize your 

theme based on your preference.  

 

To change the Custom Colors: 

1. On the Chart Theme tab Select the Custom Colors option. 

2. Click on the color you want to change. this displays the color palette 

window. 

3. Select the required the color from the color palette. 

4. Click on Ok. 

  Tip: 

  Click on the Preview button to show the effect of the color change before 

making the change permanent. 

 

Chart Fonts Settings: 

To change either the Title,Tool tip,Axis or Legend Font: 

1. On the Chart Theme tab click on the font you want to change. this 

displays the Select font dialog box. 

2. Select the required Font, Style and Size.  

3. Click on Ok. 

  Tip: 

  The Sample section displays a Preview of the selected Font, Style and 

Size.  
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Figure 1 - Chart Options window - Theme Settings 

 

 

RELATED INFORMATION 

Chart Settings 

Set Defaults 

General Settings 

Customizing ProChart Settings 
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Customize Chart Settings 
 

INTRODUCTION  

The Chart Settings can be set to satisfy your requirement in the Chart 

Settings tab.  

 

PROCEDURE  

To change the Chart Settings: 

Method I 

1. Go to the Tools menu > Select Chart Options. This displays the Chart 

Options window. 

2. On the Chart Options window click on the Chart Settings tab. 

3. Set the required changes. 

4. Click on Save. 

 

Method II 

1. Go to the Right Click menu > Select Chart Options. This displays the 

Chart Options window. 

2. On the Chart Options window click on the Chart Settings tab. 

3. Set the required changes. 

4. Click on Save. 

 

The Chart Settings tab has the following sections: 

Base Chart Title Content 

This section allows you to set the following Chart settings to be 

displayed on the chart title. 

 Mode - Tick this to display whether the Chart is in Historical or 

Intraday Mode on the chart title. 

 Period - Tick this to display the period selected for the chart on the 

chart title. 
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 Interval - Tick this to display the interval selected for the chart on 

the chart title. 

 

Chart Legend Style 

You can display the Symbol Name which is shorter in length, or display 

the Description which is the Company Name on the legend based on your 

preference by simply changing between Symbol and Company Name .  

 

Default Y-Axis position 

The Y-Axis/Price Axis position (that is whether the Y-Axis is on the Left, 

Right or on both sides of the chart), can be changed as required using one 

of the three option available in this section. 

 

Right Margin 

In this section, you can define the Number of intraday intervals and the 

Number of History intervals you need as a margin on the right side of the 

chart. The Intervals for intraday and History modes can be set 

independently. 

 

Save Chart as an image 

You can set the Default Image Type that a Chart will be saved as, when 

saving as an image. Select the image type from the Default Type Drop 

Down list. 

 

Default Window Tile Mode 

You can set the Default Window Tile Mode by selecting the mode you 

require from the given options.  
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Figure 1 - Chart Options window - Chart Settings 

 

 

RELATED INFORMATION 

Customize Chart Theme 

Customize Set Defaults 

Customize General Settings 

Customizing ProChart Settings 
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Customize Set Defaults 
 

INTRODUCTION  

The Default Settings of ProChart can be set based on your 

requirement in the Set Defaults tab so that the settings will be 

applied on opening a chart.  

 

PROCEDURE  

To change the Set Defaults: 

Method I 

1. Go to the Tools menu > Select Chart Options. This displays 

the Chart Options window. 

2. On the Chart Options window click on the Set Defaults tab. 

3. Set the required changes. 

4. Click on Save. 

 

Method II 

1. Go to the Right Click menu > Select Chart Options. This 

displays the Chart Options window. 

2. On the Chart Options window click on the Set Defaults tab. 

1. Set the required changes. 

2. Click on Save. 

 

The Set Defaults tab has the following sections: 

General 

You can change the Default Mode of the chart as either 

historical or intraday, and can set the Period and Interval 

associated with  the mode as required from their respective 

drop-down lists. 
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  Note: 

  You can set custom values for Period and Interval by selecting the 

option other on the drop down list.  

 

Chart Properties 

You can set defaults as required for the following fields by 

selecting the required option from the respective drop-down 

lists.   

 Price Field - Select the required option from the drop-down 

lists. 

 Line Style - Select the required option from the drop-down 

lists. 

 Chart Style - Select the required option from the drop-down 

lists. 

 Line Thickness - Select the required option from the drop-

down lists.  

 Chart Color -You can set the Default Color of the chart using 

this option. Select the Color for upward changes using the Up 

Color drop-down and the Color for downward changes using 

the Down Color drop-down. The option Use same Color sets 

the same color for both upwards and downwards movements 

and the option Use theme Color sets the chart color to what 

is defined in the Chart Theme. 

  Note: 

  Chart Properties can be set for the Base Chart as well as the 

Volume chart by selecting the relevant tab in the Chart 

Properties section.  
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Other 

This sections includes a check box to Enable/Disable opening a 

chart in the ProChart window by default and also includes check 

boxes to Show/ Hide the following: 

 Show/ Hide current price line 

 Show/ Hide order lines 

 Show/ Hide Bid-Ask tags 

 Show/ Hide Min-Max lines 

 Show/ Hide VWAP values (Historical mode only) 

  Note: 

  Tick the check box to Show the feature on the chart by default and 

remove the tick to Hide the feature by default on opening a chart.    

  

Figure 1 - Chart Options window - Set Defaults 
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RELATED INFORMATION 

Customize Chart Theme 

Customize Chart Settings 

Customize General Settings 

Customizing ProChart Settings 

 



© 2002-2010 DirectFN Ltd Page 689 

 
 

Customize General Settings 
 

INTRODUCTION  

The General Settings can be set based on your requirement in 

the General Settings tab of the chart options window. 

 

PROCEDURE  

To change General Settings: 

Method I 

1. Go to the Tools menu > Select Chart Options. This displays 

the Chart Options window. 

2. On the Chart Options window click on the General Settings 

tab. 

3. Set the required changes. 

4. Click on Save. 

 

Method II 

1. Go to the Right Click menu > Select Chart Options. This 

displays the Chart Options window. 

2. On the Chart Options window click on the General Settings 

tab. 

3. Set the required changes. 

4. Click on Save. 

 

The General Settings tab has the following section. 

Deleting Chart Elements 

This section contains the options to set confirmation messages 

on deletion of either indicators or objects (including line studies).  
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Option Description 

Confirm 

deleting 

indicator 

When this checkbox is selected, a confirmation alert 

will be displayed when an indicator is being deleted. 

If the deletion is to be done by mistake, clicking No 

in the message will ensure that the indicator is not 

deleted. 

Always confirm 

before deleting 

an object or a 

line study 

When this checkbox is selected, a confirmation alert 

will be displayed when either an object or a line 

study is being deleted. If the deletion is to be done 

by mistake, clicking No in the message will ensure 

that the object or line study is not deleted. 

Show tool tip 

when dragging 

objects 

When this checkbox is selected, the tool tip for the 

following objects will be displayed on moving and 

dragging the objects. 

 Trend Line 

 Arrow Headed Trend Line  

 Horizontal Line 

 Vertical Line 

 Rectangle  

 Ellipse 

 Text  

 Fibonacci Arcs 
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 Fibonacci Fans 

 Fibonacci Retracements 

 Fibonacci Price Extensions 

Show last value 

of indicator 

When this checkbox is selected, the last value of all 

indicators added on a chart will be displayed on the 

Right Y axis. 

 

 

Figure 1 - Chart Options window - General Settings 

 

 

RELATED INFORMATION 

Customize Chart Theme 

Customize Chart Settings 

Customize Set Defaults 
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Customizing ProChart Settings 

 

Saving Chart Layouts 
 

INTRODUCTION  

The Chart Layout option is particularly useful if you wish to save any 

opened chart in to a single layout file for future reference. Furthermore, it 

gives you real time updates on a previously saved chart while preserving 

the symbol, chart properties, indicators, line studies and display settings.  

Once opened, you can view the previously saved settings and change any 

setting if required. However it is not recommended to change the base 

symbol since doing so will result in losing Indicators, Line studies and 

Display Settings of the saved layout. If you wish to change the base 

symbol, create a new layout and save it. 

 

TOPICS IN THIS SECTION 

Save a New Layout 

Save a New Template 

Save a default Template 

Open a Layout 
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Save a new Layout 
 

INTRODUCTION  

Creating a chart layout is very much similar to creating a chart. 

Furthermore you can add indicators and trend lines to any layout created. 

 

PROCEDURE  

To create a chart layout: 

1. Select the required chart. 

2. Go to File menu > Select Save Chart /Save Chart As option. 

3. In the Save Chart /Save Chart As dialog box, enter a suitable File 

Name. 

4. Select Mubasher Chart Layout (*.mcl) from the File format drop 

down list. 

5. Click on the Save button. 

  Note: 

  You can edit an existing chart layout and then save it again if required.  

 

To save an existing chart layout, after editing it: 

1. Go to File menu > Click on the Save button. 

2. This saves the selected Chart‟s Layout. Saving a layout in this manner 

only saves the selected chart even if there were several charts open.   

  Note: 

  If more than one symbol is available in a given layout,  it is 

recommended not to change the base symbol. Doing so will result in 

losing Indicators, Trend Lines, Line studies and Display Settings. If you 

wish to change the base symbol, create a new layout and save it 
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To save multiple charts using Chart Layout:  

1. Specify the required settings on the multiple layouts. 

2. Go to the File menu > Select New > Select Layout option. This 

displays Chart Selection window.  

3. Select the Charts you wish to add to your layout. 

4. Click on the ok button. 

 

RELATED INFORMATION 

Open a Layout 

Add a New Chart 

Save a New Layout 

Save a New Template 

Saving Chart Layouts 
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Save a New Termplate 
 

INTRODUCTION  

ProChart has three pre-defined chart templates under Terms and 

furthermore, you can create your own templates as well as further 

customize any created template as and when required to suit your need.  

 

PROCEDURE  

To create a new template: 

1. Create/Open a chart. 

2. Add required Indicators, Strategies and Patterns to the chart. 

3. Go to the File menu > Select Save/Save As option. This displays the 

Save As dialog box. 

4. In the Save As dialog, specify a File Name and select Chart Template 

from the File format drop down. 

5. Click on the Save button. 

 

To customize a pre-defined template: 

1. Create/Open the required chart. 

2. Apply the pre-defined template. 

3. Customize the chart as required. 

4. Go to the File menu > Select Save As option. This displays the Save 

As dialog box. 

5. In the Save As dialog specify a File Name and select  Chart Template 

from the File format drop down. 

6. Click on the Save button. 

  Note: 

  You cannot save line studies and trend lines as a template.   
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RELATED INFORMATION 

Save a default Template 

Save a New Layout 

Saving Chart Layouts 

Terms 

 
 
 

Save a Default Template 
 

INTRODUCTION  

ProChart allows you to use the Save as Default Template option, which 

makes all charts to be automatically drawn according to the default 

template‟s specification and hence avoids the need to repeatedly set your 

Chart Properties and Indicators.  

 

PROCEDURE  

To create a default template layout: 

1. Create/Open a chart. 

2. Add required specifications based on your preference to be set as 

default features on opening a chart. 

3. Go to the Right Click menu > Select Save as Default Template. 

Once saved the relevant settings will be displayed by default for every 

chart you open.  

 

The properties which can be saved in a Default Template are: 

 General Properties such as Time Period, Intervals.  

 Base Chart Properties such as Price Field Colour, Chart Colour(Up, 

Down) and Chart Style. 

 Other Properties such as Show/ Hide Current Price Line, Order 

Lines, Bid-Ask Tags, Min-Max Price. 

 Indicators & Indicator Properties 
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  Note: 

  You cannot save line studies and trend lines as default templates.   

 

 

RELATED INFORMATION 

Save a New Layout 

Save a New Template 

Saving Chart Layouts 

Terms 
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Customer Support 
 

INTRODUCTION  

In order to make your trading experience more rewarding, the following 

customer support options are available with Mubasher Pro: 

 

TOPICS IN THIS SECTION  

Help Desk 

Administrator Messages 

Live Chat * 

Renew Card Subscription 

FAQ 

Troubleshooting 

Security Tips 

 

* The availability of this option may vary depending on your subscription. 
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Help Desk  
 

INTRODUCTION  

If you need further technical support, please contact the Help Desk, as per 

your location: 

 

Egypt: +16717 / info@mubashermisr.com 

Kingdom of Saudi Arabia: 9200 19 333 

United Arab Emirates: (800) 3237 

Other Countries: send us an email to support@mubasher.net 

 

RELATED INFORMATION  

Customer Support 

 

Administrator Messages 
 

INTRODUCTION  

Mubasher Pro now has the facility to deliver messages posted by the 

Customer Support Team. If you were offline when a message was 

posted, the messages will be delivered to you as soon as you get 

connected to the Application Server. 

  

To view administrator’s messages: 

1. Go to Help menu > Select Administrator Messages option. The 

Administrator Messages window opens. 

2. To view the message details, double click on the relevant message. 

 

RELATED INFORMATION  

Customer Support 

 

mailto:info@mubashermisr.com
mailto:support@mubasher.net
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Live Chat  
 

INTRODUCTION  

Mubasher Pro gives you live support via Chat. However, this feature 

depends on your subscription, so if you do not have this option on your 

Help menu, please contact Customer Support and upgrade your 

subscription. 

Note: 

  As Friday and Saturday are holidays in UAE, this feature is not available on 

these days. 

 

PROCEDURE  

To open the Chat window: 

 Go to Help menu > Select Chat With Customer Support. The Chat 

window opens. 

 

Wait for a few minutes till a Customer Support agent responds. After the 

Customer Support agent accepts your request you will be allocated 

approximately 5 minutes to chat with the Customer Support agent. 

After 5 minutes a dialog box will popup, asking if you want to extend the 

session or finish it. If you select the Yes option, your session will be 

extended by another 2 minutes. 

When the chat gets disconnected again and if you have more queries, 

please open the Chat window and start a new chat. 
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Figure 1 - Chat window 

 

 

CHAT HISTORY  

It is recommended that you save your conversation with the Customer 

Support agent, so that if the same issue arises again, you know what to 

do. 

To save the Chat History: 

1. Go to Help menu > Select Chat With Customer Support. The Chat 

window opens. 

2. Click on the Save History button ( ) 

3. This will open the Save window. The chat history will be saved in HTML 

format. Provide the file name and click the Save button. 

To view Chat History: 

1. Go to the location that you saved the history file to in the Save 

window.  
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2. The saved file can be open with any web browser.  

 

 

 

CHAT SETTINGS  

You can change the font, text colour and font style using the options 

available above the chat text entry area. The following options are 

available: 

 Change Font - Press the  button to change the font, font style and 

font size 

 Change Font Colour - Press the  button to change the font colour 

 Toggle Italics - Press the  button to turn italics on or off 

 Toggle Bold - Press the  button to turn bold lettering on or off 

 

RELATED INFORMATION  

Customer Support 
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Renew Card Subscription 
 

INTRODUCTION  

If your Card Subscription is about to expire or has expired, you can 

renew it using a Subscription Card.  

 

Note: 

  Please note that this option is available only for retail users and the following 

information is applicable only for these users. 

 

PROCEDURE  

To renew your subscription from Mubasher Pro: 

1. Go to Card Subscription menu. The Login page opens. 

 

Figure 1 - Card Subscription Login window 

 

 

2. In the Login page, Select the required renewal Method 1.e.: Card 

Account / New Mubasher Card. 
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3. Depending on the selected method, enter the Username and Password 

/ Card No. and PIN. 

4. Click on Continue button. 

If you have entered the details correctly, you will be automatically re-

directed into www.mubashercard.com where you can renew your 

subscription. For further details about renewing a subscription, please 

refer the Help in www.mubashercard.com 

  Tip:  

  You can also access www.mubashercard.com directly from your browser 

and login, to renew your subscription. 

 

RELATED INFORMATION  

Customer Support 

 

http://www.mubashercard.com/
http://www.mubashercard.com/
http://www.mubashercard.com/
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FAQ 
 

The following FAQ (Frequently Asked Questions) lists the most common issues that may arise when 

using Mubasher Pro. For further assistance please contact the Help Desk. 

 

What is the minimum requirement to run Mubasher Pro? 

 A 2GHz Standard PC (Dual Core recommended) with minimum 1 GB of RAM for Windows 2000, 

Windows 2003 and Windows XP with Service Pack 2. 

OR 

A 2GHz Standard PC (Dual Core recommended) with minimum 2 GB of RAM (32 & 64 bit) for 

Windows Vista with Service Pack 1, and Windows 7 Professional. 

 Internet Explorer 6.0 or above installed. 

 10/100 Network card if it is on a network or 56 kbps modem if it is a standalone PC. 

 A standard monitor with a minimum resolution of 1024 x 768 and colour quality of 16 bit or 

higher. 

 

What is a Trading Account with a Broker? 

Trading Account with a Broker is signing up for an online Mubasher trading account with any Broker 

who provides Mubasher services. 

Different brokers will have different criteria for getting a trading account and you can discuss this 

with your broker. However, you will get two things from your broker which is essential to trade with 

Mubasher Trade.  

These are: 

1. Your login ID 

2. Your Login Password 

I have installed Mubasher Pro.... what is next? 

OK, I have installed Mubasher Pro and have got a Trading account opened with a broker supported 

by Mubasher, what is next? 

1. Connect to the Price Servers  

Connect to the internet first. Then start Mubasher Pro. You will be prompted to enter your 



© 2002-2010 DirectFN Ltd Page 706 

 
 

Username/ Password for Mubasher Pro Price Service. You can verify if you are connected to the 

Price Server by looking at the Connectivity Panel at the bottom of the screen. 

 

2. Connect to the Trade Servers  

After you successfully login into the price servers, the Trade window will popup, prompting you 

to enter Username/ Password for trading. You can enter the login details, select your broker and 

then click on the login button. 

 

Please note that you cannot connect to trading without connecting to the price feeds. 

You can verify if you are connected to the Price Server and Trade Server by looking at the 

Connectivity Panel at the bottom of the screen. 

How do I know whether I am connected to the system? 

Always check the Connectivity Panel at the bottom left hand corner, to make sure that the system is 

connected. This panel gives you an indication about the connection status. The status bulbs at the 

top right hand corner indicates your Log in status to Price and Trade.   

Why am I getting the message "Maximum number of connections exceeded"? 

You will get this message in the following scenarios: 

 Another user has logged into the application using your user credentials. 

Solution: Exit from the application, and re-log in after a few minutes. 

 You have changed your user credentials in the Configure window, and have not exited from the 

application and re-logged into the application using your new user credentials.  

Solution: If you change your user credentials in the Configure window, exit from the application, 

and re-log in using your new user credentials. 

How to set up a workspace to be used in another machine 

You can set up and save a workspace to be used later. This is useful when you want to work on the 

same workspace using another machine or when you have to set up a workspace for someone else. 

You must first create, save and export the workspace, and then import the saved workspace when 

required.  

Create and export a workspace; 

1. Log in to Pro. 
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2. Create the workspace as required.  

3. Save and Export the workspace. (Learn More :  Save your Workspace, Export User Data) 

A file with the extension .mud is created and saved in the given location. Send this file to the 

required person through mail or save in a storage device to transfer to another machine. 

Import the workspace; 

1. Save the file in the required computer.  

2. Log in to Pro. 

3. Import the workspace required. (Learn More: Importing User Data) 

4. Go to Customize > Workspaces > Select the imported workspace. The workspace created 

earlier will be loaded to the application.  

5. To set this as the default workspace, Go to File > Select the Make Default Workspace. 

NOTE: Please note that the details (features and exchanges) available when the workspace is 

exported depend on your version and subscription.  

How to view Intraday and History data using MetaStock 

1. Select Auto Update MetaStock option. To enable automatic updates for exchanges, select the 

exchanges from the Auto Update MetaStock window. 

2. Restart the application to activate and start the auto update. 

3. To download history data use the Update MetaStock Database option. 

Note: If ONLY the Auto Update option is used the MetaStock database is not updated with historical 

data. You have to follow the steps as given above to view all history and Intraday day. Once you get 

the historical intraday data using Update MetaStock Database and activate the Auto Update the 

intraday from that day on is updated automatically.  

How can I change my Trading Password? 

To change your Trading Password: 

1. Go to Mubasher Trade menu. 

2. Select Change Password option. 

How to place an order? 

There are two ways you can place a Trade order: 
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1. Login to Mubasher Trade menu. 

2. Go to Mubasher Trade menu and select either Buy or Sell. 

                      OR  

Select the symbol you want to buy or sell in the Watch List and right click on it and the Right-Click 

menu is displayed. From the Right-Click menu, select Mubasher Trade option and then select either 

Buy or Sell. 

 

Once the order has been placed how can I know what has happened to it? 

1. Go to Mubasher Trade menu. 

2. Select Order List option. 

 

This will give you the Order List window, which shows all the trades you have placed, with their 

current status. If you wish to view pending orders, select the Pending from the Order Status drop 

down filter. This will display only pending orders (filled orders will not be shown). 

How can I Cancel an order? 

1. Go to Mubasher Trade menu. 

2. Go to the Order List option. 

 

Select the order you want to cancel and select Cancel from the Right Click menu. Once the order is 

queued/partially filled, you can send a Cancel order. 

How can I Amend an order? 

1. Go to Mubasher Trade menu. 

2. Go to the Order List option. 

 

Select the order you want to Amend and select Amend from the Right Click menu. 

Once the order is queued/partially filled, you can send an Amend order. 

How can I check my Portfolio details? 
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1. Go to Mubasher Trade menu. 

2. Select Portfolio option. 

 

Your portfolio details will be listed. 

I want to do a search for the orders I have placed? 

1. Go to Mubasher Trade menu. 

2. Select Order Search option. 

 

You can perform a search on all orders you have placed. 

How can I check my Account Details? 

1. Go to Mubasher Trade menu. 

2. Select Account Summary option. 

 

All details of your Account will be displayed. 
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Troubleshooting 
 

This section will help you when you need a answer to a common problem you may have when using 

the application. 

 

I am behind a firewall/proxy server and I cannot get connected 

Ask your firewall/proxy server administrator to enable the following ports for you. 

 For Price Servers TCP 9005 and 9006 

 For Trading Servers TCP 9999 

Please note that Mubasher Pro is not a web browser based application and does not use HTTP. 

Therefore if your computer is behind a firewall then SOCKS proxy may be needed, check with your 

administrator.  

 

To configure Mubasher Pro to use Socks proxy: 

 Go to the File menu > Connection Settings option. 

Error in displaying exchange information 

This is due to a network connection error. As property files are not downloaded properly when there 

is a problem in the network connection you may notice that the exchange information such as full 

market information and sectors are not displayed properly even after the connection is restored. 

When this happens you have to delete the corrupted property files of that exchange when the 

network connection is back to normal.  

To delete property files: 

1. Close the application. 

2. Go to the below given locations to access property files of exchanges you are subscribed to > 

Delete the required files. 

Windows Vista: 

C:\Users\<user name>\AppData\Roaming\Mubasher\Mubasher Pro 9\Exchanges 

Windows XP: 

C:\Documents and Settings\<user name>\Application Data\Mubasher\Mubasher Pro 9\Exchanges  
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**In the above given paths, <user name> is your computer user name. 

3. Reload the application. 

A warning message about a data delay is displayed  

This message is automatically displayed if you are experiencing a data delay due to network 

connectivity problems or high network traffic. Contact customer support for assistance if the 

problem persists.  

You may also notice that there is  a time delay in receiving data from the Mubasher server due to 

bandwidth problems. To fix this issue you can try disabling an exchange, a sector and/or its symbols 

as preferred using the Bandwidth Optimizer tool. Once disabled, data feeds will not flow through for 

the disabled Exchanges/Sectors/Symbols thereby saving the bandwidth and increasing the 

performance of the application. 

Learn More: Performance Optimizing 

Services are not available 

The Web proxy should be enabled in your connection settings to view the services available with 

your subscription if you are connecting through a proxy server.  

To enable Web proxy: 

 Go to the File menu > Connection Settings option > In the Proxy section enable Web proxy by 

ticking the relevant box > Enter the Web proxy settings (IP and Port number of Proxy). 
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Security Tips 
 

INTRODUCTION  

We recommend that you follow these practices to secure your 

financial and Trading information, in Mubasher Pro : 

 

 Never disclose the Trading Password to anybody even to the Broker staff 

at any instance. 

 Change your Password regularly as a normal practice and if you feel 

somebody saw it while you were entering it, change the Password 

immediately! 

 It is not advisable to use any mechanism to save Passwords and 

automatically enter the Password. The Password should only be 

memorized and should not be stored anywhere. 

 Check your account balances/portfolio details and statements regularly 

to identify any unusual transactions and to ensure that your account has 

not been accessed by anyone else. 

 Make sure your computer is always protected with a up-to-date virus 

guard. 

 To prevent viruses, do not open attachments from unknown or non-

trustworthy sources. Do not install pirated software. 

 It is recommended to use a personal firewall where Mubasher Pro is 

installed. 

 Keep your operating system up-to-date by installing all the patches 

released. 

 Disabling all unnecessary services running on your computer will make 

your computer more secure. 

 We recommend that you should not share your Mubasher Pro installed 

computer, with anybody else. 
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  Note: 

  All your data to trading servers pass through a 128-bit encrypted SSL 

tunnel, ensuring your information is always protected while in 

transmission. However, we recommend that you follow these practices to 

secure your financial and Trading information in Mubasher Pro, from your 

end. 

 

RELATED INFORMATION  

Customer Support 
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Disclaimer Notice  
 

Product Version: Mubasher Pro 

Copyright DirectFN Ltd 2002-2009. All Rights Reserved. Designated trademarks and brands are the 

property of their respective owners. 

 

Notice of Non-Liability:  

The images used in the Help Guide are for illustration purposes only and the actual interfaces may 

differ. DirectFN Ltd and the authors assume no liability for errors or omissions, or for damages, 

resulting from the use of this Help Guide or the information contained in this Help Guide. 
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